1. Jason McKesson
  2. gltut
  3. Issues


Issue #86 resolved

GL/glx.h is missing . . .

Anonymous created an issue

Hi Jason,

The tutorials look excellent. Thanks for creating them.

I'm working on Ubuntu 12.04, and am following the instructions in the Building the Tutorials section.

This appearantly worked: in glsdk premake4 gmake

The errors I'm getting are when attempting to build in the glsdk directory:

make config=debug all

==== Building glload (debug) ==== gll_gl_ext.c source/gll_gl_ext.c:251:26: fatal error: GL/glx.h: No such file or directory compilation terminated. make[1]: *** [Debug/gll_gl_ext.o] Error 1

regards, -jg-

John Gibson Toronto

Comments (4)

  1. Jason McKesson repo owner
    • changed status to open

    I'm not sure how to go about fixing this. You may need to install something Linux related. GL/glX.h should be a system header so it ought to be part of your system.

    Have you updated your graphics drivers?

  2. Jason McKesson repo owner

    I've (re)discovered that, on a fresh Linux install from popular distros like Ubuntu/Mint/etc, you need to install a bunch of package in order to build any OpenGL application. To build the SDK as part of the tutorial, you need:

    • X11's dev package
    • Mesa's dev package, for both GL and GLU
    • XInput's dev package
    • XRandr and Randr's dev package

    You can find these in the Synaptic Package Manager. I may have missed some; I wasn't taking notes as I tried lots of different packages before I could build.

  3. Log in to comment