Non-ASCII characters in path cause frozen executable to crash on Win32

Issue #73 new
mdscruggs
created an issue

I have a Python script that I've frozen to a Win32 *.exe with cx_Freeze 4.3.2, Python 3.3.2, Win7, using the default base. It has worked fine for months on Windows XP and 7. However, I noticed that if there is a non-ASCII character on the path to the executable, it crashes with this error message:

"Fatal Python error: cannot get zipimporter instance"

I can take a stable version of my script/exe/package with a path like this one, which works fine:

C:\Users\someuser\Desktop\test\myprogram.exe

...and add a non-ASCII character to the path...

C:\Users\someuser\Desktop\testᎦ\myprogram.exe

...and when the path is like this, the error occurs when launching the frozen program.

I have tested this with Chinese, Cherokee, and Cyrillic characters...they all consistently cause the issue independently, and I can always "fix" it by removing the non-ASCII characters.

Please let me know if you need any additional info or testing on my end.

Thanks!

Comments (3)

  1. mdscruggs reporter

    I should clarify that this issue occurs whether I run the frozen program from any location, including its own directory.

    I've also tried changing the active code page in a batch file (using "chcp 65001") to no avail.

  2. mdscruggs reporter

    Unfortunately I don't have much more extra time to try compiling--I'd be glad to test it if you can send me a compiled version of Console.c or one of its buddies. I did try compiling yesterday and had loads of issues (even though I successfully added a reference to the Python headers). Thanks.

  3. Log in to comment