Source

thg / CONTRIBUTING.txt

Author Commit Message Labels Comments Date
Yuya Nishihara
CONTRIBUTING: correct minimal supported PyQt and Qt version (closes #244) Since 9f85dac94241, Qt 4.6 is required. And we use keyword arguments, which requires PyQt 4.7.
Branches
stable
Steve Borho
CONTRIBUTING: document need of ctypes
Branches
stable
Adrian Buehlmann
CONTRIBUTING.txt: QXmlStreamReader.readNextStartElement() requires 4.6
Adrian Buehlmann
update PyQt version requirement in CONTRIBUTING.txt our codebase already uses PyQt new-style signal and slot support as described in http://www.riverbankcomputing.co.uk/static/Docs/PyQt4/pyqt4ref.html#new-style-signal-and-slot-support this requires PyQt 4.5.
Adrian Buehlmann
workbench: use saveGeometry/restoreGeometry According to the docs the restoreGeometry function also checks if the restored geometry is outside the available screen geometry, and modifies it as appropriate if it is. Requires at least Qt 4.3 (according to PyQt book).
Steve Borho
doc: mention Python version req in CONTRIBUTING.txt
Adrian Buehlmann
CONTRIBUTING: clarify non-mandatory ui features using newer lib versions
Adrian Buehlmann
add CONTRIBUTING.txt
Branches
stable