Georg Brandl committed 317c395

Update required Python to 2.5.

Comments (0)

Files changed (2)

 requires = ['Pygments>=1.2', 'Jinja2>=2.3', 'docutils>=0.7']
-if sys.version_info < (2, 4):
-    print('ERROR: Sphinx requires at least Python 2.4 to run.')
+if sys.version_info < (2, 5):
+    print('ERROR: Sphinx requires at least Python 2.5 to run.')
-if sys.version_info < (2, 5):
-    # Python 2.4's distutils doesn't automatically install an egg-info,
-    # so an existing docutils install won't be detected -- in that case,
-    # remove the dependency from
-    try:
-        import docutils
-        if int(docutils.__version__[2]) < 4:
-            raise ValueError('docutils not recent enough')
-    except:
-        pass
-    else:
-        del requires[-1]
-    # The uuid module is new in the stdlib in 2.5
-    requires.append('uuid>=1.30')
 # Provide a "compile_catalog" command that also creates the translated
 # JavaScript files if Babel is available.
     {envpython} tests/ {posargs}
     sphinx-build -W -b html -d {envtmpdir}/doctrees doc {envtmpdir}/html
-    nose
-    simplejson==2.1.0
+    nose
+    docutils==0.9.1
Tip: Filter by directory path e.g. /media app.js to search for public/media/app.js.
Tip: Use camelCasing e.g. ProjME to search for
Tip: Filter by extension type e.g. /repo .js to search for all .js files in the /repo directory.
Tip: Separate your search with spaces e.g. /ssh pom.xml to search for src/ssh/pom.xml.
Tip: Use ↑ and ↓ arrow keys to navigate and return to view the file.
Tip: You can also navigate files with Ctrl+j (next) and Ctrl+k (previous) and view the file with Ctrl+o.
Tip: You can also navigate files with Alt+j (next) and Alt+k (previous) and view the file with Alt+o.