Wiki

Clone wiki

aotus / CompilerSupport

Compiler Support

Aotus relies on the ISO-C-Binding of the Fortran 2003 standard, and therefore requires relatively new compiler versions, however a wide range of different compilers are known to compile the library.

Cray

Known to work with version 7.4.0 and newer.

GNU gfortran

Known to work in version 4.6 and newer, older versions are known not to work.

IBM

Known to work in version 11.1.

Intel

Known to work in version 12.0 and newer.

NAG

Known to work in version 5.2.

NEC

Known to work with the NEC Fortran 2003 Compiler Rev.003 2014/07/31.

PGI

Does not correctly resolve the generic aot_get_val interface!

Updated