Commits

Ronald Oussoren  committed 39d7047

Merged revisions 78784 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk

........
r78784 | ronald.oussoren | 2010-03-08 08:06:47 +0100 (Mon, 08 Mar 2010) | 3 lines

Fix for issue 8066: readline should not be linked against libedit when the
deployment target is 10.4, libedit on 10.4 is too broken.
........

  • Participants
  • Parent commits c676ff0
  • Branches 2.6

Comments (0)

Files changed (1)

         do_readline = self.compiler.find_library_file(lib_dirs, 'readline')
         if platform == 'darwin':
             os_release = int(os.uname()[2].split('.')[0])
+            dep_target = sysconfig.get_config_var('MACOSX_DEPLOYMENT_TARGET')
+            if dep_target and dep_target.split('.') < ['10', '5']:
+                os_release = 8
             if os_release < 9:
                 # MacOSX 10.4 has a broken readline. Don't try to build
                 # the readline module unless the user has installed a fixed
         if platform == 'darwin' and ("--disable-toolbox-glue" not in
                 sysconfig.get_config_var("CONFIG_ARGS")):
 
-            if os.uname()[2] > '8.':
+            if int(os.uname()[2].split('.')[0]) >= 8:
                 # We're on Mac OS X 10.4 or later, the compiler should
                 # support '-Wno-deprecated-declarations'. This will
                 # surpress deprecation warnings for the Carbon extensions,