Commits

Sergey Astanin  committed d0ccd9e

bump deps for GHC 7.6.1; update homepage; new version

  • Participants
  • Parent commits 999c4c3
  • Branches 0.10-bindings-libzip
  • Tags 0.10.2

Comments (0)

Files changed (2)

File LibZip/LibZip.cabal

 Name:          LibZip
-Version:       0.10.1
+Version:       0.10.2
 License:       BSD3
 License-File:  LICENSE
 Author:        Sergey Astanin
 Maintainer:    Sergey Astanin <s.astanin@gmail.com>
-Homepage:      http://bitbucket.org/jetxee/hs-libzip/
-Bug-reports:   http://bitbucket.org/jetxee/hs-libzip/issues/
+Homepage:      http://bitbucket.org/astanin/hs-libzip/
+Bug-reports:   http://bitbucket.org/astanin/hs-libzip/issues/
 
 Category:      Codec, Foreign
 Synopsis:      Bindings to libzip, a library for manipulating zip archives.
 
 Build-Type:     Simple
 Cabal-Version:  >= 1.2.3
-Tested-With:    GHC == 7.0.3, GHC == 7.2.2, GHC == 7.4.1
+Tested-With:    GHC == 7.4.1, GHC == 7.6.1
 
 Extra-Source-Files:
     examples/hzip.hs
   Other-Modules:
       Codec.Archive.LibZip.Errors
   Build-Depends:
-      base >= 4.0 && < 4.6
+      base >= 4.0 && < 5.0
     , bindings-libzip >= 0.10 && < 0.11
     , bytestring
     , filepath
     , mtl
   GHC-Options:
       -Wall
-

File bindings-libzip/bindings-libzip.cabal

 Name:                bindings-libzip
-Version:             0.10.1
+Version:             0.10.2
 Synopsis:            Low level bindings to libzip.
 Description:
   This package provides low-level bindings to libzip (v0.10) library.
   For higher-level interface please use LibZip package:
   <http://hackage.haskell.org/package/LibZip>
 
-Homepage:            http://bitbucket.org/jetxee/hs-libzip/
+Homepage:            http://bitbucket.org/astanin/hs-libzip/
 License:             BSD3
 License-file:        LICENSE
 Author:              Sergey Astanin
 Build-type:          Simple
 
 Cabal-version:       >=1.2.3
-Tested-with:         GHC == 7.0.3, GHC == 7.2.2, GHC == 7.4.1
+Tested-with:         GHC == 7.4.1, GHC == 7.6.1
 
 Flag NoPkgConfig
   Description: Do not use pkg-config to check for library dependencies.
         Bindings.LibZip
 
   Build-Depends:
-        base >= 4.0 && < 4.6
+        base >= 4.0 && < 5
       , bindings-DSL >= 1.0 && < 1.1
 
   if flag(NoPkgConfig)