Installation failing

Issue #6 invalid
Anonymous created an issue

Installing the library fails with the following error:

$ cabal update Downloading the latest package list from hackage.haskell.org

$ cabal install LibZip Resolving dependencies... Configuring bindings-libzip-0.11... cabal: The pkg-config package libzip version ==0.11.* is required but it could not be found. cabal: Error: some packages failed to install: LibZip-0.11.1 depends on bindings-libzip-0.11 which failed to install. bindings-libzip-0.11 failed during the configure step. The exception was: ExitFailure 1

Comments (2)

  1. Sergey Astanin repo owner

    Please indicate you operating system, version of C libzip library, output of pkg-config.

    If you're using an old libzip 0.10., please install bindings-libzip and LibZip with the same major version number (0.10.). The latest version of LibZip bindings is designed to work with libzip 0.11 only.

    If you're using Windows and pkg-config is not available on your system, consider using a Cabal configuration flag which disables pkg-config.

  2. Sergey Astanin repo owner

    Please run pkg-config --modversion libzip.

    If it prints 0.10 or 0.10.1, then you need to install LibZip 0.10.2: run cabal install LibZip-0.10.2.

    If it prints No package 'libzip' found, then you have to install libzip library first. Please use your OS package manager or install it from source.

    Only if it prints 0.11 or 0.11.1 then the problem may be related to the Haskell LibZip bindings.

    Closing this issue as invalid unless more information is provided.

  3. Log in to comment