Can't create dashboard on windows

Issue #61 resolved
Oliver Sträßer created an issue

C:\Users\osr\Documents\nodejs>atlasboard new testdashboard

Generating a new AtlasBoard project at C:\Users\osr\Documents\nodejs\testdashboard...

Directory C:\Users\osr\Documents\nodejs\testdashboard/ does not exist. Creating it no w. Porting sample project across... Installing npm dependencies...

Error installing dependencies. Please run "npm install" inside the dashboard dir ectory

C:\Users\osr\Documents\nodejs>cd testdashboard

C:\Users\osr\Documents\nodejs\testdashboard>npm install

C:\Users\osr\Documents\nodejs\testdashboard>atlasboard start

Checking npm dependencies for C:\Users\osr\Documents\nodejs\testdashboard\packages\de mo... Error installing dependencies for C:\Users\osr\Documents\nodejs\testdashboard\package s\demo. err:Error: spawn ENOENT


Comments (12)

  1. Oliver Sträßer reporter

    I tried to use the last comiited version as well, same issue :-( perhaps you have an idea to solve my problem.

    I'm using windows 8.1

  2. Iván Loire

    We don't really use windows, but it may be a permission related issue.

    You can just install the dependencies manually (it is what atlasboard is trying to do there) by doing "npm install" in every package directory (in this case, packages\demo)

  3. Bill Barekas

    I have the same issue. I cannot npm install manual anything. - Top-level package.json has empty dependencies list. - Also there is no package.json in the packages\demo folder.

  4. Neville Franks

    Same problem here. I have packages.json in packages/demo and in mydashboard and have run npm install in those directories. Windows 8.

  5. Joe Bott

    It worked for me after replacing the string 'npm' (including quotes) with 'npm.cmd' in both atlasboard\lib\package-dependency-manager.js and atlasboard\lib\cli\commands.js.

    Before the change I saw in Process Monitor that it was trying to start either a "npm.exe" or a "". Not sure why it'd try those but not "npm.cmd"

  6. Log in to comment