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Confluence Server documentation

Confluence is where you create, organize and discuss work with your team.

Get started

Kick start your Confluence journey with our navigation and space tutorials.
View guide

What's new in 6.3

Time to upgrade? Get the low down on the latest and greatest changes in Confluence 6.3.
View release notes

Get started

Welcome to the Confluence getting started documentation. In this section, you'll find tutorials and other
information that'll be useful for evaluating Confluence, and getting to know it when you're starting out.

Teams in Space

For each tutorial in this section, we'll use a fictional organization known as 'Teams in Space'. Their mission is to:

"Perform flight research and technology integration to revolutionize aviation and pioneer aerospace
technology. Also, land the first humans on Mars by 2020."

You're an astronaut in the 'See Space EZ' team, which is working on the upcoming colonization of Mars.
Go ahead - dive into the tutorials, and let us show you around Confluence and some of its handy features.

® Tutorial: Navigate Confluence

® The dashboard

® The space directory

® The space sidebar

® Keyboard shortcuts

® Complete your mission
® Tutorial: Space ace

® Create a project space
Create your personal space
Create the team's PR space
Delete and archive spaces

Tutorial: Navigate Confluence

Confluence is pretty simple to use, once you get to know it. This tutorial aims to get you acquainted with the
Confluence user interface, and show you how and where to perform some common tasks.

Teams in Space
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In this tutorial,you'll be working with some new Teams in Space recruits. Let's get to know them.

Alana Baczewski Emma Silvetti William Vladinov
Tech Lead Launch Specialist Aerospace Engineer

Now that you've met your team, let's take a look at your mission.

Mission brief

Your mission commander has thrown you a curveball: this week you'll be training new recruits at Teams in
Space HQ on your collaboration tool — Confluence. You just need to know the basics, so we'll go through the
main things you need to know to complete your mission.

Your mission is broken up into the following components:

® Get to know the dashboard

® Find your way in the space directory

® Master the space sidebar

® |mpress everyone with keyboard shortcuts

Those new recruits will be here tomorrow; we better get started!
Let's go!

The dashboard

The dashboard

The space directory
The space sidebar
Keyboard shortcuts
Complete your
mission

aprwNE

The dashboard is the hub of your Confluence site, providing you with access to information and updates that
are important to you. It's also the first thing your new recruits will see, so you need to make a good
impression on this one.

You can get to the dashboard from anywhere in Confluence by choosing the site logo at the left of the
Confluence header.

The dashboard has a collapsible sidebar that helps you get around:

® Discover
Watch the action unfold in real time with All updates or check out pages with lots of likes and activity
in the Popular feed.

* My Work
Get lightning fast access to your recently created and edited pages in Recently worked on, get back
to that page you stumbled across yesterday in Recently viewed, and have mission critical pages on
speed dial under Saved for later.

® My Spaces
This is where you can keep links to the spaces that you hop in and out of several times a day.
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If you're a Confluence admin you can give the dashboard some personality by adding useful announcements,
links, or a photo from your last mission (or office party). The the whole right hand column is ready and waiting
for you to customize.

= XConfluence Spaces- Poope Cuestons Csiendes | Grems oo
Recently worked on Invite Users ~ Create Space

TODAY

Welcome to Confluence

1
™
=

1. Discover: see what's happening in your site.
2. Your work: get work done with recent and useful pages at your fingertips.
3. Customize: admins can add useful content to welcome people to the site.

Try clicking one of the spaces on the sidebar, then return to the dashboard by clicking the site logo. Even
when your shuttle is spinning out of control, the dashboard is there to orient you.

You'll discover more about the dashboard as you get to know Confluence, but, for now, let's move on to the
space directory.

Pro tips
® You can choose to set any page as your personal home page
® You can always get to the dashboard at https://yoursite.conlw ki/dashboard. ac
tion
® Your Confluence admin can customize the global dashboard that all users see

The space directory

The dashboard

The space directory
The space sidebar
Keyboard shortcuts
Complete your
mission

agrwnE

The space directory won't let you look up ET in the intergalactic phone book, but it will let you see and filter
all the spaces in your Confluence site. Spaces are places to collect pages with a common theme — you can
create as many spaces as you like — and you can find them all in the space directory.

Here are some tasks to get you comfortable using the space directory:

1. Visit the space directory — To get to the space directory, choose Spaces > Space directory in the
Confluence header.

2. Choose the spaces you'll use the most — No doubt there'll be a space or two that you'll use on a
regular basis. Click the star to the right of a space to make it appear under My Spaces on the
dashboard.

3. Choose space categories — Once you're there, you'll see a list of all the spaces in your Confluence
site. Choose the 'My Spaces' category on the left to see only the spaces you marked with a star. Then
choose all spaces again.

4. Filter the list of spaces — Type part of a space name in the Filter field at the top right. That'll quickly
narrow down the list of spaces if there are a lot of them.
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= XUConfluence spaces~ People Create *e»

Space Directory ® Create
All Spaces Site Spaces Filter
Site Spaces Space Description Categories
Personal Spaces

@ IT Knowledge Base knowledge-base @
My Spaces
Archived Spaces '& Social @
CATEGORIES g Teams in Space ®
Knowledge-base

Hint: Your space administrator can organise spaces into categories. Learn more.

You can also categorize spaces with labels you create yourself. We're not going to cover that here,
but, if you'd like to know more, you can check out Use Labels to Categorize Spaces.

Understanding and using the space directory will make it much easier to find pages and blog posts that are
relevant to you.

You're ready to impress those new recruits with your knowledge of Confluence's space directory; now it's

time to sneak a peek at the space sidebar.

The space sidebar

The dashboard

The space directory
The space sidebar
Keyboard shortcuts
Complete your
mission

IS

What's in the sidebar?

The sidebar is a feature of every Confluence space; it's where you'll find the page tree (a hierarchical list of
pages in the space), customizable space shortcuts, and a link to the space's blog.

The See Space EZ team will find their meeting notes, decisions, requirements, and other pages in the
sidebar. Basically any page you create in the space will appear in the sidebar by default.

When you use certain page templates, like meeting notes, Confluence will automatically add an
index page to your space shortcuts. The index page is just a place where you can view all pages of
the same type — meeting notes in this example — in one place.

The space's blog is great for announcements and what's new-type updates.
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g Teams in Space

(2) Pages
Blog
SPACE SHORTCUTS
.1 Meeting Notes
Product Requirements o
Team Scrum Board

File Lists

PAGE TREE
v Meeting Notes

2014-07-10 SeeSpaceEZ Team Mee
> Product Planning
> Product Requirements '—o
> Teams in Space PR
» File Lists

+ Meet the SeeSpaceEZ Team

£+ Space tools ~ «

1. Space shortcuts: link to Confluence pages or other pages on the web
2. Page tree: hierarchical view of pages in this space.

Configure the sidebar
You can expand or collapse the sidebar using the left square bracket ( [ ) on your keyboard, or by dragging it
with your mouse.

There are lots of things you can change in the sidebar, but we'll stick to the basics — just enough to train your
new recruits.

You need to be a space admin to complete this task. Take a look, but feel free to skip it if you're not
an admin of any space.

Try this out:

1. Choose Space tools > Configure sidebar from the bottom of the sidebar (or the cog menu if your
sidebar is collapsed)

2. Add a space shortcut by clicking +Add link
Shortcuts can be to Confluence pages or spaces, or to any other content on the web. Try linking to thi
s blog post, which mentions Teams in Space (we're always after a plug at Teams in Space HQ!)

You can also hide things — like the space's blog — in the sidebar, if they're of no use in the space.

The sidebar is pretty easy, right? You'll be schooling those recruits in no time. Next up: Impress them with
your knowledge of keyboard shortcuts.
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Keyboard shortcuts

The dashboard

The space directory
The space sidebar
Keyboard shortcuts
Complete your
mission

aprwNE

Give a person some space food, and they'll eat for a day; teach a person to rehydrate their own space food,
and they're set for the whole mission. Or something like that. Keyboard shortcuts fall into this basket. We
could give you a list here, but then you'd need to keep referring to this page. The best way to go is to show
you how to find the list of keyboard shortcuts within Confluence.

Your recruits also need to work fast, so you'll need to pass this wisdom on to them.

Find the keyboard shortcuts

To open the list of keyboard shortcuts in Confluence, do any of the following:

® Choose the help icon
at top right of the screen, then choose Keyboard Shortcuts
® When viewing a page, press Shift+?
® While editing a page, choose the question mark icon
2

in the editor toolbar

What you'll see is a dialog listing the available keyboard shortcuts in Confluence.
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Keyboard Shortcuts
General To configure Autocomplete, go to your editor settings
Editor )
Editor Autoformatting Font Formatting Autocomplete
Bold text *Bold¥* Image/Media !
Underline text +Underline+ Link [
Italic text _Italic_ Macro {
Monospace text {{Monospace}} Mention @
Date I
Tables Styles
first [II] + enter Heading hl. H
cell Heading h3. H
heading heading ||heading||heading]| Quote bg. 0
Emoticons Lists
o (/) 1. list # lis
@D 1) o bullets * bul

The keyboard shortcuts are broken up into 3 categories:

® General — Global, page and blog post shortcuts.
® Editor — Text editing and formatting shortcuts.
® Editor Autoformatting — Wiki markup and autoformatting shortcuts.

You can turn the 'General' keyboard shortcuts off when you visit the General tab in the keyboard
shortcuts dialog.

Take some time to open the dialog and take a look at the shortcuts, and maybe find some you'll use a lot.

Then, start practising!

Next, we'll wrap up this mission and give you some ideas about where to head from here.

Complete your mission

The dashboard

The space directory
The space sidebar
Keyboard shortcuts
Complete your
mission

aglrwnE
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Well done, astronaut, you've acquitted yourself admirably. I'm sure those new recruits will be mightily
impressed with your knowledge of Confluence.

In this tutorial, we've:

¢ Explored the anatomy of the dashboard

® Navigated using the space directory and favorited a space

® Taken a look at and customized the space sidebar

® Found a handy list of keyboard shortcuts to help you work faster

Just look at your team's adoring faces...

If you'd like to take things to the next level, check out our tutorial on becoming a space ace.

Tutorial: Space ace

This tutorial will take you on a journey through Confluence to create and customize spaces, and delete them
if you want to, so you can achieve the rank of 'Space Ace'l

You'll need to have the 'Create space' and 'Create personal space' permission to complete this tutorial. If
you've just set up Confluence, you won't have any trouble; if you're using an existing instance and you're not
an admin, speak to your Confluence admin to make sure you have the right permissions.

Teams in Space

In this tutorial you're a new recruit on the Teams in Space crew, but, even though you're new, you'll be given
a lot of responsibility. You need the power to go with it.

Mission brief

You're in charge of organizing information and resources for the planned mission to Mars. There's going to
be plenty of important information, and it must be readily available to the people who need it. Some
information, though, will be sensitive, and may be 'for your eyes only.' You'll use the power and flexibility of
Confluence spaces to organize information, and make sure it's visible to the right people.

Your mission is broken up into the following components:

® Create a space to house all of the important information related to the mission
® Create your own space to keep yourself organized
® Create a public relations space, where you'll introduce your team the world
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What's a space?

Well, being an astronaut, | hope you know what space is, but what's a Confluence space all about? It's really
just a place to put related things, like information pages and files. But spaces also give you a place to
collaborate with groups of people, whether that's your team, people working on a common project, or the
whole world.

Every space has its own permissions, allowing you to grant access and other privileges to the right people.
They also have a blog, so you can post important messages and updates to whoever can see the space. You
can have as many Confluence spaces as you like, and you can archive or delete spaces when you no longer
need them.

Enough about that; let's begin.

Start the mission!

Create a project space

=

Create a project space

2. Create your personal
space

3. Create the team's PR
space

4. Delete and archive

spaces

The Mars colonization crew needs a place to put all their mission-critical information and resources, and
you're charged with setting it up. This part is going to be easy, because the information needs to be viewable
by the entire Teams in Space organization. That means we can set up the project space without any special
permissions.

If you haven't done so already, open up Confluence and log in so we can get started.

Create the space

1. Choose Spaces > Create space from the Confluence header

2. Select the Blank space option and choose Next

3. Enter a Space name - for this space, we'll call it 'Mars Colony', as it's being used for the Mars
colonization project.

4. Change the Space key to 'MARS' — this step isn't absolutely necessary, but it helps people if they're
navigating to this space by name. The space key forms part of the URL, so making it a word or name
makes it much easier to associate with your project.

5. Click Create

You now have a space set up for the Mars colonization project. Because everyone at Teams in Space HQ
needs access to the information in this space, you don't need to do anything with the space's default
permissions. It's visible to everyone in your organization, but not to the general public.

Every space has a default home page, which you can customize to suit your needs. Add the following image
and text to your space's home page to get things started. Just click Edit (or press E on your keyboard) to edit
the home page, and copy and paste the text. For the image it's best to drag it to your desktop and save it
there, then drag it into your page. That'll make sure the image is attached directly to the page.

Hit Save when you're happy with the home page.

A human mission to Mars ha
s been the subject of science
fiction, engineering, and
scientific proposals throughout
the 20th century and into the
21st century. The plans
comprise proposals to land on
Mars, eventually settling on an
d terraforming the planet, while
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exploiting its moons, Phobos a
nd Deimos.

Exploration of Mars has been a
goal of national space
programs for decades.
Preliminary work for missions
that would involve human
explorers has been undertaken
since the 1950s, with planned
missions typically being cited
as taking place 10 to 30 years
in the future when they are
drafted. The list of manned
Mars mission plans in the 20th
century shows the various
mission proposals that have
been put forth by multiple
organizations and space agencies in this field of space exploration.

Your 'Mars colony' space is ready for your team to add pages to. If you want to find it again, choose Spaces i
n the Confluence header, and select it from the list; to add a page to it, navigate to the space and hit Create i
n the header.

Now it's on to your personal space; a place where you can work in peace, and be sure that no one's looking

over your shoulder.

Create your personal space

=

Create a project space

2. Create your personal
space

3. Create the team's PR
space

4. Delete and archive

spaces

As a newbie on the team, you might want to keep some work to yourself until you're ready to present it.
There's always the chance your mission commander will also send you some information that's 'for your eyes
only," and you'll need to keep that in a safe place.

For this part of the mission, we'll be creating a special type of space: a personal space. We'll be using your
personal space like a sandbox, at least to start with — somewhere you can play around, draft pages, try out
features, and generally see what spaces are capable of.

Create your personal space

1. Choose your profile picture at the right side of the Confluence header
2. Select Add Personal Space...
3. Hit Create

You've now got a space that you can call your own. But we still need to lock it down to make sure it's
only visible to you.
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4.
5.

6.

= XUConfluence People  Create = =e-
V4 i O (a1 oo
° Admin Istrator Pages # Edit Watch = Share
H 3
Admin Istrator’'s Home

. )

& Profile Created by Admin Istrator just a moment ago

() Pages

. About Me (Admin Istrator)

RN B|09

- _ You may edit this page to include additional information about yourself.

| Questions
E-mail: tisadmin@veryrealemail.com

SPACE SHORTCUTS

Here you can add shortcut links to the Recently Updated Nawgate Space
most important content for your team

or project. Configure sidebar. As you and your team create

content this area will fill up and Search

PAGE TREE display the latest updates.

Get started by adding some pages to

this space. Create page.

$# Space tools ~ « ) Like  Be the first to like this No labels #

Choose Space tools > Permissions from the bottom of the siderbar
Hit Edit Permissions (enter your password if prompted)

You should see the conf | uence- user s group listed under Groups. To the left of the list of
permissions is the View permission, which determines whether everyone in that group can see your
space.

Uncheck View and hit Save all at the bottom of the page

You're now the only one that can view this space. Feel free to try anything in this space, and store super
secret stuff here.

Create the team's PR space

=

Create a project space
Create your personal
space

Create the team's PR
space

Delete and archive
spaces

Now it's time to go public; the world needs to know about the mission and its brave participants.

In this step, we'll create a team space and open it up to everyone. That's right — you can open Confluence
spaces up to anonymous (not logged in) users.

In order to allow anonymous access to your Confluence site, a site admin needs to grant anonymous
users the 'Use Confluence' permission. Don't worry if you can't do that, or if it's not done; it's just
something to note if you're opening up your Confluence site for real.

Create a Team space

1.
2.

Choose Spaces > Create space from the header
Select Team Space and hit Next

3. Enter a Space name (let's call it 'Mars PR")
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»

Change the Space key to 'MarsPR'

5. If there are other people using Confluence with you, feel free to add them as Team members (you
can remove them later), or just stick with yourself for now

6. Paste this in as the Description: Follow the progress of the brave Teams in Space astronauts as they

embark on their mission to colonize Mars.

Great! You now have a team space, again with its own home page. This home page is a little different to the
project space and your personal space — you'll see any team members you added, listed on the home page.

Create Team Space

Space name’ | Mars PR About Team Spaces

Share knowledge and collaborate on
projects, processes and procedures with
your team. They will be notified about this
space and all updates. Team members will
be granted permissions and added as
watchers of the space.

Space key | MarsPR ©)

Team members || (@ Admin Istrator % || [} Alana Grant x
@ Emma Paris * | gg Ryan Lee x

Description | Follow the progress of the brave Teams in
Space astronauts as they embark on their
mission to colonise Mars.

Back Close

Each space you create also has its own blog, so your social media team will be able to create posts in this
space and speak directly to all those adoring fans. But none of those fans can see this space. Yet.

Allow anonymous access

It's time to let the world in by changing the permissions on this space.

1. Choose Space tools > Permissions from the bottom of the sidebar
2. Scroll down until you see Anonymous, then hit Edit Permissions
3. Tick the View permission for anonymous users and hit Save all

That's it. You can now share the space's URL, which will be
http(s)://<your_confluence_site>/display/MarsPR. Visitors to that space don't need to log in, or have a license

for Confluence.

Delete and archive spaces

=

Create a project space

2. Create your personal
space

3. Create the team's PR
space

4, Delete and archive

spaces

We hope you've had a successful mission, and learned a bit about the power and versatility of Confluence
spaces. Flash forward 18 months, and just look how well the colony is coming along!
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If you need to clean up old spaces (or destroy the evidence of a failed mission!), you can either archive or delete
a space. Archiving just means it won't show up in the regular search, whereas deleting is obviously a lot more
permanent.

To archive a space:

1. Choose Space tools > Overview from the bottom of the sidebar
2. Click Edit Space Details
3. Change the Status from 'Current' to 'Archived' and hit Save

To delete a space:

1. Choose Space tools > Overview from the bottom of the sidebar
2. Select the Delete Space tab

What next?

If you'd like to know more about spaces and the permissions that govern them, check out Spaces and Permissio
ns and restrictions in the Confluence documentation.

Teams in Space HQ, signing off.
Spaces
What is a space? On this page:

®* What is a space?
®* How do | use a space?

Spaces are Confluence's way of organizing content
into meaningful categories. Think of it like having

different folders into which you can put your work. Related pages:
_ _ o ® Create a Space
. )
® Site spaces — These spaces are found in the . (N)?V'%]?;e Sparcess
Space Directory and are the areas where . C g? mii you ) gace
you create content and collaborate with . A;JShi?/ eSyou pace
others. They are sometimes called global . chive a space

Export Content to Word, PDF,
HTML and XML
® Delete a Space

spaces.

® Personal spaces — Every Confluence user
can set up a personal space which they can
keep private or make public so others can
view and edit. Personal spaces are listed in
the People Directory and found under your
personal profile.

How do | use a space?

Create as many spaces as you need to get things done:
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® Team spaces — Give each team (QA, HR, Engineering, Support, ...) their own space so they can
focus and make their information easier for everyone to find.

® Project spaces — Put all the information related to your project in one place. This allows everyone to
work together in Confluence instead of emailing back and forth.

® Personal space — Store everything you're working on individually, keep your to-do lists, and polish
any content before you move it into another shared space.

Stay up to date with spaces

® Watch a space to stay up-to-date with any changes.
® Add important spaces to your dashboard so that they're easy to find again.

Administer spaces
If you have admin permissions for a space you can:

® Change the colors, logo, sidebar and homepage of that space.
® Control who can view and edit your space.
®* Make your space public to share it with people who don't have access to Confluence.

Space Permissions
Some things we should make clear about space admin permissions:

® The person who creates a space automatically has admin permissions for that space.

® Space admins can grant admin permissions to others.

® Space admins don't have to be Confluence admins and can have special permissions for a single
space. For example, you are the admin for your personal space, no matter what kind of access you
have anywhere else.

Want more ideas for using spaces? Check out our kickass guides on how to:

Use Confluence as a Knowledge Base

Develop Technical Documentation in Confluence
Use Confluence as your Intranet

Use Confluence for Software Teams

Create a Space

There's no limit to the number of Spaces you can create on Confluence. You
can choose to set up a space for each team, project, or a mix of both
depending on your needs.

Each space in Confluence functions autonomously, which means that each
space:

® Has its own homepage, blog, pages, comments, files, and RSS
feeds.

® Can be customized with different color schemes, logo and sidebar.

® Has its own set of permissions, as set by the space admin.

For example, an IT team can create one overarching space with all their roa
dmaps, details of sub-teams, and a list of all the people and roles within that
team. They could then create a new space for each sub-team, such as
Quality Assurance, Developers, and Documentation, with guidelines, long
term plans, and knowledge articles within them. Each project that these
teams work on could also have its own space, which could be linked to the
team spaces using labels.

Create a personal space

Your personal space is always owned by you, and you can use it to store

Created in 2017 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/
https://confluence.atlassian.com/display/CONF63/Organize+your+Space#OrganizeyourSpace-my

Confluence 6.3 Documentation

your individual work, keep track of tasks, blog about what you've been
working on, or just use it to polish your pages before you move them into a

site space. ® Create a
personal
space

®* Create a
site space

® Space
permission
S

® Linking
related
spaces

®* Tips

On this page:

Related pages:

® Spaces

® Space
Keys

¢ Create a
Space
From a
Template

1. Choose your profile picture at top right of the screen, then choose Add Personal Space..
2. Choose Create.

You can change the permissions for your space at any time to determine who can and can't access the
content. So if you want it to be a private sanctuary, that's no problem.

ﬂ To create a personal space you need the 'Personal Space' global permission.

Create a personal space

With a personal space, you can...

1 Stay organised 2 Share news 3 Introduce yourself
Keep your notes, task lists, files Use your blog to make Customise your personal
and other personal content announcements, capture ideas homepage and introduce yourself
organised. and share learnings. to the team.

Create a site space

You can create a site space for any team or project that would benefit from having a place where people can
work together and store related files. You can create these as blank spaces, or use templates, called space
blueprints , to help you create Team spaces, Knowledge Bases spaces, or Documentation spaces quickly
and easily.

1. Hit Spaces > Create space in the header.
2. Pick a type of space.
3. Enter the required details and create your space.
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I Choose your space key carefully as you can't change this later.

Each space you create will automatically have a home page that you can customize to display relevant
information for people viewing the space. If you use a space blueprint when creating a space, it will
customize your home page for you.

ﬂ To create a site space you need the 'Create Space' global permission.
Create Team Space

Space name’ | Marketing Team About Team Spaces

® Share knowledge and collaborate on
projects, processes and procedures with
your team. They will be notified about this
space and all updates. Team members will
be granted permissions and added as
watchers of the space.

Space key'  MARKETING

Team members || ¥ Gil Admin % Karen User x
& Josh User x

Description | This is the space for all things marketing!

Space permissions

Each space is created with a set of default permissions. The user who created a site space is automatically
granted 'space admin' permissions for that space, which means that they can then grant permissions to other
users and groups. See Space Permissions Overview for more information.

o System Administrators can edit the permissions of spaces in their Confluence site at any time.

Linking related spaces

You can link related spaces together using labels. This will create categories in the space directory for each
label, grouping all spaces with that label together.

Space Directory

All Spaces Documentation

Shte Spaces Space Description Categories

Personal Spaces

MyS 9 Confluence Latest Documentation for the latest version of the Confluence wiki: Installation Guide, User Guide, Admin Guide and other technical documentation documentation
ty Spaces

Archived Spaces (118 Diagrams, Infographics and Screenshots A repository for graphic assets used in our documentation documentation

CATEGORIES B International Translations Translating our documentation for international consumption documentation

Confluence
Hint: Your space administrator can organise spaces into categories. Learn more.
Documentation

® You can also add a space description to make it easier for visitors to find the right space within each
category.

® To help navigate between related spaces, you can use the Spaces List Macro on a page and filter by
category. This will let you insert a list of all the other spaces in a certain category into your space. You
can use this, for example, to keep a list in your team space of all the project spaces your team is
working on.

® |f you want to link to only certain pages of related content, rather than whole spaces, you can use the
Content Report Table Macro. You can use this, for example, in a space that functions as a workplace
directory, to create a list of all the team pages with everyone's roles and contact details across your
organization.
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Tips

® If your needs change, or your spaces grow too big, it's easy to copy or move content from one space
to another.

® If the content or purpose of your space changes, you can update the space name, logo, colors and de
scription to reflect those changes.

® If you no longer need a space, such as when a project has been completed, you can archive it, which
makes it less visible but retains the content on your site so that you can still refer back to it later.

Create a Space From a Template

Confluence comes with a number of templates, known as space blueprints, Related pages:

which have a customized homepage and sidebar, and may contain page .

blueprints or sample content to help you get started. greate e
pace

This page is about space blueprints. You can also use Blueprints to
create individual pages.

You can find blueprints for creating a team space, knowledge base space,
documentation space, or software project space.

ﬂ' Your Confluence administrator can customize or disable your blueprint
templates. See Create a Template and Administering Site Templates for
more information on templates.

Types of Blueprints

Team space

A great building block if you are using Confluence as an intranet or to manage teams. Team spaces highlight
the members of the team, and grants permissions to those users accordingly.

Knowledge base space

This space blueprint uses search and page labels to make content easier to find, right from the space
homepage. It also contains two page blueprints for creating how-to and troubleshooting articles. The
templates used in these page blueprints are completely customizable. The Knowledge Base space blueprint
also Use JIRA applications and Confluence together.

Documentation space

This space blueprint displays the full page tree in the sidebar and hides other sidebar features including
blogs and shared links. The homepage uses search and page labels to make content easy to find. Add the
‘featured' label to any page you want to highlight on the homepage. This space does not include any page
blueprints but you can create and promote templates for your documentation authors to use.

Software project space

This space is designed to help you organize your software project. The purpose-built space home page lets
you view and edit your roadmap, see team members, and Use JIRA applications and Confluence
together#JIRA Software. Create pages in this space for requirements, meeting notes, decisions, retros, and
more.

ﬂ The software project space blueprint will only appear if you have linked Confluence to your JIRA Software
instance.
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Create space

Blank space

Team space

% © I

Start with a blank space. @

Knowledge base
Capture and share best practices and solutions
to common problems.

Collaborate and share resources with your team.

Filter Help

Documentation space
Create and manage technical documentation for
your products

Software project space

Create software requirements, capture meeting
notes, and track decisions.

3 o

Check out our guides for some more tips on how to:

Space Keys

Use Confluence as a Knowledge Base

Develop Technical Documentation in Confluence
Use Confluence as your Intranet
Confluence for Software Teams

Each Confluence space has a space key, which is a short, unique identifier
that forms part of the URL for that space.

Create Team Space

Space name”
*
Space key

Team members

Description

When you create a site space, Confluence will suggest a space key or you can enter your own key to make it

Marketing Team
MARKETING

# Gil Admin x Karen User x
& Josh User x

This is the space for all things marketing!

more memorable.

For example, you might give your marketing team's space a key of MARKETING. You can then navigate

About Team Spaces

® Share knowledge and collaborate on
projects, processes and procedures with
your team. They will be notified about this
space and all updates. Team members will
be granted permissions and added as
watchers of the space.

Related pages:

® Create a
Space

® Create a
Space
From a
Template

directly to the space using a URL like this - ht t p: / / <your si t e>/ di spl ay/ mar ket i ng

o Personal spaces always use your username as the space key.

Choosing a space key

Each space key:

® Must be unique.
® Can contain any alphanumeric character (a-z, 0-9).
® Can be up to 255 characters long.

I You can't change the space key after you create your space, so choose your space key carefully!
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Navigate Spaces

How is content arranged in spaces?

On this page:

: . . ® Howis
Think of a space as the container that holds all the important stuff a team, content
group, or project needs to work. These are autonomous — that means that arranged
each space has its own pages, blogs, files, comments and RSS feeds. in spaces?
Each space is automatically created with a homepage - the first page you'll * Viewall
see when you navigate to the space. You can edit your homepage and your Spaces In
sidebar to help people navigate their way around your space. Confluenc

e

Spaces can't be nested — you can't have a space within a space — but you
can Use Labels to Categorize Spaces. Spaces with the same label will Related pages:
appear together in the the space directory and in the recent activity area of

® QOrganize
the dashboard.

your
Space

® Watch
Pages,
Spaces
and Blogs

® Pages and
blogs

® Search

Inside the space, you can nest your pages, and you can create as many levels of hierarchy as you need.
Each space also has its own blog, which lets you share news and make announcements. Blog posts are a
great way to keep people involved in what's going on in your team or project.

You can set different levels of access for each space, and the pages and blogs within it, using Space
Permissions Overview.

D_
D_
D__
El

]

3

0

;] — [ -

J6aEE

™
D__

i
E_

Ll © &

View all spaces in Confluence

There are two main ways to view spaces in Confluence:

® The space directory — choose Spaces > Space directory in the Confluence header for a list of all
the site and personal spaces you have permission to see. Filter the list of spaces by selecting from the

Created in 2017 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 6.3 Documentation

categories on the left of the space directory.

® The dashboard — you can make your most useful spaces appear under My spaces on the

dashboard. Choose the star icon in the space sidebar or space directory to add a space to My spaces

Spaces ¥ People Questions Cal

RECENT SPACES

€3 The Beginner's Guide to Confluence
Er User Experience

D Information Experience

9 IT - Documentation

o Global

® IT-IRC

i |T - Quality Assurance

= |T - Software Development
© IT - Communications

@ Administrator

Space directory

Create space

The spaces menu in the header also displays a list of your recently viewed spaces, allowing you to quickly

navigate to the things you view most often.

The Spaces List Macro allows you to display a list of spaces on a Confluence page, and lets you filter them

by category.

Space Permissions Overview

Each space in Confluence has its own set of permissions, which can be
granted and revoked by a space administrator. The user that creates a
space, like when you create your personal space, is automatically an
administrator of that space, and they can add other space admins if they
want to by adding the Space Admin permission to another user or group.

@ How do you find out who the space admin is for a particular space?
Choose Spaces > Space directory in the Confluence header, then choose
the Space Details icon beside a space.

If you're one of those lucky space admins, you can assign permissions for
the space to individual users, groups, or anonymous users. To change
permissions for a space, choose Space tools > Permissions from the
bottom of the sidebar, then choose Edit Permissions to change permission
settings.

Space admins can also manage watchers for that space by choosing Watch > Manage Watchers at the

top-right of any page in the space.

If you accidentally deny all admin access to a space so that nobody has access to administer the space any
more, you can ask someone with Confluence Administrator global permission to recover Space Permissions.

Related pages:

® Confluenc
e Groups

® Assign
Space
Permission
S

® Page
Restriction
S

® Global
Permission
s Overview

This page is about Space Permissions. Confluence also lets you set Page Restrictions.
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Permissions Summary
The following permissions can be assigned for each space:

Permission Applies to

View This lets a user view all the content in your space.
Add This lets a user add and edit pages, blogs, comments and attachments.
Restrict This lets a user restrict others from viewing or editing a page.

Delete own This lets a user delete any pages, blogs and attachments they originally created
(regardless of whether other users have subsequently edited the content).

Delete This can be used to let a user delete pages, comments, attachments and mail items.

Export This lets a user export the whole space. This is different to page exports - anyone who can
view a page can also export it.

Admin This lets a user administer the space, including the ability to pass on admin permissions to
other users.

ﬂ' Confluence administrators aren't necessarily space administrators. In order for them to be a space admin,
they must belong to a group which has space admin and view permission for the space, or their username
must be specifically granted space admin and view permission for the space. People with the System
Administrator global permission can choose to grant themselves space admin permissions for any space.

Space permissions are additive

Space permissions are additive. If a user is granted permissions as an individual or as a member of one or
more groups, Confluence will combine these permissions together.
~ Here's an example...
Sasha is a member of the conf | uence- user s group and the devel oper s group. The conf | uence-u
ser s group has 'export' permission, but does not have 'restrict' permission. The devel oper s group has
‘restrict’ permission but does not have ‘export' permission.

By being a member of these two groups, Sasha can restrict and export content. The permissions do not
conflict, they combine to determine what Sasha is allowed to do in this space.

Assign Space Permissions

If you are the administrator of a space, you control the permissions for it.
You can choose to assign/revoke permissions on either an individual user
basis, or by Confluence Groups.

Confluence Administrators can put users into groups to make it
easier to manage permissions. If you are not an administrator and
want to know if someone belongs to a group, ask your administrator
to check for you.

@) Permissions in Confluence are additive, so if you belong to different
groups with different permissions, you will have the combined permissions
of those groups.
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To access the permissions for a space:

On this page:

1. Go to the space and choose Space tools > Permissions from the ® Assign
bottom of the sidebar space

2. Choose Edit Permissions. permission

S

The Edit Space Permissions page is divided into the following sections: ® Revoke
space
permission
S

® Manage
and
recover
space
admin
permission
S

Related pages:

® Space
Permission
s Overview

® Global
Permission
s Overview

®* Make a
Space
Public

® Give
Access to
Unlicensed
Users from
JIRA
Service
Desk

® Licensed Users - this is where you grant permissions to groups and individual users.
®* Anonymous Access - this is where you grant permissions to users who are not logged in (essentially
making the space public)
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Permissions =~ Restricted Pages

Licensed Users

Groups

Grant permissions for this space to all the members of a group.

All Pages Blog Attachments Comments Restrictions Mail Space
View Delete Add Delete Add Delete Add Delete | Add Delete Add/Delete Delete  Export Admin
Own
confluence-users [] [x] [] [x] [] B8 [] [ x] [) [ %] [x] [ x] [] [ %]
developers o o o [x] o [ x] o a o a a a a a

Edit Permissions

Individual Users

Grant permissions to individual users, regardless of which groups they are a member of.

All Pages Blog Attachments Comments Restrictions Mail Space
View Delete Add Delete Add Delete Add Delete  Add Delete Add/Delete Delete  Export Admin
Own
Rachel Robins ] 8 ] ] ] o o ] ] ] ] ] ] ]

(rrobins)
Edit Permissions

Anonymous Access

If your Confluence site is public, you can grant permissions to people who are not logged in. Anonymous users can be granted almost any
permission, but we recommend you limit this to viewing and commenting.

All Pages Blog Attachments Comments Restrictions Mail Space
View Delete Add Delete Add Delete Add Delete | Add Delete Add/Delete Delete  Export Admin
Oown
Anonymous %] %] %] [ x] %] a [ x] a a a %] %] a a

Edit Permissions

Assign space permissions

To add a new user or group to the permissions list, search for either a group or user in their respective
sections and choose Add. The group or user will appear in the list of groups; select the specific permissions
you'd like to apply then choose Save all. You can bulk assign or revoke permissions by selecting Select All
or Deselect All.

o There is no way to change permissions for multiple spaces at once. Permissions are managed on a space
by space basis. However, your Confluence Administrator is able to set default space permissions, which will
apply to any new spaces.

Default Space Permissions # Edit Permissions

These are the default permissions that will be assigned to groups when someone adds a new space. The 'confluence-administrators' group always
has all permissions for all spaces, and any permissions set for it here will be ignored.

All Pages Blog Attachments Comments Restrictions  Mail Space
View Delete Add Delete Add Delete Add Delete Add Delete Add/Delete Delete = Export Admin
Own
confluence-
o ] © B8 © a ® a8 © a a8 a o %]

users
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To set the default space permissions:

1. Goto

> General Configuration > Space Permissions.
2. Choose Edit Permissions.

Default permissions are configurable for groups only, not for individual or anonymous users.

Revoke space permissions

To remove a user or group from the space permissions list, deselect all the checkboxes for that user or group
and save the changes. The user or group won't appear in the list once you save.

Manage and recover space admin permissions

If you're a Confluence Administrator and a space admin accidentally denies all admin access to a space, so
that nobody has access to administer that space any more, you are able to recover those permissions for
them.

To recover Space Admin permissions:

1. Goto

> General Configuration > Space Permissions.
2. Locate the space in the Individual Spaces list and choose Recover Permissions.

You can then choose Manage Permissions, and add any other appropriate permissions to the space.
Requests to recover permissions are recorded in the Confluence audit log.

Users with System Administrator permissions are able to manage permissions for all spaces, they do not
need to first recover permissions.

Individual Spaces

These are the current wiki spaces.

Name Key Operations
Design Team AUDIT Manage Permissions
Software project SCRUM Manage Permissions

Make a Space Public

If you want to share your space with people who are not logged in to Related pages:

Confluence (anonymous users), you can make your space public. . Gi
ive

Access to

. . . Unlicensed
@) Making a space public does not let you choose who you want to share it Ussare (e

with — a public space can be viewed by anyone inside or outside of your JIRA

organization. Service

Desk

In order to make a space public, your administrator must first turn on the global permission for
anonymous access.

This permission doesn't automatically grant anonymous users permission to see any of the content
on your site, but it does need to be turned on to give space admins the option of granting anonymous
users access to their space.
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To make your space public:

1. Go to the space and choose Space tools > Permissions from the bottom of the sidebar.

2. Choose Edit Permissions.

3. Scroll down to the Anonymous Access section and select the specific permissions you'd like
anonymous users to have.

4. Save All to apply the changes.

Anonymous Access

If your Confluence site is public, you can grant permissions to people who are not logged in. Anonymous users can be granted almost any
permission, but we recommend you limit this to viewing and commenting.

All Pages Blog Attachments Comments Restrictions Mail Space

View Delete Add Delete Add Delete Add Delete | Add Delete Add/Delete Delete = Export Admin
Own

Anonymous v
Select All

Save all Cancel

ﬂ You can't grant space administration or page restriction rights to anonymous users.

I If your Confluence administrator turns off anonymous access to your site, users who are not logged in will
no longer be able to see any spaces. However, all logged in users (regardless of their group membership)
will be able to see all spaces that have granted space permissions to anonymous users.

Auditing considerations
There are some additional things to be aware of if you grant the Add page permission to anonymous users.

You won't be alerted, when closing the editor or publishing a page, if the only unpublished changes on the
page were made by anonymous users. This means a logged in user may inadvertently publish changes they
were not aware had been made to the page.

The changes themselves are visible in the page, but the usual warning dialog will not appear if the only
people to have made changes were not logged in.

If there are unpublished changes from both logged in users and anonymous users, the warning dialog will
appear, but only the logged in users will be listed in the dialog. Changes made by all users (including
anonymous) will be included if you view the changes from that dialog.

Give Access to Unlicensed Users from JIRA Service Desk
If you're using Confluence as a knowledge base for JIRA Service Desk, you

can choose to allow all active users and customers (that is, logged in users Related pages:
who do not have a Confluence license) to view specific spaces. This can * Make a
only be turned on via JIRA Service Desk. Space
When a space is accessible to all active users, you'll see the following Public

message in the space permission screen.
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Permissions = Restricted Pages

" Any active user can view this space

Any active user can view pages in this space, including users who don't have a Confluence license. Tt
enabled through JIRA Service Desk so people can view knowledge articles when raising a help reques

Edit this permission

ﬂ This permission overrides all existing space permissions, so any logged in Confluence user will also be
able to see the space (regardless of their group membership).

You can edit this permission at any time to revoke access to a space, but it can only be re-enabled from JIRA
Service Desk.

Active users who don't hold a Confluence license have very limited access to Confluence. They can view
pages, but can't like, comment, edit, view the dashboard, use the space directory, see user profiles or search
your full site.

See Use JIRA applications and Confluence together for more information about JIRA Service Desk
integration.

Organize your Space
Here's a few tips that'll help you organize your space

so that everyone can find what they're looking for On this page:
and stay on top of what's important to them. * How do | organize content within
my space?

® Pages and blogs
Configure the sidebar
‘- Using Labels
R S o | keep my space tidy?
’ @ Create a set of g_uidelines
e @ @ ® Use page blueprints
. o . ! Create from template macro
. ' 10 L Create your own page
JO templates
i & S o | help my team stay on top
NP ! t's important?
@ """"" ) \\ R BRhEt EEREEEES My Spaces
L o AP & Save for later
L Watch a page, blog or
"""" Eﬂ @ space

| ®* @mentions

How do | organize content within my space?

Pages and blogs
Everything you create in Confluence, from meeting

notes to retrospectives and everything in
between, takes the form of either pages or blogs.

® Your homepage will be the first thing that visitors to your site see, so to help them find relevant
content, start by curating your homepage with useful macros and including information about what is

in your space. See Set up a Space Home Page for more information.
® If you're creating content that is specific mainly to the current time-frame, and isn't going to change
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over time, create it as a blog post. Your blog displays as an infinite scroll, so it surfaces the latest
news and visitors just need to scroll down if they're interested in older content.

® If you're creating content that you want to last, and possibly evolve over time, then create it as a page.
Pages nest, so every page can have its own child pages, which lets you organize your content into
categories and subcategories.

Configure the sidebar
You can Configure the Sidebar to make it easier to navigate through your space.

® The space shortcuts section of the sidebar lets you link to important content. You can use this to
highlight pertinent pages within your space, related content from other spaces, or to external content
that is relevant to your space.

®* The navigation display lists all of the pages in your space in either a page tree or child pages format. If
you only want some content to be visible in the sidebar, you can hide the navigation display and put
the pages you want to remain visible under Space shortcuts instead.

The Beginner's Guide to
*
Confluence

() Pages
Blog
Questions
Calendars
SPACE SHORTCUTS
Tag your space with these labels
Groups of users
Emergency contacts
List of Confluence Administrators - co...
PAGE TREE
Get started in 5 steps
When to create a space
What should you put in your space?

Making all your content easy to find

Screenshot: My Spaces in the dashboard

Using Labels

Labels are keywords or tags that you can add to pages, blog posts, and attachments.

® Define your own labels and use them to categorize, identify, or bookmark content in Confluence. For
example, if you assign the label ‘accounting' to all accounts -related pages on your site, you'll then be
able to:

a. Browse all pages with that label in a single space or across the site.
b. Display a list of pages with that label.
c. Search based on that label .
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® Use the Content by Label Macro to create a table of contents for your space that is organized by label
categories.

® Labels aren't exclusive, so you can have as many labels as you want on a page. The page will then
appear under each of those categories. See Use Labels to Categorize Spaces for more information.

How do | keep my space tidy?

If you have lots of people creating in the same space, things can get messy fast. You can prevent this by
taking a few easy steps.

Create a set of guidelines

® | et your collaborators know about what parent pages to create their child pages under, so no content
gets lost or misplaced.

® Decide on standard labels to add to pages, blogs, and attachments so all content gets neatly
categorized.

® Add a link to this in the Space Shortcuts section of the sidebar so that it's easy to find.

Use page blueprints

Blueprints are templates that come with formatting, macros and sample content. You can customize these
Blueprints for each space. Everything created from a Blueprint will have it's own index in the sidebar, so for
example if you use the Meeting Notes Blueprint , you can select 'Meeting Notes' in the sidebar to see a list of
all the meeting notes in your space.

Create Filter Help
Select space Teams in Space v Parent: Meet the SeeSpaceEZ Team
& Blank page Blog post
§ Start with a blank page. Share news and announcements with your team.
—

Calendar
Track leave, meetings, releases, and other
important team or project dates.

Ask a question
Get answers from experts in your company.
Discuss and vote on the best answer.

File list
Upload, preview and share files with your team.

Decision
Record important project decisions and
communicate them with your team.

How-to article

1=
- J Pecidedo olon b oloan acdidosos fon aonenlabiooa o

<:~®Ey,

i) (2 @

JIRA report

O osemos anion to DA fnfrmmnntiom fo aooibo caad

Add or customise templates for the selected space Close

Screenshot: Page Blueprints

Create from template macro

Make things simpler for other contributors by using the Create from Template Macro . The Create from
Template Macro lets you put a button on a page that links to a specific template of your choice. When the
button is clicked, the macro opens the editor, ready to add a new page, and adds content to that page based
on the given template.

Create your own page templates
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Create your own templates for any content that you want formatted the same way every time. For example, if
you have to create a regular report tracking the same criteria, create a template with headings, variable
dates, tables, and spaces for any graphics, so that each time all you have to do is input the new data instead
of creating the whole report from scratch.

How do | help my team stay on top of what's important?

If you've got a lot of content on Confluence, staying on top of everything may seem a little daunting — but
these features will help your team save and track all the content they care about.

My Spaces

Add any spaces that you want to be able to navigate to easily to your list of ‘My Spaces'. This list can be
found under your dashboard and in the Space Directory, and you can also use the Spaces List Macro to
display it on a page or blog.

To add a space to your list of 'My Spaces', either navigate to that space or find it under the Space Directory,
and select the star icon next to the Space Name. To remove it from the list, just select the star icon again.

MY SPACES All
¢d)) The Beginner's Guide to Confluence
@ Confluence Latest

Q IT - Documentation

@ Confluence Docs

Screenshot: My Spaces in the dashboard

Save for later

If you only want links to certain pages or blogs rather than a whole space, you can choose Save for laterand
these will appear on your dashboard and under your profile. You can use the Favorite Pages Macro to
display a list of all of everything you've saved for later.

# Edit 77 Save for later @ Watch 2 Share wee

Screenshot: Save for later

Watch a page, blog or space

If you want to keep track of all the changes made to a page, blog, or space, you can also watch them.
Watching any content means that you will receive email notifications for all edits, deletions, attachments or
comments made to that content.

® To watch a page, navigate to the page you want to watch, then choose Watch > Watch page, or if
you want to watch the whole space, select Watch all content in this space .

® To watch a blog, navigate to that blog and choose Watch this blog .

® To stop watching something, deselect the relevant tick box.
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You can also manage watchers for your own space. This is useful when, for example, you're creating a new
project, and want the team members on that project to stay notified of its progress. Go to any page in that
space and choose Watch > Manage Watchers, then add or delete any names under 'Watching this space'.

# Edit 77 Save for later | © Watching | 2 Share  **°

You are watching this page

Receiving email updates about changes to this
page.

Watch page

Watch all content in this space

Cus  Manage Watchers

Screenshot: Watching a page

@mentions

Use @mentions for any work where you need someone else's input or want to assign someone a task.
Mentioning someone works like a tag; they'll immediately receive a notification that they've been mentioned,
and can click through to that page or blog. If you mention someone when creating a task, it'll assign that task
to them and they'll also be able to find it under their profile.

You can use this in place of emails — if you want someone to look something over, add in additional
information, or approve anything, simply put that work on Confluence and assign it to them as a task. They'll
be able to make any changes or comments within Confluence and let you know when they're done by
mentioning you back.

Set up a Space Home Page
When you create a space, Confluence automatically

creates a home page for that space. Spaces created On this page:

with a blueprint come with a ready-made home page * Create a kick-ass home page
populated with useful macros and sample content * Top macros for common types of
specific to the blueprint's use case. spaces

However, even if you've started with a blank space, ® Setup your personal space home
you can still customize your home page to make it pELE

easier for everyone using that space to navigate ® Setanother page as your home

their way around and find useful content. L=
Related pages:

® Organize your Space

Create a kick-ass home page

® What is this space about?
Your home page is the first page visitors will see when they visit your space, so it helps to include
some information about what the space is about, and what you're working on. You can use the Info,
Tip, Note, and Warning Macros to create a colored box in which to put this information.

® What is in this space?
You can use the Content Report Table Macro to create a table of contents for your space. You can
also set this macro to only display content with a particular label, so if you would like only some
content to display, you can do this by adding that label to only those pages and blogs you want listed
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on your home page.

® QOrganize your space with labels
You can organize content in your space with labels, so that for example, if you have a Learning and
Development space, you can create different labels for online learning resources, upcoming
workshops, and training strategy. You can then use the Labels List Macro to create a list of those
labels to make it easy for visitors to your space to find the content relating to each of those topics.

® Add asearch box so that it's easy to find content within your space
The Livesearch Macro allows you to add a search box to a Confluence page, and you can set it to only
find content within your space.

® Keep everyone updated about the latest changes within your space
If it's important for your visitors to know about the latest changes to your space, you can use the Rece
ntly Updated Macro to display a list of the most recently updated content. You can set the space
parameter to show this for just your space, or, if you have related spaces, to show the most recently
updated content across all of those spaces as well.

® Using JIRA? Create and display your JIRA issues on Confluence
If your Confluence site is connected to a JIRA application, you can both create and display your JIRA
issues without having to leave Confluence using the JIRA Issues Macro. You can connect Confluence
to any JIRA application, including JIRA Software and JIRA Service Desk.

= :{,EOH"UEI‘ICE Spaces ~ People Questions Calendars Create  ***

Pages o O
0 IT - Documentation *
Documentation
@ Pages Created by Des, last modified a minute ago
Blog
Questions
Calendars
SPACE SHORTCUTS
Here you can add shortcut links to the
most important content for your team or
project. Configure sidebar.
PAGE TREE
Graphic assets @ Welcome to the Documentation home page! The Documentation Team is part of the IT team and we write up release notes and in-app copy for all of our software.
Image alt-text guidelines Here you'll be able to find writing guidelines, style guides, publishing step-by-steps, a complete list of all feature releases ever writien up, and a compendium of all the in-
1X Toolkit
Language and speliing guidelines
Publishing guidelines
Style Guide
Q
Browse by topic Recently updated articles Other L
A-Z 3 Documentation . Atla
a minute ago - updated by Des - view change « Wh:
assets (3 Language and spelling guidelines « Dict
documentation 4 minutes ago - created by Des = The
graphics () Image alt-text guidelines
guide 4 minutes ago * created by Des
guides
\anguage % Publishing guidelines
g g 5 minutes ago - created by Des
publishing
styla (3 1X Toolkit
5 minutes ago - created by Des
@ Graphic assets
6 minutes ago * created by Des
¥ Space tools ~ « 3 Style Guide
S minutes ann « created by De

Screenshot: Space Home Page

Top macros for common types of spaces

Team Spaces:

® Introduce the team: The User Profile Macro displays a short summary of a given Confluence user's
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profile with their role, profile photo and contact details.
® Share news and announcements with your team: The Blog Posts Macro displays a stream of your
latest blog posts so your team can easily see what's been going on.

Knowledge Base:

® Have external content that you need on your page? Embed online videos, slideshows, photo
streams, and more, directly into your page with the Widget Connector Macro.
®* Put your own multimedia content onto the page: The Multimedia Macro embeds attached video,

animation, and other multimedia files on a Confluence page.
® Create an index of all your content: The Page Index Macro creates a hyperlinked alphabetical index

of all page titles within the current space.

Planning/Project:

® Keep track of everyone's tasks: Use the Task Report Macro to display a list of tasks on a page.
Filter the tasks by space, page, user, label, created date and more.

® Is your project on track? The Status Macro displays a colored lozenge (a rounded box) that is useful
for reporting project status. You can choose the color of the lozenge and the text that appears inside

the lozenge.
® | et everyone see where you're going: The Roadmap Planner Macro creates simple, visual timelines

that are useful for planning projects, software releases and much more.

Using Macros

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to
see a list of suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog
window will open, where you can edit the parameters of the macro.

Set up your personal space home page

Whether you're using your personal space as a sandbox to draft and test content, a portfolio to show off what
you're working on, a home base to navigate to your content in other spaces, or something completely
different, these are some macros that should help you use your space more effectively.

® Use the Favorite Pages Macro to create a list on your home page of all the pages you've saved for
later, so you can easily navigate back to any of them.

® Use the Content by User Macro to keep track of all the current pages, comments and spaces you've
created so you can find everything you've been working on in one place.

® Use the Task Report Macro to keep track of all tasks assigned to you, and tick them off as you finish

them.
® Use the Recently Updated Dashboard Macro to keep track of all the content across your Confluence

site that you're interested in - the Dashboard lets you choose which spaces, users, blogs, pages or files
you would like to keep updated about.

Set another page as your home page

If at any point you decide that you would like another page within your space to be your home page, you can
easily change this from the Edit Space Details tab.

To edit a space's detalils:

1. Go to the space and choose Space tools > Overview from the bottom of the sidebar.

2. Choose Edit Space Details.
3. Enter the page you want use in the Home page field then choose Save.
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Space Details = Delete Space

Edit Space Details

Name: The Beginner's Guide to Confluence

Description: = A few easy tips to get you on your
way to becoming a Confluence god!

Status: Current

4pr

Home page: The Beginner's Guide to Confluence

The page that displays when users navigate to this space.
< K

I You can change the home page, hame and description of your space, but you are not able to change the
space key.

Use Labels to Categorize Spaces

If you've got lots of related spaces, you can use labels to group them On this page:
together into categories in the Space Directory.

® Categorize

For example, if you're in an IT team who work on a number of projects, each a space

in a different space, you could label each space 'IT-projects-open’. Then in * View

the Space Directory you could select IT-projects-open to see all your current spaces in

IT project spaces. a category
. . ® Remove a

You can add as many space categories to a space as you need, so that if, space from

for example, two different teams are working on a project together, you can a category

add labels for both teams and space will appear under both categories.

. Related pages:
Labels are easy to add or remove, so if your needs change, you can always pag

recategorize your spaces. ®* Add,
Remove
and
Search for
Labels

Categorize a space

You need space administrator permissions to add categories to a space.

1. Go to the space and choose Space tools > Overview from the bottom of the sidebar
2. Choose Edit next to Space Categories.
3. Under Space Categories, enter your category name and choose Add.
Alternatively, choose a category in the list of Suggested Space Categories.
4. Choose Done.
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Add a space description
Help make it easier to find the right space within a category by adding a description to your space:

1. Go to the space and choose Space tools > Overview from the bottom of the sidebar.
2. Choose Edit Space Details.

3. Under the Description field, type a short description to tell visitors what your space is
about, then choose Save.

View spaces in a category

To see what spaces are in a category, choose Spaces > Space directory in the Confluence header, then
select one of the categories from the list.

Space Directory

All Spaces Documentation
Site Spaces Space Description Categories
Personal Spaces

9 Confluence Latest Documentation for the latest version of the Gonfluence wiki: Installation Guide, User Guide, Admin Guide and other technical documentation documentation
My Spaces

Archived Spaces |14}  Diagrams, Infographics and Screenshots A repository for graphic assets used in our documentation documentation

CATEGORIES & International Translations Translating our documentation for international consumption documentation

Confluence

Hint: Your space administrator can organise spaces into categories. Learn more.
Documentation

Screenshot: Space Directory

You can also view spaces by category by using the Spaces List Macro and filtering by category.

Head to My Spaces in the Space Directory to see all your favorite spaces. When viewing a space,
you can choose the star icon next to the space title in the sidebar to add it to My Spaces so that it's
easier to find later.

Remove a space from a category

1. Go to the space and choose Space tools > Overview from the bottom of the sidebar
2. Choose Edit next to Space Categories.
3. Under Space Categories, choose the x icon next to each category that you want to remove.

Space Details = Remove Space

Space Categories

Space Categories will appear inside the categories tab on your dashboard and as tabs in the space directory
They can be used to group together related spaces

Labels confluence = development =

Add

Screenshot: Space categories

I If you remove all spaces from a category, the category will no longer appear in the Space Directory.
There's no way to bulk remove a category, but you can choose the category in the Space Directory to find all
the spaces it appears on, and then remove it from each space.
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Customize your Space

Make your space stand out from the crowd by Related pages:
customizing its appearance.

® Changing the Look and Feel of
If you have space admin privileges, you can change Confluence

the color scheme for your space, add your own
space logo, choose what shows up in your space's
sidebar, or use Atlassian Marketplace themes to
change the whole look of your space.

® Styling Confluence with CSS

® Configure the Sidebar

® Edit a Space's Color Scheme
® Apply a Theme to a Space

® Customize Space Layouts

= XConfluence Spaces- People Questions Calendars Create ===

Pages o 0 # Edit 17 Saveforlater € Walching [ Share

e Workplace Experience 37
Workplace Experience
(31 Pages Created by Des, last modified less than a minute ago
R Blog
2) Questions
=) Calendars
SPACE SHORTCUTS
*| Upcoming Events
#| Working Rights
Time Logging (D Welcome to the home of the Workplace Experience Team.

We're here to make your everyday AWESOME. We organise your lunches, fitness classes, special events and activities, keep the office supplied, and are constantly thinking

PAGE TREE
of new ways to make working here even better.

Grants and Funding
|
Workplace Policies Check out the links below to find out more!

What we're all about

We honestly believe that if we make your day better and more enjoyable, you'll be more productive, creative, and innovative.

Our mission

Make our workplace a safe, comfortable environment that everyone enjoys being in. Ve want fo support you and help you feel both challenged, stimulated, and fuffilled. We think
that by coming up with ideas like having fully stocked showers with a towel service, we're making your life easier and giving you less to worry about.

i The team | Quick Links 1 Upcoming Events
| | [
1 New employee? Start here! ' i 126 May 2016 The Biggest Morning Tea! Come
I [ H i along to the Hall of Justice to get your bake on, eat
+ Policies H
H : on, or just bask in the atmosphere.
Funding and Grants 1
Des H H |
_____________________________________________________ : Workplaca Experience !} (131 May 2016 Bring your snake/ferret/[insert other !
i Social Clubs 1 i unusual pet] to work day! We have dogs around the
&% Snara tonle . | '
https://des jira-dev. wikifdis i ions/all?sr H office all the time so we thought it was anly fair that
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e Workplace Experience 77
Workplace Experience
(3 Pages Created by Des, last modified § minutes ago
3\ Blog
Questions

Calendars
SPACE SHORTCUTS
*| Upcoming Events
Working Rights
Time Logging ® Welcome to the home of the Workplace Experience Team.

We're here fo make your everyday AWESOME. We organise your lunches, filness classes, special events and aclivities, keep the office supplied, and are constantly thinking
of new ways to make working here even better.

Q Check out the links below to find out more!

PAGE TREE
Grants and Funding

.
Workplace Policies What we're all about

We honestly believe that if we make your day better and more enjoyable, you'll be more pi , crealive, and innovative.

Our mission

Make our workplace a safe, comfortable environment that everyone enjoys being in. We want fo support you and help you feel both challenged, stimulated, and fulfilled. We think
that by coming up with ideas like having fully stocked showers with a towel service, we're making your life easier and giving you less to worry about.

i The team i Quick Links {1 Upcoming Events
H | HE
i : New employee? Start here! i 126 May 2016 The Biggest Morning Tea! Come
HE | [r—— H 1 along to the Hall of Justice to get your bake on, eat
i i ! Policies H . .
i H H ' i on, or just bask in the atmosphere.
H H ‘ Funding and Grants : H
Des : : . i H
_____________________________________________________ : Workplace Experience ' 1 7131 May 2016 Bring your snakefferret/finsert other
! Social Clubs i | unusual pst] to work day! We have dogs around the
4F Space tools - « || office all the time so we thought it was only fair that

Configure the Sidebar

If you have administration permissions for a space,
you can customize the space's sidebar to have its

On this page:

own logo, change the way the hierarchy is displayed, * Change the space name and logo

and add shortcut links to help navigate to important * Configure the sidebar links

content quickly. ® Adding custom content to a
sidebar

To start configuring the sidebar, choose Space
tools > Configure sidebar. Related pages:

® Edit a Space's Color Scheme
Change the space name and logo ® Organize your Space

To change the space name:

1. Choose
¥ i

next to the space name.
2. Type in a new space name and Save.
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Confluence Docs
Change space name

and logo
Pages
Blog Drag to reorder
: ) shortcuts
7] Questions
Calendars

Space shortcuts

Hide pages, blogs,

Click "Add link" to add links to the shortcuts or navigation
sidebar. display options
Add link

Navigation display options

Child pages
© Page tree

Done

To change the space logo:

1. Choose the

next to the space name.

Choose Upload an image.

Select an image from your computer.

Adjust the size of the image to fit within the highlighted circle.
Choose Save.

aprwd

Things you should know:

® Space logos are 48px x 48px. Logos smaller than these dimensions will be centred with whitespace
around them.

® You can only change the space logo for a site space. For your personal space, your profile picture is
used as the space icon.

® The space logo in the default theme is always round. This cannot be changed.

Configure the sidebar links

® Choose the icons to show or hide pages, blogs, shortcuts or navigation options.
For example, if you want your space to be used primarily as a blog you can hide the 'Pages’ link.

® Add--ons such asTeam Calendars for Confluence Server may add other links in this section of the
sidebar and you can also show or hide these.

® Choose Add link to add a shortcut link to the sidebar. This could be a link to an important page for
your team, or to an external site.

® Drag links to reorder them within each section (you can't move a link from one section to another).

Change the navigation display options
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® Choose Child pages to see the current page and its children in the sidebar.

® Choose Page tree to see the page tree for the entire space, expanded to the current page.

® You can also choose to completely hide the navigation display options and instead add the pages you
want to visible as shortcut links. Alternatively, you can remove the sidebar navigation altogether and
use a Page Tree Macro or Children Display Macro on your homepage for navigation instead.

Adding custom content to a sidebar

You can further customize a sidebar using wiki markup to add custom content.

To add custom content to your sidebar:

1. Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar.
2. Choose Sidebar, Header and Footer.
3. Enter your custom content in the Sidebar field.

The sidebar, header and footer fields all use wiki markup, check our guide to wiki markup for help, or check
out some common customizations below.
~ Add a search field to your sidebar...

To add a search field to the sidebar add the following wiki markup for a search macro in the Sidebar field.

For the Livesearch Macro macro:

...................................................................................................................................................................

...................................................................................................................................................................

~ Add a panel with some content...
To add a panel with some custom content to the sidebar add the following wiki markup for the Panel
Macro in the Sidebar field:

...................................................................................................................................................................

{panel } This is sone custom content to appear in the sidebar{panel}

~ Add your own page tree to replace the default page tree...
To hide the default page tree and add your own, with additional parameters:

1. Add the wiki markup for the Page Tree Macro in the Sidebar field.
The following example includes parameters to expand the top three levels of the page tree by
default and include an Expand All and Collapse All link above the tree.

........................................................................................................................................................

2. Goto Space Tools > Configure sidebar.
3. Use the Show and Hide icons to hide the default page tree from the sidebar.

Edit a Space's Color Scheme

Spaces inherit the global color scheme by default, but if you have admin Related pages:
permissions for a space, you can jazz it up with your very own customizable )
color scheme. ¢ Configure
the
To change the color scheme for a space: Sidebar
L)
1. Go to the space and choose Space tools > Look and Feel from the ?Egz:to
bottom of the sidebar a Space
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N

Choose Color Scheme

3. Choose Select next to a scheme listed under Custom Color
Scheme (if not already selected)

4. Choose Edit

5. Enter standard HTML/CSS2 color codes or use the color-picker

[HH]|

to choose a new color from the palette provided

Customizable Elements

The color scheme allows you to edit the colors of Ul elements including the top bar, tabs and backgrounds.
Some Ul elements below are for specific themes, and color changes may not take effect for other themes.

Top Bar - the top navigation bar background

Top Bar Text - the text on the top navigation bar

Header Button Background - buttons on the top navigation bar (e.g. Create button)

Header Button Text - the text on buttons on the top navigation bar

Top Bar Menu Selected Background - background color of top navigation bar menu items when
selected (e.g. spaces)

Top Bar Menu Selected Text - text color of top navigation bar menu items when selected
Top Bar Menu Item Text - text on top navigation bar drop down menus (e.g. help or cog)
Menu Item Selected Background - highlight color on top navigation bar drop down menu items
Menu Item Selected Text - text color on highlighted top navigation bar drop down menu items
Search Field Background - the background color of the search field on the header

Search Field Text - the color of the text in the search field on the header

Page Menu Selected Background - the background color of the drop down page menu when
selected

Page Menu Item Text - the text of the menu items in the drop down page menu

Heading Text - all heading tags throughout the space

Space Name Text - the text of the current space name located above the page title

Links - all links throughout the space

Borders and Dividers - table borders and dividing lines

Tab Navigation Background - the background color of the tab navigation

Tab Navigation Text - the text of the tab navigation when highlighted

Tab Navigation Background Highlight - the background color of the tab navigation when
highlighted

® Tab Navigation Text Highlight - the text of the tab navigation elements when highlighted

Screenshot: Editing the color scheme
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Custom Colour Scheme

Edit

Top Bar [}

Top Bar Text
Header Button Background -
Header Button Text
Top Bar Menu Selected Background -
Top Bar Menu Selected Text
Top Bar Menu Item Text [}
Menu ltem Selected Background -
Menu Item Selected Text
Search Field Background
Search Field Text
Page Menu Selected Background -
Page Menu ltem Text [}

Heading Text [}

Space Name Text [
Links [}
Borders and Dividers
Tab Navigation Background -
Tab Navigation Text
Tab Navigation Background Highlight [

Tab Navigation Text Highlight

Reset Save Cancel

A custom colour scheme which can be edited.

The following colours can be customised for this colour scheme.

#205081
#FFFFFF
#357280
#FFFFFF
#3B73AF
#FFFFFF
#333333
#3B73AF
#FFFFFF
RGBA(0, 0, 0, 0.2)
#FFFFFF
#3B73AF
#333333
#333333
#999999
#357280
#CCCCCC
#3B73AF
#FFFFFF
#205081

#FFFFFF

H B B B B B B B B B B B B B B B B B B B

1]

Selected

Handy Hint

If you mess things up, just choose Reset then try again.
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Apply a Theme to a Space

Themes are used to change the appearance of your space. Confluence Related pages:
comes with two themes - the default theme and documentation theme, or ]
your Administrator can download and install other themes from The * ?Eg%g‘?oa
Atlassian Marketplace. a Site
Once a theme is installed it can be applied to the whole site or to individual * Customize
spaces. LT
Space
To apply atheme to a space: 5 =i
1. Go to the space and choose Space tools > Look and Feel from the Space's
bottom of the sidebar Color
You'll need Space Admin permissions to do this. Scheme
2. Choose Themes and select a theme option. ® Configure
3. Choose Confirm. the
Sidebar

What is the global look and feel?

When a new space is created, whichever theme is applied to the whole site will be applied by default to the
new space. This is the global look and feel, and any changes made globally will flow through to all spaces
that inherit the global look and feel.

If a space has its own theme applied, or if changes have been made to customize the look and feel of the
space, it will no longer inherit changes from the global look and feel.

If you want to go back to inheriting the global look and feel choose Global look and feel from the Themes p
age.

Documentation theme migration FAQ

As previously announced, the documentation theme is not available in Confluence 6.0. We know you'll have a lot

of specific questions, so we've created this FAQ to help you prepare for upgrading to Confluence 6.0.

If you have further questions, you can ask them at the bottom of the page and we'll do our best to provide an
answer.

What does the default theme look like?

How can | check if | am using the documentation theme in my space?
How can | check if the documentation theme is being used anywhere in my site?
What will happen to my theme customizations during the upgrade?

Will my space break after the upgrade?

Can | add custom content to the sidebar, header and footer globally?
Can | still use macros in my sidebar, header or footer?

Where should | add custom content to the sidebar, header or footer?
How do | turn off the Pages and Blogs shortcuts at the top of the sidebar?
Can | edit the default theme's sidebar globally?

| want to see the page tree, not child pages. how do | do this?

Where is Space Administration and Space Operations?

Do | have to use wiki markup in the sidebar, header, and footer?

Can I hide or change the space logo appearance?

Can | hide the built in page tree and insert my own?

How can | make my page titles wrap in the sidebar?

Can | change the order in which things appear in the sidebar?

Can | still use the space jump macro?

Why don't child pages appear below the page?

Can | restrict search to just this space?
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®* How do | view the pages in my space alphabetically?
® What will happen if | import a space that uses the documentation theme?

What does the default theme look like?

Here's an example of the documentation theme, and default theme with the same custom content side by side:

= XoConfluence Spaces- People Browss ~ Create

Not sure where to start? .
Sample Space
Read the Getting Started guide first Sample Space Home
» Meeting notes b Created by Rach Admin [Administrator], last modified 2 minutes ago
» Project Roadmap

Survey results

= X.UConfluence Spaces~ Pecple  Greate

o— Q- -
Sample Space
Sample Space Home

D Pages Crealed by Rach Admin [Administrator), last modified 6 minutes ago

R\ Blog
SPACE SHORTCUTS
:) Meeting notes

Not sure where to start?

Read the Getting Started guide first

PAGE TREE
» Project Roadmap

> Meeting notes

Survey results

1. Documentation theme: with custom sidebar content.
2. Default theme: with the same custom content in the sidebar.

How can | check if | am using the documentation theme in my space?

The easiest way to check whether your space is using the documentation theme is to look for a Browse menu in
the header, near the Create button. (If you're using the default theme already, you'll see a Space Tools menu at
the bottom of the sidebar instead.)

How can | check if the documentation theme is being used anywhere in my site?

There's no simple way to see a list of spaces using the Documentation theme in Confluence itself, however if
you have a very large site, your Confluence Administrator can use the following query to get a list of spaces
directly from the database.

..............................................................................................................................................................................

SELECT *

FROM BANDANA B, SPACES S

WHERE B. BANDANAKEY=' at | assi an. confl uence. t hene. setti ngs’
AND S. SPACEKEY=B. BANDANACONTEXT

AND B. BANDANAVALUE LI KE (' %docunment ati on% )

ORDER BY S. SPACENANME;

This query will only find spaces that are explicitly using the documentation theme. It doesn't include spaces
using the global look and feel (these spaces automatically change when you change the Site Theme, you wont
need to change the theme space by space).

What will happen to my theme customizations during the upgrade?

During the upgrade we'll automatically turn on the default theme for any spaces that currently use the
documentation theme. If you've customized the documentation theme (by adding wiki markup to the sidebar,
header or footer) we'll take this wiki markup and drop it into the sidebar, header and footer in the default theme.

The default theme adds some new sections to the sidebar, such as links to pages, blogs and space shortcuts.
You can choose to hide these - head to Space Tools > Configure Sidebar and use the

button to hide any items you don't want to see.
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Will my space break after the upgrade?

This depends on the amount of customization you have. In most cases your space sidebar may look a little
different but the changes shouldn't be dramatic.

If you've used CSS to change the appearance of your space (either in the space stylesheet or by using the
Adaptavist Content Formatting macros like {style} and {div} in the sidebar, header, or footer of the
documentation theme), you may need to make a few changes to some class names in your CSS to get your
space looking right. For example, if you specified #spl i tt er - si debar in the doc theme, you'll need to use .
acs- si de- bar for the default theme.

If you have customized default theme layouts through the Confluence Ul, you may find that your space looks
strange or broken when the default theme is re-applied to spaces previously using the documentation theme.

If you experience problems, you'll need to reset the broken layouts.

~ Reset customized layouts through the UL...

This method will only work if you have more than one theme available in your site. You'll need System
Administrator global permission to do this.

1. Switch to another theme temporarily.
If you're unable to use the space navigation, use this URL, replacing YOURSPACEKEY with the space
key for the space.

http://<yoursite>/spaces/ chooset hene. acti on?key=YOURSPACEKEY

2. In the space administration options go to Layouts (if available) or use the following link, replacing YO
URSPACEKEY with the space key for the space.

http://<yoursite>/spaces/|istdecorators. acti on?key=YOURSPACEKEY

3. Choose Reset Default next to any template that have been customized.
4. Return to the Themes page and try applying the default theme again.

Layouts can also be customized for the entire site - head to

> General Configuration > Layouts if you need to reset the layout for the entire site.

~ Remove customized layouts in the database...

If you're unable to reset the layouts via the Confluence Ul, you can remove the affected layouts directly in the
database. Be sure to take a full database backup before you try this.

First, use the following query to identify customized layouts:

Sel ect *
FROM DECORATCOR
ORDER BY SPACEKEY

Then, you can selectively remove records for spaces that are affected.

Can | add custom content to the sidebar, header and footer globally?

Yes. Head to

> General Configuration > Sidebar, Header and Footer. All spaces that use the global look and feel will
inherit your custom content. Any custom content added to the sidebar, header and footer in a particular space
will override any custom content added globally.

Can | still use macros in my sidebar, header or footer?
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Yes! If a macro worked correctly in the documentation theme it'll work in the default theme too.

Where should | add custom content to the sidebar, header or footer?

You can add custom content to the sidebar, header and footer in each space individually (Space Tools > Look
and Feel > Sidebar, Header and Footer) or globally (

> General Configuration > Sidebar, Header and Footer).

Confluence displays global custom content in all spaces, except where a space has its own custom content
defined (space custom content overrides global custom content). This behavior applies field by field, so a space
can display a combination of custom content. For example you could define the content of a footer globally, and
content of a header in each space individually, or only in some spaces.

How do | turn off the Pages and Blogs shortcuts at the top of the sidebar?

Go to Space Tools > Configure Sidebar and use the

icons to hide any items you don't want to see.

Can | edit the default theme's sidebar globally?

No. You can add custom content to the sidebar globally, but showing and hiding sections of the sidebar, setting
space logos, and adding shortcut links are done on a space by space basis.

I want to see the page tree, not child pages. how do | do this?

Head to Space Tools > Configure Sidebar and select Page Tree in the navigation options. The default for all
new spaces is Page Tree.

Where is Space Administration and Space Operations?

Instead of choosing between Space Operations and Space Administration, the documentation theme has a
single Space Tools menu that lets you jump right to Permissions, Content Tools, Look and Feel, or Integrations.

~ Here's a handy table of where to find everything in your new theme...

Old Space Operations location New Location in the sidebar
Browse > Pages Pages on the sidebar or Space Tools > Reorder pages
Browse > Blogs Blogs on the sidebar
Browse > Labels Click a label on any page, then use the
L ~
menu to see all labels, popular labels or pages from other
spaces
Browse > Space Operations > Space Space Tools > Overview
Details
Browse > Space Operations > Orphaned Space Tools > Content Tools > Orphaned Pages
Pages
Browse > Space Operations > Undefined Space Tools > Content Tools > Undefined Pages
Pages

Browse > Space Operations > Attachments = Space Tools > Content Tools > Attachments

Browse > Space Operations > PDF, HTML, Space Tools > Content Tools > Export
XML Export

Browse > Space Operations > RSS Feeds  Space Tools > Content Tools > RSS Feeds
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Browse > Space Operations > Watch this
space

Browse > Space Operations > Watch this
blog

Browse > Space Operations > Remove
from My Spaces

Browse > Space Admin > Space Details

Browse > Space Admin > Space
Categories

Browse > Space Admin > Templates
Browse > Space Admin > Delete Space
Browse > Space Admin > Trash

Browse > Space Admin > Permissions
Browse > Space Admin > Restricted Pages
Browse > Space Admin > Application links
Browse > Space Admin > Themes

Browse > Space Admin > Color Scheme
Browse > Space Admin > PDF Layout
Browse > Space Admin > PDF Stylesheet

Browse > Space Admin > Change Space
Logo

Browse > Space Admin > HipChat
Integration

Pages > Watch this space (or use the Watch button on any
page)

Blogs > Watch this blog (or use the Watch button on any
blog post)

Use the

icon in the sidebar (or in the space directory)
Space Tools > Overview

Space Tools > Overview

Space Tools > Content Tools > Templates
Space Tools > Overview > Delete Space

Space Tools > Content Tools > Trash

Space Tools > Permissions

Space Tools > Permissions > Restricted Pages
Space Tools > Integrations > Application Links
Space Tools > Look and Feel > Themes

Space Tools > Look and Feel > Color Scheme
Space Tools > Look and Feel > PDF Layout
Space Tools > Look and Feel > PDF Stylesheet

Space Tools > Configure Sidebar then choose the edit icon
on the space logo

Space Tools > Integrations > HipChat

Do | have to use wiki markup in the sidebar, header, and footer?
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Yes. Our main focus when adding this feature was to help people move from the documentation theme to the
default theme with a minimum of effort. Keeping these fields as wiki markup means that your existing
customizations can be pasted straight in.

Can | hide or change the space logo appearance?

You can upload any image to use as your space logo, but you can't change how it appears in the sidebar (it's
always round and always at the top).

Can | hide the built in page tree and insert my own?

Yes! If you want to have complete control over how the page tree appears in your sidebar you can hide the built
in page tree, and then add a Page Tree macro { paget r ee} in the sidebar custom content.

How can | make my page titles wrap in the sidebar?

Page titles do not wrap in the sidebar of the default theme (regardless of whether you're using the built in page
tree or have added a { { paget r ee}} macro as custom content). There's no way to change this.

Can | change the order in which things appear in the sidebar?

You can change the order of some items in the sidebar, such as the shortcuts, but the order of the sections
themselves can't be changed. Anything that has a

icon can be moved.

Custom content appears above the page tree. You have the option to hide the built in page tree, and then add it
back in the custom content area using wiki markup. This can be useful if you want more control over the order of
the page tree and your custom content.

Can | still use the space jump macro?

No, the space jump macro was provided by the documentation theme and will not be available once the
documentation theme is removed. If you've used this macro on a page or in the header or footer of a space, it
will show the following error after the upgrade unknown macro: {spacej unp}.

To find out whether the Space Jump macro is used on any pages in your site, enter macr oName: spacej unp int
o the search bar. All pages containing the macro will be returned (it won't search the sidebar, header or footer
unfortunately).

Why don't child pages appear below the page?

The default theme does not list child pages below the sidebar, but you can achieve a similar result by adding a C
hildren Display macro to the footer.

Can | restrict search to just this space?
No, that is one of the features we removed with the documentation theme.

One workaround is to add a Livesearch macro to the sidebar or space homepage. Use @el f in the spaces
parameter to restrict the search to the current space.

How do | view the pages in my space alphabetically?
The default theme does not have an option to view all pages in your space alphabetically.

What will happen if | import a space that uses the documentation theme?

You should have no problems importing the space, but it will have the default theme applied and any wiki
markup customization in the theme will not be automatically migrated to the default theme. Before exporting the
space you should copy the wiki markup contents of the sidebar, header, and footer fields and keep it so that you
can add it back in manually after you've successfully imported your space.

Customize Space Layouts

You can modify Confluence's look and feel by
editing the layout files. This page tells you how to
customize the layout files for a space. You'll need
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the system administrator global permission plus spa

ce administrator permission for that space. Related pages:

People with system administrator permissions can : Customize your Space

also customize the layout of the entire Confluence . Apply a Theme to a Space
site. For more information, see Customizing Site and Styling Confluence with CSS

Space Layouts. Site layout customizations modify
the default layout of all spaces in the Confluence
site.

Any space layout customizations will override the
equivalent site customizations.

If you modify the look and feel of Confluence by following these instructions, you'll need to update
your customizations when you upgrade Confluence. The more dramatic the customizations are, the
harder it'll be to reapply your changes when upgrading. Please take this into account before
proceeding with any customizations.

For more information on updating your customizations, please refer to Upgrading Customized Site
and Space Layouts .

Confluence is built on top of the Open Source SiteMesh library, a web-page layout system that provides a
consistent look and feel across a site. SiteMesh works through 'decorators' that define a page's layout and
structure.

To edit the layout of Confluence, you will need to modify these decorator files. A decorator file is a .vmd file
and is written in a very simple programming language called Velocity. Learn more about Velocity. Once you
become familiar with Velocity, you can edit the decorator files to personalize the appearance of Confluence.

The decorator files in Confluence are grouped into the following categories:

® Site layouts: These are used to define the controls that surround each page in the site. For example,
if you want to make changes to the header and the footer, you will need to modify these layouts.

® Content layouts: These control the appearance of content such as pages and blog posts. They do
not change the way the pages themselves are displayed, but they allow you to alter the way the
surrounding comments or attachments are shown.

® Export layouts: These control the appearance of spaces and pages when they are exported to
HTML. If you are using Confluence to generate a static website, for example, you will need to modify
these layouts.

Learn more about using decorators.
To edit a decorator file:

1. Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar
2. Choose Layout (Layout is displayed only if you are a Confluence system administrator.)
You'll see a list of the layouts for the space
3. Click Create Custom to edit the default vmd file
This will open up the vmd file in edit mode. If you only want to view the vmd file, click View Default.
4. Make any changes and click Update

Screenshot : Edit Layouts Example
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Content Layouts

Content layouts control the appearance of content such as pages and blog posts: they don't change the way the
pages themselves are displayed, but they allow you to alter the way the surrounding comments or attachments

are shown.
Decorator Operations
Space Layout < default > - Create custom - View Default

Controls how a space is displayed.

Page Layout < default > - Create custom - View Default
Controls how a page is displayed.

Archive a Space

Archiving a space is useful when you have content that is no longer On this page:
relevant, but you still want the option of accessing it at a later date. Archived i
spaces are less visible, but still available on your site. Archiving a space is * Archive a
easy to undo - you can make a space current again at any time. space
® The effect
of
Archive a space archiving a
space
1. Go to the space and choose Space tools > Overview from the ® Change a
bottom of the sidebar space from
2. Choose Edit Space Details. archived to
3. Select Archived in the Status dropdown menu. current

4. Choose Save.
Related pages:

® Delete a
Space

® Export
Content to
Word,
PDF,
HTML and
XML

The effect of archiving a space

If a space is archived, that space and it's contents:

® Won't appear in the Confluence search results unless you select Search archived spaces. This
option is hidden if there are no archived spaces.

® Won't appear on any dropdown menus, including the Confluence quick navigation, which drops down
when you enter text in the search box.

® \Won't appear in the general spaces lists in the Space Directory, but will instead appear under the Arc
hived Spaces list. It will, however, still appear under any categories it was labeled with.

® Won't show up in activity streams when updated.

® Won't appear on your dashboard.
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Search

CONTRIBUTOR

IN SPACE

Search archived spaces

These functions remain available for archived spaces:

® You can view the content as usual, by following a link or typing in a URL belonging to the archived

space.

® You can edit the content as usual, as determined by the space permissions.
® RSS feeds, watches and notifications remain active.

@ Archiving a space has no effect on search results of external search engines. For example, a public space
will still appear in Google search results.

Change a space from archived to current

Through the space directory:

aprwDdRE

Go to Spaces > Space directory in the header.

Choose Archived Spaces on the left.

Find your space and click the ) on the right.

Choose Edit Space Details.

Change the Status from 'Archived' to 'Current' and hit Save .

Through the archived space:

1.

wnN

If you know the space key, you can navigate straight to the archived space - htt p: // yoursi t e/ di
spl ay/ SPACEKEY

Choose Space tools > Overview from the bottom of the sidebar.

Choose Edit Space Details.

Change the Status from 'Archived' to 'Current' and hit Save.
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Space Details | Delete Space

Edit Space Details

Mame:  Demonstration Space

Description:

P
Current

Home page: | Welcome to Confluence

The page that displays when users navigate to this space.

oo R

Delete a Space
Deleting a space permanently removes the space and all of its contents,

including any calendars and questions linked to that space. Only someone Related pages:
with space admin permissions can delete that space. ® Archive a
I Deleting a space is permanent — it does not go to the trash and cannot Space

be undone. ® Export
Content to

If you're unsure about deleting a space, create an XML export of the space Word,

as a backup before proceeding. You can then restore the space from the PDF,

XML export file if you need to. HTML and
XML

To delete a space:

1. Go to the space and choose Space Tools > Overview from the
bottom of the sidebar.

2. Choose Delete Space.

3. Choose OK.

Space Details  Delete Space

Deleting a space will delete all its content (including pages, comments, attachments and blogposts)

A WARNING
This operation cannot be undone. Once the space is deleted, it cannot be retrieved. It will be gone forever.

Are you sure you want to delete this space with space key optio1460958858363 and name Adaptive user-facing solution?

OK | Cancel

Members of the conf | uence- admi ni st r at or s group can also delete spaces, including personal
spaces.

Export Content to Word, PDF, HTML and XML

You can export all or part of a Confluence space to various formats,
including Microsoft Word, HTML, PDF and XML.
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To use the space export functionality, you need the 'Export Space' On this page:
permission. See the guide to space permissions.
* Export
single
Export single pages to PDF pages to
PDF
If you need to send content to people who don't have access to Confluence, * Export
you can export a single page or blog post as a PDF. single
If you've got permission to view the page in Confluence, you'll be able to 5\73%5 0
export it in this way; go to the page and choose Tools > Export to PDF. * Exportto
Only published content is exported. This means you can create PDF exports HTML,
even while people are still working on the page. XML, or
PDF
When you export a single page to PDF, the PDF stylesheet customizations e Customizin
are applied, but any PDF layout customizations are not. To make your PDF g the
layout customizations apply to a single page exported to PDF, you'll need to appearanc
use the 'multiple page' method described below to export the single page. e of PDF
See Customize Exports to PDF. exports

Related pages:

® Customize
Exports to
PDF

Export single pages to Word

You can also choose to export single pages to a .doc file that can be opened in Microsoft Word.

If you've got permission to view the page in Confluence, you'll be able to export it in this way; go to the page
and choose Tools > Export to Word.

Only published content is exported. This means you can create Word exports even while people are still
working on the page.

Note that due to the format of this file, it can only be opened in Microsoft Word and is not compatible with
other applications such as Open Office, Libre Office or Google Docs.

Export to HTML, XML, or PDF

If you want to export a space — or selected pages in a space — to HTML, XML, or PDF, Confluence can
create a zipped archive of the HTML or XML files, or a single, downloadable PDF file.

PDF export is useful you're producing a printable user manual from your documentation space for example.
The HTML export can be used to convert your site content to a static website, and finally the XML export can
be used to import your space content into another Confluence space (running the same or later version of
Confluence).

To export pages to HTML, XML, or PDF:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Export
3. Select either HTML, XML, or PDF, then choose Next
4. Select either a normal or custom export for HTML or PDF, or a Full or Custom XML export:
® Normal Export (HTML and PDF) — to produce an HTML file containing all the pages that you
have permission to view.
® Full Export (XML) — to produce an XML file containing all the pages in the space, including
those that you do not have permission to view.
® Custom Export — if you want to export selected pages only, or if you want to exclude
comments from the export.
5. Choose Export

When the export process has finished, you can download the zipped archive or PDF.
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What's included in the export?

The following content is included in space exports.

Export type Pages Blogs Comments Attachments Unpublished changes

HTML Yes No Optional Yes No
PDF Yes No No Images only  No
XML Yes Yes Optional Yes Yes

Customizing the appearance of PDF exports

You can add a title page, table of contents, and customized headers and footers to the PDF output. For more
advanced customizations, you can apply Cascading Style Sheet (CSS) modifications. These customizations
are specific to each space, and you need the 'Space Administrator' permission to apply these customizations.
For more information, see Customize Exports to PDF.

Notes on PDF exporting

® To export a PDF containing international text, see Create a PDF in Another Language

® Confluence's PDF export feature is designed to handle a wide variety of content, but on rare
occasions the PDF Export process may fail due to an unrecognized customization. If that happens, the
PDF export screen will indicate the title of the page in which the problem occurred, to help you
diagnose the cause of the failure.

Notes on HTML exporting

® Inthe zip file, page attachments are placed in individual folders with names in the following format:
... \downl oad\ at t achment s\ XxxxxXxXx
where 'xxxxxx" is the page ID of the page containing the attachments.

® To customize the HTML output, you'll need to modify the file conf | uence-x.y. z-jar/com atl as
si an/ conf | uence/ pages/ Page. ht M export.vm To learn how to repackage this file, see How to
Edit Files in Confluence JAR Files

Notes on XML exporting

® You can only import a space into the same or later Confluence version. You can't import a space
into an earlier version.

® |f you're doing the export for backup purposes, consider another means of backup. See Production
Backup Strategy.

® |f you are running Confluence behind Apache HTTP Server and are facing timeout errors, please
consider creating the export directly from Tomcat, instead of going through Apache. This will speed up
the process and prevent timeouts.

® See Restoring a Space for notes on restrictions when importing a space into Confluence Server.

Customize Exports to PDF
Confluence administrators and space administrators
can customize the PDF exports for individual
spaces.

Please note:

® PDF customizations are unique to each
space.

® PDF customization only applies to space
exports (not single page exports via Tools >
Export to PDF)
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¢ Confluence's PDF customizations use a On this page:
combination of HTML and CSS (Cascading .
Style Sheets). ® Customizing the PDF Layout

* To achieve a particular requirement in the ® Setting a global PDF layout

exported PDF file, you make changes in one * ss,sgge]zgletcglpDF layout at
or both of the following:

* The PDF Layo%t, where HTML is used * Customizing the PDF Stylesheet
to define the structure of the exported ® Setting a global PDF
content, including features such as the Stylesheet
title page, headers and footers. ® Setting a space PDF

* The PDF Stylesheet, where CSS is stylesheet
used to define the style of elements in * Example Customizations
the exported content, such as page * Page Size

size and margins, font, color, and list ® Page Orientation: '
numbering. Landscape or Portrait

Page Margins

Page Breaks

Title Page

Table of Contents

Headers and Footers

Page Numbering

Wrapping Long Words
® General Formatting

®* Notes

For further customizations, see the Advanced PDF
Export Customizations page.

Related pages:

® Advanced PDF Export
Customizations

Customizing the PDF Layout
You can add your own HTML to customize the title page, page headers and page footers in the PDF output.

Setting a global PDF layout

1. Choose the cog icon

, then choose General Configuration under Confluence Administration
2. Choose PDF Layout. You can enter HTML and CSS that will be rendered on the PDF title page, as
well as page headers and footers.

Setting the PDF layout at space level

1. Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar You'll
need Space Admin permissions to do this.

2. Choose PDF Layout.

3. Choose Edit.

You can customize the HTML that is generated for the following areas when the space is exported to PDF:

®* PDF Space Export Title Page - title page.
® PDF Space Export Header — page headers.
® PDF Space Export Footer — page footers.

Enter your customizations into each text box as required. The PDF layout section accepts HTML code. You
can include inline CSS in the HTML too.

Customizing the PDF Stylesheet

You can adjust the appearance of the PDF pages by customizing the CSS in the PDF Stylesheet screen.

To get started, download the default CSS rules for the PDF stylesheet - confluencedefaultpdf.css.
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Any rule defined in this file can be customized and added to the PDF Export Stylesheet section. Your
customizations override any default CSS rule. If no customizations are defined, the default CSS rules will be
applied.

By default, the export does not include a title page, headers or footers. You can define these in the PDF
layout.

To customize the PDF Stylesheet:

Setting a global PDF Stylesheet

1. Choose the cog icon

, then choose General Configuration under Confluence Administration
2. Choose Look and Feel > PDF Stylesheet. The following screen allows you to enter and save CSS
code that will render content on each page.

Setting a space PDF stylesheet

1. Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar You'll
need Space Admin permissions to do this.

2. Choose PDF Stylesheet.

3. Choose Edit.

4. Enter your customizations.

The PDF Export Stylesheet field accepts Cascading Style Sheets (CSS) rules. The 'PDF Export Stylesheet'
page shows the current (e.g. customized) contents of your PDF stylesheet.

Example Customizations

This section provides examples of typical customizations that you can add. See also Advanced PDF
Customizations.

Page Size

The default page size is based on the location of your Confluence server. For example, if this server is
located in the US then the default paper size of your PDF export will be US Letter (8.5 inches wide by 11
inches long). If the server is located in Australia, the default paper size will be A4 (210 mm wide by 297 mm
long). More information about paper sizes can be found on Wikipedia.

To modify the page size to A4, edit the PDF Stylesheet to add a si ze property to the CSS@age rule, like
this:

CSS - PDF Stylesheet

@age
{
/[ *The A4 paper size is 210 mmw de by 297 mm | ong*/

size: 210mm 297nmm
}

Page Orientation: Landscape or Portrait

To change the page orientation of your PDF document, simply reverse the order of the values declared in the
@age rule's si ze property. The first and second values of this property represent the width and height of

the page, respectively.

For example, to generate PDF space exports in A4-sized landscape orientation, your @age rule might look
like this:
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.........................................................................................................................................................................

CSS - PDF Stylesheet

@age
{

/*A4-si zed pages in |andscape orientation are 297 mmw de by 210 nm
| ong*/
size: 297nm 210mm

Page Margins

To set all margins to 15 mm, with a paper size of A4, edit the CSS @age rule in the PDF Stylesheet, like
this:

.........................................................................................................................................................................

CSS - PDF Stylesheet

@age
{
size: 210mm 297mMm

mar gi n:  15mm

.........................................................................................................................................................................

.........................................................................................................................................................................

CSS - PDF Stylesheet

@age

{

mar gi n-top: 2.54cm
mar gi n-bottom 2. 54cm
margin-left: 1.27cm
margi n-right: 1.27cm

To set margins to provide a gutter for binding a printed document, use the : | eft and : ri ght pseudo-class
es, as follows:
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.........................................................................................................................................................................

CSS - PDF Stylesheet

@age :left

{

margin-left: 4cm
margin-right: 3cm
}

@age :right

{

margin-left: 3cm
margin-right: 4cm
}

@age :first

{

margi n-top: 10cm/* Top margin on first page 10cm */

Note the use of the : fi r st pseudo-class in the example above to define distinct margins for a cover or title
page.

Page Breaks

By default, Confluence pages are exported without page breaks, so that shorter pages will appear on the
same PDF page.

To make each Confluence page appear on a separate page in the PDF file, add the following rule in the PDF
Stylesheet:

.........................................................................................................................................................................

CSS - PDF Stylesheet

. pagetitle

{
page- br eak- bef ore: al ways;
}

Title Page

You can add a title page to your PDF document by adding HTML to the Title Page section of the PDF Layout
screen. The following example creates the title page and adds a title:

.........................................................................................................................................................................

HTML - PDF Layout: Title Page Section

<div class="fsTitl ePage">

<i ng src="/downl oad/ attachments/590719/titl epage. png" />
<div class="fsTitle">Planning for Confluence 4.0</div>
</ div>

Use CSS rules in the PDF Stylesheet to control the appearance of the title page and the title text:
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CSS - PDF Stylesheet

.fsTitl ePage

{

margi n-l eft: auto;

mar gi n-top: 50mm

mar gi n-ri ght: auto;
page- break- aft er: al ways

}

fsTitle
{

font-size: 42px;
font-wei ght: bol d;
margi n: 72px 0 4px O;
text-align:center;

}

Adding an Image to the Title Page

In the example above, the title page includes an image called 'titlepage.png’, centred in the middle of the
page. The "590719" in the sr ¢ attribute is the ID number of the page to which the image is attached.

Follow these instructions to include an image on your title page:

1. Attach the image to a Confluence page.

2. View the list of attachments on that page, then right-click the image and copy its location.

3. Paste the link into the appropriate src="" attribute in your PDF Stylesheet, as shown above.

4. Edit the image URL so that it is relative, by removing the first part of the URL before / downl oad/ . . ..

Table of Contents

By default, a table of contents will be generated after the title page, or at the beginning of the PDF document
if no title page is defined in the PDF Layout. To see the default CSS rules applied to the table of contents,
download the default CSS rules (confluencedefaultpdf.css) and examine the specific rules with t oc in their
name.

To make changes to the appearance of the table of contents, define CSS rules in the PDF Stylesheet.
Disabling the Table of Contents

To prevent the table of contents from being generated in your PDF document, add the di v. t oc- macr o rule
to the PDF Stylesheet and set its di spl ay property to none:

CSS - PDF Stylesheet

div.toc

{

di spl ay: none;
}

Changing the Leader Character in the Table of Contents

The leader character is used to link a heading in the table of contents with its page number. By default, the
leader character is the '.' (dot) character. Leader values of dot t ed, sol i d and space are allowed. You can
also use a string, for example | eader (". . . ").

To change the leader character to a solid line, modify the | eader () value on the cont ent property of the
CSS rule as follows:
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.........................................................................................................................................................................

CSS - PDF Stylesheet

span. tocl ead: before

{

content: |eader(solid);

Headers and Footers

You can add headers and footers to your PDF pages using the 'Header' and 'Footer' sections of the PDF Layout
screen. By default, headers and footers only apply to a space export and not to exports of single pages
(however, see Advanced PDF Export Customizations ). The following example adds a simple copyright notice.

HTML - PDF Layout: Footer Section
Copyright © 2017, Atlassian Pty Ltd.

Page Numbering

To add page numbering, you need to combine customized HTML in the PDF Layout with customized CSS in the
PDF Stylesheet.

1. PDF Layout HTML: In the Footer section (or the Header section), use an empty span element with a
unigue ID, for example pageNum to act as a place holder for the page number.

HTML - PDF Layout: Footer Section
<span id="pageNuni'/>

..............................................................................................................................................................

CSS - PDF Stylesheet

#pageNum bef ore
{

content: counter(page);

Analyzing the above CSS selector rule in more detail:

®* The #pageNumrule selects the HTML element with the specified ID of "pageNum®”, which is the span
element we created for the header or footer.

® The : bef or e part of the selector is a pseudo class that allows the insertion of content before the spa
n element is processed.

® The count er ( page) is a function that returns the current page number as its content.

® The cont ent property tells the CSS processor that dynamic content (that is, an incrementing page
number) is to be inserted at the span tag.

Wrapping Long Words

In order to break long words or words that are not separated by whitespace, add a selector to the PDF
stylesheet containing the wor d- wr ap property with a value of br eak- wor d:
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CSS - PDF Stylesheet

div
{
wor d-wr ap: br eak-word;

}

General Formatting

You can use the stylesheet to customize the output of just about anything else that will influence the look and
feel of the final document. This includes fonts, tables, line spacing, macros, etc. The export engine works
directly from the HTML output produced by Confluence. Therefore, the first step in customizing something is
to find a selector for the HTML element produced by Confluence or the Confluence macro. Then add a CSS
rule to the PDF stylesheet. Your customization will appear in the PDF export.

Notes

®* Demotion of heading elements: h1, h2, and so on. Due to the hierarchical manner in which a space
is exported, Confluence will modify the heading elements to generate a uniform appearance for the
entire space export. This means that headings will be demoted. This will affect the application of
custom PDF Stylesheets. It is possible to calculate the amount by which a heading will be demoted in
order to have the correct CSS styling applied. A heading will be demoted by the value of its depth in
the export tree. A page at the first level will be demoted by 1 (all <h1> elements will become <h2> ele
ments, and so on). A page at the second level will be demoted by 2, and so on.

® Atlassian support for PDF customization is limited. We support the mechanism for customizing the
PDF layout with HTML and CSS, and we will help if the mechanism is broken or does not work as we
say it should in our published examples. But, since custom HTML and CSS offer potentially limitless
possibilities, Atlassian will not support issues that are caused by or related to PDF customizations.

Advanced PDF Export Customizations

This page provides information about ‘advanced’
PDF export customizations. These expand upon the
regular customizations described in Customize
Exports to PDF.

I The information below is for advanced users. Be
aware that the advanced customizations described
below require knowledge of certain parts of
Confluence, and of CSS and HTML. Customizations
are not supported by Atlassian, so our support
engineers won't be able to help you with these
modifications.

Header and Footer

Adding Headers and Footers to Single Page Exports

On this page:
®* Header and Footer
® Adding Headers and
Footers to Single Page
Exports
® Adding Images to Headers
and Footers
® |ncorporating Other Fonts
® Adding a Dynamic Title to the Title
Page
® Hiding Text from the PDF Output
® |ndexing
®* Notes

Related pages:

® Customize Exports to PDF
® Create a PDF in Another
Language

Single page exports don't support adding HTML headers and footers via the PDF Layout page, but you can
use CSS rules in the PDF Stylesheet page (Space tools > Look and Feel > PDF Stylesheet) to produce
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headers and/or footers for a single page export.

For custom headers, define any of the following rules within your @age rule: @ op- | eft, @ op-center, a
nd @ op- ri ght . These rules allow you to define the cont ent of the left-hand side, centre and right-hand
side of your page's header area, respectively.

For custom footers, define @ottom | eft, @ott om cent er and @ottomri ght rules within your @ag
e rule.

For example, the following rules add a document title at the centre of the header and a page number at the
centre of the footer:

CSS - PDF Stylesheet

@age
{

@ op-center

{

content: "Docunent Title Goes Here"; /* This is the content
that will appear in the header */
font-famly: ConfluencelnstalledFont, Helvetica, Arial,
sans-serif;
font-size: 8pt;
}

@ottomcenter

{

content: "Page " counter(page); /* This is the content that
will appear in the footer */
font-famly: ConfluencelnstalledFont, Helvetica, Arial,
sans-serif;
font-size: 8pt;
}

/* Any other page-specific rules */

Notes:

® Thefont-fam |y andfont-size properties ensure that the header and footer text is rendered in

the same default font style used for the body text, based on the default CSS rules.
® |tis not possible to use this method to insert images (stored as attachments within your Confluence
instance) into the headers and footers of single page exports.

Adding Images to Headers and Footers

To insert an image into the header or footer, add HTML to the Header or Footer section of the PDF Layout
screen.

The following example uses an HTML i ng element with sr ¢ attribute to add an image to the left of the
header. The sr ¢ attribute refers to an image attached to a Confluence page. The image element is usually
placed within a di v element container.
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HTML - PDF Layout: Header Section
<div style="margin-top: 10.0nmm">
<i ngy
src="https://confluence. atl assi an. com downl oad/ att achnent s/ 12346/ head
er-image. png" />
</div>

In the example above, the header includes an image called 'header-image.png'. The "12346" in the sr ¢ attrib
ute is the ID number of the page to which the image is attached.

Follow these instructions to include an image on your page:

1. Attach the image to a Confluence page.

2. View the list of attachments on that page, then right-click the image and copy its location.

3. Paste the link into the appropriate src="" attribute in your PDF Stylesheet, as shown above.

4. Edit the image URL so that it is relative, by removing the first part of the URL before / downl oad/ . . ..

Notes:

® This example uses an inline CSS property mar gi n-t op in the st yl e attribute to force the image
away from the top of the page by 10mm. This comes in handy when your header image is large
enough to touch or spill over the top of the page.

® Likewise, for footers, you can use the mar gi n- bot t om XXmmproperty to force an image away from

the bottom of the page by 'XX' mm.

® Very large images can spill over into the body of a page or alter the position of text or other elements
used within a header or footer. In such situations, it is recommended that you reduce the size of the
image and then attach it to your Confluence page again. If you prefer to keep the image size and want
to move the content lower instead, you can do so by configuring the mar gi n- t op properties in the @
age CSSrule.

® By default, a header or footer image is aligned to the left-hand side of the page. However, you can
align this image to the centre or right-hand side of a page by adding either the t ext - al i gn: cent er
ortext-align:right properties to your st yl e attribute. For example, to align the header image to
the right-hand side of the page, your st yl e attribute would look similar to this: st yl e="rmar gi n-t op
:10mMm text-align:right".

Incorporating Other Fonts

By default, Confluence provides Times New Roman, Helvetica or Courier fonts for use in PDF exports. You
can use your own fonts for PDF exports by declaring them in a @ ont - f ace CSS rule in your PDF

Stylesheet.

The following CSS rule example shows how to declare the Consolas font and apply it to some elements for
your PDF export:

CSS - PDF Stylesheet

@ont-face { src: url(file:///usr/share/fonts/Consolas.ttf);
-fs-pdf-font-enbed: enbed; } .code pre, .preformatted pre, tt, kbd,
code, samp { font-family: Consol as, nonospace; font-size: 9pt; }

The font path specified in the CSS must be the path to the font on the Confluence server.

Adding a Dynamic Title to the Title Page

When you export an arbitrary set of pages from Confluence, you may like to have a corresponding title added
to the cover (or title) page automatically. This can be done (in a somewhat irregular way) by using the top
level item from the default table of contents as the title. This method relies on having the exported pages
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structured as sub-pages of the top-level page. In other words, the pages to be exported should consist of a
page (at the top-level) and all of its child pages. The result is that the title that appears on the cover page
changes depending on the top-level page that is used for the export.

The CSS below moves, and styles, the top-level TOC item for use as the title on the cover page, and turns
off the leader and page number normally associated with this item in the TOC.

.........................................................................................................................................................................

CSS - PDF Stylesheet

.fsTitlePage { position:relative; left:0px; } /* Turn off the default
section nunbering for this TOCitem*/ .toclvlO:before { content:
&quot; &quot;; counter-reset: chapter 0; } /* Hi de the default page
nunbering for this TOCitem*/ .toclvl0O .tocnum{ display: none; } /*
Move and style this TOC item™*/ .toclvl0 { position:absol ute;

top: 250px; font-size: 42px; font-weight: bold; margin: 72px 0 4px O;
text-align:center; }

Hiding Text from the PDF Output

This section describes a way to hide text from your PDF export. In other words, you can have text on the
Confluence page that will not appear in the PDF export.

There are three steps:

1. Follow the instructions to define the NoPrint user macro.
2. Use the NoPrint macro to mark some text on a Confluence page.
3. Add the following CSS to your PDF stylesheet to make the PDF export recognize the NoPrint macro:

.........................................................................................................................................................................

CSS - PDF Stylesheet

.noprint { display: none ; }

Indexing

To obtain an index at the end of the exported PDF file, consider using the Scroll Wiki PDF Exporter plugin tha
tis produced by K15t Software GmbH.

Notes

If styling is not working as expected, it is useful to look at the intermediary HTML source to which the CSS is
applied. This intermediary HTML is created whenever you create an HTML export that contains multiple
pages, and is stored in the t enp directory in Confluence's home directory. For example:

[tenp/ ht M export-20110308- 154047- 1/ export-internedi at e- 154047-2. htm

Create a PDF in Another Language
To export a Confluence page written in a language
other than English, you'll need the necessary font for

that language. ® Export Content to Word, PDF,
HTML and XML

Related pages:

Upload a Font File to Confluence

1. Find the appropriate font file:
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S

Notes

®* Windows users:All font files in Windows are stored in a directory called:

C: \ W NDOW6\ Font s

® Unix users:All font files in Unix are stored in:

/usr/share/fonts

® Microsoft True Type core fonts such as Verdana can be downloaded from this page: http://coref
onts.sourceforge.net/
Copy the font file into a temporary folder, for example a folder on your desktop.
Choose the cog icon

, then choose General Configuration under Confluence Administration

then choose PDF Export Language Support.
Upload the file you copied in step 2.
Choose Install.

The only font files supported are true type fonts and true type collections. The accepted file extensions

are *.ttf and *.ttc.

Confluence can only store one font file at any one time. Please create a collection to install more than

one *.ttf files.

We recommend that you use Unicode font Verdana for correct character encoding and exporting to

PDF.

If the font file size is bigger than your current attachment size limit, you will not be able to upload it.

Please increase the attachment size limit temporarily and re-upload again. An improvement of the
CONFSERVER-24706

error messaging is tracked at |RESOLVED|

To make use of an installed font in your PDF Export style sheet (CSS) refer to it by the font-family

ConfluencelnstalledFont.

Pages and blogs

Pages and blog posts allow you to capture and share information in Related pages:
Confluence.
® Create and
Whether it's taking down some quick notes from a meeting, writing a require Edit Pages
ments page, or letting your teammates know about the company's latest ® Blog Posts
marketing push — you can create it as a Confluence page or blog post. ® The Editor
®* Page

Pages are great for when you want the information to last and evolve over

: . o . o Templates
time. If it's a point-in-time update or one-time communication then a blog o Delefe or
post is the way to go. These aren't hard-and-fast rules; they're just pointers -
to give you a place to start. Page
Each Confluence space, including your personal space, allows you to create ® Spaces

pages in it, and has its own blog where you can create posts. If you're not
sure what a space is, or what you can do with spaces, check out our page
on Spaces.

Take a look at the below pages to learn more about pages and blog posts in Confluence.

Create and Edit Pages
Blog Posts

The Editor

Move and Reorder Pages
Copy a Page
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Delete or Restore a Page

Add, Remove and Search for Labels
Drafts

Page Restrictions

Links

Anchors

Tables

Add, Assign, and View Tasks
Autocomplete for links, files, macros and mentions
Page Layouts, Columns and Sections
Create Beautiful and Dynamic Pages
Page Templates

Blueprints

Import Content Into Confluence

Orphaned Pages

Undefined Page Links

View Page Information

Page History and Page Comparison Views
Confluence Markup

Create and Edit Pages

Create a page On this page:
) ) . ® Create a
You can create a page from anywhere in Confluence; just choose Create in page
the header and you're ready to go. Pages are the place to capture all your e Edit
important (and unimportant) information; start with a blank page and use it together
like a word processor to add rich text, tasks, images, macros and links, or e Collaborat
use one of the useful blueprints to capture meeting notes, decisions, and e or restrict
more. ® Organize
and move
® Other page
actions
®* Not
es

If you want to quickly create a blank page, hit the Create button in the header; if you want to create a
page from a template, hit the Create from template button.

1. Create blank page
2. Create from template
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Create Filter Help

o—. Select space Teams in Space - Parent: Teams in Space Home.—e
%  Blank page
Start with a blank page.

Ask a question
Get answers from experts in your company.

Blog post
Share news and announcements with your
team

Decision
Record important project decisions and

PRGANENE2

Discuss and vote on the best answer. communicate them with your team.
—_—
File list How-to article
Upload, preview and share files with your team. Provide step-by-step guidance for completing a
task.
JIRA report Meeting notes
Macmeniininata DA infavemnntinem in anas: bo vand Dlan vimiie maantinman and ahava samtan sed
Add or customise templates for the selected space Close

1. Select space: choose the space where you'll create the content.
2. Page templates: create a page from a template or create other types of content.
3. Parent page: your page will be a child of this page.

Once you decide on a blank page or blueprint, you'll be taken straight into the Confluence editor. The editor
is where you'll name or rename your page, add the content, and format it to look great. When you've added
some content, choose Preview to take a peek at what your finished page will look like, and Publish when
you're ready to make it appear in the space.

After you save you'll see the page in 'view' mode. You can re-enter the editor any time by choosing Edit or
pressing E on your keyboard.

= XConfluence spaces- People Create +o+

Pages &' # Edit © Watch [2 Share +* @
Teams in Space
Teams in Space Home
@ Pages Created by Alana Grant, last modified by Admin Istrator on Jul 01, 2014
3 Blog
SPACE SHORTCUTS ® Welcome to your new space!

3 Meeting Notes Confluence spaces are great for sharing content and news with your team. This

is the home page for Teams in Space. Right now it shows recent space activity,
e—. Product Requirements but you can customize this page in anyway you like. Scan along the lefthand
Team Scrum Board side to see important pages in this space.
£ File Lists ‘You can customize the left navigation to fit your team.
PAGE TREE
> Meeting Notes . .
‘ Recent space activity Space contributors

> Product Planning

Admin Istrator
» Product Requirements ¥ * Ryan Lee (6 days ago)

[® We're colonising Mars e Alana Grant (7 days ago)
> Teams in Space PR created Aug 06, 2015 e Harvey Jennings (7 days ago)

Admin Istrator (19 days ago)
* File Lists *
5 Ryan Lee e Emma Paris (65 days ago)

= Meet the SeeSpaceEZ Team [ Summer Saturn Sizzle Blog . ...

Announcement updated Aug

o Ti i I
eam Sprint Calendar 03, 2015 + view change

[ Teams in Space Analyst
Deck.pdf commented Aug

£ Space tools ~ “ 03, 2015

1. Confluence header: create blank pages, pages from templates and visit spaces or your profile.
2. Space sidebar: access pages, blogs and administer the space.
3. Page tools: edit or share the page, watch it to get updates and perform more actions.

Another useful way to create a page is to use the Create from Template Macro. This macro allows
you to choose a page template, and adds a button to the page allowing one-click page creation. If
you want others to create pages using this template, this is a great option.
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Edit together

Need input from your team members? Multiple people can edit your page at the same time.

Hit the Invite button in the editor and either grab the link, or enter some people or groups to invite by email (t
hey need the appropriate Confluence and space permissions of course).

See Collaborative editing for all the ins and outs.

Collaborate or restrict

Once you've created a page, you can decide if you want to keep it private, using restrictions, or collaborate
on it with others using @mentions, sharing, and comments.

Organize and move

You can also organize pages in a hierarchy, with child and/or parent pages for closely related content. When
you navigate to a Confluence page and choose the Create button in the header, the page you're creating will
by default be a child of the page you're viewing. Have as many child pages and levels in the hierarchy as you
need to, and move pages if you want to change their location.

If you want to view all pages in a Confluence space, choose Pages in the sidebar.

Each time you create a page, you're creating it in a space. Spaces are containers used to contain
pages with related content, so you can set them up for each team in your organization, for projects, a
combination of both, or for any reason you want to group pages together. See Spaces for more
information.

Other page actions

Copy a page and its child pages

Delete a page or remove a specific version of a page

Monitor page updates and other activity through page notifications
View page history, and manage and compare versions of a page
Search page content, including attachments

Export pages to Word, PDF, HTML or XML

Like a page

I We recommend you don't use special characters in page or attachment names, as the page or
attachment may not be found by Confluence search, and may cause some Confluence functions to behave
unexpectedly.

If you rename a page, Confluence will automatically update all relative links to the page, except in
some macros. Links from external sites will be broken, unless they use the permanent URL. See Wor
king with Links for more information.

Notes

You may experience problems saving extremely large pages. Confluence can accept approximately 5mb of
content (not including attached files) which is roughly equivalent to 800,000 words. If you do experience
errors that indicate the page is too large to save, you should break up the page into several smaller pages.

Blog Posts

Blog posts are an easy way to share announcements, journal entries, status
reports, or any other timely information. Others can join in by commenting
on and/or liking your blog post and, if you get enough of either, your post
might make it to the popular feed on the dashboard!
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Each space in Confluence, including your personal space, has it's own blog. On this page:
To view a space's blog, go to a space and choose Blog in the sidebar. You'l ® Create a
see a list of the latest blog posts, and you can click through to earlier posts blog post
via the navigation area in the sidebar. ®* Move a
blog post
® Restrict a
Create a blog post blog post
® Delete a
You can follow the same process to create a blog post as when you create a blog post
Confluence page. * Exporta
1. Navigate to the space where you want to create your blog post blog post

2. Choose Create in the Confluence header and select Blog post )

3. Add your content and choose Publish Related pages:

® Subscribe
to RSS
Feeds
within
Confluenc
e

® Blog Posts
Macro

® Collaborati
on

®* Export
Content to
Word,
PDF,
HTML and
XML

You can create blog posts from the Dashboard, but you'll need to make sure
you choose the space it's going to appear in in the create dialog.

Blog posts can be attractive and engaging in the same way a page can be, so go ahead and add images,
YouTube clips (preferably of cats), and tables to your post to really grab your audience.

To create a blog post, you need the 'Add Blog' permission. See Space Permissions.

Move a blog post

If you create a blog post in the wrong space, or want to reorganize your spaces, you can move an individual
blog post to another space.

To move a blog post, go to the post and choose

ane

> Move and select the new destination space.

You'll need the 'Delete blog' permission in the current space, and 'Add blog' permission in the new
(destination) space to do this.

Restrict a blog post

You can restrict a blog post so that it is only available to specific users or groups. Blog post restrictions work
in the same way as page restrictions.

To restrict a blog post prior to publishing it, choose the Unrestricted button in the footer and apply your
restrictions. To restrict a blog post after publishing, choose

LE L]

> Restrictions and apply your restrictions.
Notes:

® Notifications are sent at the point a blog post is created - removing restrictions does not trigger a new
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notification.
® As a blog post has no parent, restrictions aren't inherited.

Delete a blog post

To delete a blog post, choose

ane

> Delete. Deleting a blog post follows the same rules as deleting a page.

Export a blog post

You can export individual blog posts to PDF. This is useful, for example, if you want to email an internal blog
post to people outside your organization.

See Export Content to Word, PDF, HTML and XML for more information on exporting blog pages to PDF.

The Editor

The Confluence editor is what you'll use to create and edit Confluence
pages, blog posts, and comments. You can enter content as you would in a
Word document, apply formatting, and embed other content and files on the

page.

Note: To edit a page, you need the 'Add Pages' permission for the space.
See space permissions. Someone may also apply page restrictions that
prevent you from editing the page.

Edit a page or blog post

You'll be taken to the editor whenever you create a new page or blog post,
or add a comment. To edit an existing page or blog post, choose Edit at the
top of a page or press E on your keyboard.

Confluence automatically saves drafts of your page as you work. If another
user begins editing the same page as you, Confluence will display a
message and will try to merge the changes when you save your page. To
see changes between different versions of the page, look at the history of
the page.

The editor

The editor allows you to enter or change the title of your page; insert content
including text, images, and links; and format your content using the toolbar.

If you're renaming your page, there are some things you should take into
account.

Paragraph ~ ~ B I U A~ %A~ = = E | F T OE

Demonstration Space / Pages / Welcome to Confluence % 4« @ e

o—
Capture the knowledge that's too often lost in email inboxes and shared network drives in
team, project, or department its own space with its own permissions and theme. Keep info

Create anything with a rich content editor in your web browser. Whether it's meeting notes
Confluence.Target feedback on any Confluence page or file — project plans, Office files, i
place, so you don't waste time connecting feedback in email with your work done elsewhe

1. Page content: add your page title and body text.
2. Page tools: add labels or restrict the page.
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m F & #@r +~ 9

On this page:

Edit a
page or
blog post

® The editor

Editor
toolbar
Restriction
s, labels,
and
notification
S

Things to
help you
work faster
Find and
replace
text

Invite
people to
edit with
you
Record
change
comments
and notify
watchers

Related pages:

® Tables

Page
Layouts,
Columns
and
Sections
Display
Files and
Images
Links

® Symbols,

Emoticons
and
Special
Characters

edge base articles - on the web so everyone can contribute. Give feedback on any Confluence page
ites.doc or messy track changes. Capture all the information that's scattered among email inboxes

its own space to store work. Confluence keeps everything organised and accessible.l

ved

What did you change?

Notify watchers

Preview Close
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1. Insert: add files, links, images, tables and macros
2. Notify: notify others and leave a comment when you change a page.

Editor toolbar

The editor toolbar is where you format your page layout and text, and add links, tables, images, attachments
and macros. You can also perform a find and replace, or get help using the editor by choosing the help icon

?

Screenshot: The editor toolbar

Paragraph - B I U A - A - = = i = = = = [m (SFiles &Lnk EBTable~ +lInset~ 9 O
Paragraph Strikethrough & Files and images
Heading 1 mo Space Home / Sal g hecript 2 Link

Heading 2 Superscript I Attachment
Heading 3 Monospace 0 Symbol

Heading 4 Clear formatting © Emoticon

1} Markup
Heading 5
= Horizontal rule

Heading & _ "
= Task list

Preformatted
@ User menticn

Quote
¥ JIRA Issue/Filter

@ Info
== Status

Gallery
= Table of Contents
=3 Team Calendar

2 Other macros

The Insert menu

The Insert menu is particularly useful. Use the Insert menu to include any of the following content types on
your page:

An image
A link to another Confluence page or external URL, or a link to an attachment or image
An emoticon or symbol, or a horizontal line

[}
[}
[}
® A macro (choose a specific macro, or Other Macros, from the Insert menu)

You can also use keyboard shortcuts to insert links, images, and macros. Try out the shortcuts listed below:

® Type [ (square bracket) to insert a link.
®* Type ! (exclamation mark) to insert an image or other media.
® Type { (curly bracket) to insert a macro.

Typing any of the above shortcuts will trigger the autocomplete functionality, prompting you with a list of
suggestions to finish off the entry. For more shortcuts, click the help icon

3
on the editor toolbar.

Restrictions, labels, and notifications

When editing a page, you may want to set restrictions on who can view or edit the page, or add labels to the
page to make it easily searchable.

Once you're ready to save, you can enter change comments to let others know what you've changed, and, if
you like, send an email notification to anyone watching the page.

Things to help you work faster

Auto-formatting
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You can type Confluence wiki markup directly into the editor to have Confluence auto-format your text as you
type. To learn more, choose help icon
>

in the toolbar, then choose Editor Autoformatting.

Autoconvert for pasted links

When you paste certain URLs into Confluence, the editor will analyze what you're pasting and automatically
convert it into something that will display well in Confluence. Examples include:

YouTube videos

JIRA issue queries

Google Maps

Confluence pages, blog posts, comments, user statuses, user profiles.
Shared screenshot links from Skitch

And more.

Drag-and-drop for external images and files

You can drag files, like images, multimedia, Office files and PDFs, from your computer and drop them directly
into the editor. The contents of the file will be embedded into the page or blog post.

Drag-and-drop within the editor

In the editor panel, you can drag an image or a macro from one location to another on the page. Hover your
cursor over the image or the macro placeholder and your cursor changes to a drag-and-drop icon

&

. Click the image or macro and drag it to a new location.

Keyboard shortcuts
To view the available keyboard shortcuts, choose the help icon
<@

in the editor toolbar.

Find and replace text

Click the
Q

icon on the toolbar, or use the keyboard shortcut Ctrl+F (Windows) or Cmd+F (Mac OS).

Search matches are highlighted in yellow. You can step through the results one by one, replace the matching
text strings one by one, or replace all matching strings at once. Find and replace works only within the
current page.

Invite people to edit with you

Speed up your draft and review cycles and get input from the right people by inviting them to edit the page
with you. The page does not need to be published.

Hit the
+

button in the editor and either grab the link, or add people, groups or email addresses to invite, just like shari
ng a page.

Sharing or inviting someone to edit a page or blog post does not automatically grant any permissions - they
will still need the appropriate Confluence permissions to access Confluence and view or edit the page.
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Up to 12 people can edit the same page at the same time (your administrator can change this limit).

Record change comments and notify watchers

When you finish editing a page, you can add a comment to let others know what you changed. Type a short
message in the change comments field in the footer. The comment will be visible in the page history.

If you want to send a notification to people watching the page, select Notify watchers. The change comment
will be included in the notification email.

The Notify watchers checkbox remembers your last selection for each page, so if you choose not to notify
people, the checkbox will be deselected for you next time you edit that page.

What did you change? « Notify watchers Preview Close
Symbols, Emoticons and Special Characters
You can add various symbols and special characters to Confluence pages. On this page:
You can also use them in other places that display content, such as blog ® |Insert
posts, comments, and the dashboard welcome message. symbols
and
Insert symbols and special characters special
characters
1. Edit the page (if you're viewing the page, press E on your keyboard) ¢ Insert
2. Choose Insert > Symbol . emoticons
3. Choose a symbol to insert it Prevent
emoticons
Screenshot : Available symbols from
appearing

Related pages:

® The Editor

Symbol

& " ¢ EL ¥ O® ™ % . T TR

c oo » 0T e > 2 - — 7 7 o\ v

i i T —x=/ x 123 YN[y black
. £=M-na o ++ AAAAA
AECEEEEI T T 1T PNOOOOHO®GBCE
SUUUUY Ybaaaaaaeseceédeée

i i T 7T 6/ 0668 060 s 0 U000y Dp
yvABIAEZHO!I KAMNZ ONNPZIT

Yo XWQOQapyde I nB 1 kK h pveEo

TP COTU@XWYWW T = | <0 &ve

Cancel

Insert emoticons

There are two ways to add an emoticon, or smiley, to your page.
By choosing an emoticon from those available:

1. Choose Insert > Emoticon
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2. Choose an emoticon to insert it

By typing a character combination:
You can insert emoticons by typing commonly-used character combinations. This table shows the emoticons
(and other icons) available in Confluence, and the character combinations that create them:

) (n) (on) (off) (Y
* ¢n (9 (b (v

N 0 0 & 6

(?) <8 </3

Prevent emoticons from appearing

To undo the conversion of a character combination into an emoticon, press Ctrl+Z (Windows) or Cmd+Z (Ma
C).

To prevent Confluence from converting text to emoticons automatically, disable 'Autoformatting' in your user
profile. See Edit Your User Settings.

Collaborative editing

Collaborative editing takes teamwork to the next level by letting you and your team work together in real
time on software requirements, meeting notes, retros, and any other Confluence page.

See who's editing a page with you and their cursor position, and see changes as they happen. Colorful
avatars show who is editing right now, and grey avatars show people who have made changes and then left
the editor. Hit

+

to invite more people to edit with you.

Changes are automatically synced so that everyone editing sees the same thing. And, because we're saving
all the time, there's no need to manually save. Your only decision is when to publish the changes.

= X,Confluence Spaces ~ Pecple Questions Calendars Create s

Paragraph ~ | B T U A~*aA~ 2 E M B &2 F ¥ = M @ £ @~ +~ 9 O Q <> ?

Teams in space / Pages / Teams in space / Launch pad product requirements S  off r'aﬁl ria -.-e
Launch pad product requirements

Background
——
o We rEad away to launch rockets into space, 5o that we can have you know... Teams in Space

User story Description Priority
As an operator | want to have a launch pad The launch pad will be used to blast rockets into space  1- MVP
As an operator | want to have a cancel button  This will be a manual override 1- MVFP
As an operator | want to have a turbo button This will enable super fast launches into space 2 - Nice to have
(@ Ready to go What did you 3¢ Notify watchers Preview [I.LEICE Close

1. Invite more people: see who is editing the page and invite others to edit with you.
2. See what they're doing: watch others edit the page in real time.
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Up to 12 people can edit the same page at the same time. Your administrator can change this limit using a sy
stem property.

Once you and your team are done editing you can:

® publish (or update if the page has previously been published) to make everyone's changes visible
® close the editor and keep everyone's work to finish later
® close the editor and discard everyone's changes.

We'll warn you if you're about to publish (or discard) other peoples' changes along with your own.
Resuming your work

One of the wonderful things about collaborative editing is that you don't need to publish a page before you're
ready.

Here's how you can resume working on your unpublished changes:

® If the page has been published previously, all you need to do is hit Edit and any unpublished changes
will be ready and waiting.

® |f you created the page, and it has never been published, head to Profile > Drafts to resume working
on the page.

® |f someone else created the page, and it has never been published, you'll need the URL of the editing
session to resume working on it (as the page only appears in the original creator's Drafts list).

So, what’s new with collaborative editing?

% 9 @

Real-time collaboration No more merge conflicts No need to save. We're on it

Work together with your team and  Collaborative editing uses shared Changes are auto-saved as you
see their changes in real time. drafts, so there's no need to make them, so now your only
merge because you're all working decision is when to publish.
on the same page.

Things you should know

Limited content auditing Changes in drafts aren’t versioned

We don't yet have the same auditing capabilities We’'re saving all the time in collaborative editing, but
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with collaborative editing. All page changes are we don’t save versions in a draft. When restoring an
currently attributed to the person that publishes the earlier page version, you can only roll back to
page, rather than the person who made each published versions (the page draft is deleted when
specific change. you restore a previous version).

Changes to drafts

Collaborative editing introduces a new type of draft, a shared draft. Previously when you edited a page but
didn't save it, Confluence would create a draft that was only visible to you (a personal draft). Now,
Confluence creates a shared draft whenever anyone edits a page. All page editors work on this same shared
draft, and it exists until someone publishes the page.

When you publish a shared draft, you're publishing all the changes you have made and changes made by
others. Publishing creates a version in the page history.

If you discard a shared draft, you're discarding all changes, including changes made by others. Because
shared drafts aren't versioned, there's no way to get a discarded draft back.

Accessing your personal drafts

Your personal drafts are still available, but are no longer editable. If you edit a page, you'll see the shared
draft of the page, not your personal draft (if one exists).

If you need to get content out of your previous personal drafts head to Profile > Drafts, locate your page and
copy the contents.

© Watching Personal Space

Recently Viewed

Profile
Tasks

into gear for A Saved for later

hal features or fi Watches

Network
Settings

Atlassian Marketplace

Log Out

Move and Reorder Pages

The easiest way to set a page's location in Confluence is to navigate to the
space where you want the page to live and, if necessary, find its parent
page and choose Create. Sometimes though, you'll want to change a page's
location either while you're creating it, or after it's been created.

You can also move and reorder pages in the page tree (hierarchy).

Set page location or move a page

1. Do either of the following:
®* While creating a page — choose the location icon
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UIE On this page:
at the top of the page * Set page
® Once apage is created — choose location or
oo move a
> Move page
2. Use the tabs on the left of the 'Set Page Location' dialog to help you ® Reorder
find the new space and/or parent page for your page (the Current pages
location and New location breadcrumbs at the bottom of the dialog within a
indicate the current parent page and new parent page) space
3. Select Reorder if you want to move the page to a different position * Notes
amongst the child pages (when you choose Move in the next step, about
you'll be able to reorder the page) permission
4. Choose Move (If you're reordering the child pages, choose the new S

position for the page and choose Reorder)
Related pages:

® Create and
Edit Pages

®* Copya
Page

® Delete or
Restore a
Page

® Orphaned
Pages

The page — along with any attachments, comments, and child pages — is moved to your chosen location.
Confluence will automatically adjust all links to the moved pages, to point to the page(s) in its new location.

When completing the New parent page field, you need to select the page suggested by
Confluence's autocomplete. Typing or pasting the page name (or using your browser's autocomplete)
won't work.

Screenshot: Setting the location or moving a page
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Set Page Location Help
Advanced Specify the new parent page for this page and its children by space and title.

Search

Recently Viewed New space: | Confluence Development

Browse

New parent page:  Confluence Development home

Start typing a page title to see a list of suggestions.

Current location: Dev Team ' Dev Team * Product requirements * Requirements page

New location: Confluence Development * Confluence Development home

Reorder = Move @ Cancel

Reorder pages within a space

You can change the location of a page within its space, and reorder pages in the hierarchy. This allows you
to:

® Move a single page, or a family of pages, to a different parent within the space.
® Reorder pages that are children of the same parent.

All links to the page are maintained. When you move a parent page, the entire hierarchy of child pages will
move too.

To move or reorder a page:

1. Go to the space and choose Space tools > Reorder pages from the bottom of the sidebar
2. Expand the branches to locate the page you want to move.
3. Drag the page to a new position in the tree.

Alternatively, you can choose to order a group of child pages alphabetically by choosing the Sort
Alphabetically (A-Z) icon. The Sort Alphabetically (A-Z) icon only appears next to the parent page if the
page family is currently sorted manually.

If you change your mind, you can use the Undo Sorting icon to revert back to the previous manual page
order. This option is only available immediately after sorting the page, while you're still on the Reorder
Pages tab, and haven't performed any other action.
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v [2) Confluence User's Guide %]+

v [2) Getting Started with Confluence ¥) ~—@

[Z) Dashboard

[2) Keyboard Shortcuts

1. Alphabetical: sort all child pages alphabetically.
2. Undo: undo sorting.

Notes about permissions

To move a page, you need the following permissions:

® 'Add' permission on the page you're moving, and

® 'View' permission on the page's parent page. If you're moving the page to a different parent, you need

‘View' permission on the new parent.
To move a page into a different space, you also need:

® 'Delete’ permission on the space you're moving from, and
® 'Add' permission on the space you're moving to.

If the page has restrictions, and you want to keep the page restrictions in the new location, you'll also need

'Restrict’ permission on the space you're moving to. Alternatively, remove the page restrictions before

performing the move.

Copy a Page

If you need to duplicate the contents of a page, the easiest way is to copy
the page. You can copy pages into the same space or to a different space.

When you copy pages into the same space, you'll need to rename them, as
two pages with the same name can't live in the same space. We give you
some handy tools to help rename your pages during the copy process.

o You need the 'Create Page' permission to copy pages. See space
permissions for more information.

Copy pages

To copy a single page:

1. Go to the page and choose

> Copy.
2. Choose a Location for the new page.
3. Hit Copy.

On this page:

¢ Copy
pages

® Copy the
contents of
an entire
space

Related pages:

® Create and
Edit Pages

® Move and
Reorder
Pages

Confluence will open the copy of the page in the editor and name it 'Copy of [original page title]". You can

then rename the page and work in the editor like any ordinary page.
To copy a page and all its child pages:

1. Go to the page and choose

> Copy.
2. Choose a Location for the new pages.
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3. Select Include child pages.
4. Use the options provided to customize your new page titles.
You can add a prefix, replace a keyword or phrase in existing titles, or both. The preview will give you
a good idea of what your new page hierarchy will look like, and warn you if there are any problems.
5. Deselect any items you do not want to copy over (attached files, labels, restrictions)
6. Hit Copy.

You'll find a link to your newly copied pages in the copy complete message.

I Note: It's not possible to selectively copy multiple pages. You will be copying the entire hierarchy.

What's included when you copy a page?
Here's some more info on what's included when you copy a page.

Single Page and its child pages

page
Page contents (text, Yes Yes
macros)
Attached files and Yes Optional - if you choose not to include attachments, you may see
images ‘unknown-attachment' errors on the copied pages.
Comments No No
Labels Yes Optional
Restrictions No Optional - you may not be able to change this option if you don't have
appropriate 'Restrict' space permissions.
Watchers No No
Saved for later info No No
History No No
Child pages with - Yes - if you have permission to see the child pages.

view restrictions ) . )
No - if you do not have permission to see the child pages.

Space permissions and page restrictions

Your space permissions and any existing page restrictions have an impact on what you can copy:

®* To copy pages you need the 'Create' page permission in the destination space.
® To copy pages with restrictions in tact, you need the 'Restrict’ page permission in the destination
space.

When copying a page and its child pages, you also have a choice to copy over any existing page restrictions.
This is useful if you need to maintain the current view or edit restrictions. If you don't have 'Restrict' page
permission in the destination space, you won't be able to choose this option.

Copy the contents of an entire space

Confluence does not provide an option to copy a space, however if your space has less than 1000 pages,
you can use copy page to copy all the pages in an existing space to a hew space.

To copy the contents of a space to a new space:

1. Create a new space.
2. Go the homepage of the space you want to copy, and choose

LT

> Copy.
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Set your new space as the Location.

Select Copy child pages then hit Copy.

5. In the new space, go to Space Tools > Reorder pages and drag your copied homepage to the root of
the space (so it is no longer a child of the current space homepage).

Go to Space tools > Overview > Edit space details.

7. Enter the copied space homepage title in the Home page field and Save.

hw

o

That's it. You can now delete the homepage that was automatically added when you created the space.

Note that this is a new space, and no space settings (permissions, color schemes, templates etc) will be
copied. See these instructions on copying a space for some other workarounds.

Delete or Restore a Page

When you delete a Confluence page, we'll move it to the space's trash. It's
not permanently deleted, and can be restored by a space admin, until the

On this page:
® Delete a

page is permanently deleted from the trash. single
. . age
Don't see a delete option? Delete only appears if you are allowed to o gegljete -
delete the page. Both space permissions and page restrictions can prevent page
you from deleting. hierarchy
® Delete a
Delete a single page page
version
When you delete a page in Confluence, you're deleting its page history too. ® Restore
If you only want to delete a specific version of a page, take a look at the deleted
instructions below for deleting a specific version. pages
®* Empty the
To delete a page: trash
1. Go to the page and choose or perman
J ently
> Delete. delete a
2. We'll warn you of any issues, such as incoming links that will Ll

break. Choose Delete to proceed.

The page will be sent to the trash, where it can be restored by a space

Related pages:

; ® Editing or
admin. Deleting a
Any child pages (including any restricted pages that you are not allowed to Page That
see) will move up to the nearest parent page. Won't

Render
* Copy a
Delete a page hierarchy Page

When deleting a page that has child pages you have the option to delete the
entire page hierarchy.

To delete a page hierarchy:

1. Navigate to the parent page and choose

> Delete.

2. Choose Also delete child pages then hit Next.

3. We'll warn you of any issues, such as incoming links that will break.
Choose Delete to proceed.

The pages will be sent to the trash, where they can be restored by a space
admin.

Any pages that are restricted (that you are not allowed to see or delete) will
not be deleted and will move up to the nearest parent page.

Delete a page version

Space admins can delete specific versions from the page history. This is useful if you need to prevent older
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versions of a page being restored in future. Deleting a page version is permanent and cannot be undone.
To delete a specific version of a page:

1. Go to the page and choose

LE L

> Page History
2. Choose Delete next to the version you want to delete.

Once you've deleted a version, the other versions are re-numbered where necessary.

Restore deleted pages

If you're a space admin you can restore deleted pages back into a space. This is useful if someone
accidentally deletes a page and needs to get it back.

To restore a deleted page:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Trash.
3. Choose

> Restore next to the page you wish to restore.

Pages are restored to the root of the space. Head to Space Tools > Reorder Pages to drag your restored
page back into the page hierarchy.

Empty the trash or permanently delete a page

If you're a space admin you can permanently delete a page (and all its attached files) by purging it from the
trash. Once purged, the page and all its versions and attached files will be gone for good.

To purge deleted pages:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Trash.
3. Choose

ane

> Purge next to a specific page or you can Purge all to completley empty the trash.

Add, Remove and Search for Labels

Labels are key words or tags that you can add to pages, blog posts and
attachments. You can define your own labels and use them to categorize,
identify or bookmark content in Confluence.

For example, you could assign the label 'accounting' to all accounts-related
pages on your site. You can then browse all pages with that label in a single
space or across the site, display a list of pages with that label, or search
based on the label.

Because labels are user-defined, you can add any word that helps you
identify the content in your site.

You can also apply labels (known as categories) to spaces, to help organize
your Confluence spaces. See Use Labels to Categorize Spaces.

Label a page or blog post

Any user with permission to edit a page can add labels to it. Any existing
labels appear at the bottom-right of the page, below the page content.

To add a label to a page or blog post:
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On this page:
® |abela
page or
blog post
® |abel an
attachment
® The
Labeled
content
page
® Search by
label
® Search for
labeled
pages
using a
URL
® Remove
labels
Related pages:
® Use Labels
to
Categorize
Spaces
® Display
Pages with
Label
Macros
1. Go to the page Labels Help
choose the
edit icon
r
beside the list | "2 AL
of labels or
press L on label =  example = confluence-label-filter =
your keyboard
2. Typein a new
label (existing _ _ _ -
labels are Shortcut tlp In page view, pressing | also opens this dlalng box Close
suggested as
you type)

3. Choose Add

If you're editing or creating a page, and you want to add labels, choose the label icon

L
at the top of the page.

Label an attachment

1. Do either of the following:
® Go to the page that contains the attachment and choose Go to

ane
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> Attachments
® Go to the space and choose Space tools > Content Tools from the bottom of the sidebar,
then choose Attachments
You'll see a list of attachments, with any existing labels listed in the Labels column.

2. Choose the edit icon

&£
beside the list of labels and type in a new label (existing labels are suggested as you type)

3. Choose Add

You can also add labels in a list of attachments displayed by the Attachments macro, by choosing the edit
icon

4

beside each label.

o If you add one or more labels to a template, that label will be copied to the page when someone adds a
page based on that template. See Creating a Template.

The Labeled content page

If you're viewing a page or post that has labels or displays the Attachments macro, you can choose any label
to go to the Labeled content page for the space. Choose Popular Labels or All Labels from the cog at the
top-right — to view the most-used labels or all labels in the space — or choose See content from all spaces fr
om the cog to view labeled content from all spaces in your Confluence site.

Screenshot: The Labeled content page

Labelled content L -

See content from all spaces

Every content item in this list is tagged with all the required labels: | - 20% | | - planning FPopuIarLabeIs

To add a label to the list of required labels, choose '+ labelname’ from Related Labels. All Labels

To remove a label from the required labels, choose '- labelname' from above.
+ plugins
(S] 20% Planning
Apr 30, 2008 » Agnes Ro

20% | | planning

+ atlassian-plugins

+ fedex8 | | + spike | | + editor
+ propeosal | | + batching

+ confluence | | + tinymce

The Popular Labels option displays a word cloud, where the bigger a label is displayed, the more popular it
is. Choose any label to view content tagged with that label.

You can also navigate to the labels view for a space by entering the following URL (replace SPACEKEY with
the space's key):

<your . Confl uence. site>/1 abel s/li stl abel s-al phavi ew. acti on?key=SPACEKE
Y

Search by label

You can use the ' | abel Text: ' prefix to search specifically for content that has a specific label. For
example, if you're looking for pages with the label 'chocolate’, type | abel Text : chocol at e into the search
field in the Confluence header. For more examples of searching by label, see Confluence Search Syntax.

Search for labeled pages using a URL

Entering a URL with an appended label or labels is another way to search for pages with particular labels.
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In your browser's address bar, enter the following URL and press enter: ht t p: / / <your . Conf | uence. sit
e>/| abel / f oo+bar

The Labeled content page will load, showing search results for pages with the both labels, 'foo' and 'bar'.
Replace 'foo' and 'bar' with the label(s) you want to search for, and separate multiple labels with a + symbol.

Adding a label to your results:

Once you're on the Labeled content page, you can add more labels to your search by choosing them from
the Related Labels list at the top-right of the page. Each label is listed with a plus (+) sign.

If you want to remove labels from your search, locate the included labels at the top of the page and choose
the label(s) you want to remove. Each included label will be listed with a minus (-) sign.

Remove labels

When viewing page, blog post, or attachment labels, an x appears alongside each label. Choose the x to
remove the label.

If you have deleted pages that contain a label, you may need to purge the deleted pages from the
space's trash to ensure that the label disappears too.

Display Pages with Label Macros

Using labels and macros, you can categorize pages and then display them Related pages:
in Confluence in a number of ways.

* Add,
As an example, you could label all pages relevant to the marketing team Remove
with 'marketing’, and then add more specific labels like ‘online’, 'mobile’, and and
'physical’ to different pages where required. Search for
You could then use the Content by Label Macro to display different o k/laabcerloss
combinations of pages with the marketing label. Some combinations you O Use el
could use would be: o
® All pages with the label 'marketing'. Categorize
® Pages with all of the following labels: 'marketing’, 'mobile’', and Spaces
‘online’.
® Pages with either the 'mobile’ or 'online' labels, in the Marketing
space.

There are a lot of ways you can filter the content, making it easier for you to find content that's relevant to
you.

Other label macros

Here are some other macros that use labels, and can help you categorize and display your content.
Navigation Map macro

The Navigation Map macro renders the list of pages associated with a specified label as a navigation map.
Related Labels macro

The Related Labels macro lists labels commonly associated with the current page's labels.

Content by Label macro

The Content by Label macro displays a list of content marked with specified labels.

Content Report Table macro

The Content Report Table macro displays a set of pages and blog posts in tabular format, based on the
specified labels.

Created in 2017 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/
https://confluence.atlassian.com/display/DOCM/Purging+Deleted+Pages

Confluence 6.3 Documentation

Labels List macro

The Labels List macro lists all labels of a space, grouped alphabetically.

Recently Used Labels macro

The Recently Used Labels macro lists labels most recently used in a specified scope - global (site), space, or
personal.

Popular Labels macro

The Popular Labels macro displays popular labels in a list or in a heatmap (also called a cloud).
Drafts

A draft is a version of a page with unpublished changes. Confluence creates a draft whenever you create or edit
a page or blog post but haven't yet published the changes.

When you're working on a new page — one that you've never published — Confluence creates it as a draft. If you
get interrupted and close your tab or navigate away, your content lives on in your drafts page ready for you to
resume editing or publish.

You can even bring in other people to help you edit your draft - either use the Invite button in the editor or just
share the URL with them (they'll need the appropriate Confluence and space permissions of course).

If you're editing a page that's previously been published, but you don't want to publish your changes yet, simply
hit Close to close the editor. Your changes are safely preserved in a draft version of the page. For example, you
might be editing a page with your team, and no one wants to publish until all the changes are in. The last person
to finish editing will publish the page, or everyone else uses Close to leave the editor without publishing.

Find page drafts

Pages that you have created, but have not yet published, are
kept in the drafts section of your user profile. To see them, head
to your profile picture at top right of the screen and choose Draf
ts. © Watching

Personal Space

. . . . Recently Viewed
If you didn't enter a page title, the draft will be called 'Untitled'.

Profile
Resuming your work Tasks

One of the wonderful things about collaborative editing is that Saved for later

you don't need to publish a page before you're ready. into gear for Al

hal features or fi Watches

Here's how you can resume working on your unpublished
changes: LU

® |f the page has been published previously, all you need to Network
do is hit Edit and any unpublished changes will be ready Settings
and waiting.

* |f you created the page, and it has never been published, Atlassian Marketplace
head to Profile > Drafts to resume working on the page.

® |f someone else created the page, and it has never been Log Out

published, you'll need the URL of the editing session to
resume working on it (as the page only appears in the
original creator's Drafts list).

Recently worked on on the dashboard is a great way to get back to pages you've edited recently.
Concurrent Editing and Merging Changes

This page covers the concurrent editing behavior in Confluence 6.0
or later when your administrator has chosen to disable collaborative
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editing. Related pages:
In most cases, this won't apply to your Confluence site. * Page
History
and Page
Compariso
Sometimes, another user may edit the same page as you're editing, at the n Views
same time you do. When this happens, Confluence will do its best to ensure ® Drafts

nobody's changes are lost.
How will | know if someone else is editing the same page as | am?

If another user is editing the same page as you, Confluence will display a
message above your edit screen letting you know who the other user is and
when the last edit was made.

Screenshot: Concurrent editing notification

G) This page is also being edited by Ewan User. Your changes will be merged with theirs when you save. X

What happens if two of us are editing the same page and the other user saves before | do?

If someone else has saved the page before you, when you click Save, Confluence will check if there are any
conflicts between your changes and theirs. If there are no conflicting changes, Confluence will merge the
changes.

If there are conflicts, Confluence will display them for you and give you the option to:

® Continue editing - Continue to edit the page; useful if you want to manually merge the changes.

® OQOverwrite - Replace the other person's edits with yours (their edits will not be included in the latest
version).

® Cancel - Discard your changes and exit the editor, keeping the other person's edits.

Example Scenario
For example, Alice and Bob both edit the same page at the same time.

If Alice clicks save before Bob, Bob is now effectively editing an out-of-date version of the page. When Bob
clicks save, Confluence will examine his changes to see if any overlap with Alice's. If the changes don't
overlap (i.e. Alice and Bob edited different parts of the page), Bob's changes will be merged with Alice's
automatically.

If Bob's changes overlap with Alice's, Confluence will display an error message to Bob showing where Alice
has changed the page, and giving Bob the options to overwrite Alice's changes with his own, to re-edit the
document to incorporate Alice's work, or to cancel his own changes entirely, maintaining Alice's changes.

Page Restrictions

Page restrictions allow you to control who can view
and/or edit individual pages in a space. So, if you're
working on a page that shouldn't be viewed by just
anybody, it's easy to lock it down to the people who
need to know. You can add restrictions for
individuals or for Confluence groups.

On this page:
® Restrict a page or blog post
® Remove restrictions from a page
® Request and grant access a
restricted page
® View all restricted pages in a
To add or remove page restrictions, you'll need to space
have permissions to edit the page and 'Restrict’ or ®* Notes
'Admin’' permission in the space.

Restrict a page or blog post

To restrict who can view or edit a page or blog post:
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1. Chose the Restrictions

-

icon at the top of the page.

Choose whether you just want to limit only who can Edit, or who can View and / or Edit.

3. Enter users or groups then click Add to add them to the list.
If you chose Viewing and Editing restricted you can further specify for each person or group
whether they can edit or just view the page.

4. Apply the restrictions.

N

You can add as many users and/or groups as you need. You can apply page restrictions to published and
unpublished (draft) pages.

Restrictions

&' No restrictions - Everyon

&' No restrictions
Everyone can view and edit

&' Editing restricted
Everyone can view, only some can edit

& Viewing and editing restricted
Only some can view or edit 1

Right now everyone cal
Use the dropdown aboy

Learn more about restri

In this example, some users and groups can view only, others can also edit, plus there are inherited
restrictions that might impact who can view the page.

Restrictions Help
& Viewing and editing restricted - Only some people can view or edit this page. There are inherited view restrictions. .—o
o_. B Edith Tom x| & Valter Fatia % | | [0 administrators % Can view H Add
E Everyone Can't view
r: Rachel Robins Can view and edit
o | ——
i Giles Brunning Can view and edit ; Remove e
E developers Can view B Remove

1. Speed it up: apply the same restriction to multiple people and groups.
2. Watch out: restrictions on other pages can affect this one.
3. Be specific: choose exactly what each group or person can do.

Who is ‘everyone'?

When we say "everyone can view this page" everyone means all the people who can view the page by
default. There's two things that can affect who can view a page - the space permissions, and view restrictions
on any parent pages that are being inherited.

Restrictions don't override a person's space permission. For example, if you say a person ‘can view' in the
restrictions dialog and they don't have 'view' permissions for the space, they won't be able to see the page.
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How do inherited restrictions work?

View restrictions are inherited, which means a restriction applied to one page will cascade down to any child
pages. Edit restrictions are not inherited, which means pages need to be restricted individually.

The restrictions dialog will tell you when there are inherited restrictions that might affect who can view your
page.
Here's the basics:

® |f you restrict viewing to a person or group, only they will be able to see that page and all its child
pages (unless there are further restrictions on the child pages).

® If you restrict editing to a person or group, they'll be able to see and edit that page, plus see its child
pages.

® Parent pages (higher up in the page hierarchy) can have their own view restrictions that may prevent
people from viewing your page.

If the person you've listed as a viewer or editor can't see the page, check to make sure:

® they have View space permission for that space, or
® there's no view restriction on a page higher up the page hierarchy that prevents them seeing any
children of that page.

View current page restrictions

The restrictions icon at the top of the page gives you a clue that the page has restrictions:
“ Viewing this page is not restricted. Everyone can see this page (but editing may be restricted).
&  The page is restricted. Click the icon to see the list of who can view and edit this page.

“ The page is inheriting restrictions from another page. Click the icon then choose Inherited
Restrictions to see a list of pages this page is inheriting restrictions from.

Remove restrictions from a page

Removing restrictions is easy. Choose No restrictions to remove all restrictions, or click Remove next to
each person or group in the list if you want to change who can view or edit the page.

Request and grant access a restricted page

If you navigate to a page that you're not able to view or edit because it has page restrictions applied (for
example from a link or page URL) you may be able to request access to the page.

To request access to arestricted page:

1. On the restricted page choose Request access.
2. Wait for an email confirming that access has been granted.

If the request access message doesn't appear, you're not able to request access for that particular page.
This usually is because the page has inherited view restrictions from a parent page, or you may not have
adequate space permissions.
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You do not have permission to view the page.
Request access below, and you will receive an
email notifying that your access has been granted.

To grant access to a restricted page:

1. In the request access email, choose Grant access
You'll be taken to the restricted page, and a dialog will appear with the access request.
2. Choose Grant access.

The user will receive an email confirming that access has been granted.

Pages @&

Samr

Created

Ewan User requested access to view
the page
@ v Grant access to the page, or deny it explicitly

your tean|
Grant access | Deny |

This process is the same as navigating to

LE L]

> Restrictions and adding a 'View' restriction for the user.

Who can grant access?

To grant access to a restricted page you will need to have permission to edit that page, and have the
'Restrict' or '"Admin’ permission for the space.

Confluence will send an email to a user who can grant permissions. The sequence that Confluence will use
to search for the appropriate user is:

1. The last person to edit the page.

2. All non-admin users that can set permissions on the page (given that an admin user can always set
permissions).

3. The page creator.

4. All the space administrators.

Confluence will try each of these roles in turn, emailing the first user that has appropriate permissions.

View all restricted pages in a space

You need space admin permissions to view the list of restricted pages in a space.
To view restricted pages:

1. Go to the space and choose Space tools > Permissions from the bottom of the sidebar
2. Choose Restricted Pages.

Screenshot: Restricted pages in a space
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Permissions = Restricted Pages

This report shows all the pages where access is restricted to specific groups or users by page level permissions

Title (Space) Type Permitted Creator Created Operations
User/Group

[3) Induction plan - Edit leah Leah Admin Feb 18, 2013 .
Sophie User (Stars)
[2) Induction plan - Edit leah Leah Admin Feb 18, 2013 -
Ewan User (Stars)
[3) Draft status report View admin Rach Admin Feb 18, 2013 .
(Stars)

View sophie Rach Admin Feb 18, 2013 .

Notes

® You can't exclude yourself
When you apply a restriction, Confluence will automatically add you to the list. You can't remove
yourself from this list.

® Space Admin and System Administrator access to restricted pages
Users with '"Admin’ permissions in a space, or users with the System Administrator global permission
can remove restrictions from pages, even if the page restriction prevents them from viewing the
page. Go to Space Administration > Restricted Pages .

Links
You can create links to pages, blog posts, anchors, attachments, external On this page:
websites, JIRA issues and more. Links can be text or images, and can be ® Inserta
added in many different ways. text link
. - . . . ® Insert an
Links to pages within your Confluence site are relative, which means that image link
you can move pages and rename pages without breaking links. * Modify a
This page explains the most common ways to create links. link
® Remove a
link
Insert a text link * Lmkf[c')
specific
To insert a link on a page: types of
content
1. Select some text or position your cursor where you want to insert the ® Linkto
link Confluenc
2. Choose Link on the toolbar or use the keyboard shortcut Ctrl+K e pages
3. Select a page, blog post or attachment, or enter an external URL (see from other
below for how to link to particular types of content) websites
4. Enter or modify the link text (this is the text that will appear on the ® Linktoa
page. If this field is left blank, the page name or URL will be used as comment
the link text.) ® Using
5. Choose Insert shortcut
) Links
Alternatively you can type [ followed by the page or attachment name. Autoc * Trackback
omplete will suggest matching items for you.
Related pages:
® Anchors
Inserting
JIRA
Issues
® The Editor
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You can also paste a URL directly onto your page. Confluence will automatically create the link, and if the
URL is for a page in the current site, the page name will be set as the link text.

Insert an image link

1. Select an image on your page

2. Choose Link on the Image Properties toolbar

3. Select a page, blog post or attachment, or enter an external URL (see below for how to link to
particular types of content)

4. Choose Insert

150px " | @ | W | Original Border = | ink Properties

Modify a link

1. Select the link text or image
2. Choose Edit from the link properties toolbar
3. Modify the link and choose Save

Remove a link

1. Select the link text or image
2. Choose Unlink from the properties toolbar

Click to find out more

Goto Link | Edit | Unlink

Link to specific types of content

Confluence supports many methods for creating links. Some of the common ones are listed here.

Type of link Ways to do this
Link to a page Choose Link > Search then enter part of the page name.
Choose Link > Recently viewed and select a page from the list.
Type [ and enter part of the page name then select the page from the list.

Paste the URL of the page onto your page (Confluence will automatically create the
link).
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Link to a page in
another space

Link to a blog post

Link to an
attachment or
image on this page

Link to an
attachment on
another page

Link to a website

Link to an email
address

Link to an anchor
on a page

Link to a heading
on a page

Link to a comment
on a page

Choose Link > Search enter part of the page name and select All Spaces from the
drop down.

Choose Link > Advanced then enter the space key followed by the page name spa
cekey: nypage.

Type [ and enter part of the page name then select the page from the list.
(you can hover over each suggestion to see which space the page is from).

Choose Link > Search and enter part of the blog post name.

Type [ and enter part of the blog post name then select the blog post from the list.

Choose Link > Attachment then upload or select an attachment from the list.

Type [ and enter part of the attachment file name then select the attachment from
the list.

Choose Link > Search and enter part of the attachment name.

Type [ and enter part of the attachment file name then select the attachment from
the list
(you can hover over each suggestion to see which space the page is from).

Choose Link > Web Link then enter the website URL.

Type or paste the URL onto the page (Confluence will automatically create the link).

Choose Link > Web Link then enter the email address.

Type or paste the email address onto the page (Confluence will automatically create
a 'mailto:’ link).

Choose Link > Advanced then enter the anchor name in one of the formats below.
For an anchor on this page: #anchor nane.
For an anchor on another page in this space: page nane#anchor nane.

For an Anchor on another page in another space: spacekey: page name#anchor
nane.

See Anchors for more information on using anchors.

Choose Link > Advanced then enter the heading in one of the formats below.
Heading text is case sensitive and must be entered without spaces.

For a heading on this page: #MyHeadi ng.
For a heading on another page in this space: Page Nane#MyHeadi ng.

For a heading on another page in another space: spacekey: Page
Nanme#MyHeadi ng.

Be aware that these links will break if you edit the heading text. Consider using the
Table of Contents macro or an Anchor instead.

Go to the comment, right click the Date at the bottom of the comment and copy the
link. Paste the link directly onto your page or choose Link > Web Link and paste in
the URL.

Type [$ then enter the Comment ID ('12345' in this example): [ $12345]
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Link to an Choose Link > Advanced then enter the new page name (a page will be created on
undefined page click).
(a page that does

not exist yet) Type [ then enter the new page name then choose Insert link to create page .

See Undefined Page Links for more information on undefined pages.

Link to a personal Choose Link > Search then enter the user's name and select their personal space
space or user homepage or their profile from the list.
profile

Type [ then enter the user's name and select their personal space homepage or
their profile from the list.

Link to a JIRA issue Paste the JIRA issue URL - Confluence will automatically create a JIRA Issue
(where Confluence  macro.

is connected to

JIRA)

Link to Confluence pages from other websites

The best way to link to a Confluence page from outside Confluence, for example from another site or in an
email, is to use the share link which is a permanent URL. This ensures that the link to the page is not broken
if the page name changes.

To access the permanent URL for a page:

1. View the page you wish to link to.
2. Choose Share.
3. Copy the Share link.

You do not need to use the share link to link to pages within your Confluence site. Confluence automatically
updates links when you rename or move a page to another space.

If you want to link to specific content such as anchors, headings or comments you need to use the following
link syntax. Note that there are no spaces in the page name, anchor name or heading text.

In the examples below, the anchor name is ‘InsertLinkAnchor' and the heading text is 'Insert a link'.

Purpose Link syntax

Link to htt p:// nyconfl uence. com di spl ay/ spacekey/ pagenane#pagenane- anchor name

an :

anchor Example from this page:

(froman  nttps://confluence. atl assi an. com di spl ay/ DO/ Wor ki ng+wi t h+Li nks#Wor ki ngwi
external

website)

Linktoa http://nyconfluence. conidi spl ay/ spacekey/ pagenane#pagenarne- headi ngt ext

heading . .
(from an Example from this page:

extgrna; htt ps://confl uence. atl assi an. coni di spl ay/ DOC/ Wor ki ng+wi t h+Li nks#Wbr ki ngwi
website

Linktoa http://nyconfluence. conidi spl ay/ spacekey/ pagenane?f ocusedComent | d=conmel

comment .
(from an Example from this page:

external htt ps://confl uence. atl assi an. coni di spl ay/ DO Wor ki ng+wi t h+Li nks?f ocusedC
website)

Some things to note when linking to anchors from a website or email message:

® The page name is repeated in the URL, after the # sign. The second occurrence of the page name is
concatenated into a single word, with all spaces removed.
® There is a single dash (hyphen) between the concatenated page name and the anchor name.
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® The anchor name in the full URL is concatenated into a single word, with all spaces removed.
® The anchor name is case sensitive. You must use the same pattern of upper and lower case letters as
you used when creating the Anchor.

Link to a comment

You can add a link to a comment by using the comment URL (a permanent link), or by using wiki markup to
link to the Comment ID.

To find out the comment URL and comment ID:

1. Go to the comment you wish to link to
2. Choose the Date at the bottom of the comment and examine the URL

The number after ‘comment-' is the Comment ID. An example is shown here.

https://confluence. atl assi an. cont di spl ay/ DOC/ Wor ki ng+wi t h+Li nks?f ocus
edConment | d=368640803#conment - 368640803

You can use wiki markup directly in the editor to link to a comment. Enter [$ followed by the Comment ID, for
example [ $12345] where '12345' is the Comment ID.

Using shortcut Links

If you have configured shortcut links on your Confluence site, then you can link to an external site using a
shortcut link that looks like this:CONF- 17025@ i r a.

Our Confluence site (where this documentation is housed) is configured to allow shortcut links to our JIRA
site, using the shortcut @i r a. So the shortcut link CONF- 17025@ i r a produces this link.

To add a shortcut link using the ‘Insert Link' dialog:

1. Choose Link > Advanced and enter or paste the shortcut link into the Link field (shortcut links are
case-insensitive)

2. Modify or enter link text (this is the text that will appear on the page)

3. Choose Insert

You can also type '[' and choose Insert Web Link > Advanced to enter a shortcut link.

See Configuring Shortcut Links for more details.

Trackback

Trackback enables two sites can stay informed each time one site refers to the other using trackback 'pings'.

In Confluence, Trackback can be enabled by a site administrator in the Administration Console. When
Trackback is enabled, any time you link to an external webpage that supports Trackback Autodiscovery,
Confluence will send a Trackback ping to that page to inform it that it has been linked to.

Confluence pages also support Trackback Autodiscovery, and when Trackback is enabled, can receive
trackback pings sent by other sites.

To see who has sent a Trackback ping to a Confluence page:

1. Go to the page
2. Choose Tools > Page Information

Any Trackback pings the page has received will be listed under the page's Incoming Links.

Confluence incoming trackback pings only work with referenced pages that are public (anonymously
viewable).

Anchors
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You can use anchors to enable linking to specific locations on a page, and On this page:
they can be especially useful for allowing your readers to navigate to

A .
specific parts of a long document. Anchors are invisible to the reader when itreegttthe
the page is displayed. anchor
There are two steps to using an anchor: ® Step 2:
. Create a
Step 1: Create the anchor link to the
Step 2: Create a link to the anchor anchor
®* Notes

Step 1: Create the anchor Related pages:

® Links
Add the Anchor Macro to mark the location you want to link to:

1. Do either of the following in the Confluence editor:
® Choose Insert > Other Macros, then find and select the
Anchor macro
* Type { and the beginning of the macro name, then select the
Anchor macro
2. Enter the Anchor Name (For example, 'bottom' or 'important
information’)
3. Choose Insert

Macro options (parameters)

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Anchor None This is the anchor name that you will use when creating the link.

Name . .
® The anchor name can include spaces. Confluence will remove the spaces

automatically when building a URL that points to this anchor.

® The anchor name is case sensitive. You must use the same pattern of upper
and lower case letters when creating the link as you used when creating the
Anchor macro.

Step 2: Create a link to the anchor
You can link to an anchor from:

® A page on the same Confluence site. The link may be on the same page as the anchor, another page
in the same space, or a page in another space on the same Confluence site.
® Another web page or another Confluence site, using a specifically formatted URL.

Link to an anchor on the same Confluence site:

1. Select some text or position your cursor where you want to insert the link
2. Choose Link in the toolbar or press Ctrl+K
3. Choose Advanced and enter the anchor name in the Link field, following the format below.

Anchor location Link syntax for anchor Examples

Same page #anchor name #bottom

#important information

Page in same space  page name#anchor name My page#bottom

My page#important information
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Page in different spacekey: page nane#anchor DOC:My page#bottom

space name )
DOC:My page#important

information

4. Enter or modify the Link Text (this is the text that will appear on the page. If this field is left blank, the
page name or URL will be used as the link text)
5. Choose Save

® Anchor names are case sensitive

® Enter page and anchor names with spaces when you link to them in the same Confluence site

® If you're linking to an anchor on a different page that has special characters in its name, where
the URL displays a page ID rather than a name, you should still enter the page nhame when
linking to it

Screenshot: The 'Advanced' option in the link dialog

Edit link Help

Search Here you can insert a link into the page using wiki markup.

Recently viewed

Attachments Link  #goodstuff

To insert a link to a new page, type in the desired page title.

Web link
To insert an anchor link, type #anchorname.
Advanced
Link text | Link to the good stuff!
Browse
Hint: type "[" in the editor to see a list of suggested pages and insert a link. Save @ Cancel

Link to an anchor from another web page or another Confluence site:

Use a full URL in the following format:

Link syntax Examples

http:// nyconfl uence. com di spl ay/ spacekey/ pagenane#pagenane- anchor name http://myconfl

http://myconfl

Notes about the full URL:

® The page name is repeated in the URL, after the # sign. The second occurrence of the page name is
concatenated into a single word, with all spaces removed.

® There is a single dash (hyphen) between the concatenated page name and the anchor name.

® The anchor name in the full URL is concatenated into a single word, with all spaces removed.

® The anchor name is case sensitive.

Notes

® Table of contents on a page: Consider using the Table of Contents Macro to generate a list of links
pointing to the headings on the page. The list of links will appear on the page, and will be
automatically updated each time someone changes the wording of a heading.

® Linking to headings: You can link directly to the headings of a page. See Links. However, if
someone changes the wording of a heading, those direct links will be broken. Use the Anchor macro
to ensure a lasting link within the body of a page.

® Site welcome message: If you are adding an anchor to a page that you are using in the site welcome
message, you can only link to that anchor from another page. Internal links within that page will not
work.

®* Templates: When you are previewing a template, a link to an anchor is displayed as a 'broken’ link.
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However, when you create a page using the template the resulting page will have the correct link.

Tables

Confluence tables allow you to present important information and discuss it
with your team. Use familiar table formatting options —resizing columns,
coloring cells, rows and columns, and sorting the table by clicking the
column headers — to view the information the way you like it.

Insert a table

To create a table:

1. Hit the Table button in the toolbar
2. Click a cell in the drop-down to set the number of columns and rows
in your table

Screenshot: Insert a table with 3 rows and 3 columns

i & H~Y +~ 9 O

ove legacy users, gro

S, grc 4., dbal g

Hold SHIFT for a table without a
heading.

Edit your table

To resize table columns, just click and drag the column's border. To make other changes to your table, click

inside it to reveal the table toolbar.

Here's a summary of the table tools:

Column width modes
Responsive «

Responsive
page-viewer's window size (within reason).
Fixed width | * Fixed width — Drag column borders to set width. Columns appear
at your set size, regardless of content and window size.
él- ?I_ 2« Rows
® Insert rows before or after the current row
® Delete the current row
=) =) * Cut, copy and paste the current row
[ ]

On thi
[ )

s page:
Insert a
table

Edit your
table
Shortcut
keys

Sort the
table in
view mode
Sticky
table
headers in
view mode

Related pages:

Page
Layouts,
Columns
and
Sections
The Editor

® Responsive — The table will expand as you add content, and you
can drag to resize the columns. It'll also resize itself to fit the

Mark a row as a header row (shaded with bold text)
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&=
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Columns

Delete the current column

[ ]
[ ]
® Cut, copy and paste the current column
[ ]

Cells

®* Merge selected cells
® Split selected cells
® Change cell color

Table

® Delete table

Insert columns before or after the current column

Mark a column as a header column (shaded with bold text)

¢ Add a numbering column to automatically number each row

Table settings

Insert numbering column

Shortcut keys

Windows
Ctrl+Shift+c
Ctrl+Shift+i

Ctrl+Shift+v

Ctrl+Shift+x
Alt+Up Arrow

Alt+Down
Arrow

Action
Copy the current table row, or the selected rows.
Insert a table. (Opens the Insert Table dialog.)

Paste the table rows from your clipboard, placing them above the
current row.

Cut the current table row, or the selected rows.
Add a row above the current row.

Add a row below the current row.

For more editor keyboard shortcuts, see Keyboard shortcuts.

Sort the table in view mode

When viewing a table on a page, you can sort it by clicking the sort icons in the header row.

Screenshot: A colorful, sortable table

Mac OS X
Cmd+Shift+c
Cmd+Shift+i

Cmd+Shift+v

Cmd+Shift+x
Alt+Up Arrow

Alt+Down
Arrow
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Document Author Reviewer
Getting Started Sandy Joan
Installation Guide  Sandy Pete

Upgrade Guide Juan Lise

Sticky table headers in view mode

In some instances table header rows will stick to the top when you're viewing a page, making those really lon
g tables easier to read. There are a few exceptions, though. Table headers aren't sticky when your table:

® |sinside a page layout, or inside another table.

®* Has no header row or there are cells in the top row that aren't marked as headers.
® Has a header column, instead of a header row, and scrolls horizontally.

® Contains another table, that has its own header row.

Add, Assign, and View Tasks

Keep track of the things that need to get done with tasks. With the ability to On this page:
give each task an assignee and due date, and plenty of ways to see your ® Add atask
tasks, you can make sure nothing slips through the cracks. ® View tasks

® Notes
Add a task

You can add tasks on any page in Confluence. For example, you might add
tasks under action items on a meeting notes page, or in a project planning p
age — anywhere you need a lightweight task management solution.

To create a task:

1. In the editor, choose the Task list

e

button or use the keyboard shortcut [ ]

2. Start typing your task — @mention someone to assign the task to them, and type // and choose a due
date

The first person you mention in a task is the assignee; you can even assign tasks to yourself.

Note: If you assign a task to someone who doesn't have permission to view the page or space, they won't
see the task.

View tasks

There are a number of ways to keep track of tasks assigned to you, or tasks you've created for others.

On a page

The simplest way to see a task is on the page it was originally created on. It's easy to see if a task is
complete, who it's assigned to, and when it's due. If a task is nearing or passed its due date, the color of the
date will change (red for overdue, orange for due in the next 7 days).
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Action items

v @ Rach Admin| to decide on name of project space
@ Ewan User to finish creating the new project space by [ 15 Apr 2014

» |[@Sophie| to investigate venues for offsite and prepare costings for at least three
different options by | 02 Apr 2014
@ Sophie User distribute agenda for offsite 1123 Apr 2014

In your profile

The tasks page in your profile gives you a place to see all the tasks relevant to you. Easily keep track of the
status of tasks assigned to you, and tasks you've created and assigned to others.

To view the tasks page, go to Profile > Tasks. Use the filters to show tasks that were assigned to you or
created by you in the last 6 months, and toggle between complete or incomplete tasks.

Assigned to me = Created by me Incomplete  Complete
Description Due date Task appears on
Organise venue for project offsite |07 Apr 2014 |@ Sophie User 07 Apr 2014 2014-04-09 Meeting notes
Organise customer interviews - |@ Sophie User| |[z]17 Apr 2014 17 Apr 2014 Project Offsite
@ Sophie | schedule a follow up meeting (=130 Apr 2014 30 Apr 2014 2014-03-25 Meeting notes
@ Sophie| to prepare talk about new campaign Project Offsite
Prev 1 ext For a custom view create a task report

If you need to see more than just your last 6 months of tasks, use a Task Report.

In a Task Report

If you're looking for a more custom view of tasks, the Task Report blueprint is a great way to track tasks
assigned to a specific team or project.

To create a task report:

1. Choose Create > Task Report
2. Select the type of report:

® Assigned to my team — for tasks assigned to particular people.

®* In my project — for tasks that appear in a specific space or page.

® Custom — for a wide range of filtering options, including by date or page label.
3. Follow the prompts to create the report.

This blueprint uses the Task Report Macro. You can also choose to use this macro on an existing page, for
example, on a project or team space homepage.

Meeting actions this month
Created and last modified by Rach Admin a minute ago
Description Due date ~  Assignee Task appears on
@ Leah Admin | to schedule a follow up meeting Leah Admin  2014-03-25 Meeting notes
@ Ewan User| to finish creating the new project space by |10 Mar 2014 10 Mar 2014  Ewan User 2014-03-25 Meeting notes
@ Josh User| add designs to the project space's file list by (102 Apr 2014 02 Apr 2014 Josh User 2014-03-29 Meeting notes
Notes

Created in 2017 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 6.3 Documentation

® The date picker can be triggered by typing // or by typing a date in the format dd/mm/yyyy or
dd-mm-yyyy. Typing other date formats in the editor won't trigger the date picker.

® Personal Tasks (created in the Workbox in older versions of Confluence) don't appear in the Tasks
view or Task Report. To migrate any incomplete personal tasks, go to Workbox > Personal Tasks an

d follow the prompts.
® The wiki markup based Tasklist Macro has been removed from the macro browser. If you have a

Tasklist macro on a page it will continue to work, but you will be unable to add new Tasklists using this

macro.

Autocomplete for links, files, macros and mentions

When using the Confluence editor, you can type a trigger character or press
a keyboard shortcut to see a list of suggested links, files or macros to add to
your page, or to mention another user (and automatically notify them of this).

Summary of autocomplete

What you want
to do

Add a link on
your page

Display an
image, video,
audio file or
document on
your page

Add a macro on
your page

Notify another
user by email
that you have
mentioned them
on your page

Using autocomplete for links

Trigger
character

[

Keyboard
shortcut

Ctrl+Shift+K

Ctrl+Shift+M

None

None

Description

See a list of
suggested
pages or other
locations to link
to from your
page. More...

See a list of
suggested
images,
multimedia files
and documents
to embed in your
page. More...

See a list of
suggestions as
you begin typing
a macro name.
More...

See a list of
suggested users
to mention. Mor
e...

On this page:

® Summary
of
autocompl
ete

® Using
autocompl
ete for
links

® Using
autocompl
ete for
images,
videos,
audio files
and
documents

® Using
autocompl
ete for
macros

® Using
autocompl
ete for
mentions

® Canceling
autocompl
ete

® Enabling
and
disabling
autocompl
ete

® Ignoring
autocompl
ete

Related pages:

® Links

® Using
Images

® Macros

® Keyboard
shortcuts

®* Your
profile and
settings
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Type T, or press Ctrl+Shift+K, to see a list of suggested pages or other locations to link to from your page.
You can link to pages, user profiles, images, documents and other file attachments.

To autocomplete a link:

1. Edit the page.
2. Click where you want to insert a link and do one of the following:
®* Type T and then the first few characters of the page title, user's name, image name or file

name.
® Type the first few characters of the page title, user's name, image name or file name (or select

relevant text) and then press Ctrl+Shift+K.
3. Click the relevant link from the list of suggestions.

If the item you need is not in the list, either:

® Choose Search for 'xxx' to continue looking for the page within Confluence, or
® Choose Insert Web Link to insert a link to an external web page using the link browser.

Screenshot: Autocomplete for a link

| want to add a link to [ sam|

Link suggestions
(=] sample Page
f2) Sample Space

Q, Search for ‘'sam’
& Insert Web Link

+ Insert Link to Create Page

Using autocomplete for images, videos, audio files and documents

You can use the autocomplete as a fast way of embedding images, videos, audio files and documents into
your page. Type an exclamation mark or press Ctrl+Shift+M to see a list of suggested images, multimedia
files and documents to display on your page. You can use autocomplete to embed the following file types:

® Images — any format that Confluence supports.

® Videos, audio files and all multimedia formats that Confluence supports.

® Office documents supported by the Confluence Office Connector: Word, Excel and PowerPoint.
[}

PDF files.

ﬂ Autocomplete works most efficiently for files that are already attached to the Confluence page.
To embed an image, video, audio file or document:

1. Edit the page.
2. Click where you want to insert the image, video, audio file or document and do one of the following:

®* Type 'I"and then the first few characters of the image, file or document name.
® Type the first few characters of the name of the image, file or document (or select relevant text)
and then press Ctrl+Shift+M.
3. Choose the relevant file from the list of suggestions.

If the item you need is not in the list, either:

® Choose Open Image Browser to find images and documents using the image browser, or
® Choose Insert Other Media to embed videos, audio and other multimedia files using the macro
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browser. Insert the 'Multimedia' macro to display your multimedia file.

Screenshot: Autocomplete for an image or document

| want to add an image |
Media suggestions
¢4 iBugs.gif
e{;ga iAngryNerdsGr.png

i DefaultSpacelLogo_AngryNerds png

Open Image Browser

= Insert Other Media

Using autocomplete for macros

Type '{ to see a list of suggested macros to add to your page.

Autocomplete provides access to all available macros in your Confluence site, including any user macros that
your administrator has added and made visible to all.

ﬂ You need to know the name of macro. Autocomplete for macros will only match the name of the macro,
not the description.

To autocomplete a macro using '{":

1. Edit the page.

2. Click where you want to insert the macro.

3. Type {' and then the first few characters of the macro name.

4. Choose the relevant macro from the list of suggestions.

5. Configure the macro by completing the form fields as prompted.

If the macro you need is not in the list, choose Open Macro Browser in the list of suggestions to continue
looking for the macro in the macro browser. See Macros.

Screenshot: Autocomplete for a macro

| want to add a macro {
Macro suggestions
@ Info
= Status
Gallery

= Table of Contents

= Open Macro Browser
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Using autocomplete for mentions

You can use autocomplete to automatically notify another Confluence user that you have mentioned them in
a page, blog post, or comment. Type ‘@' and part of the person's name, to see a list of suggested users.

Note: Use the person's full name. Autocomplete will recognize users' full names only, not their usernames.

Canceling autocomplete

The autocomplete starts automatically when you press the trigger characters. You may want to close the
autocomplete menu or escape from autocomplete once it has started.

There are a few different ways to stop the autocomplete once it has started:

Press the escape key, 'Esc’, on your keyboard.

Click somewhere else in the editor panel.

Press an arrow key to move out of the autocomplete area.

For the link autocomplete only: enter a right-hand square bracket, like this: ]

Enabling and disabling autocomplete

You can turn off the triggering of autocomplete by the '[' and '!" characters. This will prevent the autocomplete
from starting automatically when you press one of the trigger characters. You can also turn it back on again.

Notes:

® This setting does not affect the keyboard shortcuts for autocomplete (Ctrl+Shift+K and Ctrl+Shift+M).
Even if the trigger characters are disabled, you can still use the keyboard shortcuts for autocomplete.

® This setting affects only you. Other people using Confluence can enable or disable the setting on their
user profiles independently.

® Note that autocomplete is enabled by default.

To enable or disable the autocomplete trigger characters:

. Choose your profile picture at top right of the screen, then choose Settings
. Choose Editor under "Your Settings' in the left-hand panel.
. Choose Edit.
Either:
® Disable autocompletion by selecting Disable Autocomplete.
® Enable autocompletion by clearing Disable Autocomplete.
5. Choose Submit.

AN R

Screenshot: User settings for the editor
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Profle MNetwork Status Updates Favourites Watches Drafts Settings

GADGETS
View QAuth Access Tokens . .
Editor Settings
YOUR SETTINGS Disable Autocomplete
Password Dizable Autocomplete in the Editor, where it allows links to be inserted
. with the trigger [ and images with the trigger |
Email
Editor Disable Autoformatting

Dizable Autoformatting in the Editor, where it allows wiki-formatted text to
be converted to its Rich Text equivalent (e.g. "h1. title™ for a heading).

Edit

Ignoring autocomplete

You can add macros, links and images by wiki markup alone. Type the macro, including its parameters and
the closing curly bracket. Add a link, such as an anchor link, and end it with a square bracket. Insert an
image or other embedded object, enclosed between exclamation marks. As soon as you close the macro,
link, or embedded image, Confluence will convert it to rich text format and add it to the page.

For more information about mouse-free macros, links and images, choose Help

> Keyboard Shortcuts from the Confluence header.

Page Layouts, Columns and Sections

The layout of your pages can have a big impact on how they're read, and On this page:
layouts, used well, allow you to position text, images, macros, charts, and .
much more, to have the best visual impact. The ,
Section
There are two ways to modify the layout of a Confluence page: and
. Column
® Use page layouts to add sections and columns
. macros
® Use macros to add sections and columns.

Page layouts provide a simple, visual representation of your page layout in
the editor, while the macros are more flexible and allow for greater
complexity in your layout.

Use page layouts

The page layouts tool allows you to structure your page using horizontal sections and vertical columns. By
adding multiple sections with different column configurations you can build quite complex layouts very easily.

Screenshot: Editor view of a page showing three sections with different column configurations.
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+ Add section @ Remove section ~Moveup +Movedown [ BB IB B I N

Demo Space / Pages / Demo Space Home / Sample Page Title T2 % o

Sample Page Title

' Capture the knowledge that's too often lost in email inboxes and shared network drives in Confluence

instead — where it's easy to find, use, and update. Disfribute a clear agenda before, take notes during,

and assign tasks afterward. With all your notes and action items in one place, you can give email a

' break. Great products require equally great planning. Document, discuss, and track product .
requirements so your developers can hit the ground running | q

Start by adding a horizontal section to your page.
To add a section:

1. Choose the Page Layout

(]

button in the toolbar

The Page Layout toolbar appears.
2. Choose Add Section

The new section appears below your current content, with the boundaries of the section(s) indicated by
dotted lines (the dotted lines aren't visible when you view the page).

To change the column layout in a section:

1. Place your cursor in the section you wish to change
2. Choose a layout from the page layout toolbar (for example, two columns or three columns)

Any text, images or macros in your section are not lost when you change the column layout. When you
decrease the number of columns, Confluence will move your content to the left. When you increase the
number of columns, Confluence will add blank columns to the right of your existing content.

To move a section to another part of the page:

1. Place your cursor in the section you wish to move
2. Choose the Move up or Move down buttons

The section and all of its content will be moved above or below other sections on the page.
To delete a section:

1. Place your cursor in the section you wish to remove
2. Choose Remove section

The section and all of its content will be removed.

Notes about Page Layouts

® Column width — The width of the columns are fixed. If you need more than three columns, or columns
of a specific width, you should use the Section and Column macros described below.
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* Very wide tables — The width of each column is set to a percentage of the page width. The icons in
the drop-down menu indicate the relative widths for each layout. In most cases, Confluence will adapt
the width of the columns to fit the width of the page. If a column includes an item that's too wide for it,
you'll see a horizontal scroll bar when viewing the page.

The Section and Column macros

You can use the Section and Column macros to add a set of columns to the page. The Section macro
defines an area that will contain the columns. You can have as many sections as you like. Within each
section, you can have as many columns as you like.

The Section and Column macros are useful if you want to define a specific percentage or pixel width for each
column.

To add a section and some columns to a page:

1. In the Confluence editor, choose Insert > Other Macros

2. Find the Section macro, select it and insert it onto the page
3. Choose Insert > Other Macros again

4. Find and insert the Column macro

5. Add your content to the column

Insert as many columns as you like within the section.

You should always have at least one column macro within a section macro. Using a section macro
without any column macros can negatively affect page loading time.

Screenshot: A section and two columns in the editor

Section | border = true

Column

Content for column 1 goes here

Column

Content for column 2 goes here

When you see the page in view mode, the above layout is displayed like this:
Content for column 1 goes here
Content for column 2 goes here

Macro parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).
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Parameters of the Section macro

Parameter Default Description

Show Border false Select this option to draw a border around the section and columns.

Note: Without a Column macro , the border will not be displayed correctly.

Parameters of the Column macro

Parameter Default Description

Column 100% of the page width, divided Specify the width of the column, in pixels (for example,

Width equally by the number of columns 400px) or as a percentage of the available width (for
in the section. example, 50%).

All content within your section must be enclosed within a Column macro, otherwise the section layout
will not work as expected.

Create Beautiful and Dynamic Pages

Confluence has a number of features that help you On this page:
build attractive pages to engage your readers and ® Add visual appeal
give them the opportunity to interact with up-to-date ® Bring numbers to life
information. This page summarizes those features ® Display presentations and
and provides links to detailed instructions. documents
® Pullin content from JIRA
applications

Add visual appeal ® Tell a story in pictures

® Vary the structure of your pages

® Integrate your content with social
media

® Show activity streams

Pictures, photographs and
screenshots. Confluence pages
can display images from your
Confluence site and from other

websites. To put an image into Related pages:

Confluence, you can upload it

and attach it to a page or blog * Macros

post, then display it on any page, ® The Editor

blog post or comment. ® Create and Edit Pages

Alternatively, display a remote image using its web
address (URL). See Displaying Images.

Galleries. Use the Gallery Macro to display a set of
images. When viewing the page, people can click
any of the pictures to zoom in and view the images
as a slide show.

People. Add a Profile Picture Macro to show a picture of a Confluence user, or a User Profile Macro to show
a summary of the person's profile as well as their avatar.

Multimedia. You can display movies, animations and videos, and embed audio files on your Confluence
page. For example, Confluence supports Adobe Flash, MP3, MP4, and various other movie formats. See Em
bedding Multimedia Content.

Social video and image sharing. The Widget macro displays live content from social sites such as YouTub
e and other video sharing sites, and Flickr for shared photographs. See the guide to the Widget Connector
Macro.

Bring numbers to life

The Chart Macro offers a variety of graphs and charts that you can use to illustrate statistics and other
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numerical data.

lllustration: A 3-dimensional bar chart produced by the Chart macro

2003 2010 2011

B Revenue W Expense

Display presentations and documents

Display your Office documents and other presentations directly in Confluence.

® Attach your Office documents to a Confluence page then display them on the page, using the View
File Macro. This works for Excel spreadsheets, PowerPoint presentations and Word documents.

* Display PDF files in Confluence too, also with the View File Macro.

® Use the Widget Connector Macro to show slide decks hosted on SlideShare and other online
presentation sites.

K Atlassian ;e

Illustration: A PowerPoint slide deck

Pull in content from JIRA applications

Many project teams and customers also use JIRA applications such as JIRA Software or JIRA Service Desk.
Rather than copying and pasting issues onto your Confluence page, you can display it directly from the
source, thus ensuring that the information shown in Confluence is always up to date.

Link to a feature request in your issue tracker, or display a list of fixed issues — useful for release notes and
project planning. See the JIRA Issues Macro.

Tell a story in pictures

A number of Confluence add-ons provide sophisticated tools for creating diagrams and mockups.
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For example:

Balsamiq Mockups for Confluence
Creately for Confluence

Gliffy Confluence Plugin

Graphviz Plugin for Confluence
Lucidchart for Confluence

Search the Atlassian Marketplace for more add-ons.

Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's
information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our
guidelines on add-on support.

Space

Home page

Files Files Files Files

lllustration: A Gliffy diagram

Vary the structure of your pages

You can build up a custom layout by using the page layout tool to add sections and columns to your page.
See the detailed guidelines to Page Layouts, Columns and Sections.

Do you need to display tabular data, which your readers can sort when viewing the page? See Tables.
Use other macros to highlight and format sections of your page:

Panel

Info, Tip, Note, and Warning
Code block

Noformat

Integrate your content with social media

People share information on various social sites. You can make Confluence a focal point where people
collect their shared information and see what is happening in the areas that matter to them.

Use the Widget Connector macro:

Show a live stream of tweets from a Twitter user, or tweets matching a Twitter search.
Display a video from YouTube or other online movie sites.

Share photographs from Flickr.

See what else the Widget Connector macro can do.
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Tweets W Follow @confluence

Y Atlassian Confluence 2 Jul
< Gconfluence

Walking the requirements
documentation tightrope in an agile
waorld atlss.inf13hgGlh via @atlassian

Expand

vy Atlassian Confluence 27 Jun
Cx @confluence

Keep up-to-date with the new Watch

pbutton in Confluence — available

today! ow.lyimgm1l #collaboration
#atlassian -

Tweet to @confluence
lllustration: Twitter stream via the Widget macro

Show activity streams

Make your Confluence pages dynamic and interactive with:

® An activity stream showing updates and comments on Confluence and other linked applications. See
Gadgets.

®* An RSS feed from within Confluence or an external site. See Subscribe to RSS Feeds within
Confluence.

® Alist of recent blog posts from within Confluence. See Blog Posts Macro.

Page Templates

When you add a new page, you don't have to start from scratch. Instead,
you can base your new page on a template — a Confluence page with
predefined content. Some templates are provided by blueprints or add-ons,
and you can even create your own templates.

Some examples of useful templates are:

® The meeting notes template will help you and your team collaborate
on notes and follow-up tasks

® The requirements template allows you to capture your
software/hardware product requirements, and create related JIRA
issues from the page

Global templates and space templates

In Confluence, there are two categories of page templates:

® Space templates: These page templates are available in a specific
space only. If you have space administrator permission, you can
define templates via the space administration screen.

®* Global templates: These page templates are available in every
space on your site. If you have Confluence Administrator permission,
you can define global templates via the Confluence Administration
Console.

If you're a system administrator, you can also download predefined
templates.
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On this page:

® Global
templates
and space
templates

®* Create a
template

® Usea
template

® Templates
provided
by
blueprints

®* Promote
templates
in the
Create
dialog

® System
templates

Related pages:

¢ Create a
Template
® Administeri
ng Site

Templates
® |mporting
Templates
¢ Create a
Page from
a Template

Create a template

You can write your template using the Confluence editor. You can also add special variables to the page, if
you want to include fields that the author will complete when adding the page. See Create a Template for
more information.

Use a template

Page templates are used only when adding a page. It is not possible to apply a template to an
already-existing page. Once a page has been added using a template, the template is no longer linked to the
page. All further editing is performed as if the template was never used. Some plugins provide enhanced
template functionality. You can search the Atlassian Marketplace for template add-ons. See Create a Page
from a Template for more information.

Templates provided by blueprints
A blueprint is a page template with added functionality to help you create, manage and organize content in
Confluence, and there's a collection of predefined ones that ship with Confluence. You can also download

additional blueprints from the Atlassian Marketplace. You can customize the blueprint templates to suit your
individual needs, disable particular blueprints or even develop your own blueprints.

Promote templates in the Create dialog

If you're a space administrator, you can choose to promote specific templates and blueprints in the Create
dialog. Promoting items can help ensure consistency in a space by encouraging users to create particular
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types of content, instead of blank pages.

The promoted templates or blueprints will appear at the top, with all other content types, including Blank
Page and Blog Post collapsed under them. To view the other types of content available choose the Show

more link.
Create Fil
Select space Demonstration Space - Pa
,— How-to article Troubleshooting article
§; Provide step-by-step guidance for completing a Provide solutions for comm

task. problems.

Show more

o—

1. Show more: see more templates and blueprints.
To promote a template or blueprint:

1. Goto Space Tools > Content Tools
2. Choose Promote next to the templates or blueprints you want to appear in the Create dialog

Remember, by promoting a blueprint or template you'll be hiding all other items, including blank page and
blog post, under the Show more link.

If you use the Show more link in the create dialog more than three times in a single space, the dialog will
show you all templates by default from then on.

System templates

Confluence also provides 'system templates' containing content like the site welcome message and default
space content. See Administering Site Templates.

Create a Template
In Confluence, there are two categories of page templates:

® Space templates: These page templates are available in a specific
space only. If you have space administrator permission, you can
define templates via the space administration screen.

®* Global templates: These page templates are available in every
space on your site. If you have Confluence Administrator permission,
you can define global templates via the Confluence Administration
Console.

Add a template

To create a new space template:

1. Go to the space and choose Space tools > Content Tools from the
bottom of the sidebar
2. Choose Templates > Create new template.

To create a new global template:

1. Goto

> General Configuration Global Templates and Blueprints.
2. Choose Add New Global Template
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On this page:
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® Edit or
delete a
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Related pages:

® Create a
Page from
a Template

® Page
Templates

®* Add,
Remove
and
Search for
Labels

® Macros

® The Editor

Check out the article How to document releases and share release notes to see how helpful creating
templates in Confluence can be.

The template editor

When you create or edit a template, you'll be using the editor in much the same way as when you edit a
page or blog post. In addition you can add variables, which will produce a form for data collection when
anyone adds a page based on the template.
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Screenshot: The template editor with an image, table, text, and variables

Paragraph - B I Uu A -~ %2 -~ = = ~ = = = = [m] &PFiles & Link EBTable ~
g I = S S S| oWy B M Eil B HE B~ B ol
Confluence Docs / Templates S
Template title
Minutes for (TTTITITETD
Date [§ date]
Time [§time}
Location
gliandees Text Multidine Text List
Apologies

@ Template ~

Instructional text

New variable
$date

$location
$meetingName

$time

Screenshot: The form displayed when you create a page based on the template
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Confluence Docs / Pages / Confluence Docs Home / Confluence top 50 pages

Page Template Wizard

Step 2: Fill in template variables

The information you supply will become part of the content in your new page.

P e - e T

Minutes for

m (meetingName)

Date (date)

Time (time)
Location Meeting room 1 | (location)
Attendees

Apologies

Minutes

e Add your first meeting minute, here.

____________________________________________________________________________________

<< Back Next>>

Template variables

When you add variables to your template, they will act as form fields. When you create a page based on a
template, you'll see a text entry box for each field. Enter data into each field, and it'll be added to the page.

You can add the same variable more than once in the same template, which is useful if you need the same
information in more than one place on the page.

To insert a variable into a template:

1. Choose Template > New Variable from the editor toolbar (or choose an existing variable to add it to
the page)

2. Enter a name for the variable

3. Press Enter (by default this will create a single-line text input field)

To change the variable type, click the variable placeholder and the variable's property panel will appear.
Choose one of the variable types: Text, Multi-line Text, or List.

You can change the number of lines and width in characters of a Multi-line Text field. If you choose List,
enter each of the items in your list, separated by commas.
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5 X 100 Text Multi-line Text List

kick-off,standup,sparring Text = Multi-line Text = List

Hint: Type $ and the variable name, then press Enter to add a new variable or to select an existing variable
from a list of suggestions. The suggestions dialog shows variables already defined in this template.

Labels
If you'd like all pages created using this template to have one or more labels, choose the labels icon

%

next to the breadcrumbs at the top of the page to add them.

Images and other attachments
You can't upload an image or other file into a template directly. First you'll need to upload the file to a page in
your site, then in your template, choose Insert > Files > Search on other pages to embed the file or image.

Instructional text
Instructional text is placeholder content in a template, and is only visible while you're editing the page. Use it

to give guidance to whoever is creating a page from the template.

To insert instructional text:

1. Choose Template > Instructional Text in the toolbar
2. Type in your instructional text (for example, Insert an image of the interface here.)

Instructional text appears in italics with a shaded background, to distinguish it from normal paragraph text.

You can also change the placeholder type from Text to either:

® User mention — Opens the user mention dialog.
* JIRA Macro — Opens a dialog that allows you to create a new JIRA issue, or search for one or more

JIRA issues to include on the page.

Add a description to your template
The template description displays in the 'Create' dialog, and is useful for explaining the purpose of your
template to other users.

To add a description to a template:

® Go to the space or global templates page (as described above)
® Choose the Edit icon in the 'Description' column
® Enter your description and choose Save
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User Created Templates Create New Template
Name Description Last Updated By Updated Operations
Meeting Minutes My new meeting . ;
Template minutes tempiate. & Gil User Aug 27, 2014  Promote - Edit - Delete

1. Edit: use the pencil icon to edit your template's description.

Edit or delete a template

If you need to change anything about your template, or want to delete it, navigate to either your space or
global template (as described above) and choose either Edit or Delete.

Notes

® Page templates are used only when adding a page. It is not possible to apply a template to an
already-existing page. Once a page has been added using a template, the template is no longer linked
to the page. All further editing is performed as if the template was never used. Some plugins provide
enhanced template functionality. You can search the Atlassian Marketplace for template add-ons.

®* When you use a Table of Contents macro in a template, you'll see an error when you preview the
template, but the Table of Contents macro works on the pages that people create from the template.

® The editor for templates is available only in Confluence 4.3 and later. Please refer to the earlier
documentation for a description of the wiki markup editor templates.

® Confluence also provides 'system templates' containing content like the site welcome message and
default space content. See Administering Site Templates.

Create a Page from a Template

You can create a page based on a global template (available to all spaces) On this page:
or a space template (available only to that space). ® |nformation
copied
If you want to quickly create a blank page, hit the Create button in from the
the header; if you want to create a page from a template, hit the Cre template to
ate from template button. the page

® Form fields

o o displayed
by the
template

1. Create blank page ® Using a
2. Create from template template to
create a
page
® Notes

Information copied from the template to the page

Related pages:
When you create a page based on a template, Confluence will copy the

following content and information from the template to the new page: ¢ Create a
Template
¢ Labels ® The Editor
® Text and styles * Add,
® layouts and formatting Remove
® Macros and
®* Embedded images and other files. Note that you cannot attach an Search for
image or other file to a template. But if the template displays an Labels
image or file from another page, the new page will display that image
or file too.

Form fields displayed by the template

If the template author included variables in the template, Confluence will display a form prompting you to
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supply values for the variables when you add the page.

Using a template to create a page

To create a page based on a template:

1. Choose Create from template

in the Confluence header
2. Select a space and the template you want to use and choose Next
If the template contains variables, you'll see a form allowing you to add values for the form variables.
3. Type the relevant information into the form fields, and choose Next
Now you'll see a new page based on the template. If you added information in the form fields, the
page content will include that information.
4. Name your page, add content or make any other changes required and hit Save

Screenshot: Form showing template variables when creating a page from a template

Page Template Wizard

Step 2: Fill in template variables

The information you supply will become part of the content in your new page.

_____________________________________________________________________________________________

Minutes for

Status Meeting (MeetingMame)

. Date 15/02/2013  (Date)

| Time 9:00 AM| (Time)

| Location Meeting Room 1 ~ (Location)
| Attendees

. Apologies

. Minutes

|« Add the first item here...

<= Back Mext ==

Notes

Page templates are used only when adding a page. It is not possible to apply a template to an
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already-existing page. Once a page has been added using a template, the template is no longer linked to the
page. All further editing is performed as if the template was never used. Some plugins provide enhanced
template functionality. You can search the Atlassian Marketplace for template add-ons.

Blueprints

What's a blueprint?

A blueprint is a set of page templates with added functionality to help you

create, manage and organize content in Confluence more easily.

Create meeting notes, shared file lists and requirements documentation out
of the box, and Customize the blueprint templates to suit your individual

needs. You can even develop your own blueprints.

Create content using a blueprint

1. Choose Create from template

in the Confluence header
2. Select a blueprint from the create dialog
3. Hit Create

The editor will open, and, depending on the blueprint selected, a prompt to

enter information or the page will appear. You can now follow the
instructions built in to the blueprint to add content.

On this page:

®* What's a
blueprint?

® Create
content
using a
blueprint

® Customize
blueprint
templates

®* Promote
blueprints
in the
Create
dialog

® Add more
blueprints

® Disable a
blueprint

® Full list of
blueprints

Related pages:

®* Page
Templates

® Request
Add-ons

The first time a blueprint is used in a space, Confluence creates an index page and adds a shortcut to your
sidebar (if you're using the default theme). The index displays a list of pages made with the blueprint, and
information selected information from your blueprint pages. For example, the meeting notes index displays a
list of all meeting notes pages in the space, who created them, and when they were last modified. Here's the

index page for the Meeting Notes blueprint;

Meeting notes

Incomplete tasks from meetings
Description Due date ~

Giles Brunning to arrange venue for team outing Giles Brunning

All meeting notes
—
o Title

2015-06-01 Meating not

Greator

Rachel Robins [Atassian Technic..,

2015-06-04 Mesting nates Rachel Robins [Atiassian Technic.

Like  Be the first to like this

1. Easy to find: notes from all your meetings are listed here.

2. Start a new meeting: create a new meeting notes page here.

Customize blueprint templates

Create meeting note (e e

Task appears on

2015-06-01 Meeting notes

Medified

i85S than a minute age

a minute ago

Blueprints are made up of templates that can be customized for an individual space or the whole site. This
means you can adapt the content of the blueprint pages to suit your specific needs. For example, you might
update the Meeting Notes blueprint templates to include a heading for apologies.
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If you have space administrator permissions, you can customize blueprint templates for the spaces you are
an administrator of. You must be a Confluence Administrator to customize blueprint templates for a whole
site. See Administering Site Templates for more information.

To customize a blueprint template for a space:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Edit beside the blueprint template you wish to edit
3. Make your changes to the template and choose Save

Editing a blueprint template is very similar to editing a page template, except:

® Be careful not to remove any macros that the blueprint page or index page may use to store and
display information
® You can't remove a blueprint template or change the template name

To reset a blueprint template back to the default:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Reset to default beside the blueprint template you wish to reset

See Working With Templates and Administering Site Templates for more information on templates.

As with user created space and site templates, editing a blueprint template will not change existing pages,
but any new blueprint pages will be based on the updated template.

Promote blueprints in the Create dialog

If you're a space administrator, you can choose to promote specific templates and blueprints in the Create
dialog. Promoting items can help ensure consistency in a space by encouraging users to create particular
types of content, instead of blank pages.

The promoted templates or blueprints will appear at the top, with all other content types, including Blank
Page and Blog Post collapsed under them. To view the other types of content available choose the Show

more link.
Create Fil
Select space Demonstration Space v Pa

,— How-to article = Troubleshooting article
§; Provide step-by-step guidance for completing a Provide solutions for comm
task. problems.

Show more

o—

1. Show more: see more templates and blueprints.
To promote a template or blueprint:

1. Goto Space Tools > Content Tools
2. Choose Promote next to the templates or blueprints you want to appear in the Create dialog

Remember, by promoting a blueprint or template you'll be hiding all other items, including blank page and
blog post, under the Show more link.

If you use the Show more link in the create dialog more than three times in a single space, the dialog will
show you all templates by default from then on.

Add more blueprints

You can find more blueprints for Confluence in the Atlassian Marketplace. Blueprints are managed using
add-ons (also known as plugins).
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See Request Add-ons for information on how you can search for new blueprint add-ons and send a request
to your System Administrator.

If you are a System Administrator, see Managing Add-ons or Plugins for information on how to install new
blueprint add-ons.

You can also develop your own blueprints. See our developer documentation on Writing a Blueprint.

Disable a blueprint

You may want to disable particular blueprints. For example, you may not want to see the Product
Requirements blueprint in the create dialog in an HR or Social space. If you are a Confluence Administrator
you can also disable particular page and space blueprints for the whole site.

To disable a blueprint in a space:

® Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
® Choose Disable next to the blueprint you wish to disable in that space

You can re-enable the blueprint at any time.
To disable a blueprint across a whole site:

® Choose the cog icon

, then choose General Configuration under Confluence Administration (You need Confluence
Administrator permissions to do this)

® Choose Global Templates and Blueprints

® Choose Disable next to the page or space blueprint you wish to disable

The blueprint will not appear in the 'Create’ or 'Create Space' dialogs.

Full list of blueprints
Here's the full list of blueprints bundled with Confluence.

Page blueprints Space blueprints

Meeting notes ® Documentation space
File list ® Team space
Decision * Knowledge base space
How-to article

Troubleshooting article

JIRA report

Product requirements

Retrospective

Share a link

Task report

DACI decision (Atlassian Team Playbook)

Experience canvas (Atlassian Team Playbook)

Health Monitor (Atlassian Team Playbook)

Project poster (Atlassian Team Playbook)

Decisions Blueprint

The Decisions blueprint helps you make decisions and record the outcomes
with your team.

The first time you use the Decisions blueprint in a space, Confluence will
create an index page and add a shortcut on your space sidebar (if you're
using the default theme). The index acts as your Decision Register and lists
all the decisions in that space.
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If you want to quickly create a blank page, hit the Create button in Related pages:
the header; if you want to create a page from a template, hit the Cre ,
ate from template button. Blueprints
® File List
o e Blueprint
® Meeting
Notes
1. Create blank page SV
® Product
2. Create from template .
Requireme
nts
To create a decision page: Blueprint

1. Choose Create from template

in the Confluence header

Select Decision and hit Next

3. Enter information about the decision and relevant stakeholders (the
blueprint will prompt you) and hit Create

N

Once you save your first decision page, Confluence will create a decision
register page for the space you're in, and add a shortcut to it in the space's
sidebar.

Here's how the decisions page looks in the editor:

What is our target launch date?

¥ Page properties | label

Status IN PROGRESS

Stakeholders  Rosie Admin, Josh User, Sophie User

Outcome What did you decide?

Due date =119 Mar 2015

Owner Rosie Admin
Background

o Summit will be on again in 2015, so we need to be locked-in well in advance.
« Rosie Admin will be on leave in February, so that may hold things up. Can Josh User take on the leadership role?
« We have 4 teams working on this throughout that period. Is this enough?

Once you save your first decision page, Confluence will create a decision register page for the space you're
in, and add a shortcut to it in the space's sidebar. The decision register and lists all the decisions in that

Pages / Confluence Docs Home # Edit @ Watch [2 Share £} Tools ~
Decision register
Created by Rachel Robins, last modified on Aug 15, 2013
Create decision{jmmm e
Decision Status Stakeholders Outcome Due date Owner
How should we divide up 2 Rachel Robins| @ Giles Brunning| /@ Nick Doherty Split for 5.7 onwards 08 0ct2014  @Rachel Robins
=8 confluence teams between decided here
writers
Should we retire Planning for Rachel Robins , |& Giles Brunning Move pages with 03 Oct 2014 Rachel Robins
Confluence 4 and 5 doc from comments to CONF40
the latest space and CONFS50 archive

spaces.

Where should CQ developer 7703 Oct 2014 Rachel Robins

doc live

IN
PROGRESS
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1. Decision pages: your existing decisions appear here.
2. More decisions: create new pages using the decision template.

The Decisions blueprint uses these Confluence features:

® Page Properties and Page Properties Report macro - content that you enter within the page properties

macro can appear on the index page.
® Mentions - add a user as a stakeholder, owner or @mention them on the page and they will be notified

in their workbox.

For an example of the Decisions Blueprint, and some other great page elements, check out: How to
make better decisions as a development team.

Customizing this blueprint

You can customize the templates that are used by the Decisions blueprint - see Customizing the blueprint
templates. For example, you might choose to edit the decisions index page in a space to change the
columns displayed by the Page Properties Report macro.

You can also edit the page template to add headings or instructional text to the background section, or even
add rows to the Page Properties macro. For example, a row for the date the decision was made.

See Instructional text to find out more about using instructional text in templates.

File List Blueprint

The File List blueprint helps you to create lists of files to share with your Related pages:
team. Great for organizing documents, images and presentations. _
® Blueprints
The first time you use the File List blueprint in a space, Confluence will ® Meeting
create an index page and add a shortcut to your space sidebar (if you're Notes
using the default theme). The index page lists the latest File List pages in Blueprint
that space. You can have as many File List pages as you need. ® Product
Requireme
If you want to quickly create a blank page, hit the Create button in nts _
the header; if you want to create a page from a template, hit the Cre Blueprint

ate from template button.

1. Create blank page
2. Create from template

To create a file list:

1. Choose Create from template

in the Confluence header
2. Select File List and hit Next
3. Enter the details for your file list and hit Create
4. Drag files from your desktop or choose browse for files to search for files on your computer

Here's an example of a file list page:
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Presentations
Created by Rosie Admin 32 minutes ago
File Modified *
> (£] Atlassian presentation graphic assets.key.zip 30 minutes ago by Rosie Admin
> (] IX Image Tools.key.zip 30 minutes ago by Rosie Admin
» (1) 10 tech writing tips .key.zip 30 minutes ago by Rosie Admin
o—. v (@] 10 tech writing tips .ppix 24 minutes ago by Frank Admin

Atlassian

riting tips:

Don't does

I
.
-~
v
Nal

Labels
No labels #

Version history
Version 3 (current version) Modified by Frank Admin 24 minutes ago  @——— e
Version 2 Modified by Administrator 26 minutes ago

Version 1 Created by Rosie Admin 29 minutes ago

View Edit in Office Properties Delete

e_. Drag and drop to upload or browse for files

¥ Download Al

1. Expand: view each file's details and preview.
2. Upload and download: drop files to upload, and download all files.
3. Version history: see and manage other file versions.

Attachments appear on the page, and you can expand each attachment to preview the file and/or view its
details.

In this example, we've created three file list pages to store project-related presentations, images and
customer feedback. Confluence looks after the versioning of the files, so there's no need to use the
document file name to mark version numbers.

Once you save your page, Confluence will create an index page and add a shortcut to your space sidebar.
The index page lists the latest File List pages in the space. Create as many File List pages as you need.

Pages / Blue Sky Project Home Edit @ Walch =+ Share Tools ~
e Blue Sky Project 9 ue Sky Pro) 2Edt @ I &
File lists
&
(2 Pages Created by Rosie Admin 16 minutes ago
S Blog
[ .
Create file list
SPACE SHORTCUTS
geoseoy Title Creator Modified
1) Meeting notes
Customer Feedback Frank Admin a minute ago
Retrospectives
Project Images Frank Admin a minute ago
o —® 5 File lists e g
Presentations Rosie Admin 16 minutes ago (————
PAGE TREE

1. Space shortcut: a quick way to find all of your file lists in this space.
2. Create a new list: create more file lists in this space.
3. Current file lists: see all the file lists in this space.

Customizing this blueprint

You can customize the templates that are used by the File List blueprint - see Customizing blueprint
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templates.

The File List blueprint template uses the attachments macro. You can customize the macro to change the
sort order or hide features such as version history and the upload attachment fields.

You can also edit the Content Report Table macro used on the Index page to specify the number of pages

you want to display.

Meeting Notes Blueprint

The Meeting Notes blueprint helps you to plan your meetings and share
notes and actions with your team.

The first time you use the Meeting Notes blueprint in a space, Confluence

will create an index page and add a shortcut on your space sidebar (if you
are using the default theme). The index page lists the latest Meeting Notes
pages in that space.

If you want to quickly create a blank page, hit the Create button in the header; if you want to create a

page from a template, hit the Create from template button.

1. Create blank page
2. Create from template

To create a meeting notes page:

1. Choose Create from template

in the Confluence header
2. Select Meeting Notes and hit Next
3. Enter the information required by the template and hit Create
4. Save your page and get ready to attend your meeting

You can edit the page during or after your meeting, and enter your notes, action items and @mention users

to assign tasks to them.

Screenshot: A Meeting Notes index page

Related pages:

® Blueprints

® File List
Blueprint

® Product
Requireme
nts
Blueprint
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Pages / Marketing team home # Edit © Watich 2 Share soe

Meeting notes

Created by Gil User, last modified just a moment ago

Create meeting note

All meeting notes

Title Creator Modified

Gil and Nick 1:1 2015-04-28 Gil User Apr 29, 2015
Cloud space relaunch kick-off meeting Gil User Apr 24, 2015
Cloud relaunch - product stakeholder meeting Gil User Apr 14, 2015

Screenshot: A blank Meeting Notes page showing instructional text

Heading 2 v B I U A~ A~ R [ &= =

m & @ =@~

People / Gil User / Pages /... / Testingpage T2 % o

2015-05-04 Meeting notes

Date

7104 May 2015

Attendees

+ Gil User
* @mention a person to add them as an attendee and they will be notified.

Goals

» Set goals, objectives or some context for this meeting.

Discussion items

Time Item Who Notes

dmin | Agendaitem Name o Notes for this agenda item

Action items

Type your task here. Use "@" to assign a user and "//" to select a due date.

+ -

Created in 2017 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.

132


http://creativecommons.org/licenses/by/2.5/au/

Confluence 6.3 Documentation 133

The Meeting Notes blueprint uses some cool Confluence features:

® |nstructional text - this handy text prompts you to enter information and disappears when you start
typing or view the page.
Mentions - @mention a user on the page and they will be notified in their workbox.

® Task lists - @mention a user in a task to assign it to them — the task will appear as a personal task in
their workbox. You can also add a due date by typing //, then choosing a date from the calendar.

Customizing this blueprint

You can customize the templates that are used by the Meeting Notes blueprint — see Customizing the
blueprint templates.

You might choose to edit the headings or add additional headings, or change the instructional text that
prompts users to enter information to suit your context. To find out more about using instructional text in a
template, see Instructional text.

You can also edit the Content Report Table macro used on the Index page to specify the number of pages
you want to display.

Product Requirements Blueprint

The Product Requirements blueprint helps you to define, scope and track Related pages:
requirements for your product or feature. .

® Blueprints
The first time you use the Product Requirements blueprint in a space, ® File List
Confluence will create an index page and add a shortcut on your space Blueprint
sidebar (shortcut only available in the default theme). The index lists all the ®* Meeting
Product Requirements pages in that space, and displays a summary of the Notes
information on each page (such as status and owner). You can have as Blueprint

many Product Requirements pages as you need.

If you want to quickly create a blank page, hit the Create button in the header; if you want to create a
page from a template, hit the Create from template button.

1. Create blank page
2. Create from template

To create a requirements page:

1. Choose Create from template

in the Confluence header
2. Select Product Requirements and hit Next
3. Enter information about your product or feature (the instructional text will prompt you) and hit Create

You can @mention team members to bring them into the conversation about the page.

In this example we've created a series of Product Requirements pages. The index page shows summary
information about each one.
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6 L Pages / Project Inception Home  of ZEiN  ©Wach % Shae

Product Requirements

J Pages Croated by Shorl Mar I dar 18, 2013

3\ Blog
Noteg Add Product Requirements (e o

SPACE SHORTCUTS

Title Designer owner status QA Target release Theme

Meeting Notes
z Share with friends feature Valter Fatia TBA Sherif Mansour  ([ZXEENTSN TBA 44 Notifications.

Pluggable Nofifications Valler Fatia Niraj Bhawnani Bill Arconati IN PROGRESS: Joey Corea 44 Notifications:

Pad Client Henry Tapia Chris Kiehl John Masson [ swerep | Glenn Martin 43 Clignts

CHILD PAGES
Prc nception H Signup via Facebook Henry Tapia Anna Dominguez Sherif Mansour DRAFT Glenn Martin 5.0 Onboarding  (— e
vject Inception Home

Erxteglaneny ©) Like  Bo the first to like this Nolabels #

1. New requirements: create more requirements pages in this space.
2. Requirements pages: see the existing requirements pages in this space.

Here's how a requirements page looks in the editor:

Pluggable Notifications

V/ Page properties

Target release 4.4
Epic x JIRA | CONF-1
Document status IN PROGRESS

Document owner  Frank Admin

Designer Rosie Admin Josh User
Developers Lead developer
QA Lead tester

Goals

o E.g. Simplify the user experience, reduce friction efc...

Background and strategic fit

Why are you doing this? How does this relate to your overall product strategy?

The Product Requirements blueprint uses these Confluence features:

® Page Properties and Page Properties Report macro - content that you enter within the page properties
macro can appear on the index page.

® |nstructional text - this handy text prompts you to enter information or create a JIRA issue
and disappears when you start typing or view the page.

®* Mentions - @mention a user on the page and they will be natified in their workbox.

Customizing this blueprint

As no two products or projects are alike, you can customize the templates that are used by the Product
Requirements blueprint - see Customizing the blueprint templates.

You might choose to edit the index page in a space to change the columns to be displayed by the Page
Properties Report macro.

You might choose to edit the page template to:

® edit the headings or add additional headings
® change the instructional text that prompts users to enter information to suit your context
® add or remove rows within the Page Properties macro.

See Instructional text to find out more about using instructional text in templates.

Shared Links Blueprint
The Shared Links blueprint helps you take content from the web and share it
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with your team. You can use Shared Links to share and collaborate on web Related pages:
content, or to create a centralized repository of useful links. ,
® Blueprints
The first time you use the Shared Links blueprint in a space, Confluence will ® Decisions
create an index page and add a shortcut on your space sidebar (if you're Blueprint
using the default theme). The index lists all the shared links in that space. ® File List
Blueprint
If you want to quickly create a blank page, hit the Create button in * Meeting
the header; if you want to create a page from a template, hit the Cre Notes
ate from template button. Blueprint
® Product
gl Crezte | - [
nts
Blueprint

1. Create blank page
2. Create from template

To create a shared links page:
1. Choose Create from template

in the Confluence header
2. Select Share a link and hit Next
3. Enter the URL of the web content you want to share, then hit Create

You can also:

® Include topics to help categorize your links — these are added as labels to your page.
® Share the link immediately with another user or group — users will receive a notification.
® Add a comment to start the discussion.

To make sharing links even faster, you can add a Share on Confluence button to your browser's
toolbar. Click this button and the webpage you're currently viewing will be added as a shared link!

To add the Share on Confluence button to your browser:

1. Choose Create from template

, then select Share a link
2. Drag the Share on Confluence button to your browser toolbar

Now, when you want to share a link in Confluence, choose the Share on Confluence button in your browser
and follow the prompts.

Screenshot: Share a link from the Create dialog.
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Share a Link

Link™ | Paste a link to any website About sharing Links

Share links to anything you find on the web. To
- e .
Title | Title of the page make sharing easier, drag this bookmarklet to
your bookmarks bar.
Topics
. & Share on Confluence

Share with | share thiz page with user It will appear like this in your browser.

N

comment | Share your thoughts about this link 8 00 | NewTab
<« C|[a

ﬁ Atlassian ¥ Share on Cenfluence

JIRA Report Blueprint
The JIRA Report blueprint helps you create easy to read reports to

communicate the progress of your JIRA Software projects and releases. Yo On this page:
u can choose from a Change Log report that generates a list of JIRA issues ¢ Create a
or a Status Report that includes charts to visually communicate your Change
progress. Log
® Create a
The first time you use the JIRA Reports blueprint in a space, Confluence will Status
create an index page and add a shortcut on your space sidebar (if you're Report
using the default theme). ® Customizin
g this
If you want to quickly create a blank page, hit the Create button in blueprint

the header; if you want to create a page from a template, hit the Cre
ate from template button.

gl croate | -+ [
1. Create blank page

2. Create from template

To use the JIRA Report Blueprint your Confluence and JIRA application
(such as JIRA Software) must be connected via Application Links .

Create a Change Log

The Change Log report displays a list of issues from your JIRA application. This list can be static or dynamic,
automatically updating as the status of your issues change in JIRA.

To create a static change Log:

1. Choose Create from template

in the Confluence header
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2. Select JIRA report and hit Next
3. Select a Change log and hit Next
4. Enter the information required for the change log and hit Create

A report page will be created with sample text and a list of all issues for the project and fix versions selected,
organized by issue type. This list of issues is static; it won't be updated when the issues are updated, and is
visible to users who don't have JIRA access or permissions to view that project.

Screenshot: Creating a Change Log in simple mode.

Change log

About Change Log

Keep a log of your teams progress or
communicate deliverables. Generate a static
or dynamic list of JIRA issues from a saved
Fix Veersion(s) 5.4 x search, JRA URL or JQL query.

P’-:jec" Confluence -

Switch to advanced

Title = Confluence 5.4

Back m Close

Screenshot: Static list of JIRA Issues displaying in the Change Log.

All updates for this release

Improvement
s CONF-29057 - Automatically embed WuFoo forms and Reports in Confluence when pasting a URL
Bug

: . Cursor doesn't appear in editor in Chrome 30
o CONF-27451 : Login should say "Log in"

To create a dynamic change log:

1. Choose Create from template

in the Confluence header

Select JIRA report and hit Next

Select a Change log and hit Next

Choose Switch to advanced

Enter a JQL query or paste in the URL of a JIRA search (find out about using JQL in the JIRA
Documentation)

6. Hit Create

arwd

A report page will be created with sample text and a JIRA issues macro that's configured to show your
issues. The macro is dynamic and will update when the issues are updated. For more information on
changing the information displayed, refer to the JIRA Issues macro.

Screenshot: Dynamic list of JIRA Issues displaying in the Change Log.
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All updates for this release

Key Summary Type Updated Priority  Status
CONF-31163  Cursor doesn't appear in editor in Chrome 30 [e] Oct21, 2013 ¥ Resolved
CONF-29057  Automatically embed WuFoo forms and Ed] Oct18, 2013 # Resolved

Reports in Confluence when pasting a URL

CONF-27451  Login should say "Log in" (=] Oct02, 2013+ #> Resolved

3issues 3 Refresh

Create a Status Report

The Status Report displays the progress of a JIRA project and fix version in pie charts by status, priority,
component and issue type. The Status Report uses the JIRA Chart macro, and is dynamic.

To create a status report:

1. Choose Create from template

in the Confluence header
2. Select JIRA report and hit Next
3. Select a Status report and hit Next
4. Enter the information required for the report and hit Create

A report page will be created with sample text and a series of pie charts, using the JIRA Chart macro. The
macro is dynamic and will update when the issues in JIRA are updated. For more information refer to the JIR
A Chart macro.

As with the Change Log, you can switch to Advanced mode and use JQL or paste in a JIRA URL to search
for issues to display in the report.

Screenshot: Excerpt from the Status Report.

Confluence 5.3

Release Confluence 5.3

Status Oct 28, 2013 - GREEN

Report summary

This is the report summary - you can add a summary or some commentary on the status of your project here.

Overall status for 70 issues Priority

- Irrelevant
" =16

Resolved
B

Major =
18

—__ Critical =
13
Awvaiting
Quality’
. Review = - Trivial = 2
— 1 Minor = _ —
— |n109r I ~—————__ Blocker =

TTopen=1 2

Customizing this blueprint
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You can customize the templates used by this blueprint. The Change Log uses the Snapshot JIRA Report
Template (for static list of issues) and the Dynamic JIRA Report Template, and the Status Report uses the
Status Report Template. See Customizing the blueprint templates. Variables represent the JIRA Issues
and JIRA Chart Macros. While these can't be edited, they can be moved around the page or deleted if you
don't want every chart to be included.

You can also choose to edit the page template to modify the format of the page, change some headings, or
modify the instructional text. To See Instructional text to find out more about using instructional text in
templates.

Retrospective Blueprint

Retrospective pages help you track team successes and opportunities after Related pages:
projects or at the end of a sprint. Use this blueprint to document what went .
well, what needed improvement, and assign actions for the future. : E,Illéef_g?ts
ile Li
The first time you create a retrospective page in a space, Confluence will Blueprint
automatically create an 'index' page, which will list all retrospectives in the ® Meeting
space, and add a shortcut to it in the space sidebar. Notes
Blueprint

If you want to quickly create a blank page, hit the Create button in the header; if you want to create a
page from a template, hit the Create from template button.

1. Create blank page
2. Create from template

To create a retrospective page:

1. Choose Create from template

in the Confluence header
2. Select Retrospective and hit Next
3. Add participants, change the title if you want to and click Create

Run a Retrospective

Title | 2013-10-24 Retrospective About retrospectives

Brainstorm and vote on what went well and

Participants | [ Ruth Buchanan x what could be improved in your last sprint or
project with your team, then set out some
action items.

Screenshot: The 'retrospective’ template page
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2014-10-13 Retrospective

V! Page properties

Date 14 Oct 2014

Participants  Rosie Admin Josh User

Retrospective

= Panel =: Panel

What did we do well? What should we have done better?

o List all items that you did well. o List all items that you should have done better.

Actions

@mention a person to assign them an action item

The Retrospective blueprint uses the following Confluence features:

® Page Properties and the Page Properties Report macro make content listed within the macro visible

on the index page.
® |nstructional text prompts you to enter information and disappears when you start typing or view the

page.
® Mention a user on the page to notify them in their workbox.

Check out how the retrospectives blueprint can be used in the article Create sprint retrospective and
demo pages (like a BOSS).

Customize this blueprint

Every team conducts retrospective meetings differently, so you can customize the Retrospective blueprint
template to match your team's culture and practices. You can:

® Edit headings and pre-populated text
® Add instructional text to capture specific information
® Add additional sections and content

See Customize blueprint templates for instructions.

How-To Article Blueprint
The How-To Article blueprint helps you to provide step-by-step guidance for
completing a task.

To create a How-To Article page:
1. Choose Create from template

in the Confluence header
2. Select How-To Article and hit Next
3. Enter the article name and some labels and hit Create

If you want to quickly create a blank page, hit the Create button in
the header; if you want to create a page from a template, hit the Cre
ate from template button.
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o e Related pages:

Blueprints

Troublesho
1. Create blank page oting

2. Create from template Article

Blueprint

® Create
Technical
and
Onboardin
g
Document
ation

® Use
Confluenc
easa
Knowledge
Base

Screenshot: A blank How-To Article page showing instructional text

How to prepare for Winter

Describe when someone would need this information. For example “when connecting to wi-ii for the first time".

Step-by-step guide
Add the steps involvea:

1. Insert your steps.
2. You can also copy and paste or drag and drop images into your instructions.

@ Info

You may also want to use visual panels to communicate related information, tips or things users need to be aware of.

Related articles
Related articles appear hera based on the labsls you select. Click to edit the macro and add or change labels.
[ content by Label | cgl = label = "kb-how-to-ar..

¥ Page properties | hidden = true

Related issues

Once you save your page, Confluence will create an index page and add a shortcut to your space sidebar.
The index lists all the How-To Article pages in that space, and displays a summary of the information on each
page (such as creator and modified).

How-to articles

Created by Desiree Conceicac yesterday at 3:01 PM

Add how-to article

Title Creator Modified
How to groom a direwolf Desiree Conceicao yesterday at 3:01 PM
How to grow a weirwood Desiree Conceicao yesterday at 3:01 PM
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The How-To Article blueprint uses some cool Confluence features:

® Instructional text - Prompts you to enter information and disappears when you start typing or view the

page.
® Content by Label Macro - Displays lists of pages that have particular labels, to let you collect related

pages together.
® Page Properties Macro - This works together with the Page Properties Report Macro to automatically

create a list of 'related issues' on each article.

Customizing this blueprint

You can customize the templates used by the How-To Article blueprint - see Customizing the blueprint
templates. For example, you might choose to edit the How-to index page in a space to change the columns
displayed by the Page Properties Report macro.

You can also edit the page template to add headings or instructional text to the background section, or even
add rows to the Page Properties macro. For example, a row for the date the How-To Article was created.

See Instructional text to find out more about using instructional text in templates.

Troubleshooting Article Blueprint

The Troubleshooting Article blueprint helps you to provide solutions for Related pages:
commonly-encountered problems. .
® Blueprints
® How-To
. : Article
To create a Troubleshooting Article page: Blueprint
1. Choose Create from template e Create
- Technical
. and
in the Confluence header Onboardin
2. Select Troubleshooting Article and hit Next g
3. Enter the article name and some labels and hit Create Document
ation
® Use
Confluenc
easa
Knowledge
Base

If you want to quickly create a blank page, hit the Create button in the header; if you want to create a
page from a template, hit the Create from template button.

° CZIES
1. Create blank page

2. Create from template

Screenshot: A blank Troubleshooting Article page showing instructional text
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Winter is coming

Problem

Describe the problem as the user would experience it. For example "Level 7 printer is flashing red and wont print".

Solution
Provide steps that the user can take to solve the problem. For exampie "The level 7 printer will flash red when it is out of paper. Add paper to tray 1°.
== Panel

You may want to use a panel to highlight important steps.

1. Use numbered lists to provide step-by-step help.
2. Copy and paste or drag and drop images to add them to this page.

Related articles

Related articles appear here based on the labels you select. Click to edit the macro and add or change labels.
Content by Label | cql = label = "kb-troublesh. ..

¥ Page properties | hidden = true

Related issues

Once you save your page, Confluence will create an index page and add a shortcut on your space sidebar.
The index lists all the Troubleshooting Article pages in the space, and displays a summary of the information
on each page (such as creator and modified).

Troubleshooting articles

Created by Desiree Concelcao, last modified 10 minutes ago

Add troubleshooting article

Title Creator Modified

Winter is coming Desiree Conceicao less than a minute ago
The wall is understaffed Desiree Conceicao 2 minutes ago

Ghost is hungry Desiree Conceicao 4 minutes ago

The Troubleshooting Article blueprint uses some cool Confluence features:

® Instructional text - Prompts you to enter information and disappears when you start typing or view the
page.
® Content by Label Macro - Displays lists of pages that have particular labels, to let you collect related

pages together.
® Page Properties Macro - This works together with the Page Properties Report Macro to automatically

create a list of 'related issues' on each article.

Customizing this blueprint

You can customize the templates used by the Troubleshooting Article blueprint - see Customizing the
blueprint templates. For example, you might choose to edit the decisions index page in a space to change
the columns displayed by the Page Properties Report macro.

You can also edit the page template to add headings or instructional text to the background section, or even
add rows to the Page Properties macro. For example, a row for the date the Troubleshooting Article was
created.
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See Instructional text to find out more about using instructional text in templates.

You can also edit the Content Report Table macro used on the Index page to specify the number of pages

you

want to display.

Create a Blueprint-Style Report

Using a combination of templates and macros you can make a wide range of reports for managing anything from
customer interviews, product requirements to IT service catalogs and more. In this tutorial we'll guide you
through the process of creating a blueprint-style report.

In this example, we'll create a multi-team status report. Here's the scenario we'll use for this tutorial.

The Design, Development and QA teams working on the Blue Sky Project need to produce a short
status update page each week, containing the focus area for the week, contact person, risks and
overall status for each team. They like the way the Product Requirements blueprint works and want
to be able to manage their status updates in a similar way.

What do each of the players want out of this report?

Project Lead — Wants an at-a-glance report that shows only the status for each team.

Team Leads — Want a summary report, including the focus areas and risk, just for their team.
All team members — Want it to be easy to create the new page each week.

Management Team — Want to see all the details for a week on one page, and don't want to
have to look at a different page for each team.

With this scenario in mind, this tutorial will guide you through how to:

1.

N

Create a status update template containing a separate page properties macro for each team's section of
the report.

. Create a high level status report, showing just the status of all teams.
. Create a summary report for each team.
. Create your first status update page.

You'll need Space Administrator permissions to complete some of the steps in this tutorial.

Part 1: Create a status update template

First we'll create a page template and add the Page Properties macros.

1
2
3.
4
5

. Go to Space Admin > Content Tools > Templates

. Choose Create Template

Give the template a name (in this example the template will be called 'Status Update")
. Add the skeleton of your status report to the page

. Choose the label icon

)
at the top of the page to add a label to the template (in this example, we'll add the label: 'status-update’)

Screenshot: Adding teams to our status update template
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Heading2 ~ B I U A~ ‘A~ Ho = v sE FE = =E W | &F @ B B +~ 9 Q 7

Gil User / Templates %

Status update

Executive Summary
Text summary of the week's status, to be completed by the project lead.
Design Team

Development Team

QA Team

Preview m Cancel

Now we'll add a Page Properties macro to record the status of the Design team.
Choose Insert > Other Macros > Page Properties to add the Page Properties macro to the page
7. In the macro body create a two column table and remove the heading row
8. In the left column enter the column headings for your report (these are known as metadata 'keys')
In this example we'll add 'Design Focus', 'Design Status', 'Design Contact' and 'Design Risks").
9. In the right column, leave the cells blank, or enter some instructional text to prompt your users (Choose T
emplate > Instructional Text)
We've also added a status macro.
10. Edit the Page Properties macro and enter a Page Properties ID for this macro (in this example we'll use
'status-update-design'. This will allow us to report on the status of just the Design team later on)
Repeat this process for the Development and QA teams, remembering to specify a different ID for each
macro (we used 'status-update-dev' and 'status-update-qa’).
11. Finally, add any other headings, instructional text or content to your template and Save.
You can enter a Description for your template - this appears in the Create dialog.

o

Screenshot: Our status update template
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Design Team

N Page properties | id = status-update-design
Design Focus What was your team's main focus this week?
Design Status STATUS

Design Contact  Who is the contact person?

Design Risks Risks that have emerged this week

Development Team

) Page properties | id = status-update-de
Dev Focus What was your team's main focus this week?
Dev Status STATUS

Dev Contact Who is the contact person?

Dev Risks Risks that have emerged this week

Part 2: Create a report showing the high level status of each team

Next we'll create an index page, just like you see in many blueprints.

1.

2.

In your space create a new blank page (this will be our 'Status Report - all teams' page, showing just the
status of each team)

Choose Insert > Other Macros > Page Properties Report to add the Page Properties Report macro to
the page

Enter the Label to report on (in this example, it'll be the 'status-update' label we added to the template
page)

Leave the Display options > Page Properties ID field blank (we want to report on all the macros on the
page)

In the Columns to Show field, list the 'keys' from each macro that you want to include in the report (in

this example, we only want to show the values of 'Design Status', 'Dev Status', 'QA Status')
Choose Save to add the macro to the page

Screenshot: The page properties report macro on the 'Status Report - all teams' page
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10.

11.
12.
13.

Edit ‘Page properties report’ Macro

¥ Preview

Options
Page properties 1D (optional) Title

No content found.

Title column heading

Change the heading of the Title column
which contains links to pages. Maximum
35 characters.

Columns to show

Design Status, Dev Status, QA Sta

Comma separated list of columns to
include in the table. Page title is always
shown.

Number of items to display

Select macro Save @ Cancel

Now we'll add a button to the page to allow team leads to easily create new status update pages from the
template we created earlier.

Choose Insert > Other Macros > Create from Template to add the Create from Template macro to the
page

Enter the text for the button (in this example we'll call the button ‘New Status Update Page')

Select the template from the Template Name drop down (in this example our template was called 'Status
Update")

Specify the title of any pages to be created (This is a great way to keep your titles consistent. In this
example we'll call the page 'Status update week ending @currentDate', which will append the current date
when the page is created, as in the meeting notes blueprint)

Choose Insert

Add any other content, links or images to the page and Save

Choose Space Tools > Configure Sidebar > Add Link to add a shortcut to the page on the sidebar

Part 3: Create a separate report for each team

Now we'll create some index pages that show a more detailed summary for each team, starting with the Design

team.

1.

2.

o

Create a new blank page — this will be the 'Design Status Report' index page, showing just information for
that team.

Choose Insert > Other Macros > Page Properties Report to add the Page Properties Report macro to
the page

Enter the Label (the page label is once again 'status-update’, the label we added to the template)

Expand the Display options and enter the Page Properties ID that was specified in the Page Properties
macro in the template (in this example it was 'status-update-design') — this allows us to report on just
information in that macro.

Leave all of the other fields blank (we want to show all columns from this Page Properties macro)
Choose Save to add the macro to the page

Screenshot: The page properties report macro on the 'Design Status Report' index page
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Edit ‘Page properties report’ Macro

“ Preview

Label *

status-update x Title

In space No content found.

Current space x

Add a field

Options
Page properties ID (optional)

status-update-design

Title column heading

Change the heading of the Title column

wihirh rontaine linke tn nanae Mavimum

Select macro

© N

9. Create a new page and repeat this process for each team

Add any other content, links or images to the page and Save
Choose Space Tools > Configure Sidebar > Add Link to add a shortcut to the page on the sidebar

148

Save Cancel

Remember to specify a different Page Properties ID each time (in this example 'status-report-dev' and

'status-report-ga’).

If your Design, Dev and QA teams have their own team spaces, this summary report could even be created in
their team spaces. Just be sure to specify the space where the Status Updates pages are created in the Restric

t to spaces field, to make sure the macro can find the pages to report on.

Part 4: Create your first status update page

That's it! Create from template

in the Confluence header, then select Status Update, or use the Create a new status update button to make

your first status update page. Just like a blueprint, but 100% made by you.

Here's how our finished pages look.

Screenshot: Team Leads and the management team still have a single page for the weekly status update
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9 Blue Sky Project

3 Pages

3\ Blog

SPACE SHORTCUTS

[2) Status Report - all teams

PAGE TREE

~ Status Report - all teams

Status Report - Design
Status Report - Development

Status Report - QA

£ Space fools ~

Status update week ending 2014-03-08
Status update week ending 2014-03-01
Status update week ending 2014-02-21

Pages / Blue Sky Project Home / Staius Report - all teams

Status update week ending 2014-03-08

Created and |last modified by Rach Admin on Feb 28, 2014

Executive Summary

This week saw the release of Widgets 5.0. Support activity was higher than usual.

Teams are moving on to their Q3 focus areas from this week.

Design Team

Design Focus ADG in all modal dialogs

Design Status
Design Contact | @Josh User

Design Risks « No time to polish new designs
Development Team
Dev Focus Warranty bugs

Dev Status DELAYED

Dev Contact |@ Unknown User (sophie)

Dev Risks « No time to implement new designs
¢ Infroduce new bugs
QA Team
QA Focus Visual regressions
QA Status
QA Contact @Ewan User
QA Risks

* MNone identified this week

« @) Like  Be the first to like this

# Edt  © Watch [ Share

aes

status-update | #

Screenshot: The Project Lead can see the status of each team, each week, at a glance in the All Teams status

report.

e Blue Sky Project

@ Pages
R Blog
SPACE SHORTCUTS
[2) Status Report - all teams
PAGE TREE
~ Status Report - all teams
Status update week ending 2014-03-08
Status update week ending 2014-03-01
Status update week ending 2014-02-21
Status Report - Design
Status Report - Development

Status Report - QA

Pages / Blue Sky Project Home

Status Report - all teams

Created and last medified by Rach Admin on Feb 28, 2014

Title Design Status

Status update week ending 2014-02-21

STATUS
Status update week ending 2014-03-08
Status update week ending 2014-03-01 BEHIND TARGET

@ Like  Be the first to like this

ﬁ Write a comment

# Edit © Watch [ Share <

New Status Update Page

Dev Status QA Status
STATUS STATUS
DELAYED

No labels &

Screenshot: Each team can see their focus, risks and status at a glance in their status report.
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9 Blue Sky Project

@ Pages
Blog
SPACE SHORTCUTS
Status Report - all teams
PAGE TREE
Status Report - all teams
Status Report - Design
Status Report - Development

Status Report - QA

Pages / Blue Sky Project Home
Status Report - Design

Created and last modified by Rach Admin 18 minutes ago

Title Design Contact
Status update week ending 2014-02-21
Status update week ending 2014-03-08 Josh User

Status update week ending 2014-03-01 Josh User

@) Like

n

Be the first to like this

# Edit © Watch [ Share

Design Focus Design Risks Design Status

STATUS

‘ON TRACK

BEHIND TARGET

ADG in all modal dialogs « No time to polish new designs

Sentence case all the things « Team members not available

status-update | #

Remember, these concepts don't just apply to status updates — you can use them for any purpose at all.

Import Content Into Confluence

There are a number of ways you can get existing
content, such as text, images and other content into

Confluence.

Import content from other Confluence sites

To import content from another Confluence site you

can:

On this page:
® Import content from other
Confluence sites
® Import content from a Microsoft
Word document
® Import web content
® Import other content

® Import a backup of the entire Confluence site
® Import an XML export of an individual space.
Page history, attachments, and page content

will be preserved.

See Restoring a Site and Restoring a Space for more information.

Import content from a Microsoft Word document

The Office Connector allows you to create pages by importing Word documents. The document content is
copied onto one or more Confluence pages. See Import a Word Document into Confluence.

Import web content

To displaying web content on a page:

® Use the Widget Connector Macro to display videos, slide shows, twitter chats, documents and more,
sourced from other web sites and displayed on your Confluence page.

Embed an external web page into Confluence with the HTML Include macro.
Use HTML code in a page with the HTML macro.

Import other content

Importing non-wiki markup into Confluence requires a conversion process:

® Text with basic formatting can be pasted directly into the editor. This includes simple Word documents

or web pages.

® Confluence pages saved to disk can be imported from disk.
Files can be uploaded in bulk using the Confluence WebDav Plugin. See Use a WebDAYV Client to

Work with Pages.

¢ Build your own import solution using the Confluence APlIs.
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Import a Word Document into Confluence
The Office Connector allows you to import Word

documents and create one or more Confluence
pages from the content.

On this page:
® Import a Word document
® Import options

You can create a single page, or divide the contents

up into multiple pages, based on the headings in

Related pages:

your document. ® Export Content to Word, PDF,

This is useful if you have a lot of content stored in

HTML and XML

existing documents, or if you are migrating from
another system or platform that allows you to export
to Word format.

I'. The Office Connector is only available for some
browsers, operating systems and applications, so
you'll need to check the Office Connector
Prerequisites before you start.

Import a Word document

=

6.
7. Choose whether to create a single page or multiple pages based on the heading styles in the file (this

8.

Create a page in Confluence or go to an existing page (you want to view the page, not edit it).
Choose

> Import Word Document

Choose Browse and locate the Word document you want to import then choose Next.

The import document options appear.

Enter a title for the new page (useful if you do not want to use the file name as your page title).
Choose where you want to import the file (as a brand new page, or overwriting an existing page with
the same title).

Choose how to handle title conflicts (rename the new pages or replace existing pages).

option is only available if the file contains heading styles).
Click Import.

When the upload has finished, pages will be created with the content of the Word documents. You can then

view and edit this page as normal. There's no connection between the original Word document and this page.

Import options

There are a number of options when importing a Word document that control how pages are created,
whether the import should overwrite existing pages in the space, and how it should handle page name
conflicts.

Option Description

Root

page
title

This is the title of the page that will be created or updated by the import.

Where Controls whether the document is imported into the current page (the page you were viewing

to

import

when you selected Tools > Import) or created as a new page. Choose from

®* |mport as a new page in the current space - a new page will be created as a child of the
space home page.

® Replace <page name> - content will be imported into the current page. The title of this
page will change to the title you specified in the Root page title field.

* Delete existing children of <pagename> - any existing children of the current page will
be removed when the content of the page is replaced.
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Title Controls how page name conflicts (a page with the same title already exists in the space) are
conflicts handled.

®* Rename imported pages if page name already exists - new pages get a new name (a
number added to the end of the page title). Existing pages will be unchanged.

®* Replace existing pages with imported pages of the same title - overwrite the content of
existing pages. The change will be shown in the Page History for the page.

® Remove existing pages with the same title as imported pages - remove original pages
and then create new pages. The change is not shown in the Page History for the page.

Split by  If the document contains Word heading styles you can choose to create multiple pages based
heading on the heading. Options are:

®* Don't split - creates a single page.
® | evel Headings - creates multiple pages in a hierarchy based on the heading levels in the
document.

A preview of the pages that will be created appears under Document Outline.

Screenshot: Import Word options for a document that contains multiple heading levels.

Import Word Document: Configuration
Root page title: | mporting Word

Where to import: Import as a new page in the current space
* Replace Importing Word

Delete existing children of Importing Word

Title conflicts: (=) Rename imported pages if page name already exists
Replace existing pages with imported pages of the same title
Remove existing pages with the same title as imported pages

Split by heading: Level 2 Headings =

Document Qutline: [S) Importing Word
[Z] Example Word document
[2) Splitting by Headings

Import
Orphaned Pages

An orphaned page is a page without any incoming links and is located at Related pages:

what's called the 'root of the space’, meaning it sits alongside the space's . i

home page. This means that, unless you know the page exists, you're not Undefined

likely to come across it during the natural course of navigation. Page Links
® Create and

There may be a legitimate reason you want to have a page at the root of a Edit Pages

space. For example, you may be effectively hiding it in the navigation. If you
don't want orphaned pages though, you can easily view all orphaned pages
in a space so you can tidily delete the pages or reorganize them so they're
no longer orphaned.

To view the orphaned pages in a space:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Orphaned Pages.

While in the orphaned pages view, you can do any of the following:
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® Delete an orphaned page by choosing the 'trash can' icon next to the page name.
® Edit a page by choosing the 'pencil' icon next to the page name.
® Give an orphaned page a parent — see Move and Reorder Pages.

Screenshot: Managing orphaned pages

Publishing = Templates = Reorder Pages = Orphaned Pages  Undefined Pages = Attachments Trash  Export RSS Feeds
This report shows all the 'orphaned’ pages which are not linked to by other pages.

Title (Space) Creator Created Last Updated By Updated Operations
[2) Appendix A - Extending JIRA (Atlassian Atlassian Sep 25, 2012 Atlassian Jul 10, 2014 PR |
OnDemand Documentation) Documentation Bot Documentation Bot
[© _InclusionsLibrary (Atlassian OnDemand Andrew Lui QOct 22, 2008 Andrew Lui Oct 22, 2008 P |
Documentation) [Atlassian Technical [Atlassian Technical

Writer] Writer]
[ Enterprise Hosted Service Deactivation Christine Burwinkle Apr 04, 2013 Andrew Lui Jul 09, 2014 P |
(Atlassian OnDemand Documentation) [Atlassian Technical [Atlassian Technical

Writer] Writer]
E _Redirects (Atlassian OnDemand Christine Burwinkle Feb 07, 2013 Andrew Lui Sep 24, 2013 VR |
Documentation) [Atlassian Technical [Atlassian Technical

Writer] Writer]

Undefined Page Links

You can add links to pages that don't yet exist in Confluence, but you intend Related pages:
to create later. Known as links to 'undefined pages', they allow you to create
a link which, when clicked, will create a page with the name you specify in * Orphaned
the link. Pages
® Create and
Edit Pages
Create an undefined page link ® Links

1. Choose Insert > Link or press Ctrl+K on your keyboard.
2. Choose Advanced.
3. Enter the name of the page to be created in the Link field.

A link to an undefined page is shown in dark red while in the editor. When
anyone clicks the link, Confluence will create a new page with the name you
typed in the Link field.

View undefined pages in a space

The Undefined Pages view shows you all undefined pages in your space.

The undefined page links are badged with a
%

icon to remind you that those pages are yet to be created.

To view a list of the undefined links in a space:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Undefined Pages.

You can choose the link for an undefined page to create the page and add content to it.

Links to pages that are in the trash are not considered undefined links, and will not appear in this list.
View Page Information

The Page Information view for a page shows you useful information about the page.

To see the information about the page:
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1. View the page.
2. Choose

LL Y]

> Page Information

You will see the following information:

® Page details: Title, author, date of creation, date of last modification and the tiny link (permalink) of the

page.

Page hierarchy: Parent-child relationships of the page.
Incoming links: Lists other pages in your Confluence Site that have links to this page, or reference this

page in an Include Page or Excerpt Include macro.

Labels: Any labels (tags) that have been applied to this page. See Add, Remove and Search for Labels.

Page Permissions: Displays page-level security restrictions that apply to the page (if present). See Page

Restrictions.

* Hot Referrers: The external website pages which send the most viewers to the page. See Trackback and

External Referrers.

® Recent Changes: Links to the five most recent versions of the page along with the name of the editor

and the date of modification. See Page History and Page Comparison Views. Choose View page history
to see the page history view, all the versions of the page in reverse chronological order and allows you to
compare versions or to restore a previous version.

® Qutgoing links: A summary of the links contained on this page, pointing to other pages on the

Confluence site or to external websites.

Note: if there is no information to report (for example the page has no restrictions or no incoming links), that

section of the Page Information won't appear.

Screenshot: Page information for this page

Confluence Latest /... / Viewing Page Information

Page Information

+ View Page  =-*

Title: Viewing Page Information
Author: Vidya Madabushi
Last Changed by: Sarah Maddox [Atlassian]

Tiny Link: (useful for email)

IIKCAC
Export As: Word
Operations: Copy

Jul 24, 2005
Feb 18, 2013
https:/iconfluence stg.internal atiassian.com

Incoming Links

Confluence Latest (2)
[2) Page History and Page Comparison Views
[2) Recording Change Comments

Confluence 4.1 (1)
[2) Recording Change Comments

Recent Changes

Time Editor
Feb 18, 2013 21:05 Sarah Maddox [Atlassian]
Migrated to Confluence 5.3
Feb 18, 2013 21:05 Sarah Maddox [Atlassian]
Updated for Confluence 5.0
Dec 21, 2012 03:26 Sarah Maddox [Atlassian]
Removed obsolete link
Sep 07, 2011 06:19 Paul Watson [Atlassian] Wiew Changes
Corrected links that should have been relative instead of absolute.
Sep 07, 2011 06:19 Paul Watson [Atlassian]

View Changes

View Changes

View Changes

View Page History

Hierarchy

Farent Page
[2) Working with Pages

Labels

Global Labels (3)
metadata | | referrers | | incoming-links

Outgoing Links

Confluence Latest (8)  [2) Page Restrictions
(3) Page History and Page Comparison Views
(3 confluence User's Guide
[3) Working with Confluence Labels
() Working with Pages
[3) viewing Page Information
[3) Managing External Referrers
(3 Confluence Glossary

Page Permissions

Page resfrictions:
« Only users in group atlassian-staff can edit this page. (setby
Anonymous at Jul 07, 2014 22:07) ‘1
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Page History and Page Comparison Views

Confluence tracks the history of changes to each page by creating a new
version of the page each time it's modified. You can view the changes
between different versions, and roll back to a previous version if you need
to.

Access the page history

To view the history of a page:

1. Go to the page and choose

aee

> Page History
2. Choose a version number to view the content of that version

Screenshot: Page history

Pages / Teams in space / Launch pad product requirements = View Page ¢ Save for later
Page History
Compare selected versions
Version Published Changed By Ci Actions
CURRENT (v. 3) Sep 02, 2016 07:56 () Fixing typos
v.2 Sep 01, 2016 14:05 ﬁ, m ( ) Team review Restore - Delete
v. 1 Sep 01, 2016 10:33 h Restore - Delete
Return to Page Information

On this page:

Access the
page
history
View an
older
version
Restore a
previous
version
Delete a
specific
version
View the
changes
made
Compare
two
versions
More
about the
compariso
n view

Related pages:

View Page
Information
Create and
Edit Pages
Watch
Pages,
Spaces
and Blogs

Hover over each avatar to see the names of people who contributed changes in that version. It is not
possible to view the individual changes made by each person in a single page version.

View an older version

When you select a previous version of the page, you'll see a header like this at the top of the page:

You are viewing an old version of this page. View the current version.

A Compare with Current - Restore this Version - View Page History

« Previous = Version 2 Current »

ﬂ If you want to send this page version to someone, copy and paste the URL from your browser. The link
will look something like this: htt p: // confl uence. at | assi an. com pages/ vi ewpage. acti on?pagel

d=12345.

When you're viewing a specific version of the page, the following functions are available:

Function Description

current version View the latest version of the page.

Created in 2017 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.

155


http://creativecommons.org/licenses/by/2.5/au/

Confluence 6.3 Documentation 156

Compare with Compare the differences between the version of the page you are viewing and the
Current current version.

Restore this Roll back the content of the page to the previous version that you are viewing.
Version

View Page History Return to the list of page versions.

<< Previous and Ne View the previous or next version of the page.
Xt >>

Restore a previous version

1. Go to the page and choose

> Page History

2. Choose Restore this version beside the version you want to restore (or at the top of the page if
you've opened the version)

3. Change the default change comment if necessary, and choose OK

ﬂ All page history is retained; restoring an older version creates a copy of that version. For example, if you
restore version 39, Confluence will create a copy of version 39 and the copy will become the new, current

version.

If the page has an unpublished draft, the content of the draft will be lost when you restore a previous version.

We'll warn you if there is an unpublished draft.

Delete a specific version

Choose Delete next to a version in the page history, to remove that version.

View the changes made

Using the page history view or the page information view, you can see the recent changes made to a page.
To view recent changes made to a page:

1. Choose

> Page Information
In the section titled 'Recent Changes' you'll see the most recent versions of the page, along with the
date of their modification and the name of the modifying author.

2. Choose View Changes beside the required version
The page comparison view is displayed, showing the differences between the selected and previous
versions.

Compare two versions

1. Go to the page and choose

> Page History
2. Choose the versions you want to compare by selecting the check boxes beside them
3. Choose Compare selected versions

You'll see the page comparison view showing the differences between the selected versions. Changes are
highlighted as follows:

Created in 2017 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 6.3 Documentation

Highlighted color Meaning

Green Added content
Red Deleted content
Blue Changed formatting

Screenshot: Comparing changes

View Page History
Add this line

Reformat this line,

Versions Compared Key
This line was added.
6 Current FhisHre-wasremeved
4 R S . A e ’
Administrato Administrato Formatting was changed.
less than a minute ago less than a minute ago

More about the comparison view

When you view a page comparison, all large sections of unchanged text are hidden and reduced to an

ellipsis (. . .).

You can view page changes between versions which are adjacent to your current page comparison view.

Click the link containing:

® << to view the page comparison with the earlier adjacent version
® >>to view the page comparison with the more recent adjacent version

For example, if your page comparison view is between v. 30 and v. 34 of a page, you can view changes

between:

® v. 29 and v. 30 by clicking << Changes from 29 to 30
® v. 34 and v. 35 by clicking Changes from 34 to 35 >>

Confluence Markup

This section describes two types of markup found in Confluence:

® Confluence storage format. Confluence stores the content of pages

and blog posts in an XHTML-based format. Advanced users can view

Related pages:

®* Macros
®* The Editor

the storage format of a page and even edit it, provided their
Confluence site is configured to allow that.
® Wiki markup. Confluence allows data entry via a shorthand code

called wiki markup. Some parts of the Confluence administration

interface also accept wiki markup for defining content. For a

description of the wiki markup syntax, see Confluence Wiki Markup.
Wiki markup code examples for macros can be found in the documentation
for each macro.
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Confluence Storage Format

This page describes the XHTML-based format that Confluence uses to store
the content of pages, page templates, blueprints, blog posts and comments.
This information is intended for advanced users who need to interpret and
edit the underlying markup of a Confluence page.

We refer to the Confluence storage format as 'XHTML-based'. To be correct,
we should call it XML, because the Confluence storage format does not
comply with the XHTML definition. In particular, Confluence includes custom
elements for macros and more. We're using the term '"XHTML-based' to
indicate that there is a large proportion of HTML in the storage format.

You can view the Confluence storage format for a given page by choosing

> View Storage Format. This option is only available if one of the following
is true:

® You are a Confluence administrator.
® Your Confluence site has the Confluence Source Editor plugin
installed and you have permission to use the source editor.

® If you would like to edit the storage format for a page, your
Confluence system administrator will need to install the Confluence
Source Editor plugin.

® Clarification of terminology: If you choose

> View Source, you'll see the format used within the editor panel,
not the storage format of the page.

Macros

On thi
°

S page:
Macros

® Headings
® Text

effects
Text
breaks
Lists
Links
Images
Tables
Page
layouts
Resource
identifiers
Template
variables
Instruction
al Text

Storage format and wiki markup examples have been included in the documentation for each macro.

Headings
Format type In In Confluence 4.0 and later What you will get
Confluence
3.5and
earlier
Heading 1 hi.
Headi ng 1 <hl>Headi ng
1</ h1>
Heading 2 h2.
Headi ng 2 <h2>Headi ng
2</ h2>
Heading 3 h3.
Headi ng 3 <h3>Headi ng
3</ h3>

Heading 1

Heading 2

Heading 3

Underlined in
the
Documentation
Theme

Underlined in
the
Documentation
Theme

Created in 2017 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.

158


http://creativecommons.org/licenses/by/2.5/au/
https://marketplace.atlassian.com/plugins/com.atlassian.confluence.plugins.editor.confluence-source-editor
https://marketplace.atlassian.com/plugins/com.atlassian.confluence.plugins.editor.confluence-source-editor
https://marketplace.atlassian.com/plugins/com.atlassian.confluence.plugins.editor.confluence-source-editor

Confluence 6.3 Documentation 159

Headings 4 to
6 are also
available and
follow the
same pattern

Text effects

Format In Confluence 3.5 and In Confluence 4.0 and later
type earlier

.............................................................................................

strong/bold *strong*

.............................................................................................

emphasis _enphasi s_

.............................................................................................

strikethrough - stri ket hr ough-
<span styl e="text-decoration:

i ne-through; ">striket hrough</ span>

.............................................................................................

underline +under | i ne+

.............................................................................................

superscript ~ “superscri pt”®

.............................................................................................

subscript ~subscri pt ~

.............................................................................................

monospace {{nonospaced}}
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.............................................................................................

preformatted n/a

.............................................................................................

block quotes bg. bl ock quote
<bl ockquot e>

or . <p>bl ock quot e</ p></ bl ockquot e>
{ quot e} ’
bl ock
quot e
{quot e}
text color {color:red}red --------------------------------------------------------------------------------
text{col or} . <span style="col or:

rgb(255,0,0);">red text</span>

.............................................................................................

small n/a
<smal | >smal | text</snmall >

.............................................................................................

big n/a

.............................................................................................

center-align  n/a _
<p style="text-align:

center;">centered text</p>

.............................................................................................

.............................................................................................

right-align n/a
<p style="text-align: right;">right

al i gned text</p>

Text breaks

Format In Confluence 3.5 and earlier In Confluence 4.0 and later What you
type will get
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New
paragraph

Line break

Horizontal
rule

— symbol

— symbol

Lists

Format
type

Unordered
list —
round
bullets

Ordered
list
(numbered
list)

..............................................................

Par agraph 1 g g Paragraph 1
<p>Par agr aph 1</ p> :
Paragraph 2

(enpty ;
l'ine) i <p>Paragraph 2</p>
Par agr aph
2
Line 1 \\ Line 2 Line 1
. Line 1 <br /> Line 2 Line 2
Note: Created in the editor using Shi ft +
Ret urn/ Ent er
<hr />
&nmdash;
&ndash:;
In In Confluence 4.0 and later
Confluence
3.5 and
earler
* Round e
bul | et Co<ul>

list item
<li>round bullet list itenc/li>

</ ul >

...............................................................................................................................

# Ordered .
list item . <ol >

<li>nunbered list itenc/li>
</ ol >
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..........................................................

Task Lists [] Task .
list item i <ac:task-list>

<ac: t ask>

<ac: task-status>i nconpl et e</ ac: t ask- st at us>
<ac: task-body>task list itenx/ac:task-body>

</ ac:task>
</ac:task-list>

Links

Format In Confluence 3.5 and earlier

type

Link to [Link to another Confluence
another page| Page Titl e]

Confluence

page

Linktoan [Link to an
attachment attachnent*at| assi an_| ogo. gi f]

Linktoan [Atlassian|http://ww. atl assian.con ]
external
site

Anchor link [ Anchor Li nk| #anchor ]
(same
page)

Anchor link [ Anchor Li nk| pagetitl e#anchor]
(another
page)

In Confluence 4.0 and later

...................................................................

<ac:|ink>

<ri:page ri:content-title="
<ac: pl ai n-text-Iink-body>
<I [ CDATA[ Li nk to another C
</ ac: pl ai n-text-1ink-body>
</ac:|ink>

...................................................................

<ac: | i nk>

<ri:attachment ri:fil ename=
<ac: pl ai n-text-1ink-body>
<! [ CDATA[ Li nk to a Confl ue
</ ac: pl ai n-text-1ink-body>
</ac:|ink>

...................................................................

...................................................................

<ac:link ac:anchor="anchor"

<ac: pl ai n-text-I1ink-body>

<! [ CDATA[ Anchor Link]]>

</ ac: pl ai n-text-1ink-body
</ac:|ink>

...................................................................

<ac:|link ac:anchor="anchor"

<ri:page ri:content-title

<ac: pl ai n-text-Iink-body>

<! [ CDATA[ Anchor Link]]>

</ ac: pl ai n-text-1ink-body
</ac:|ink>
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Link with ['google.png!|pagetitle#anchor]

an <ac:link ac:anchor="Anchor
embedded <ac: | ink-body>

image for <ac:inmage><ri:url

the body ri:value="http://confluence

/ ></ ac: i mage>
</ ac:|ink-body>
</ac:|ink>

For rich content like images, you neec

A note about link bodies

All links received from the editor will be stored as plain text by default, unless they are detected to contain the
limited set of mark up that we allow in link bodies. Here are some examples of markup we support in link
bodies.

An example of different link bodies

<ac:|ink>
<l-- Any resource identifier -->
<ri:page ri:content-title="Home" ri:space-key="SANDBOX" />
<ac:|ink-body>Sonme <strong>Ri ch</strong> Text</ac:|ink-body>
</ac:|ink>
<ac: | i nk>
<ri:page ri:content-title="Plugin devel oper tutorial stuff"
ri:space-key="TECHWRI TI NG' />
<ac: pl ai n-text-link-body><![ CDATA[ A plain <text> |link
body] ] ></ ac: pl ai n-text-1i nk-body>
</ac:|ink>
<ac:|ink>
<ri:page ri:content-title="Plugin devel oper tutorial stuff"
ri:space-key="TECHWRI TI NG' />
<l-- Alink body isn't necessary. Auto-generated fromthe resource
identifier for display. -->
</ac:link>

The markup tags permitted within the <ac:link-body> are <b>, <strong>, <em>, <i>, <code>, <tt>, <sub>,
<sup>, <br> and <span>.

Images

Format In Confluence 3.5 and earlier In
type
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Attached !atl assi an_| ogo. gi f!

image

External !http://confluence. atl assi an. conli mages/| ogo/ confl uence_48_trans. png!

image

Supported image attributes (some of these attributes mirror the equivalent HTML 4 IMG element):

Name Description

ac:align image alignment

ac:border Set to "true" to set a border

ac:class css class attribute.

ac:title image tool tip.

ac:style css style

ac:thumbnail Set to "true" to designate this image as a thumbnail.
ac:alt alt text

ac:height image height

ac:width image width

ac.vspace the white space on the top and bottom of an image
ac:hspace the white space on the left and right of an image
Tables

Format In Confluence 3.5 and In Confluence 4.0 and later
type earlier

What you will get
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Two | | Tabl e Headi ng Cell
column, 1|]| Tabl e Headi ng Cell
two row 2| |

(top

header | Nor mal

row) Cell 1| Normal Cell 2]

Two N/A
column,
three
rows,
2nd

and
third
with
merged
cells in
first row

.................................................................

<t abl e>
<t body>
<tr>

<t h>Tabl e Headi ng Cell
1</t h>

<t h>Tabl e Headi ng Cell
2</th>
</[tr>

<tr>
<td>Normal Cell 1</td>

<td>Normal Cell 2</td>
</tr>

</ t body>

</t abl e>

.................................................................

<t abl e>
<t body>
<tr>

<t h>Tabl e Headi ng Cell
1</t h>

<t h>Tabl e Headi ng Cel |
2</th>
</[tr>

<tr>

<td rowspan="2">Mer ged
Cell </td>

<td>Normal Cell 1</td>
</[tr>

<tr>

<td col span="1">Nor nal
Cell 2</td>
</[tr>
</t body>
</tabl e>

Table
Heading
Cell 1

Normal
Cell 1

Table
Heading
Cell 1

Merged
Cell
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Page layouts

Confluence supports page layouts directly, as an alternative to macro-based layouts (using, for example, the
section and column macros). This section documents the storage format XML created when these layouts

are used in a page.

Notes:

® Page layouts were originally introduced in Confluence 4.2, and are not available in earlier versions of
Confluence. If you are using Confluence 4.2 - 5.1 you should refer to the documentation for your
version of Confluence:
® Confluence Storage Format (Confluence 4.2)
® Confluence Storage Format (Confluence 4.3)
® Confluence Storage Format (Confluence 5.0)
® Confluence Storage Format (Confluence 5.1)
® Pages with a layout created in the old format will be converted to 5.2 format.
® Confluence 5.2 provides more flexible layouts with a more concise storage format.

Element name In Confluence 5.2 and later Attributes

ac: | ayout Indicates that the page has a layout. It should be the top level None
element in the page.

ac: | ayout -section Represents arow in the layout. It must be directly withinthe ac: 1 a ac:type
yout tag. The type of the section indicates the appropriate number
of cells and their relative widths.

ac:layout-cell Represents a column in a layout. It must be directly within the ac: | None
ayout - sect i on tag. There should be an appropriate number of
cells within the layout-section to match the ac: t ype.

The recognized values of ac: t ype for ac: | ayout - secti on are:

ac:type Expected number of  Description
cells
single 1 One cell occupies the entire section.
two_equal 2 Two cells of equal width.
two_| eft _si debar 2 A narrow (~30%) cell followed by a wide cell.
two_ri ght _si debar 2 A wide cell followed by a narrow (~30%) cell.
t hree_equal 3 Three cells of equal width.
three_with_sidebars 3 A narrow (~20%) cell at each end with a wide cell in
the middle.

The following example shows one of the more complicated layouts from the old format built in the new. The
word { cont ent } indicates where further XHTML or Confluence storage format block content would be

entered, such as <p> or <t abl e> tags.
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.........................................................................................................................................................................

<ac: | ayout >
<ac: | ayout-section ac:type="single">
<ac: | ayout-cel | >
{content}
</ac:|ayout-cell >
</ ac: | ayout -section>
<ac: | ayout-section ac:type="three_w th_si debars">
<ac: | ayout-cel |l >
{content}
</ac:|ayout-cell >
<ac: | ayout-cell >
{content}
</ac:|ayout-cell >
<ac: | ayout-cel | >
{content}
</ac:|ayout-cell>
</ ac: | ayout - secti on>
<ac: | ayout-section ac:type="single">
<ac: | ayout-cel | >
{content}
</ac:|ayout-cell >
</ ac: | ayout - secti on>
</ ac: | ayout >

Emoticons
Format In Confluence 3.5and In Confluence 4.0 and later What you
type earlier will get

.........................................................................

Emoticons ) . .
ac: enoticon

ac: nane="smle" />

.........................................................................

.........................................................................

<ac:enoticon ac: nane="sad"
/>
P o
<ac: enoticon
ac: name="cheeky" />
R e

<ac: enpticon
ac: name="I| augh" />
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.........................................................................

<ac: enpticon
ac: nane="w nk" />

.........................................................................

v) .

<ac: enpticon

ac: nane="t hunbs-up" />
(n) .

<ac: enpticon

ac: nane="t hunbs- down" />
(i) .

<ac: enpticon

ac: nane="infornmation" />
0] .

<ac:enoticon

ac: nane="tick" />
) .

<ac: enpticon

ac: nanme="cross" />
(0]

<ac: enoticon
ac: name="warni ng" />

Resource identifiers

Resource identifiers are used to describe "links" or "references"” to resources in the storage format. Examples
of resources include pages, blog posts, comments, shortcuts, images and so forth.

Resource Resource identifier format

..............................................................................................................................................

Page
<ri:page ri:space-key="FOO' ri:content-title="Test

Page"/ >

® ri:space-key: (optional) denotes the space key. This can be omitted to create a
relative reference.
® ri:content-titl e: (required) denotes the title of the page.
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..............................................................................................................................................

Blog Post
<ri: bl og-post ri:space-key="FOO' ri:content-title="First

Post" ri: posting-day="2012/01/30" />

® ri:space-key: (optional) denotes the space key. This can be omitted to create a
relative reference.

® ri:content-titl e: (required) denotes the title of the page.

® ri:posting-day: (required) denotes the posting day. The format is YYYY/MM/DD.

..............................................................................................................................................

Attachment
<ri:attachnent ri:fil ename>

resource identifier for the contai ner of the
at t achnment
</ri:attachnent>

® ri:fil enane: (required) denotes the name of the attachment.

® the body of the ri : at t achnent element should be a resource identifier denoting the
container of the attachment. This can be omitted to create a relative attachment
reference (similar to [foo.png] in wiki markup).

Examples:

..............................................................................................................................................

Relative Attachment Reference

<ri:attachnment ri:filenane="happy.gif" />

..............................................................................................................................................

Absolute Attachment Reference

<ri:attachnent ri:filename="happy.gif">

<ri:page ri:space-key="TST" ri:content-title="Test
Page"/ >
</ri:attachment>

..............................................................................................................................................

URL

..............................................................................................................................................

Shortcut
<ri:shortcut ri:key="jira" ri:paraneter="ABC 123">

® ri: key: (required) represents the key of the Confluence shortcut.

® ri:paraneter: (required) represents the parameter to pass into the Confluence
shortcut.

® The example above is equivalent to [ ABC- 123@ i r a] in wiki markup.

Created in 2017 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.

169


http://creativecommons.org/licenses/by/2.5/au/

Confluence 6.3 Documentation

..............................................................................................................................................

User : :
f <ri:user ri:userkey="2c9680f 7405147ee0140514¢26120003"/ > f
Notes
® ri:userkey: (required) denotes the unique identifier of the user.
Space
. <ri:space ri:space-key="TST"/> 5
Notes
® ri:space- key: (required) denotes the key of the space.
Content
Entity . <ri:content-entity ri:content-id="123"/> 5
Notes

® ri:content-id: (required) denotes the id of the content.

Template variables

This screenshot shows a simple template:

Dashboard » Chocolate » Browse Space » Edit Template

Sarah template

Paragraph B I U A A = | iE | I=

This is Sarah's template

A single-line text variable: ML)
A multi-line text variable: EILLITLD
A selection list: LAY

End of page.

The template contains the following variables:

Variable name Type Values

$MyText Single-line text

$MyMulti Multi-line text ~ Size: 5 x 100

$MyList List List items: Appl es, Pear s, Peaches

The XML export produces the following code for the template:
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.........................................................................................................................................................................

<at:decl arati ons>
<at:string at:name="MText" />
<at:textarea at:columms="100" at:nane="MyMulti" at:rows="5" />
<at:list at:name="MList">
<at:option at:val ue="Apples" />
<at:option at:val ue="Pears" />
<at:option at:val ue="Peaches" />
<lat:list>
</ at: decl arati ons>

<p>This is Sarah's tenpl ate</p>
<p>A single-line text variabl e: &bsp; <at:var at:nanme="MText" [></p>
<p>A multi-line text variabl e: &bsp; <at:var at:name="MyMilti" /></p>

<p>A selection |ist:&bsp;<at:var at:name="MList" /></p>

<p>End of page. </ p>

Instructional Text

Instructional text allows you to include information on how to fill out a template for an end-user (the person
using creating a page from the template). Instructional text will:

® automatically clear all instructional text as the user types in a specific text block, and
® automatically trigger a @mention prompt for user selection (for ‘'mention’ type instructional text).

Screenshot: Example of instructional text.

Paragraph ~ B I U A ~ 3~ iZ iZ i 3=

« This is an example of instruction text that will get replaced when a user selects the

@mention example. This placehoider will automatically search for a user to mentig

.........................................................................................................................................................................

<l i ><ac: pl acehol der>This is an exanple of instruction text that wll
get replaced when a user selects the text and begins
typi ng. </ ac: pl acehol der></1i >

</ ul >
<ac:task-list>
<ac:task>

<ac: t ask- st at us>i nconpl et e</ ac: t ask- st at us>
<ac: t ask- body><ac: pl acehol der ac:type="nention">@rention
exanpl e. This placeholder will automatically search for a user to
mention in the page when the user begins
typi ng. </ ac: pl acehol der ></ ac: t ask- body>
</ ac:task>
</ac:task-list>
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Confluence Wiki Markup

This page describes the wiki markup used on some administration screens
in Confluence.

Wiki markup is useful when you want to do one of the following:

® Type wiki markup directly into the editor. Confluence will convert it to
the rich text editor format as you type.

® Create links using the Advanced tab of the Links Browser.

® Add custom content to the sidebar, header or footer of a space.

® Insert a block of wiki markup (or markdown) into the Confluence
editor. (Choose Insert > Markup.)

Note: You cannot edit content in wiki markup. Confluence does not store
page content in wiki markup. Although you can enter wiki markup into the
editor, Confluence will convert it to the rich text editor format immediately.
You will not be able to edit the wiki markup after initial entry.

Can | type wiki markup into the editor?

On this page:

Can | type
wiki
markup
into the
editor?
Can|
insert
markdown
?
Headings
Lists
Tables
Text
Effects
Text
Breaks

® Links
®* Images
®* Page

Layouts
Macros

Yes. You can type wiki markup directly into the editor, and Confluence will convert it as you type. (You

cannot edit the wiki markup after conversion.) See it in action in this video:

Can |l insert markdown?

Confluence supports inserting content in markdown. This is often used in ReadMe files. See Markdown

syntax guide for some examples of markdown syntax.
To insert markdown in the editor:

1. Choose Insert > Markup
2. Select Markdown

3. Type or paste your text - the preview will show you how it will appear on your page

4. Choose Insert.

As with wiki markup, Confluence will convert your markdown to the rich text editor format. You will not be

able to edit your content using markdown.

Headings

To format a line as a heading, type "hn." at the start of your line, where n can be a number from 1 to 6.

What you need to type What you'll get

hl. Bi ggest

headi ng Biggest heading

h3. Bi g headi ng
Big heading

h5. Smal | headi ng
Small heading
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Lists

Wiki markup allows you to create bulleted or numbered lists, and is flexible enough to allow a combination of
the two list types.

o If you need to separate the text within lists using line breaks, make sure you do so using a double slash
(/). Empty lines may disrupt the list.

Simple lists

Use the hyphen (-) to create simple lists with square bullets. Make sure there's a space between the hyphen
and your text.

What you need to type  What you'll get

...............................

: = some
- Sone i " pullet
- bullet ® points

poi nts

Bulleted lists

Use the asterisk (*) to create bullets. For each subsequent level, add an extra asterisk.
Make sure there is a space between the asterisk and your text.

What you need to type What you'll get
""""""""""""""""""""" * some
* sone i ® hullet
* bul | et i * indented
** jndented * bullets
** pullets | * points
* points '

Numbered lists

Use the hash (#) to create numbered lists.
Make sure there is a space between the hash and your text.

What you need to type What you'll get
"""""""""""""""""""" 1. a
# a i 2. numbered
# nunbered | 3. list
# list ’

A second level of hashes will produce a sub-list, such as the alphabetical sub-list shown below.

What you need to type What you'll get
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1. Here's a sentence.

# Herfe' s a sent ence. _ a. This is a sub-list point.
## This is a sub-list point. b. And a second sub-list point.
## And a second sub-list point. 2. Here's another sentence.

# Here's anot her sentence.

You can use a third level of hashes to produce a sub-sub-list.

What you need to type What you'll get
1. Here's a sentence.
# Here's a sentence. a. This is a sub-list point.
## This is a sub-list point. i. Third list level.
### Third list |evel. ii. Another point at the third
### Anot her point at the third level.
| evel . b. And a second sub-list point.
## And a second sub-1ist point. 2. Here's another sentence.

# Here's anot her sentence.

Note: In numbered lists as described above, the format of the 'number' displayed at each list level may be
different, depending upon your browser and the style sheets installed on your Confluence instance. So in
some cases, you may see letters (A, B, C, etc; or a, b, ¢, etc) or Roman numerals (i, ii, iii, etc) at different list
levels.

Mixed lists

What you need to type What you'll get

1. Here
# Here ® s
#* is ® an
#* an 2. example
# exanpl e ® of
#* of ¢ a
#* a 3. mixed
# mi xed 4. list
# list

Tables
You can create two types of tables.

Table Type 1

Allows you to create a simple table with an optional header row. Once you've added this type of table, you
can set the width of the columns using the table controls in the toolbar.

Use double bars for a table heading row.

What you need to type:
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...........................................................................................

| | headi ng 1| | headi ng 2| | headi ng 3| |
[cell Al|jcell A2|cell A3|
|cell Bil|cell B2|cell B3|

What you'll get:
heading 1 heading 2 heading 3

cell Al cell A2 cell A3

cell B1 cell B2 cell B3

You can also use a vertical header.

What you need to type:

............................................................................

A3|
B3|

| | headi ng 1] col Al|col A2|col
| | headi ng 2| col B1l|col B2]|col

What you'll get:

heading 1 col A1 col A2 col A3

heading 2 colB1 colB2 col B3

Table Type 2

This method uses section and column macros to create the table, and allows you to specify the width of the

columns in the markup.

What you need to type

............................................................................

{section: border=true}
{col um: wi dt h=30%

Text for this colum goes here.

wi dth of only 30%
{col um}
{col um: wi dt h=70%

Text for this colum goes here.

wi dth of 70%
{col um}
{section}

What you'll get

Text for this column goes here.
This is the smaller column with a
width of only 30%.

This is the smaller colum with a

This is the larger colum with a

Text for this column goes here. This is the larger column with a width of

70%.

ﬂ For more details please see the Column Macro and the Section Macro.

Advanced Formatting

Color and Other Formatting
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To add color and other formatting to your tables, you can use the Panel Macro within columns.

More table-formatting options may be available if your Confluence administrator has installed additional macr
0s.

Lists

Here's an example of how to embed lists in a table:

What you need to type

| | Headi ng 1| | Headi ng 2| |

|* Item 1
*

Iltem 2
* [tem3|# Item 1
# ltem 2
# ltem 3|

What you'll get

Heading 1 Heading 2

® |[tem1l 1. ltem 1
® Jtem 2 2. Item 2
® |jtem3 3. ltem 3

Text Effects

Use the markup shown in the examples below to format text.

What you need to type What you'll get
*strong* strong

*bold text* bold text
_emphasis_ emphasis
_italics_ italics

Hint: To italicize parts of a word, add braces (curly
brackets) around the underscore. For example,

Thing{ _}x_

gives you this: Thingx

??citation?? —citation
-deleted- deleted
+inserted+ inserted
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Text with~superscript® Text withsuperscript

Hint: There are two ways to make superscripts work,
when used directly after another word or character:
® Add a space before the superscript. For example, kg
/ m A3~ gives you this: kg/m 3
® Add braces (curly brackets) around the superscript
markup. For example,

kg/ m{"3"}

gives you this: kg/m3

Text with~subscript~ Text withsubscript

{{rmonospaced}} nonospaced

bg. Here's how you nake a Here's how you make a paragraph appear
par agr aph appear as a bl ock as a block quotation.

quot at i on.

{color:red}look ma, red text!{color} look ma, red text!

Text Breaks

Paragraph Break

In wiki markup, a paragraph is a continuous line of text ending in two carriage returns. This is equivalent to a
continuous line of text followed by a blank line.

When rendered into HTML, the result is a line of text wrapped in a set of <p></ p> tags.

Line Break

Confluence provides two options for forcing a line break within a paragraph of text:
* |mplicitly, by entering a single carriage return at its end.
® Explicitly, by entering two consecutive backslashes: \\

When rendered into HTML, the result is a paragraph of text that is split into separate lines by <br > tags,
wherever a forced line break appears.

@ For most purposes, explicit line breaks are not required because a single carriage return is enough.

The examples below show how to use explicit line breaks.

What you need to type What you'll get
here is some text here is some text
divided
\\ L
using line
di vi ded \\
breaks

using line \\ \\

br eaks\\
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This is a short list: This is a short list:

* Point 1 . .

Text to go with point 1 Point 1 . .

* Point 2 Tegt to go with point 1
® Point 2

VoW

. . , Text to go with point 2 with a break
Text to go with point 2 with a break

If you wish to use multiple consecutive line breaks, each should be separated by a space character. For
example, use this for two consecutive line breaks:
\\ W\

Horizontal Rule

To create a horizontal line across the width of your page or content block, type four dashes (like this: ----) at
the beginning of a line, then press Enter or space.

Make sure that the dashes are on a separate line from the rest of the text.
What you need to type What you'll get

here is some text here is some text

divided by a horizontal rule
divided by a horizontal rule

Links

You can use wiki markup to add hyperlinks to your text.

What you need to type What you'll get
[#anchor] A link to an anchor on the same page.
[Confluence Wiki Markup”attachment.ext] A link to a file attached to the page.
[pagetitle] A link to a page.
[pagetitle#anchor] A link to an anchor on another page.
[pagetitle™attachment.ext] A link to a file attached to another page.
[spacekey:pagetitle] A link to a page in another space.
[spacekey:pagetitle#anchor] A link to an anchor on a page in another space.
[spacekey:pagetitle*attachment.ext] A link to a file attached to a page in another space.
[/2004/01/12/blogposttitle] A link to a blog post.
Note: blogposttitle is the title of the blog as it appears
on the page.
[spacekey:/2004/01/12/blogposttitle] A link to a blog post in another space.
Note: blogposttitle is the title of the blog as it appears
on the page.
[/2004/01/12] A link to a whole day's blog posts.
[spacekey:/2004/01/12] A link to a whole day's blog posts in another space.

Created in 2017 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 6.3 Documentation

[spacekey:]

[~username]

[phrase@shortcut]

[http://confluence.atlassian.com]

A link to the space homepage (or the space summary
page of the space.

A link to the user profile page of a particular user.

A shortcut link to the specified shortcut site. Shortcuts
are configured by the site administrator.

A link to an external resource.

[mailto:legendaryservice@atlassian.com] A link to an email address.

[file://z:/file/lon/network/share.txt]

A link to a file on your computer or on a network share
that you have mapped to a drive. This only works on
Internet Explorer.

['http://external/image.png!|http://external/link.ht  Displays an external image and links to an external

ml]

URL.

Note that Confluence treats headings as anchors, so you can link to headings using this pattern:
[spacekey:pagename#headingname], where headingname is case-sensitive and must be entered without

spaces.

For each of these link forms:

® You can prepend a link alias, so that alternate text is displayed on the page. Example: [link

alias|pagetitle#anchor]

® You can append a link tip, which appears as a tooltip. Example: [pagetitle#anchor]|link tip]

Images

You can display images from attached files or remote sources.

What you need to type

Ihttp://www.host.com/image.gif!

lattached-image.qgif!
IpageTitlerimage.gif!
IspaceKey:pageTitleimage.gif!

1/2010/05/23/My Blog
Post"image.qif!

limage.jpg|thumbnail!

limage.qgif|align=right,
vspace=4!

What you'll get

An image from a remote source is displayed on the page. Uses a fully
qualified URL.

An image file attached to the page is displayed.

An image file attached to a different page is displayed.

An image file attached to a page in a different space is displayed.

An image file attached to a blog post is displayed.

The image is displayed as a thumbnail on the page (only works with
images that are attached to the page). Users can click on the thumbnalil
to see the full-sized image. Thumbnails must be enabled by the site

administrator for this to work.

For any image, you can specify attributes of the HTML image tag as a
comma separated list of name=value pairs.

Available HTML image tags include:

Image tag  Details

align Available values are 'left', 'right', 'bottom’, 'center’, 'top'.

border Specifies the width of the border (in pixels).
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bordercolor Use with the 'border' tag. Specify colors by name or hex value.

hspace Specifies the amount of whitespace to be inserted to the left and right of the image (in
pixels).

vspace Specifies the amount of whitespace to be inserted above and below the image (in pixels).

width Specifies the width of the image (in pixels). This will override the natural width of the image.

height Specifies the height of the image (in pixels). This will override the natural height of the
image.

title Specifies alternate text for the image, which is displayed when the pointer hovers over the
image.

alt Specifies alternate text for the image. This text is retrievable via search, and contributes to

accessibility of the page for text-only viewing.

Page Layouts

There is no wiki markup representation for page layouts.

Macros

Storage format and wiki markup examples have been included in the documentation for each macro.

Files
Share your team's PDFs, Office documents, images, and more in one place . .
by uploading your files to Confluence. Automatic versioning, instant On this page:
previews, permissions, and full-text search, means shared network drives e Using Files
can be a thing of the past for your team. * Permission
When you upload a file it is attached to the current page or blog post. This is 2
why files are often referred to as attachments in Confluence. Related pages:
You can att_ach anything from project plans and design mockups to video _ e Configurin
and audio files. You and your colleagues can also collaborate by commentin g
g on files displayed on Confluence pages. Attachmen
t Size
Using Files * Configurin
g your
Upload Files Attachmen
Display Files and Images t Storage

Manage Files
Share and Comment on Files
Edit Office Files

Permissions

The 'Add Attachment' and 'Delete Attachment' permissions are used to control who can upload and delete
attachments in a space.

Users with 'Add Page' or 'Add Blog' permissions can insert existing attachments to their pages, but not
upload new attachments unless they also have the 'Add Attachment' permission.

There is no permission that controls downloading attachments. See our knowledge base article about disabli
ng the download of attachments if you need to do this.

Upload Files

When you upload a file, such as an image or
document, it will be attached to the current page.
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You can then choose to display the file on the page O e peerE

as a link, an image or embed it in the page (using a * Upload a file

macro). ® Accepted file types and size
To upload a file you'll need the 'Add Attachments' : Ellcl)etze\;ersmns

space permission.
Related pages:

Upload a file Files

Configuring Attachment Size
Display Files and Images

There are many ways to attach a file to a page. .
y way Pag Manage Files

In the editor you can:

® Drag the file directly onto the page.
® Goto Insert > Files and images and upload
a file.

When viewing a page you can:

® Drag the file directly onto the page.
* Goto

LY ]

> Attachments and upload a file.

You can attach multiple files at a time.

Accepted file types and size

Confluence allows you to attach most file types, but you cannot attach a folder of files (including folders
created by applications like Keynote - you'll need to export your presentation to zip or other format).

Although just about any file type can be attached to a page, not all file types can be displayed on or
embedded in a page. See Display Files and Images to find out more.

The maximum file size you can upload to Confluence is set by your system administrator. By default it is
10mb, but your administrator may have increased or reduced this limit.

File versions

If you upload a file with the same name as an existing attachment on the same page, Confluence will
overwrite the existing attachment. Version history is kept for all attachments. See Manage Files to find out
more.

Any changes you make to the source file will not affect the copy that was uploaded to Confluence. To update
the Confluence copy, you need to upload the new version of the file.

Notes

I We recommend you don't use special characters in page or attachment names, as the page or
attachment may not be found by Confluence search, and may cause some Confluence functions to behave
unexpectedly.

Display Files and Images

Files can be displayed on a page as a thumbnail or
as a link. There are a few different ways to Upload
Files.

You can control how the file appears on your page.
The options available depend on the type of file.
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Insert a file into your page On this page:

® Insert a file into your page

There's a few ways to insert a file into your page: * Insert a file attached to

® Goto Insert > Files on the editor toolbar and another page
select any of the previously uploaded files, or *® Insert an image file from the
® Drag the file directly into the editor (this will web
upload and insert the file in one step), or * Delete files from your page
* Type ! and choose an attached file from the ® Preview a file
autocomplete drop down. ¢ Office and PDF files
® Image files
Your file will appear on your page as a thumbnail. * Multimedia files
Click the thumbnail to resize it or to switch to * Show a list of files on a page

showing the file as a link.
Related pages:

® Links
®* Manage Files

BlueSkyP...nODT.od|

(U] BlueSkyPresentation0DT.odp

s o 8 Show as link

Insert a file attached to another page

You can display a file that's attached to a different page of the same Confluence site, if you know the name of
the file.

To display an image attached to a different page:

. Goto Insert > Files and choose the Search on other pages.

Enter the name of the file.

. Choose whether to search the current space or All Spaces and choose Search.
. Select the file from the search results and choose Insert.

AwWN R

Insert an image file from the web

You can display an image from a remote web page on your Confluence page, without needing to attach it to
your page. You need to know the URL for the image, not for the web page it appears on. This is only
available for image files, not other types of files (like documents).

To display an image from a web page:

1. While editing the page, position the cursor where you want to place the image.

2. Choose Insert > Files and choose Images from the web.

3. Enter a URL for the image. (example: http://atlassian.wpengine.netdna-cdn.com/wp-content/uploads/A
tlassianBushRegeneration-12January2012-083-trunc.jpg

4. Choose Preview to check that the URL and image are correct.

5. Choose Insert.

Delete files from your page

If you delete a file or image in the editor, the attached file will not be deleted. Go to

LE L]

> Attachments to delete the attachment completely from the page.

Seeing an 'unknown attachment' placeholder on your page? This means that the attached file has been
deleted from the page (or another page).
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Preview a file

Click an image, file thumbnail or link when viewing a page to launch the preview.

The preview includes images from the web that are displayed on the page and files that are attached to the
page (even if they are not currently displayed on the page).

In the preview you can:

Download the image file.

Upload a new version of the file (attached files only).

Comment on the file.

Zoom in, out or fit the image to the width of your browser.

Browse like a slideshow using the next and back buttons.

See other files attached to the page and select a thumbnail to preview that file.
® Switch to a full screen presentation mode.

Many file types can be previewed, including Office files, PDFs and many image types.

*~ Which files can be previewed?

Images files Office files Other files

* JPEG * DOC * PDF
* PNG * DOCX * MP3
* TIFF * PPT * MP4
* PSD * PPTX

* WMF * XLS

* EMF ¢ XLSX

* ICO

®* ICNS

[&] VividOperaHouse jpg « v.2 [Current] ] = o

Hide all files ¥

Data-Center-C... VividOperaHou...  Magnoliajpg  101_samplepre...

1. See more files: see other files also attached to this page.
2. Manage this file: download the file, upload a new version or share with your team.
3. Add a comment: drag the pin to comment on the file.

Office and PDF files

Inserting a file in a page is a great way to make useful documents, spreadsheets, presentations and other
files available to your team.

As with all file types, you can choose to insert the file as a link, or as a thumbnail. The thumbnail shows a
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preview of the document's contents, and can be resized.

To view an Office or PDF file, click the link or thumbnail to see the full preview (no need to have Excel, Word
or PowerPoint installed). Alternatively, use the Download button in the preview to download the file and view
offline.

You can even comment on Office and PDF files.

Image files

When editing the page, select an image to show the image properties panel. The panel allows you to set the
display size, add a border and effects and link the image to other pages.

143px | & M@ Original Border = & Link Properties

From the image properties panel you can:

Choose a preset size for the image

Enter a width for the image (between 16px and 900px)

Add a border around the image

Link the image to a page or URL

Align the image (you can use the left and right align buttons to make the text wrap around the image

too)

® Add a title, which is shown when you hover over the image (go to Properties > Title)

® Add alt text, which is used by screen readers and when the image can't be shown (go to Properties >
Title)

* Add effects to the image such as drop shadow or snapshot (go to Properties > Effects).

To add a caption to an image using the Instant
Camera effect:

® Choose Effects in the image properties panel
and choose the Instant Camera image effect.

® Save the page.

®* Goto

> Attachments to go to the 'Attachments’ view
of the page.

® Choose Properties next to the image file.

® Add a comment to the attachment. The text in
your comment will appear as the image caption.

You will need to re-enter the comment each time you HL.:JL Kicks!
upload a new version of the image.

Note: The Instant Camera effect only works with Latin
character languages, due to a lack of handwriting style
fonts in multi-byte languages.

Note about image effects

Displaying image effects can be resource intensive. Confluence limits the threads that are dedicated to
displaying image effects so that it does not impact your whole instance. If a thread is not available,
Confluence will display the image without the effect.

The following knowledge base article provides information if you need to adjust the number of threads - Imag
e effects are not displayed in Confluence 5.5 or later.

Multimedia files
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The file preview also supports MP3 audio and MP4 video files. It uses HTMLS5 to play attached audio and
video files. This means the file types people can play in the preview depends on the audio and video formats
their browser supports.

You can also display a wider range of multimedia files (video, audio and animation) using the Multimedia
Macro.

Display online video (such as YouTube or Vimeo videos) using the Widget Connector Macro.

Show a list of files on a page

There are several ways you can display a list of files on a page. You can:

® Use the Attachments Macro to show files attached to the current page.
® Use the Space Attachments Macro to show all files in a space.
® Use the Gallery Macro to show thumbnails of images attached to a page.

You can also use the File List blueprint for uploading, viewing and managing lists of files.

Manage Files

Files are attached to Confluence pages. See Upload On this page:
Files to find out about attaching files to pages.

® Download attached files

Once attached you can download, delete and edit ® Delete an attached file
these files, for example if you need to upload a new ® Upload a new version of an
version of the file, or change the page it is attached attached file

to. ®* Move a file to another page

® Edit properties of an attached file

: ®* View all attached files in a space
Download attached files P

Any user with permission to view a page can also Related pages:
download any files attached to that page. .
® Files
To download an individual file: ® Display Files and Images

® Click the Download button in the file preview,
or
®* Goto

LE L]

> Attachments
® and then right click on the file name and save
the link.

To download all files attached to a page as a zip
file:

1. Goto

ane

> Attachments
2. Click Download All.

There's no option to download all attachments in a
space.

Delete an attached file

You'll need the 'Delete Attachment' space permission to delete an attached file.
To delete all versions of an attached file:

1. Go to the page that contains the attachment.
2. Goto

LE L

> Attachments
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3. Choose Delete next to the attachment you want to delete.
4. Choose Delete to confirm your action.

Deleted files can be restored from the trash. You'll need to be a space admin to do this.
Space Admins can also delete a specific versions of an attachment:

1. Goto

LE L]

> Attachments
2. Click the expand arrow next to the attachment name to see the list of attachment versions
3. Choose Delete next to the version you want to delete.

Deleted file versions are not recoverable from the trash.

Screenshot: Attachments and attachment versions

Attachments
Name Size Creator Creation Date Labels Comment
~ [ad) penguin_png 5 kB Rach Admin Feb 15, 2013 15:33 penguin  chocolate & Updated colours Properties | Delete
Version 2 (current) 5 kB Rach Admin  Feb 15, 2013 15:33 Updated colours Delete
Viersion 1 5 kB Josh User Feb 14, 2013 10:58 Delete
> [ad) iBugs gif 22 kB Josh User Feb 15, 2013 14:31 useful logo & Properiies | Delete
> [ad sitelogo.png 2 kB Josh User Feb 15, 2013 14:51 logo confluence 4 Properties | Delete

Upload a new version of an attached file

There are two ways up upload a new version of an attached file. You can:

® Upload a file with the same file name to the page.
® Use the Upload a new version

button in the file preview to upload a file with a different name (for images and PDFs only).
To view attachment versions:

® Goto

LE L]

> Attachments
® Click the expand arrow next to the attachment name.

All earlier versions of the file will appear.

You can't revert to an earlier version of the file, but you can choose to remove earlier versions if you have
Space Administrator permissions.

Move a file to another page

You'll need the 'Add Page', 'Add Attachment' and 'Remove Attachment' space permissions to move an
attached file to another page.

To change the page that a file is attached to:

® Goto

> Attachments
Choose Properties next to the attachment you want to move.
Enter the name of the page you want to move the attachment to (for example My Desti nati on
Page) .
® Choose Save.
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If you want to move the file to a page in another space, add the space key before the page name (for
example DOC:My Destination Page).

Edit properties of an attached file

You'll need the 'Add Attachment' permission in the space to edit the file properties.
To edit the properties of an attached file:

® Goto

LT

> Attachments
® Click Properties beside the attachment you want to edit.

You can:

change the file name

add a comment (used in the version list and also by the Snapshot image effect)
change the MIME type

move the attachment to another page

add a label.

Changing the MIME type may cause your file to display incorrectly.

View all attached files in a space

There are two ways you can view all files in a space. You can:

® Use the Space Attachments macro to display the list of files on a page.
® Go to the space and choose Space tools > Content Tools from the bottom of the sidebar Then
choose Attachments.

You can use the filters to only show files with a particular label or file extension.

Screenshot: Space attachments macro

Sample Page
3 Added by Rach Admin, last edited by Rach Admin on Feb 15, 2013 (view change)
Aftachments in this space - displayed via the space aftachments macro.
Filter By File Extension: Filter By Label:
Name Size Creator Creation Last Modification Labels Attached To
Date Date
@a2) penguin_png 5kB  Rach 20 minutes 20 minutes ago penguin [2) sample Page
Admin ago chocolate #
@2 iBugs gif 22 Josh User  aboutanhour  about an hour ago useful logo # [3) sample Page
kB ago
@ad sitelogo.png 2kB  JoshUser  aboutanhour  aboutan hour ago logo  confluence [2) sample Page
ago 4
) 10 Rach Feb 13,2013  Feb 13, 2013 No labels # [ Fancy Page
DefaultSpacelLogo_AngryNerds. png kB Admin

Share and Comment on Files

Collaboration doesn't just happen on pages; often you'll need to collaborate
with your team on documents, presentations, images and spreadsheets.
Whether it's mockups for a new marketing campaign or a full project plan,
you can simplify your team's feedback loop by working together on files in
Confluence.

Share a file
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Do you have lots of files on a page and want to get a team member's input On this page:
on just one of them? You can share the file with them directly.
® Share a
It works just like sharing a page: file
(]
1. Click the thumbnail or link to preview the file gﬁrgmgnt
2. Choose the Share button e Edit a file
3. Enter an email address, user name or group name, add your
message and send Related pages:
Your team members will get an email with your message and a link to view ®* Files
the file. ® Display
Files and
Images
¢ Comment
on pages
and blog
posts

Share natifications are only sent by email, they won't appear in the workbox

Comment on a file

Whether it's an image — like a mockup of the new marketing campaign that needs feedback — a PDF, a
presentation, or any other file you can preview in Confluence, you can drop a pin anywhere on the preview
and add your comment to start a conversation.

To comment on a file:

1. Click the thumbnail or link to preview the file
2. Drag the pin icon from the bottom of the preview and drop it where you want to comment
3. Add your comment and Save

Pinned comments work just like inline comments on pages. You can use @mentions and links, and drop as
many pins as you need on any part of the file. You can even add simple macros such as the code macro
using wiki markup autocomplete. Anyone with permission to add comments to the page can add and reply to
comments on a file.

When you preview a file, you'll see pins for any existing comments. Select a pin to view the comment.

Once the conversation is finished, you can resolve the comment to hide it (and any replies) from view. If you
need to see resolved comments again, you can reopen them. Go to

> Resolved comments in the preview.
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Atlassian Summit

Atlassian

We just wrapped up our biggest Summit ever! See all the
highlights, keynotes, and sessions from this year.

Drag a pin onto a file to comment.
Drag more pins to make more commen

You can't comment on files that are hosted on a web server and added to Confluence using their
URL, or on files that can't be viewed in the preview (such as videos, zip files, and some other file

types).

Edit a file

Need to go beyond commenting on files? You can even edit some files right from the Confluence page. See
Edit Office Files to find out about supported file types and applications.

Edit Office Files

The Office Connector allows you to edit attached On this page:

office files in their native application (such as Word, ® Edit an attached document
Excel, PowerPoint or OpenOffice) and save the file ® Other ways to edit

right back to the Confluence page. No need to ®* Troubleshooting

download and re-upload the file.
Related pages:

I The Office Connector is only available for some . i o
browsers, operating systems and applications, check . Office Connector Prerequisites
the Office Connector Prerequisites before you Office Connector limitations and

start for the combination that will work best for you. known issues _
® Configuring the Office Connector

Edit an attached document

To edit an Office document attached to a Confluence page:

1. Goto

LT

> Attachments
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2. Choose Edit in Office beside the attachment you want edit.
Your browser will ask you to confirm that you want to open the file.

3. Choose OK.
You may also see a security warning or be asked to log in to your Confluence server - enter your
Confluence username and password, then choose OK.

4. The file will open in your Office application - make your changes then save the document. It will be
saved back to Confluence.

I Edit in Office will not work on files that have special characters (such as ' # @ or €) in the filename.

Screenshot: Edit in Office option on the attachments page

Pages / sample space Home = \iew Page wee
Attachments

Name Size Creator Creation Date Labels Comment
» (] Meeting agenda- IE 44 kB Rach Admin Oct 14, 2014 09:33 No labels # View | Edit in Office

11.docx | Properties | Delete
» G] Spreadsheet.xls T kB Rach Admin Oct 14, 2014 09:03 Mo labels # iew | Edit in Offic

| B 4_.“ | - cte

& Download All

Other ways to edit

Edit options also appear in the:

® Attachments macro (choose Edit in Office beside each attached office file)
® File preview (choose

> Edit in Office)
Troubleshooting

Check out the Office Connector Prerequisites for the combinations of browsers, operating systems and office
applications that are supported. Here's some common issues:

® Using Chrome? You can't edit Office documents as Chrome does not support WebDAYV clients. See
CONFSERVER-23322
OPEN

® Using Firefox? You'll need to install the WebDAV add-on. See Installing the Firefox Add-On for the
Office Connector.

® Using Internet Explorer? You can only edit documents in Microsoft Office. OpenOffice is not
supported.

® Using Linux? You can only edit documents in OpenOffice. Microsoft Office is not supported. See

CONFSERVER-17250
OPEN
CONFSERVER-25594
® Using Mac OS X? You can't currently edit documents. See |RESOLVED
® Special characters in the filename? Edit in Office does not work for files with special characters (Ilke

CONFSERVER-22403
"# @ €) in the filename. See |OPEN

® Not seeing the Office Connector options? Your system administrator may have disabled all or part
of the Office Connector.
See Configuring the Office Connector .

You can find more troubleshooting info in the Office Connector Limitations and Known Issues knowledge
base article.
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Office Connector Prerequisites

The Office Connector allows you to import, and edit
office documents (such as Word, Excel and
PowerPoint) within Confluence.

The browser, operating system and applications pages
required depend on what you are trying to do with an ® Editing Office files attached to a
office file. page

On this page:
® Viewing Office files
® Importing Word documents as

® Troubleshooting

Viewing Office files

You can upload, insert and preview Office files in the
same way as any other file. You don't need to have
an Office application installed on your computer in
order to view Office files in Confluence.

Importing Word documents as pages

Confluence can import the content from Microsoft Word 97-2013 documents (. doc and . docx ).

Editing Office files attached to a page

The Office Connector allows you to edit Office files that are attached to pages.

You'll need to use a browser, operating system and application (either Microsoft Office or OpenOffice) as
described in the compatibility matrix below.

Here's

a few common issues:

Using Chrome? You can't edit Office documents as Chrome does not support WebDAYV clients. See
CONFSERVER-23322
OPEN
Using Firefox? You'll need to install the WebDAV add-on. See Installing the Firefox Add-On for the
Office Connector.
Using Internet Explorer? You can only edit documents in Microsoft Office. OpenOffice is not
supported.
Using Linux? You can only edit documents in OpenOffice. Microsoft Office is not supported. See
CONFSERVER-17250
OPEN

CONFSERVER-25594
Using Mac OS X? You can't currently edit documents. See |RESOLVED

Special characters in the filename? Edit in Office does not work for files with special characters (I|ke

CONFSERVER-22403
"# @ €) in the filename. See |OPEN .
Not seeing the Office Connector options? Your system administrator may have disabled all or part
of the Office Connector.
See Configuring the Office Connector .

Configuration matrix

You need one of the following software combinations to edit Office files from your Confluence page.

Software Operating System Browser

Microsoft Office 2013 ®* Windows 7 ® Internet Explorer 11
* Windows 8 * Firefox — latest stable

version

Microsoft Office XP, 2003, 2007, ®* Windows 7 ® Internet Explorer 11

2010 * Windows Vista * Firefox — latest stable
® Windows XP (Service Pack 2 version

or 3)
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OpenOffice 2.x — 3.x ® Windows 7 * Firefox — latest stable
* Windows Vista version
* Windows XP (Service Pack 2 ® Internet Explorer 11
or 3) (Windows Platforms only)
® Linux

Note: The only known supported Office editor for Linux is OpenOffice. But in theory it should work with any
WebDAV-aware application.

If you experience problems editing documents using the Office Connector (using an application, operating
system and browser combination above) please raise an issue and tell us as much as you can about your
operating system, application version, document version (if its different to the version of Office / Open Office
you're using to open the document) and browser.

Troubleshooting

Having problems with the Office Connector?

® The WebDAYV plugin must be enabled, because the Office Connector uses WebDAYV to transfer
information to and from Office documents. The WebDAYV plugin is bundled with Confluence, and can
be enabled or disabled by the System Administrator. If necessary, refer to the instructions on enabling
plugins and configuring the WebDAYV options.
® Ensure that your Confluence server's base URL is set correctly (see Configuring the Server Base URL
to find out how to check this). When a user edits a Confluence page in Word and then uploads the
page back to the Confluence server, the base URL determines where the document will be saved. If
the base URL is incorrect, the documents may be saved to a different Confluence server.
® Using Office 2013? Your administrator will need to enable 'Allow authentication tokens in the URL
path' in the Office Connector configuration. See Configuring the Office Connector.
See the Office Connector Limitations and Known Issues knowledge base article for more troubleshooting
tips.

Install the Firefox Add-On for the Office Connector

If you are using Firefox as your browser, you will On this page:
need to install an add-on into Firefox (the Firefox

WebDAV Launcher) in order to use some features of : Installing the Firefox Add-On

the Office Connector. You will be prompted to install . Configuring the Add-On

the add-on the first time you try to use a function Security Risks o

which requires it. ® |nformation about this Firefox
add-on

I For more information on the browsers, operation
systems and application combinations required to
use the Office Connector see Office Connector e Edit Office Files
Prerequisites.

Related pages:

Installing the Firefox Add-On

The first time you try to edit an attached Office document in Firefox you'll be prompted to install a WebDAV
add-on for your browser. Without this add-on you can't edit Office documents from Firefox.

1. Choose Edit in Office or Edit Document next to the document you wish to edit.
You'll see a prompt to download the add-on.

Aplugin is required to use this feature. Would you like to download it?

Ok ] | Cancel

2. Choose OK.
Your browser will ask you to confirm that you want to allow the add-on.
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t Firefox prevented this site (pug.jira-dev.com) from
asking you to install software on your computer.

| Allow ||

3. Choose Allow.
An installation dialog like the one below will appear.

-
Software Installation Iﬁ

Install add-ons only from authors whom you trust.

Malicious software can damage your computer or vielate your privacy.

You have asked to install the following item:

WebDAVY Launcher (Atigssign Pty Ltd)
https://update.atlassian.com/office-connector/URLLauncher/latest/webdavlcader.xp

l Install Mow l | Cancel

A

4. Choose Install Now.
Once the installation is complete you'll be prompted to restart Firefox. Make sure you've saved any

open pages or other work in your browser before you restart.
5. Next you need to configure the add-on, and tell it which applications to use.

Configuring the Add-On

After installing the add-on you need to configure it, to tell the add-on which desktop applications to launch for
each file type.

Configuring the add-on is slightly different in each operating system.

Configuring the add-on in Windows

In most cases the add-on will automatically configure itself, based on information from the system
registry. The first time you edit a new file type, the add-on will look up the default editor for that file type and

make that the permanent setting.

If you want to override the registry settings, or the automatic configuration is not working, you can configure
the Firefox add-on manually.

1. In Firefox locate the WebDAV Launcher add-on and choose Options.
The WebDAV Launcher Options dialog, like the one below, will appear.
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-

WebDAV Launcher Options [

ext Application path

A

d... CAProgram Files (x86)\Microsoft Office\ Officel N WINWORD.EXE
p.. CAPROGRA~2Z\MICROS5~3\0fficel2\Moc.exe

Delete
Add extension
File Extension Auto
Application Path | Browse || Add |

[ Save ]| Cancel |

2. Enter a file extension in the File Extension field. Do not include the leading period in the extension
name.

For example, to associate the 'doc' file extension with Microsoft Word 2003 you would type doc in the
File Extension field.

Using Office 2007 or later?

You should configure the WebDAV launcher to open both Office 2003 file extensions (doc, ppt
and xls) and Office 2007 and later file extensions (docx, xIsx and pptx).

3. Enter the Application Path - you can either:

® Choose Auto to load the associated application from the Windows registry, or
® Choose Browse to find the application on your computer, or
® Manually enter the path to the application's executable file.
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WebDAV Launcher Options o
ext Application path 25}
d.. CAProgram Files (x86)\Microsoft Office\ Officel S\ WINWORD.EXE
p.. CAPROGRA~2\MICROS5~3\0Officel2\Moc.exe
Add extension

File Bxtenzion docx
Application Path  C:\Program Files (x86] [ Browse l | Add |
| Save | | Cancel |

4. Choose Add to add the file extension association to the list.
Repeat this process for all the file extensions you need.

Configuring the Add-On in Mac OS X

The configuration procedure is similar to Windows, as shown above. Note that there is no 'Auto’ button in
Mac OS X.

CONFSERVER-25594
You can't currently edit documents in Mac OS X. See |RESOLVED

Configuring the Add-On in Linux
The only known supported Office editor for Linux is OpenOffice (see Office Connector Prerequisites).

There is no automatic configuration on Linux. You will need to associate each file type with your Office editor
in Firefox. Note that there is no 'Auto’ button in Linux.

The configuration procedure is similar to Windows. For both Ubuntu and OpenSUSE, the configuration will
look something like this:

File Extension Application Path

doc and docx  /usr/bin/oowriter
ppt and ppt x  /usr/bin/ooimpress

x| s and xI sx  /usr/bin/oocalc
Security Risks

Please be aware that there are security risks in installing this add-on to Firefox. Internet Explorer is
exposed to the same risks, because it can directly open Office documents.

Summary of the risks:

® Office documents can contain macro viruses. Before opening an Office document, make sure that you
trust the source of the document.
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® There are known flaws in the Office file formats and Microsoft Office that an attacker can exploit to
gain control of your machine. Microsoft has fixed the known exploits in the latest Service Packs for all
Microsoft Office versions, but new exploits may arise at any time. Be sure that you trust the source of

a document before opening it.

The add-on reduces the risk by supporting:

® Same origin policy - the add-on can only open documents from the same host that initiated the

action.

® Digital signature - the add-on is digitally signed. When you install the add-on please verify that it is

signed by Atlassian.

®* Prompt the user for confirmation - You will always be warned before a file is opened. Please read
these warnings carefully before opening a file. The warning tells you the complete URL of the file

as well as the complete application path of the application opening the file.

Information about this Firefox add-on

Add-on name: WebDAV Launcher
Description:

Latest version: See the WebDAV Launcher add-on page at Mozilla

Compatible with:  All versions of Firefox, up to and including the latest stable version.

Author: Atlassian Pty Ltd

Confluence Mobhile

This page is about Confluence mobile web. If you're a Confluence
Cloud customer, head over to our Cloud documentation to find out
about the Confluence Cloud app for iOS and Android.

When you access Confluence on a mobile device, you'll see a version of
Confluence which is optimized for mobile viewing. Confluence chooses the
mobile or desktop interface based on your device, but you can still switch to
the desktop site on your mobile by choosing menu

then choosing Switch to desktop version.

You can also swap from the desktop view to the mobile view if you're on a
mobile device, by choosing Switch to Confluence Mobile at the top of the

page.

On your supported mobile device, you can:

Add or reply to a comment on a page or blog post.
Like a page, blog post or comment.

Watch a page or blog post.

See your notifications and tasks.

You can't add or edit pages or blog posts, or edit existing comments, using
the mobile interface.

The dashboard —the first thing you see

Choose a tab to see:

View the Confluence dashboard, pages, blog posts, and user profiles.

Adds the ability to launch a WebDAV URL directly in a WebDAV-aware client.

On this page:

The
dashboard
— the first
thing you
see
Searching
for content
and people
Viewing
pages,
blog posts
and
comments
Viewing
people's
profiles
Following
up on
notification
S

Viewing
tasks
More
things you
may need
to know
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® Popular content — what people like in your wiki.

® Recent blogs — the latest blog posts.

® Network — updates by people in your network.

Tap the links to view the full content of a page, blog post or comment.

Popular Recent Blogs MNetwork

JIRA 5.2 Bug Fixing

m Re: On culture and ideas

Workshop - "The Business
Case" - Why is Customer
Experience Important? ¥

Searching for content and people

Tap the menu icon

to open the menu panel on the left of the page. Then type text or a person's name in the Search box. The
mobile interface offers the quick navigation search, which returns matches on page title only. (See Search.)

To use the full search, switch to desktop mode.

Q Search people and content

Dashboard Pop

Recently viewed

m

Motifications

Tasks

Give Atlassian feedback

Switch to desktop version

Log out

Viewing pages, blog posts and comments

Tap a link on the dashboard or on any other page. Confluence will display the linked page, blog post or
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comment.
You can:

* View the content, tap a link to move to another page, and interact with the page using the standard
functionality supported by mobile browsers.

® Like or unlike a page, blog post or comment.

® \Watch or stop watching a page or blog post.

® Add or reply to a comment.

Viewing people's profiles

Search for a person's name, then view that person's user profile. Tap the options to phone, SMS or email a
colleague directly from your mobile device.

Following up on notifications

You can view and respond to your notifications on your phone or other mobile device. Tap the menu icon

to open the menu panel on the left of the page. Choose Notifications, and tap a notification to see its
details. You can reply, watch or like via the inline actions. Tap Open to open the page or blog post in a new
page. For full details, see Workbox Notifications.

— Notifications

7 likes of Feedback requested - all ... »
¢} Joe Clark liked Last chance for a da... >
- Re: Ul Text Guidelines b

Atlassian Foundation's bush regene. .. >
- EOFY 2012: Choose your own Adv. .. >
2 comments on Confluence for tech ... >

More

Viewing tasks

You can view and manage your tasks on your phone or other mobile device too. Tap the menu icon

to open the menu panel on the left of the page. Choose Tasks then tap a task to see its details.
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— Tasks
To Do Completed
Atlassian Foundation's bush rege... »

Overview of FY12 Speaking Events >
Leave work early to pick up choco... »
Sarah Maddox — buy the chocolates >
Sarah Maddox — write the docum... >

Recommended database migratio... »

More things you may need to know

Some macros may not appear

Confluence macros are not yet fully supported in Confluence mobile. If you view a page that contains an
unsupported macro, you will see a message inviting you to click through to the desktop version of the page.

Screenshot: Macro not rendered in Confluence mobile

View macro in desktop version

Administrators can disable Confluence mobile on your site

The mobile functionality is provided by a system add-on called the 'Confluence Mobile Plugin'. To remove the
functionality from your site, you can disable the plugin.

In Confluence versions 5.9 and above, disabling the Confluence Mobile Plugin will also disable the
Workbox - Host Plugin plugin. This issue is being tracked at

CONFSERVER-40782 - Disabling the Confluence Mobile Plugin also disables the Workbox - Host Plugin in
Confluence 5.9.X |OPEN

Native Confluence mobile app

The Confluence iOS app is available for Confluence Cloud sites only. It cannot be used with Confluence
Server.

You can access Confluence Server on any device using a browser. Confluence will detect your device's size
and switch to the mobile web version when necessary.

See Supported Platforms for supported mobile browsers.
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Macros
Using macros helps you to expand the capabilities of your Confluence .
pages, allowing you to add extra functionality or include dynamic content. On this page:
For example, use the Attachments macro to list files attached to a page, or ® Adda
use the Widget Connector macro to include things like a YouTube video or Macro to
Twitter feed. your Page
® Confluenc
€ macros
Add a Macro to your Page * Creating
your own
Including Macros with the Macro Browser mac_ros
® Getting
To add a macro to a page: more
macros
1. In the Confluence editor, choose Insert > Other Macros from The
2. Find and select the required macro Marketplac
Speeding up macro entry with autocomplete: Type { and the beginning of . (l\3/lacro
the macro name, to see a list of suggested macros. Details are in Autocompl usage
ete for links, files, macros and mentions. statistics

To edit an existing macro: Click the macro placeholder and choose Edit. A
macro dialog window will open, where you can edit the parameters of the
macro.

Macro Parameters

Many macros have optional parameters you can use to control the macro's output.
With the Attachments Macro, for instance, you have two optional parameters allowing you to:

® Specify the file formats of the attachments displayed
® Choose whether or not you want old versions of the attachments displayed

Macro Placeholders

Macro placeholders are displayed in the editor where you have added a macro to the page.
When editing a page, you can:

® Double-click a macro placeholder (or click the placeholder and choose Edit) to open the macro dialog
window and edit the macro's parameters
® Select a macro placeholder to cut, copy and paste the macro

Confluence macros

Below is a list of the macros currently bundled with Confluence. Click a macro name for details of the usage,
including optional parameters and examples.
Activity Stream Macro

Anchor Macro

Attachments Macro

Blog Posts Macro

Change-History Macro

Chart Macro

Cheese Macro

Children Display Macro

Code Block Macro

Column Macro

Content by Label Macro

Content by User Macro
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Content Report Table Macro
Contributors Macro
Contributors Summary Macro
Create from Template Macro
Create Space Button Macro
Excerpt Include Macro
Excerpt Macro

Expand Macro

Favorite Pages Macro
Gadget Macro

Gallery Macro

Global Reports Macro

HTML Include Macro

HTML Macro

IM Presence Macro

Include Page Macro

Info, Tip, Note, and Warning Macros
JIRA Chart Macro

JIRA Issues Macro

JUnit Report Macro

Labels List Macro
Livesearch Macro
Loremipsum Macro
Multimedia Macro
Navigation Map Macro
Network Macro

Noformat Macro

Office Excel Macro

Office PowerPoint Macro
Office Word Macro

Page Index Macro

Page Properties Macro
Page Properties Report Macro
Page Tree Macro

Page Tree Search Macro
Panel Macro

PDF Macro

Popular Labels Macro
Profile Picture Macro
Recently Updated Dashboard Macro
Recently Updated Macro
Recently Used Labels Macro
Related Labels Macro
Roadmap Planner Macro
RSS Feed Macro

Search Results Macro
Section Macro

Space Attachments Macro
Space Details Macro
Spaces List Macro

Status Macro

Table of Contents Macro
Table of Content Zone Macro
Task Report Macro

User List Macro

User Profile Macro

View File Macro

Widget Connector Macro

Creating your own macros
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Users with System Administrator permissions can create user macros - see Writing User Macros.

If you want to create something more complex, you can develop your own plugin - see Writing Confluence
Plugins.

Getting more macros from The Marketplace

You can find a wide range of Atlassian and third party macros at The Marketplace. These are distributed as
add-ons and can be installed by a Confluence Administrator.

Macro usage statistics

Confluence administrators can check how often each macro is used in your site.

To see how often a macro is used, go to
> General Configuration > Macro Usage. This lists how often each macro is used in current spaces but
doesn't include any macros used on pages in archived spaces or macros provided by disabled add-ons.

Activity Stream Macro

The Activity Stream macro is a specific instance of the Gadget macro. It inserts an Activity Stream gadget onto
your page. For instructions, see Activity Stream Gadget.
Related pages:

® Activity Stream Gadget
® Gadget Macro

Anchor Macro
Allows you to link to a specific part of a page. For more information on using anchors see Anchors.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: anchor

Macro body: None.

..............................................................................................................................................................................

Attachments Macro

The Attachments macro displays a list of files attached to a page.
It also allows users (with appropriate permissions) to:

upload a file to the page, directly from the list

edit attachment properties and labels

delete an attached file (this deletes all versions of the file)

preview image attachments

edit attached Office and PDF documents using the Office Connector.
download all files attached to the page.

Note: you can use the macro parameters to turn off previews if you have very large attachments.

Screenshot: The Attachments macro, showing details of an attachment
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Pages / Ewan User's Home

Customer Feedback

File -
> CustomerFeedbackJApr.pdf
> CustomerFeedbackMarch.pdf
v FeedbackSpreadsheet xls

Labels
positive-feedback | #

Version history

Version 1 (current version)

View Edit in Office Properties

* Download All

# Edit

[ 3 Added by Ewan User, last edited by Ewan User on Mar 12, 2013 (view change)

Have you received feedback from our customers? Add it to this page.

Created by Ewan User

Delete

browse for files

2 share  £F Tools -

Modified

Mar 12, 2013 by Sophie User

Mar 12, 2013 by Ewan User

Mar 12, 2013 by Ewan User

Mar 12, 2013

Using the Attachments Macro

To add the Attachments macro to a page:

1. In the Confluence editor, choose Insert > Other Macros

2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of

suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,

where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro

browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Filename all A comma-separated list of regular expressions, used to filter the attachments by
Patterns file name. Note that the parameter values must be regular expressions. For
(patterns) example:

®* To match a file suffix of 'jpg’, use . *j pg (not *. j pg).
® To match file names ending in 'jpg' or 'png’, use . *j pg,. *png

Created in 2017 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
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Attachment  (none) A list of labels, used to filter the attachments to display. If you wish to enter more
Labels than one label, separate the labels with commas. Confluence will show only
(1 abel s) attachments that have all the labels specified. (The match is an AND, not an
OR.) For information on labeling the attachments, see Add, Remove and Search
for Labels.

Include Old  false A value of t r ue will include previous attachment versions in the list.
Attachment
Versions
(ol d)
Sort By date The sort order for attachments. Note that people viewing the page can change
(sortBy) the sort order by clicking the column headings. Valid values are:

® date — sorts by updated date in reverse chronological order (newest first)

® size — sorts largest to smallest

® name — sorts alphabetically

® created date - sorts by creation date in reverse chronological order (newest

first)

Sort Order ascending Used in combination with the Sort By parameter, to sort the attachments in
(sort Order ascending or descending order.
)
Allow true If selected, the list of attachments will include options allowing users to browse
Upload for, and attach, new files.
(upl oad)
Page Title (none) Used to display attachments from another page. If you do not enter a page title,
(page) the macro will display the files attached to the current page.
Show true Used to display a preview of the attached file. If true, preview will be visible when
Previews the list item is expanded.
(previ ew)

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: at t achnent s

Macro body: None.
{attachnent s: ol d=f al se| patterns=. *png, . *j pg| sort by=nane| page=My page
about

chocol at e| sort or der =descendi ng| | abel s=chocol at e, cooki es| upl oad=f al se| pre
vi ew=f al se}

Blog Posts Macro

The Blog Posts macro allows you to display blog posts on a Confluence page. Clicking on a title takes you to the
blog post.

Using the Blog Posts Macro

To add the Blog Posts macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro
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Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Required Default Description
Content No titles Available values:
Type to

® titles — Display the title, creator, space, and created date stamp
for each blog post.

(content) ® excerpts — Display a short excerpt from each blog post. If the post
contains an Excerpt macro, the Blog Posts macro will display the
content defined in the Excerpt macro. If the post does not contain
an Excerpt macro, the Blog Posts macro will display the first few
sentences of the post.

® entire - Display the whole content of each blog post.

Display

Time No no limit Specify how far back in time Confluence should look for the blog posts
Frame to be displayed.
(time)

Available values:

® m— Minutes
® h — Hours, so '12h' displays blog posts created in the last twelve

hours.
®* d — Days, so '7d' displays blog posts created in the last seven
days.
* w— Weeks
Restrictto No None Filter the results by label. The macro will display only the blog posts
these which are tagged with the label(s) you specify here.
Labels
(1 abel) You can specify one or more label values, separated by a comma or a
space.

® To exclude content which matches a given label, put a minus sign
(-) immediately in front of that label value. For example: If you
specify a label value of - badpage you will get only content which is
not labeled with 'badpage’'.

® To indicate that the results must match a given label value, put a
plus sign (+) immediately in front of that label value. For example: If
you specify a label value of +super page, +goodpage you will get
only content which has at least two labels, being 'superpage' and

‘goodpage’.
Restrictto No None Filter the results by author. The macro will display only the blog posts
these Aut which are written by the author(s) you specify here.
hors
(aut hor)
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Restrictto No @self, i.e.

these the space

Spaces which

(spaces) contains
the page
on which
the macro
is coded

Maximum  No 15

Number of

Blog

Posts

(max)

Sort By No creation

(sort)

Reverse No false

Sort

(reverse

)

Wiki markup example

206

This parameter allows you to filter content by space. The macro will
display only the pages which belong to the space(s) you specify here.

You can specify one or more space keys, separated by a comma or a
space.

®* To exclude content in a specific space, put a minus sign (-)
immediately in front of that space key. For example: If you specify a
space key of - BADSPACE you will get only content which is not in
the BADSPACE.

® To indicate that the results must come from a specific space, put a
plus sign (+) immediately in front of that space key. For example: If
you specify a space key of +GOODSPACE you will get only content
in GOODSPACE. (Note that this is not particularly useful, because
each content item belongs to one space only. If you put a plus sign
next to one space key and list other space keys too, the other
space keys will be ignored.)

Special values:

@el f — The current space.

@er sonal — All personal spaces.

@l obal — All site spaces.

@ avorit e — The spaces you have marked as favorite.
@ avourite — The same as @ avori t e above.

@l | — All spaces in your Confluence site.

* — The same as @l | above.

When specifying a personal space, remember to use the tilde (~) sign
in front of the username, such as ~j bl oggs or ~j bl oggs @xanpl e.
com

Specify the maximum number of results to be displayed. Note that the
results are sorted first, and then the maximum parameter is applied.

Specify how the results should be sorted. If this parameter is not
specified, the sort order defaults to descending order (newest first)
based on the creation date.

Values:

® title — Sort alphabetically by title.

® creation — Sort by the date on which the content was added.

* modified — Sort by the date on which the content was last
updated.

Select to change the sort from descending to ascending order (oldest
first). Use this parameter in conjunction with the Sort By parameter.
This parameter is ignored if the Sort By parameter is not specified.

In storage format and wikimarkup a value of t r ue changes the sort
order.

This example is useful when you want to add a macro outside the editor, for example as custom content in the

sidebar, header or footer of a space.

Macro name: bl og- post s
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Macro body: None.

..............................................................................................................................................................................

{bl og- posts:content=titl es| spaces=@el f, ds| aut hor=jsm th|time=4w reverse
=true| sort =creati on| max=10| | abel =chocol at e, cooki es}

..............................................................................................................................................................................

Change-History Macro

The Change-History macro shows the history of updates made to a page: version number, author, date and
comment. It displays the information inline.

Screenshot: The Change-History macro in Confluence

This is the change history macro
Version Date Comment
Current Version (v. 4) Feb 19, 2013 16:27 Rach Admin:
Formatting change
V.3 Feb 19, 2013 16:27 Rach Admin:
Added the change history macro
V.2 Feb 19, 2013 16:26 Rach Admin:
Added a macro
V. 1 Feb 19, 2013 16:25 Rach Admin

To add the Change-History macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Note: There are no parameters for this macro.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: change-hi story

Macro body: None.

..............................................................................................................................................................................

Chart Macro

The Chart macro allows you to display a chart based
on tabular data. When you add the macro to a page,
you:

® supply the data to be charted by the macro as
a table in the placeholder of the macro.

® edit the macro parameters in the Macro
Browser to configure the format of the chart.

Screenshot 1: A table of data in the Chart macro
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placeholder

Weeks

04/07/2011
11/07/2011
18/07/2011
25/07/2011
01/08/2011
08/08/2011
15/08/2011
22/08/2011
29/08/2011
05/09/2011

Issues Burndown

a1
68
67
66
65
65
64
44
24
0

Chart | type = timeSeries | columns = Weeks, Issues Burndown | dataOrientation = vertical | tim...

Screenshot 2: The resulting chart

Mumber of I1ssues
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= = o] L] L]
(5] (5] (5] (5] (5]
L S - B
- - oo oo oo
o) o) = = =
- - T T T
(=31 (¥=] (3] L=3] o
— (3] = L] —
Weelks

|ssues Burndown
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On this page:

® Using the Chart Macro
® Parameters
® Examples

[ )
® Code
[ )

Pie Chart

Bar Chart

3D Bar Chart

Time Series Chart

XY Line Chart

XY Area Chart

Area Charts

Gantt Chart
examples

Chart type parameters
Chart display parameters
Chart title and label
parameters

Chart data parameters
Chart color parameters
Chart axis parameters
Pie chart Parameters
Chart attachment
parameters

Wiki markup example

06/09/2011

Using the Chart Macro

To add the Chart macro to a page:

1. Edit the page and use autocomplete to add the Chart macro. (Type {chart}'.)

2. Enter your chart data as one or more tables in the body of the macro placeholder. (See the screenshot

above.)

© N OhW

Parameters

Chart Type Parameters | Display Control Parameters | Title and Label Parameters | Data Specification

Click the macro placeholder and choose Edit.

Select a chart type using the Type parameter (see below).
Choose other parameter settings in the macro browser, as described below.

Click Refresh in the 'Preview' area, to check that the chart appears as you expect.
Click Save to add the chart to your page.

Click Save again when you are ready to save the page.

Parameters | Color Parameters | Axis Parameters | Pie Chart Parameters | Attachment Parameters

Chart Type Parameters

These parameters determine the type of chart to display and the way the chart looks.

Parameter

Default

Description
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Type

Display
Orientation

Show in
3D

Stacked
Values

Show
shapes

Opacity

pie

vertical

false

false

true

® 75 percent for
3D charts

® 50 percent for
non-stacked
area charts

® 100 percent for
all other charts

Display Control Parameters

Parameter

Width
Height
Display

rendered
data

Image format

Default
300
300

false

png

Title and Label Parameters

Parameter

Chart Title

Chart Subtitle

Horizontal-axis Label

Vertical-axis Label

209

The type of chart to display. XY charts have numerical x- and y-axes.
The x values may optionally be time-based (see the Time Series para
meter).

Standard — pie, bar, line, area

XY Plots — xyArea, xyBar, xyLine, xyStep, xyStepArea, scatter,
timeSeries

Other — gantt

Applies to area, bar and line charts.

® vertical — y-axis is vertical

® horizontal — x-axis is vertical
Applies to area, bar and line charts.
Applies to area and bar charts.

Applies to line charts. Shapes are shown at each data point.

A percentage value between 0 (transparent) and 100 (opaque) that
determines how opaque the foreground areas and bars are.

Description

The width of the chart in pixels.

The height of the chart in pixels.

Sets whether to display the rendered body of the macro (usually the data
tables). By default, the chart data table isn't rendered.

®* before — the data are displayed before the chart.
* after — the data are displayed after the chart.

The image format to be used for the chart.

® png
* ipg
Default Description
none The title of the chart.
none A subtitle for the chart, using a smaller font than for Title.
none The label for the x-axis (domain).
none The label for the y-axis (range).
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Show Legend true Show a legend or key.

Data Specification Parameters

The data for the chart is taken from tables found when the macro body is rendered. These options control
how this data is interpreted. By default, numeric and date values are interpreted according to the Confluence
global default language (locale) formats. If conversion fails, other languages defined in Confluence will be
tried. Additional conversion options can be specified using the parameters below.

Parameter  Default Description
Tables all first Comma separated list of table ids and/or table numbers (starting at 1)
level tables contained within the body of the macro that will be used as the data for the
chart. If data tables are embedded in other tables, then table selection will be
required. This occurs when more complex formatting is done (for example
using section and column macros).
Columns all columns Comma separated list of column labels and/or column titles and/or column
numbers for tables used for chart data. This applies to all tables processed.
Columns are enumerated starting at 1. Column label is the text for the column
in the header row. Column title is the (html) title attribute for the column in the
header row.
Content horizontal ® vertical — data table columns will be interpreted as series.
Orientation ® horizontal — data tables rows will be interpreted as series.
Time false ® true — the x values in an XY plot will be treated as time series data
Series and so will be converted according to date formats.
Date Confluence For time series data, the date format allows for additional customization of the
format language conversion of data to date values. If a Date format is specified, it will be the
defined first format used to interpret date values. Specify a format that matches the
date time series data. See simple date format.
formats
Time Day The time period for time series data. Defines the granularity of how the data is
Period interpreted. Valid values are: Millisecond, Second, Minute, Hour, Day, Wee
k, Month, Quarter, Year.
Language none Use in combination with the Country parameter to form a locale.
These additional number and date formats will be used for data conversion
before the default languages.
Valid values are 2 character ISO 639-1 alpha-2 codes.
Country none Use in combination with the Language parameter to form a locale. Valid
values are 2 character ISO 3166 codes.
Forgive true ® true — the macro tries to convert numeric and date values that do not

Color Parameters

totally match any of the default or user-specified formats.
® false — enforce strict data format. Data format errors will cause the
chart to not be produced.

Colors are specified using hexadecimal notation or HTML color names.

Parameter Default Description
Background White Background of the chart.
Color
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Border Color

Colors

Axis Parameters

Border around the chart.

border

Comma-separated list of colors used to customize category, sections, and
series colors.

Depending on the chart type, the range and domain axis may be customized. These values are automatically
generated based on the data but can be overridden by specifying one or more more of these parameters.

Parameter

Range
Minimum
Value

Range
Maximum
Value

Range
Axis Tick
Unit

Range
AXis
Label
Angle

Domain
AXis
Lower
Bound

Domain
AXis
Upper
Bound

Domain
Axis Tick
Unit

Domain
AXis
Label
Angle

Category
Label
Position

Created in 2017 by Atlassian.

Default

none

none

none

none

none

none

none

none

none

Description

Range axis lower bound.

Range axis upper bound.

Range axis units between axis tick marks.

Angle for the range axis label in degrees.

Only applies to XY plots. Domain axis lower bound. For a date axis, this value
must be expressed in the date format specified by the Date format parameter.

Only applies to XY plots. Domain axis upper bound. For a date axis, this value
must be expressed in the date format specified by the Date format parameter.

Only applies to XY plots. Domain axis units between axis tick marks. For a date
axis, this value represents a count of the units specified in the Time Period param
eter. The Time Period unit can be overridden by specifying a trailing character: y
(years), M (months), d (days), h (hours), m (minutes), s (seconds), u
(milliseconds).

Only applies to XY plots. The angle for the domain axis label, in degrees.

Placement of the axis label text for categories.

up45 — 45 degrees going upward
up90 — 90 degrees going upward
down45 — 45 degrees going downward
down90 — 90 degrees going downward
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Date Tick start Placement of the date tick mark.
Mark

Position ® start — tick mark is at the start of the date period.

®* m ddl e — tick mark is in the middle of the date period.
®* end — tick mark is at the end of the date period.

Pie Chart Parameters

Parameter  Default Description
Pie Section Show only the pie Format for how pie section labels are displayed. The format uses a
Label section key value string with special replacement variables:

®* 9%0% is replaced by the pie section key.
®* %1% is replaced by the pie section numeric value.
®* 9%2% is replaced by the pie section percent value.

Example 1: "%0% = %1%" would display something like
"Independent = 20"

Example 2: "%0% (%2%)" would display something like
"Independent (20%)"

Pie Section No exploded Comma separated list of pie keys that are to be shown exploded.
Explode sections Note: requires jFreeChart version 1.0.3 or higher.

Attachment Parameters

These are advanced options that can be used for chart versioning, to enable automation and to improve
performance. Use these options carefully! Normally, the chart image is regenerated each time the page is
displayed. These options allow for the generated image to be saved as an attachment and have subsequent
access re-use the attachment. This can be useful especially when combined with the Cache Pluginto
improve performance. Depending on the options chosen, chart images can be versioned for historical

purposes.

Parameter Default Description

Attachment none The name and location with which the chart image will be saved as an
attachment. The user must be authorized to add attachments to the page
specified.

® MattachmentName.png — the chart is saved as an attachment to the
current page.

® page”attachmentName.png — the chart is saved as an attachment to the
page name provided.

® gspace:page”attachmentName.png — the chart is saved as an attachment
to the page name provided in the space indicated.

Attachment new Defines the the versioning mechanism for saved charts.

Version .
® new — creates new version of the attachment.

® replace — replaces all previous versions of the chart. To replace an
existing attachment, the user must be authorized to remove attachments
for the page specified.

® keep — only saves a new attachment if an existing export of the same
name does not exist. An existing attachment will not be changed or

updated.
Attachment none Comment used for a saved chart attachment.
Comment
Thumbnail false ® true — the chart image attachment will be shown as a thumbnail.

Chart Type Parameters | Display Control Parameters | Title and Label Parameters | Data Specification
Parameters | Color Parameters | Axis Parameters | Pie Chart Parameters | Attachment Parameters
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Examples

Pie Chart

Parameters in Macro

Browser
Type pie
Chart Title Fish Sold

2011
Show Legend true

Content vertical
Orientation

Bar Chart

Data Table in Macro
Placeholder

Fish Type 2011
Herring 9,500
Salmon 2,900

Tuna 1,500

Parameters in Macro Data Table in Macro

Browser Placeholder
Type bar

Fish 2010 2011
Chart Title  Fish Type

Sold

Herring 9,500 8,300
Show true
Legend Salmon 2,900 4,200

Tuna 1,500 1,500
3D Bar Chart
Parameters in Data Table in Macro

Macro Browser Placeholder

213

Rendered Chart

Fish Soild 2011

Herring

Salmeon

Tuna

® Herring (9,500 - 68%)
® Salmon (2,900 - 21%) ®m Tuna (1,500 - 11%)

Rendered Chart

Fish Sold
5,000
8,000
7,000
5,000
5,000
4,000
3,000
2,000
1,000 IIII IIII
= ___E ____H __TESS———— =8 8 ..
2010 2011

B Herring ® Salmon ® Tuna

Rendered Chart
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Type

Show in
3D

Opacity

Show
Legend

bar

true

2009 2010 2011

Revenue 124 31.8 41.1

50 Expense 43.6 41.8

true

Time Series Chart

Parameters in
Macro Browser

Type

Date
Format

Time
Period

Content
Orientation

Range
AXxis

Lower
Bound

Show
Legend

XY Line Chart

Time
Series
MM/yyyy

Month

vertical

true

Parameters in
Macro Browser

Type

xyLine

31.1

45

40

33

30

25

20

15

10

Data Tables in Macro Placeholder

Month

1/2011

2/2011

3/2011

4/2011

5/2011

6/2011

7/2011

8/2011

9/2011

10/2011

11/2011

12/2011

Revenue

31.8

41.8

51.3

33.8

27.6

49.8

51.8

77.3

73.8

97.6

101.2

113.7

Data Table in Macro

Placeholder

Month

1/2011

2/2011

3/2011

4/2011

5/2011

6/2011

7/2011

8/2011

9/2011

10/2011

11/2011

12/2011

2003

2010

2011

B Revenue W Expense

Rendered Chart

Expenses 110
100
41.1

43.8 =
45.3 &0
45.0

44.6 30
43.8
51.8
52.3
53.8
55.6
61.2

63.7

Rendered Chart

At

01720114

02720114

i
—
)
[l
]

=

03720114
04520114
0520114
0&/20114

20114

=]

o]

= Fevenue =—Expen
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Show true 12 14 23
Legend Revenue 41.1 31.8 12.4

Expense 31.1 41.8 43.6
XY Area Chart

Parameters in Data Table in Macro

Macro Browser Placeholder
Type xyArea
12 14 23
Show true
Legend Revenue 41.1 31.8 124
Expense 31.1 41.8 43.6

Area Charts
Example 1
Parameters Data Table in Macro Placeholder
in Macro
Browser
Type area

Satisfaction 2009 2010 2011
Show true
Legend Very 20 23 34

satisfied
Width 300

215

45

40

35

20

25

20

15

10

12 13 14 15 1s 17 18 13 20 21 22 23

= Revenue = Expense

Rendered Chart

45
40
35
20
25
20
15

10

12 13 14 15 18 17 18 1% 20 21 22 23

a Revenue & Expense

Rendered Chart
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Height 300 Satisfied 40 34 23
Opacity 50 Dissatisfied 25 26 25
Very 15 17 18
dissatisfied
2009 2010 2011
mVery satisfied m Satisfied m Dissatisfied
[Wery dissatisfied
Example 2
Parameters Data Table in Macro Placeholder Rendered Chart
in Macro
Browser
Type area
Satisfaction 2009 2010 2011  *%°
Show true a0
Legend Very 12 23 31
satisfied =0
Width 300 70
Satisfied 1 34 36 -
Height 300
Dissatisfied 4 6 22 S0
Stacked true an
Values Very 2 7 12
dissatisfied 50
20
10
]
2009 2010 2011
mVery satisfied m Satisfied m Dissatisfied
[Very dissatisfied
Gantt Chart
Parameters in Macro Data Table in Macro Placeholder Rendered Chart
Browser
Type gantt
Plan Start End Status
Width 300
Stage 1 6/25/2013 7/10/2013 30%
Height 200

Stage 2 7/13/2013 11/28/2013 40%
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Columns ,,1,2,3,4 Stage

Date MM/dd/yyyy
format

3 12/1/2013

Actual Start

Stage

Stage

Stage

6/ 25/ 2013

7/ 29/ 2013

12/ 25/ 2013

End
7/ 26/ 2013

12/ 01/ 2013

12/10/ 2013 12/25/2013

07012012 0%f0L/2012
-
Stage 1
—
Status —
100% —
Stage 2
e
40%
Stage 2

o You must include the two leading commas in the column parameter (for example , , 1, 2, 3, 4) for the

chart to be created correctly.

Code examples

This example is useful when you want to add a macro outside the editor, for example as custom content in
the sidebar, header or footer of a space.

Macro name: chart

Macro body: Accepts rich text, consisting of tables that hold the chart's data.

This macro recognizes a large number of parameters, listed here by type.

~ See all parameters...

Chart type parameters

These parameters determine the type of chart to display and how the chart looks.

Parameter Required

type No

orientation No

3D No

st acked No

showShapes No

Default

pi e

verti cal

fal se

fal se

true

Description

The type of chart to display. XY charts have numerical

x- and y-axes. The x values may optionally be
time-based. See the t i neSer i es parameter.

Available values:

® Standard charts -

® XY plots —xyArea, xyBar, xyLi ne,
XySt epArea, scatter, timeSeries
® Other charts — gant t

pie, bar, line, area

xy St ep,

The display orientation. Applies to area, bar and line

charts.

Available values:

® vertical

— y-axis is vertical

® horizontal — x-axis is vertical

Show in three dimensions. Applies to area, bar and line

charts.

Stacked values. Applies to area and bar charts.

Applies to line charts. Shapes are shown at each data

point.
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opacity No

218

® 75 percent A percentage value between 0O (transparent) and 100

for 3D (opaque) that determines how opaque the foreground
charts areas and bars are.

50 percent

for

non-stacked
area charts
100 percent

for all other
charts
Chart display parameters
Parameter Required Default Description
wi dt h No 300 The width of the chart in pixels.
hei ght No 300 The height of the chart in pixels.
dat aDi splay No fal se  Determines whether to display the body of the macro,

i mgeFormat No

Chart title and label parameters

consisting of the data table. By default, the chart data table is
not displayed.

Available values:

® false — the data is not displayed.
® trueorafter — the data is displayed after the chart.
®* bef ore - the datais displayed before the chart.

png The image format to be used for the chart.

Available values:

® png
® jpg

Parameter Required Default Description

title No (None)  The title of the chart.

subTitle No (None) A subtitle for the chart.

xLabel No (None)  The label for the x-axis (domain).

yLabel No (None)  The label for the y-axis (range).

| egend No fal se Determines whether to show a legend (key) for the chart.

Chart data parameters

The data for the chart is taken from tables found in the macro body. The parameters below control how
this data is interpreted. By default, numeric and date values are interpreted according to the Confluence
global default language (locale) formats. If conversion fails, other languages defined in Confluence will be
tried. You can specify additional conversion options using the parameters below.

Parameter Required Default Description
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t abl es No

col ums No

dataOrientation No

ti meSeries No
dat eFor mat No
ti mePeri od No
| anguage No
country No

All first level
tables

All columns

hori zont al

fal se

Confluence
language
defined date
formats

day

(None)

(None)

219

You can supply a comma-separated list of table IDs
and/or table numbers (starting at 1) contained within
the body of the macro that will be used as the data
for the chart. If data tables are embedded in other
tables, then table selection will be required. This
occurs when more complex formatting is done (for
example using section and column macros).

You can supply a comma-separated list of column
labels and/or column titles and/or column numbers
for tables used for chart data. This applies to all
tables processed. Columns are enumerated starting
at 1. Column label is the text for the column in the
header row. Column title is the HTML title attribute
for the column in the header row.

The content orientation. By default, the data tables
will be interpreted as columns (horizontally)
representing domain and x values.

Available values:

® vertical - datatable columns will be
interpreted as series.
® horizontal - datatables rows will be

interpreted as series.

If 't r ue', the x values in an XY plot will be treated as
time series data and so will be converted according
date formats.

For time series data, the date format allows for
additional customization of the conversion of data to
date values. If a dat eFor mat is specified, it will be
the first format used to interpret date values. Specify
a format that matches the time series data. See simp
le date format.

The time period for time series data. Defines the
granularity of how the data is interpreted.

Available values: m | | i second, second,
m nute, hour, day, week, nonth,
quarter, year

Use in combination with the count r y parameter to
form a locale. These additional number and date
formats will be used for data conversion before the
default languages.

Available values are the two-character ISO 639-1
alpha-2 codes.

Use in combination with the | anguage parameter to
form a locale. Valid values are the two-character ISO
3166 codes.
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forgive No

Chart color parameters

true

220

Determines whether the macro will forgive (allow)
some data formatting errors.

Available values:

® true — the macro tries to convert numeric and

date values that do not totally match any of the
default or user-specified formats.

* fal se — the macro enforces strict data

formatting. If there are data format errors, the
chart will not be produced.

Colors are specified using hexadecimal notation or HTML color names.

Parameter Required Default

bgCol or No White

bor der Col or No No
border

colors No

Chart axis parameters

Description

Background color of the chart.

Color of the border around the chart.

A comma-separated list of colors used to customize the colors
of categories, sections, and series.

Depending on the chart type, the range and domain axis may be customized. These values are
automatically generated based on the data but can be overridden by specifying one or more more of

these parameters.
Parameter
rangeAxi sLower Bound
r angeAxi sUpper Bound
rangeAxi sTi ckUni t
rangeAxi sLabel Angl e

domai nAxi sLower Bound

domai nAxi sUpper Bound

domai nAxi sTi ckUni t

domai nAxi sLabel Angl e

Required Default

No

No

No

No

No

No

No

No

(None)
(None)
(None)
(None)

(None)

(None)

(None)

(None)

Description

Minimum value for the range axis.
Maximum value for the range axis.

Range axis units between axis tick marks.
Angle for the range axis label in degrees.

Only applies to XY plots. Domain axis lower
bound. For a date axis, this value must be
expressed in the date format specified by the dat
eFor mat parameter.

Only applies to XY plots. Domain axis upper
bound. For a date axis, this value must be
expressed in the date format specified by the dat
eFor mat parameter.

Only applies to XY plots. Domain axis units
between axis tick marks. For a date axis, this
value represents a count of the units specified in
the ti mePeri od parameter. Theti nePeriodu
nit can be overridden by specifying a trailing
character: y (years), M(months), d (days), h (hour
s), m(minutes), s (seconds), u (milliseconds).

Only applies to XY plots. The angle for the domain
axis label, in degrees.
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cat egorylLabel Position No (None)
dat eTi ckMar kPosition  No start
Pie chart Parameters

Parameter Required Default

No Show only the
pie section

key value

pi eSecti onLabel

No exploded
sections

pi eSecti onExpl ode No

Chart attachment parameters

221

Placement of the axis label text for categories.

Available values:

up45 — 45 degrees going upward
up90 — 90 degrees going upward
down45 — 45 degrees going downward
down90 — 90 degrees going downward

Placement of the date tick mark.
Available values:

® start — tick mark is at the start of the date

period.
® m ddl e — tick mark is in the middle of the

date period.
® end — tick mark is at the end of the date

period.

Description

Formatof pie section labels. The format uses a
string with special replacement variables:
* 9%9%is replaced by the pie section key.
® 94 %is replaced by the pie section numeric
value.
®* 92%is replaced by the pie section percent
value.

Example 1: To display something like
'Independent = 20"

%% = %%

Example 2: To display something like
'Independent (20%)":

%0% (%R%
A comma-separated list of pie keys that are to be

shown exploded. Note: requires jFreeChart
version 1.0.3 or higher.

These are advanced options that can be used for chart versioning, to enable automation and to improve
performance. Use these options carefully! Normally, the chart image is regenerated each time the page is
displayed. These options allow for the generated image to be saved as an attachment and have
subsequent access to re-use the attachment. This can be useful especially when combined with the
Cache plugin to improve performance. Depending on the options chosen, chart images can be versioned

for historical purposes.

Parameter Required Default

Description
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at t achnent No (None) The name and location where the chart image will be
saved as an attachment. The user must be authorized
to add attachments to the page specified.

Available syntax for this parameter:

® ~attachnent Name. png — the chart is saved as
an attachment to the current page.

® page nane”attachnment Nane. png — the chart
is saved as an attachment to the page name
provided.

®* pane”att achnment Nane. png — the chart is
saved as an attachment to the page name provided
in the space indicated.

attachment Versi on No new Defines the the versioning mechanism for saved charts.
Available values:

® new— creates new version of the attachment.

®* repl ace — replaces all previous versions of the
chart. To replace an existing attachment, the user
must be authorized to remove attachments for the
page specified.

® keep — only saves a new attachment if an existing
export of the same name does not exist. An existing
attachment will not be changed or updated.

at tachnent Comment  No (None)  Comment used for a saved chart attachment.

t hunbnai | No fal se If t r ue, the chart image attachment will be shown as a
thumbnail (small, expandable) image.

Wiki markup example

Below is a simple example of a pie chart. See more examples in Wiki Markup Examples for Chart Macro.

{chart:type=pie|title=Fish Sol d}
|| Fish Type || 2004 || 2005 |
|| Herring | 9,500 | 8,300

|| Salmon | 2,900 | 4,200

|| Tuna | 1,500 | 1,500

{chart}

Wiki Markup Examples for Chart Macro

This page is an extension of the documentation for the Chart Macro. This page contains additional examples for
the Chart macro.

Pie chart
Here is a simple example of a pie chart.

Wiki markup
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{chart:type=pie|title=Fish Sol d}
|| Fish Type || 2004 || 2005 |

|| Herring | 9,500 | 8,300

|| Salmon | 2,900 | 4,200

[| Tuna | 1,500 | 1,500

{chart}

Resulting chart

Fish Sold

2005

2004

®m 2004 (1,500 - 50%) m 2005 (1,500 - 50%)

Bar chart

Here is a simple example of a bar chart.

Wiki markup

{chart:type=bar|title=Fi sh Sol d}
|| Fish Type || 2004 || 2005 |

|| Herring | 9,500 | 8,300

|| Salmon | 2,900 | 4,200

[| Tuna | 1,500 | 1,500

{chart}

Resulting chart
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5,000
£,000
6,000
5,000
4,000
3,000
2,000
1,000

Fish Sold

2004

2005

B Herring ® Salmon ® Tuna

Time series chart

Here is an example of a time series chart.

Wiki markup

Created in 2017 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.

{chart:type=ti meSeri es| dat eFor mat =MV yyyy| ti nePeri od=Mont h|
dat aOri entati on=verti cal | rangeAxi sLower Bound=0| dorai naxi sr ot at et i ckl abel

=true}

|
|
|
I
I
|
|
I
I
|
|
|
I
{

Month | |
1/ 2005 |
2/ 2005 |
3/ 2005 |
4/ 2005 |
5/ 2005 |
6/ 2005 |
7/ 2005 |
8/ 2005 |
9/ 2005 |
10/ 2005 |
11/ 2005 |
12/ 2005 |

Month | |
1/ 2005 |
2/ 2005 |
3/ 2005 |
4/ 2005 |
5/ 2005 |
6/ 2005 |
7/ 2005 |
8/ 2005 |
9/ 2005 |
10/ 2005 |
11/ 2005 |
12/ 2005 |

chart}

49.
51.
77.
73.
97.6 |
101. 2 |
113.7 |

Expenses | |
41.
43.
45.
45.
44.
43.
51.
52.
53.

55.6 |

61.2 |

63.7 |

1

0 W oo oO O W o
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Resulting chart

110
100

0L/2005
022005

i
o
o
o
o

=

082005

037200354
047200359
057200359
0Ef 2005
08720054

[}

==Revenue ==Expenses

XY line chart

Here is an e

Wiki markup

xample of an XY line chart.

{chart:type=xyline}

| 12 [ 14 || 23 ||

| Revenue | 41.1 | 31.8 |

| Ex

pense | 31.1 | 41.8 |

{chart}

Resulting ch

a5

art

10720054

1172005

12.
43.

4
6

1272005

XY bar chart

= Revenue = Expense

Here is an example of an XY bar chart.
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Wiki markup

{chart:type=xybar| opaci t y=60}

[| |] 2005 || 2006 || 2007 ||

| Revenue | 41.1 | 31.8 | 12.4 |
| Expense | 31.1 | 41.8 | 43.6 |
{chart}

Resulting chart

45

40

35

20

25

20

15

10

2,005 2,008 2,007

N Revenue § Expense

XY area chart

Here is an example of an XY area chart.

Wiki markup

{chart:type=xyarea}

[ 12 0] 14 |1 23 ||

| Revenue | 41.1 | 31.8 | 12.4 |
| Expense | 31.1 | 41.8 | 43.6 |
{chart}

Resulting chart
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45
40
35
20
25
20
15

10

12 13 14 15 16 17 18 1% 20 21 22 23

& Revenue & Expense

Area chart
Here are two examples of area charts.

Wiki markup for area chart 1

{chart:type=area| dat aDi spl ay=t r ue| | egend=t r ue| wi dt h=300| hei ght =300| opaci
t y=50}

|| Satisfaction || 2002 || 2003 || 2004 ||

| Very satisfied | 20| 23 | 34 |

| Satisfied | 40 | 34 | 23 |

| Disatisfied | 25| 26 | 25 |

| Very disatisfied | 15| 17 | 18 |

{chart}

Resulting area chart 1
40
25
30
25
zo
1s

10

2002 2003 2004

mVery satisfied m Satisfied m Disatisfied
[Wery disatisfied

Satisfaction 2002 2003 2004
Very satisfied 20 23 34
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Satisfied 40 34 23
Disatisfied 25 26 25

Very disatisfied 15 17 18

Wiki markup for area chart 2

{chart:type=area| dat aDi spl ay=t rue| | egend=t r ue| wi dt h=300]| hei ght =300] st ack
ed=true}

|| Satisfaction || 2002 || 2003 || 2004 ||

| Very satisfied | 12 | 23 | 31 |

| Satisfied | 1| 34| 36 |

| Disatisfied | 4| 6| 22 |

| Very disatisfied | 2| 7| 12 |

{chart}

Resulting area chart 2

100

2002 2003 2004

mery satisfied m Satisfied m Disatisfied
Wery disatisfied

Satisfaction 2002 2003 2004

Very satisfied 12 23 31

Satisfied 1 34 36
Disatisfied 4 6 22
Very disatisfied 2 7 12

Cheese Macro

The Cheese macro simply displays the words "I like cheese!" You can use this macro to test the Confluence
macro functionality. 2

To add the Cheese macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.
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To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Note: There are no parameters for this macro.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: cheese

Macro body: None.

..............................................................................................................................................................................

Children Display Macro

Use the Children Display macro to list the child pages of a page and the further descendants (children's
children). By default, the macro displays links to the child pages as shown in the screenshot below. People
viewing the page will see only the links for pages that they have permission to view.

Screenshot: The Children Display macro in Confluence

This is the Children Display macro

* Step 1 - download the game

Step 2 - Play

Step 3 - share your favourite nerd
Sample page

Games as a communication medium

Using the Children Display macro

To add the Children Display macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Example

This list of child pages is generated by a Children Display macro on this page:

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
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Show false
Descendants

(all)

Parent Page  current
(page)

Number of none

Children

(first)

Depth of none

Descendants

(dept h)

Heading none

Style

(style)

Include none

Excerpts

(excerpt)

Sort Manual if

Children By  manually

(sort) ordered,
otherwise
alphabetical

Reverse Sort false
(reverse)

Wiki markup example

Choose whether to display all the parent page's descendants.

If t r ue shows the complete tree of pages underneath the parent page,
regardless of Depth of Descendants

Specify the page to display children for, from either the current space or
a different space. Enter:

* ' /' —to list the top-level pages of the current space, i.e. those
without parents.

® ' pagenane' — to list the children of the specified page.

® 'spacekey:' —to list the top-level pages of the specified space.

® 'spacekey: pagenanme' — to list the children of the specified page
in the specified space.

Restrict the number of child pages that are displayed at the top level.

Enter a number to specify the depth of descendants to display. For
example, if the value is 2, the macro will display 2 levels of child pages.

This setting has no effect of Show Descendants is enabled.

Choose the style used to display descendants.

Allows you to include a short excerpt under each page in the list. Choose
between:

®* None - no excerpt will be displayed

® Simple - displays the first line of text contained in an Excerpt macro
any of the returned pages. If there is not an Excerpt macro on the
page, nothing will be shown.

® Rich content - displays the contents of an Excerpt macro, or if there
is not an Excerpt macro on the page, the first part of the page
content, including formatted text, images and some macros.

Optional. Choose:

® creation — to sort by content creation date
® title — to sort alphabetically on title
* modified — to sort of last modification date.

Use with the Sort Children By parameter. When set, the sort order
changes from ascending to descending.

This example is useful when you want to add a macro outside the editor, for example as custom content in the

sidebar, header or footer of a space.

Macro name: chi | dren

Macro body: None.

{children:reverse=true| sort=creation|styl e=h4| page=Home| excer pt =none| fir

st =99| dept h=2| al | =t rue}

Code Block Macro

Created in 2017 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.

230


http://creativecommons.org/licenses/by/2.5/au/

Confluence 6.3 Documentation 231

The Code Block macro allows you to display source code in your page with syntax highlighting, like the one
below:

public static woid main(String[] args)

{
System.out.println({"Hello World!™);

Add the Code Block Macro

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

You type the code block directly into the macro placeholder in the editor. Note that any white space contained in
the placeholder is not manipulated in any way by the Code Block macro. This is to provide the writer with
flexibility over code indentation.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
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Syntax java Specifies the language (or environment) for syntax highlighting. The default
highlighting language is Java but you can choose from one of the following
(1 anguage) languages/environments:

ActionScript
AppleScript
Bash

C#

C++

CSS
ColdFusion
Delphi

Diff

Erlang
Groovy
HTML and XML
Java

Java FX
JavaScript
Plain Text
PowerShell
Python
Ruby

SQL

Sass

Scala
Visual Basic

Title none Adds a title to the code block. If specified, the title will be displayed in a header
row at the top of the code block.

Collapsible false If selected, the code macro's content will be collapsed upon visiting or refreshing
(col |l apse) the Confluence page. Clicking the expand sour ce link allows you to view this
content. If false, the code macro's content is always displayed in full.

Show line false If selected, line numbers will be shown to the left of the lines of code.

numbers

(l'i nenunbers

)

First line 1 When Show line numbers is selected, this value defines the number of the first
number line of code.

(firstline)

Theme Default = Specifies the color scheme used for displaying your code block. Many of these
themes are based on the default color schemes of popular integrated
development environments (IDEs). The default theme is Confluence (also
known as Default), which is typically black and colored text on a blank
background. However, you can also choose from one of the following other
popular themes:

DJango
Emacs
FadeToGrey
Midnight
RDark
Eclipse
Confluence

Configure the Code Block macro

Created in 2017 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 6.3 Documentation 233

You can configure the Code Block macro to use a specific language and theme by default and also upload new
lanuages. You need Confluence Administrator permissions to change the default theme and language and Sy
stem Administrator permissions to upload new languages.

To set the default appearance of code blocks in your site:

1. Choose the cog icon

, then choose General Configuration under Confluence Administration
2. Choose Configure Code Macro
3. Select a Default Theme and Default Language
4. Choose Save

All new code blocks will use the default theme and language unless you specify otherwise. Existing code blocks
will be unchanged.

To add an additional language:

1. Choose the cog icon

, then choose General Configuration under Confluence Administration

Choose Configure Code Macro

3. Choose Add a new language

4. Locate your language file and enter a Name for the new language (this will appear when selecting the
language)

5. Choose Add

N

Language files must be correctly formatted JavaScript files and adhere to the Custom Brush syntax.
To disable or remove a user-installed language:

1. Choose the cog icon

, then choose General Configuration under Confluence Administration

2. Choose Manage Add-ons

3. Goto User-installed Add-ons and locate the add-on for your uploaded language - it will appear like this
'‘Custom Code Macro Highlighting for..."

4. Choose Uninstall or Disable

The language will no longer appear in the Code Macro.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: code

Macro body: Accepts plain text.

..............................................................................................................................................................................

{code:title=This is ny

title|theme=FadeToG ey| | i nenunber s=true|l anguage=j aval firstline=0001] col
| apse=true}

This is ny code

{code}

Column Macro

Used with the Section macro to define columns on a page. See Working with page layouts and columns and
sections.

Parameters
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Parameter Required Default Parameter description and accepted values

name

wi dt h No 100% of the page width, The width of the column. Can be specified either in
divided equally by the pixels (for example, 400px) or as a percentage of
number of columns in the the available page width (for example, 50%.
section.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: col um

Macro body: Accepts rich text.

..............................................................................................................................................................................

{col um: wi dt h=100px}
This is the content of *columm 1*.
{col um}

Content by Label Macro

The Content by Label macro is used to display lists of pages, blog posts or attachments that have particular
labels. It's great for collecting related pages together and filtering out content that you don't want to see.

For example, you could use this macro to display a list of all pages that have the label 'feature-shipped' and
include the word 'Blueprint’, or to list any pages with the label 'meeting-notes' that you've been mentioned in.

Here's how the macro looks on your page:

[S Confluence PM Weekly - 30 Jan 2015 - ACE and PMIM Update (Confluence PM)
meeting-notes

() AAC Migration Messaging Meeting notes (Confluence Questions)
meeting-notes

[2) 2013-12-18 CQ Standalone Meeting Notes (Confluence Questions)
meeting-notes

[2) AAC Migration to CQ Design Meeting notes (Confluence Questions)
meeting-notes

() 2014-11-13 - Contextual Inguiry set up (Confluence Design)
meeting-notes

And here's how you would set it up in the macro browser:
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Insert ‘Content by Label’ Macro Help

¥ Preview

Label*
meeting-notes * i B a ) i
[ confluence PM Weekly - 30 Jan 2015 - ACE and PMIM Update (Confluence
PM)
Mentioning user D) meeting-noles

I}
& Jonn Wetenhall x [© Aac migration Messaging Meeting notes (Confluence Questions)

meeting-notes

Add a filter - ) ) _ ) )
[ 2013-12-18 CQ Standalone Meeting Notes (Confluence Questions)
meeting-notes
Options Show [© AAc Migration to CQ Design Meeting notes (Confluence Questions)
meeting-notes
[ 2014-11-13 - Contextual Inquiry set up (Confluence Design)
meeting-notes
b
Select macro Insert | Cancel

Using the Content by Label Macro

To add the Content by Label macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

CQL filters

CQL (Confluence Query Language) is a query language developed for Confluence, which you can use in some
macros and the Confluence search. Confluence search and CQL-powered macros allow you to add filters to
build up a search query, adding as many filters as you need to narrow down the search results.

Use the Add a filter link to add more filters to your query.

~ Use AND, OR, and NOT operators
®* For an OR search, specify multiple values in the same field.
So to show pages with 'label-a’, 'label-b' or both you'd put 'label-a’ and 'label-b' in the same Label field,
like this:

Label *

label-a % | | label-b *

® For an AND search, add more than one filter and specify a single value in each.
To show only pages with label-a and label-b you'd put 'label-a’ in one label field, then add a second
Label field to the macro, and put ‘label-b* in the second one, like this:
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Label *

label-a ®

Label [
label-b %

Put simply, OR values are entered in the same filter, AND values are entered in different filter.
Only some filters support AND. If the filter doesn't support the AND operator, you won't be able to add
that filter more than once.

®* For a NOT search, enter a minus sign (-) before the label. This'll exclude everything with that label.

You can use the following CQL filters to build your query:

Filter Description Operators
Label* Include pages, blog posts or attachments with these labels. OR (multiple values in the
same filter)

AND (multiple Label filters)

With Include pages that are children of this page. OR (multiple values in the
ancestor ) _ : same filter)
This allows you to restrict the macro to a single page tree.
Contributor** Include pages or blog posts that were created or edited by OR (multiple values in the
these people. same filter)
Creator Include items created by these people. OR (multiple values in the
same filter)
Mentioning Include pages and blog posts that @mention these people. OR (multiple values in the
user same filter)

With parent Include only direct children of this page (further sub-pages EQUALS (one page only)
won't be included)

In space** Include items from these spaces. OR (multiple values in the
same filter)

Including Include items that contain this text. CONTAINS (single word or

text** phrase)

With title Include items that contain this text in the title. CONTAINS (single word or
phrase)

Of type** Include only pages, blogs or attachments. OR (multiple values in the
same filter)

* This field is required in CQL-powered macros.

** You can add these filters in CQL-powered macros but in search they're part of the standard search filters, so
they don't appear in the Add a filter menu.

Macro display options
These options control how the macro appears on your page.

Parameter Default  Description
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Sort by Modified Sort the list by title, the date it was created, or the date it was last modified. If you
don't select an option, CQL default ordering by relevancy is used.

Reverse sort  False Sort the list descending instead of ascending (Z - A, earliest - latest)

Maximum 15 Limit the number of items to include in the list. This can be any value up to 500

number of pages.

pages

List title Blank Include an optional heading for the macro

Show labels  True Show or hide the labels applied to each item

for each

page

Show space  True Show or hide the space name for each item

name for

each page

Display False Allows you to include a short excerpt under each page in the list. Choose

excerpts between:

®* None - no excerpt will be displayed.

® Simple - displays the first line of text contained in an Excerpt macro any of the
returned pages. If there is not an Excerpt macro on the page, nothing will be
shown.

® Rich content - displays the contents of an Excerpt macro, or if there is not an
Excerpt macro on the page, the first part of the page content, as formatted
text, including images and some macros.

Content by User Macro

The Content by User macro generates a tabulated list of the content items, throughout the Confluence
installation, that have been created by a specified Confluence user. The list includes all current pages,
comments and spaces created by the user. Each item in the table is linked to its corresponding page, page
comment or space dashboard.

Note that items for page comments contain a link to the page, followed by a second link to the comment itself,
with these separated by a greater-than sign (>).

Using the Content by User macro

To add the Content by User macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters
Parameters are options that you can set to control the content or format of the macro output. Where the

parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).
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Parameter Required Default Description

Username yes none

(nane) Parameter is unnamed in wikimarkup.

Wiki markup example

The Confluence username for a person who has created content.

This example is useful when you want to add a macro outside the editor, for example as custom content in the

sidebar, header or footer of a space.
Macro name: cont ent - by- user

Macro body: None.

..............................................................................................................................................................................

Content Report Table Macro

The Content Report Table macro displays a set of pages and blog posts in tabular format, based on the labels

specified in the macro parameters.

A working example

Below is a working example of the Content Report Table macro, displaying content with the label 'LDAP".

Title

Connecting to LDAP or JIRA applications or Other Services

via SSL

Configuring the LDAP Connection Pool

Managing Nested Groups

User Management Limitations and Recommendations

Managing Multiple Directories

Configuring an SSL Connection to Active Directory

Synchronizing Data from External Directories

Connecting to an Internal Directory with LDAP Authentication

Requesting Support for External User Management

Diagrams of Possible Configurations for User Management

Configuring User Directories

Creator

Nick Faiz

Sarah Maddox
[Atlassian]

Sarah Maddox
[Atlassian]

Sarah Maddox
[Atlassian]

Sarah Maddox
[Atlassian]

Sarah Maddox
[Atlassian]

Sarah Maddox
[Atlassian]

Sarah Maddox
[Atlassian]

Matt Ryall

Sarah Maddox
[Atlassian]

Sarah Maddox
[Atlassian]

Modified

about an hour
ago

about an hour

ago

Feb 21, 2017

Feb 01, 2017

Nov 09, 2016

Nov 08, 2016

May 27, 2016

May 27, 2016

Oct 07, 2015

Oct 07, 2015

Oct 07, 2015
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Connecting to an LDAP Directory Sarah Maddox Aug 18, 2015
[Atlassian]

Using the Content Report Table Macro

To add the Content Report Table macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Required Default Description
Label(s) Yes None This parameter is required. Specify one or more labels, separated by a
(1 abel s) comma. The macro will display the content tagged with any of the

label(s) specified here.

For example, if you specify labels 'A" and 'B', the macro will display all
pages that have the label 'A’, and all pages that have the label 'B', and
all pages that have both those labels.

Space(s) No (All Specify one or more space keys, separated by a comma or a space.
(spaces) spaces) The macro will display only the content which belongs to the space(s)
specified here.

When specifying a personal space, remember to use the tilde (~) sign
in front of the username, such as ~j bl oggs or ~j bl oggs @xanpl e

.com
Maximum No 20 Define the maximum number of pages that the macro will show in a
Number of single set of results. If there are more pages to be shown, the macro
Pages will display a link labeled 'Find more results'. People viewing the page
(maxResul ts can choose the link to go to a search view, which shows all pages
) tagged with the specified label(s).

Which pages will appear? Before displaying the results, Confluence
will sort them by the date the page was last modified. The
most-recently created/updated pages will appear first.

Wiki markup

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.

Contributors Macro

The Contributors macro displays a list of Confluence users who have made a contribution of some type to a
page. It can also be used to list watchers of the page.

The scope of this macro can be extended to include the immediate children or descendants of the specified
page. The list of contributors can be based on people who have:
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® authored or edited the page(s)
® contributed comments or added labels to the page(s), or
® are simply watching the page(s).

Screenshot: Example list of Contributors

This is the Contributors macro

= Rach Admin
s Josh User
= Sophie Staunton

In this example, the Display Format parameter has been set to list.

Using the Contributors Macro

To add the Contributors macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Contribution Type authors Filters by either the type of contribution made to a page (and optionally

(i nclude) its descendant pages), or the watches on the page. Contribution types
are:

® aut hor s - includes people who created or have edited the page(s)

® conmment s - includes people who have added comments to the
page(s)

® | abel s -includes people who have added labels to the page(s)

® wat ches - includes people who are watching the page(s).

You can specify one or more contribution types, separated by
commas.

Sort By count Specifies the criteria used to sort contributors. Sort criteria are:

or der _—
( ) ® count - sorts people based on the total number of contributions to

the page(s)

® name - sorts people into alphabetical order

® update - sorts people based on the date of their last contribution to
the page(s).

Reverse Sort false Reverses the sort order of contributors in the list. Must be used in
(reverse) conjunction with the Sort By parameter.
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Maximum Number of

Contributors
(limt)

Display Format
(rmode)

Show Anonymous
Contributions?
(showAnonynous)

Show Count?
(showCount)

Show Last
Contribution Time?
(showLast Ti nre)

Page Name
(page)

Label(s)
(1 abel s)

Space(s)
(spaces)

Content Type
(cont ent Type)

Blog Post Date
(publ i shDat €e)

Include Page
Hierarchy
(scope)

Show Selected
Pages
(showPages)

no limit

inline

false

false

false

current

none

current

both
pages
and blog
posts

none

specified
page only

false
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Limits the number of contributors in the list. If a number is not specified,
all contributors are included.

Sets how the list of contributor's names is formatted:

® inline — a comma-separated list
® list — a bullet list.

Sets whether to include those who contributed anonymously to a page.

Sets whether to show the number of times each person made a
contribution of the specified Contribution Type.

Sets whether to show the last time each person made a contribution of
the specified Contribution Type.

Specifies the page to use when generating the list of contributors. If Pag
e Name and Space(s) are left blank, the current page is assumed.

Filters the list of contributors to those who created the specified labels
from a page. You can specify one or more labels, separated by
commas.

Specifies the space key of the Confluence space that contains the page
set in Page Name or alternatively, specifies the spaces to search.
Space keys are case-sensitive.

This parameter also takes special values, including:

* @l obal — All site spaces.
® @ersonal — All personal spaces.
® @l | — All spaces in your Confluence site.

You can specify one or more space keys or special values,
separated by commas.

If no Page Name and Label(s) are specified, all pages from the
specified set of spaces are included.

Restricts the content type to use when generating the list of
contributors:

® pages — pages
®* blogposts — blog posts.

Specifies the publish date for a blog post. The date format required is:
YYYY/MM/DD.

Specifies additional pages to include when generating the list of
contributors:

® children — just the child pages of the specified page
®* descendants — all descendants of the specified page.

Sets whether to show a list of the pages used to generate the list of
contributors.
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Custom "None default Specifies the message to be used to override the default message that
Found" Message message s displayed when no contributors are found.

(noneFoundMessage

)

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: contri butors
Macro body: None.

This example specifies a content type of blog posts:

{contributors:|imt=10| spaces=ds, @ersonal | reverse=true| | abel s=chocol ate
, cake| showPages=t r ue| noneFoundMessage=Ch dear, no contributors

f ound| showCount =t r ue| cont ent Type=bl ogpost s| i ncl ude=aut hors, corment s, | abe
| s, wat ches| node=l i st | showAnonynous=t r ue| or der =updat e| showLast Ti ne=t rue| p
ubl i shDat e=2012/ 06/ 30}

This example specifies a content type of pages:

{contributors:|imt=10| spaces=ds, @er sonal | reverse=true| scope=descendant
s| | abel s=chocol at e, cake| showPages=t r ue| noneFoundMessage=Ch dear, no
contributors

f ound| showCount =t r ue| cont ent Type=pages| i ncl ude=aut hor s, comrent s, | abel s, w
at ches| node=l i st | showAnonynmous=t r ue| or der =updat e| page=ds: Advanced

Topi cs| showlLast Ti ne=true}

Contributors Summary Macro

The Contributors Summary macro displays a table of contribution-based statistics for a set of pages. These
statistics can be grouped according to individual pages or individual contributors.

The default scope for this macro is an individual page, but this can be extended to include the immediate
children or descendants of a specified page. The statistics cover the following types of contributions:

edits to the page(s)

comments added to the page(s)
labels added to the page(s)
people watching the page(s)

A simple example of the Contributors Summary macro is shown in the screenshot below. It lists statistics for the
number of times each contributor has edited, added comments and added labels to this page.

Screenshot: Example Contributors Summary table of statistics
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User Edits Comments Labels
Sarah Maddox 2 2 0
Edwin Dawson 2 0 0
Giles Gaskell 2 0 0
Rosie Jameson | 2 0 0
Andrew Lui 2 0 1
Charles Miller 1 0 0
Andrew Prentice 0 0 1

In this example, all default parameter settings are used. For more information about this macro's parameters,
refer to the Parameters section below.

Using the Contributors Summary Macro

To add the Contributors Summary macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
Group By contributors Specifies the basis for grouping contribution-based statistics:
(groupby)

® contributors — group by the people who have contributed
® pages — group by the pages used to find contributors.
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Columns to edits,comments,labels Sets the columns that should appear in the table. The
Display statistics or type of information presented depends on the
(col ums) basis for grouping set with the Group By parameter. Statistics

may be calculated for:

® edi t s — the number of times each contributor has edited
the page(s) or the number of edits made to each page.

* edit ed — alist of the pages edited by each contributor or
a list of contributors who have edited each page.

* comment s — the number of times each contributor has
added comments to the page(s) or the number of
comments on each page.

®* commrent ed — a list of pages to which each contributor
has added comments or a list of contributors who have
commented on each page.

® | abel s — the number of times each contributor has
added labels to the page(s) or the number of labels on
each page.

* | abel ed — a list of pages to which each contributor has
added labels or a list of contributors who have added a
label to each page.

® | abel | i st — alist of labels either added by each
contributor or on each page.

®* wat ches — the number of pages being watched by each
contributor/person or the number of contributors/people
watching each page.

®* wat chi ng — a list of pages being watched by each
contributor/person or a list of contributors/people watching
each page.

® | ast updat e — the last time each contributor made an
update or when each page was last updated. Valid
updates can include edit, comment or label modifications
to a page.

One or more columns can be used.

Sort By edits Sets the criterion used for sorting items in the table. The items
(order) sorted depend on the basis for grouping set with the Group
By parameter. Sort criteria are:

® edi ts — sorts items in the table based on the total
number of edits made, either by a contributor or to a page.

®* nane — sorts items in the table in alphabetical order,
either by contributor or page name.

® edit Ti me — sorts items in the table based on when the
contributor last edited a page (or a specified set of pages)
or when the page was lasted edited.

® updat e — sorts items in the table based on when the
contributor last made any contribution to a page (or a
specified set of pages) or when the page last had any
contribution made to it.

Reverse Sort false Reverses the sort order of items in the table, as specified
(reverse) using the Sort By parameter. (Used only in conjunction with
the Sort By parameter.)

Maximum Number  no limit Limits the number of contributors or pages in the table to the
of ltems value specified. If no number is specified, all items are
(limt) included.
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Show Anonymous false
Contributions?
(showAnonynous)

Show Zero false
Counts?

(showZer oCount s

)

Page Name current
(page)

Label(s) none
(I abel s)

Space(s) current
(spaces)

Content Type both pages and blog
(cont ent Type) posts
Blog Post Date none

(publ i shDat e)
Include Page specified page only

Hierarchy
(scope)

Wiki markup example

245

Includes individuals who have made anonymous contributions
to a page.

Sets whether contributors or pages are included for which a
calculated statistic is zero.

Sets the page for which to calculate the contribution-based
statistics. If no values for Page Name and Space(s) are
specified, the current page is assumed.

Restricts the contribution-based statistics to the specified
labels only. You can specify one or more labels, separated by
commas.

Specifies the space key of the Confluence space which
contains the specified page name or alternatively, specifies a
scope of spaces to search. Space keys are case-sensitive.

This parameter also takes special values, including:

* @l obal — All site spaces.
® @ersonal — All personal spaces.
®* @l | — All spaces in your Confluence site.

You can specify one or more space keys or special values,
separated by commas.

If no Page Name and Label(s) are specified, all pages from
the specified set of spaces are included.

Restricts page types to either pages (pages) or blog posts (bl
ogposts). If no value is specified in the Macro Browser, both
pages and blog posts are included.

Available values pages and bl ogpost s.

Specifies the publish date for a blog post. The date format
required is: YYYY/MM/DD.

Includes either the immediate children or all descendants of
the specified page. If no value is indicated in the Macro
Browser, only the specified page is included.

This example is useful when you want to add a macro outside the editor, for example as custom content in the

sidebar, header or footer of a space.
Macro name: cont ri but or s- summary

Macro body: None.

This example specifies a content type of blog posts:
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..............................................................................................................................................................................

{contributors-sumary:|imt=10| spaces=ds, @er sonal | rever se=true| showAnon
ynous=t r ue| or der =updat e| | abel s=chocol at e, cake| col ums=edi ts, coments, | ab
el s, | ast updat e| gr oupby=pages| cont ent Type=bl ogpost s| showZer oCount s=t rue| p
ubl i shDat e=2012/ 06/ 07}

..............................................................................................................................................................................

{contributors-sunmary:|imnmt=10| spaces=ds, @ersonal | rever se=true| showAnon
ynous=t r ue| scope=descendant s| or der =updat e| page=ds: Advanced

Topi cs| | abel s=chocol at e, cake| col utms=edi t s, comment s, | abel s, | ast updat e| gr
oupby=pages| cont ent Type=pages| showZer oCount s=t r ue}

Create from Template Macro

The Create from Template macro displays a button on a page, linked to a specific template. When someone
clicks the button, the macro opens the editor, ready to add a new page, and adds content to the page based on

the given template.

When adding the macro to the page, you can specify a blueprint or a user-created template in the macro. You
will also specify the name of the button displayed, and the space in which the new page will appear.

Example

Screenshot: A page with three buttons, all displayed by the 'Create from Template' macro

Pages / Doc Theme Test Space Home 2 Edit * Share £ Tools
How to write documentation

Added by Sarah Maddox, last edited by Sarah Maddox on Mar 14, 2013 (view change)

Done all your analysis and chatted to the SMEs? Now's the time to create your page. Choose a template:

Shared files Meeting notes Product requirements

Using the Create from Template Macro

To add the Create from Template macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.
Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro

browser, it will be listed below in brackets (exanpl e).
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Parameter Required Default Description

Button 'Create from The description that people will see when viewing this macro on the

Text Template' page.

Template None Select the template or blueprint to base the new page on. Only

Name global and user-created templates for the current space appear
(unless you have specified a different space in the 'Space Key'
field).

Template Blank Specify a default title for pages created using this macro (optional).

Title You can include @currentDate, @spaceName and @spaceKey

variables in the title.

Space The space Supply the unique space identifier (space key), to determine where
Key where the the new page will be created when someone uses this macro to
current page  create a page.
is located
Wiki markup

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.

Create Space Button Macro

The Create Space Button macro displays a create space icon that links to the 'Create Space' page. To see this
icon, viewers need the 'Create Space' permission which is assigned by a site administrator.

Using the Create Space Button macro

To add the Create Space Button macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Icon Size  large Specify whether to use large or small icon. Available values:
si ze

® large

* small

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: cr eat e- space- button

Macro body: None.
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{create-space-button:size=snall}
{creat e-space- button: hei ght =50px| wi dt h=50px}

The following additional paramteters are available in wiki markup.

~ See all parameters...

Parameter Required Default
name

wi dt h No Natural
size of
icon
(12
pixel
ratio)

hei ght No Natural
size of
icon

(12
pixel
ratio)

Excerpt Include Macro

Parameter description and accepted values

The width of the icon to be displayed, specified in pixels. Confluence
will stretch or shrink the width of the icon to the number of pixels
specified.

Note: This parameter is not available via the macro browser.

The height of the icon to be displayed, specified in pixels. Confluence
will stretch or shrink the height of the icon to the number of pixels
specified.

Note: This parameter is not available via the macro browser.

The Excerpt Include macro is used to display 'excerpted’ (that is, a segment of) content from one page in

another.

Before you can use this macro, the excerpt must have been defined using the Excerpt macro. Note that you can

have more than one Excerpt Include macro on a page (although you can have only one Excerpt macro on a

page).

Example

The paragraph below shows an example of an Excerpt Include macro, containing content from an excerpt which

we have defined on the Excerpt Macro page. On the Excerpt Include macro below, we have set the options to
show both the title of the page and the panel surrounding the content.

Using the Excerpt Include Macro

To add the Excerpt Include macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
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browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Page Containing the none Type the name of the page that contains the excerpt to be displayed.
Excerpt You can use an excerpt from a page in the same space or another space
(def aul t - paranet er in the same wiki.

)

When you type the name of the page into the Excerpt Include macro
dialog, Confluence will offer a list of matching pages, including those
from other spaces.

Alternatively, you can type the space key followed by a colon (:) and the
page name, like this;

SPACEKEY: Page nane

This parameter is unnamed in wikimarkup.

Remove Surrounding  false Determines whether Confluence will display a panel around the

Panel excerpted content. The panel includes the title of the page containing the

(nopanel) excerpt, and the border of the panel. By default, the panel and title are
shown.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: excer pt -i ncl ude

Macro body: None.

{excerpt-include: My page nane| nopanel =true}

Excerpt Macro

The Excerpt macro is used to mark a part of a page's content for re-use. Defining an excerpt enables other
macros, such as the Excerpt Include and Blog Posts macros, to display the marked content elsewhere.

You can only define one excerpt per page. In other words, you can only add the Excerpt macro once to a page.

Using the Excerpt Macro

To add the Excerpt macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

To add reusable content to the macro:

1. Add your content inside the Excerpt macro placeholder.

2. Choose the macro placeholder to see the options panel, and select the option to Display on new line or
to Display inline. The default is to display the content of the macro on a new line. If you choose the inline
option, the content of the macro will form part of the same paragraph as the text preceding and following
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it. Note that this option affects only the page that contains the Excerpt macro. It does not affect any pages
where the content is reused.

Screenshot: The Excerpt macro placeholder and options panel

Text before the Excerpt macro

Excerpt

This is my reusable text

Edit Remove

o

1. New line
2. Inline

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro

browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Hide false Controls whether the page content contained in the Excerpt macro placeholder is
Excerpted displayed on the page.

Content . . .

(hi dden) Note that this option affects only the page that contains the Excerpt macro. It

does not affect any pages where the content is reused.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: excer pt

Macro body: Accepts rich text.

..............................................................................................................................................................................
1

{excerpt: hi dden=t rue| at| assi an- nacr o- out put - t ype=BLOCK}
This is the *text* | want to reuse in other pages. This text is inside

an Excerpt macro.
{excerpt}

Expand Macro
The Expand macro displays an expandable/collapsible section of text on your page.

Here is an example:
~ Expand me...
This text is hidden until you expand the section.
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Using the Expand Macro

To insert the Expand macro into a page using the macro browser:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Title Click here to expand... Defines the text that appears next to the expand/collapse icon.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: expand

Macro body: Accepts rich text.

{expand: This is ny nessage}
This text is _hidden_ until you expand it.
{ expand}

Notes

® Textis expanded in PDF and HTML exports. When you export the page to PDF or HTML, the text
between the macro tags is expanded so that readers can see it in the PDF and HTML versions of the

page.
® Nesting your Expand macros. You can put one Expand macro inside another, and Confluence will
correctly show and hide the contents of all Expand macros, including the nested ones.

Favorite Pages Macro

Use the Favorite Pages macro to list the pages you've saved for later on a Confluence page. You can also get
to your saved pages from the Dashboard.

Screenshot: The Favorite Pages Macro in Confluence
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This is the Favourite Pages macro

Favourite Pages

Displaying pages recently added to your favourites list.
Why | loved Angry Nerds (Angry Merds)

Which nerd are you? (Angry Merds)

* % %

[;] Cur new logo (Angry Merds)

Using the Favorite Pages Macro

To insert the favorite pages macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

There are no parameters for this macro.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: f avpages

Macro body: None.

..............................................................................................................................................................................

Gadget Macro

Gadgets are small applications that can offer dynamic content. They are typically served from a web application
server and can be re-used in many other web applications. In Confluence, use the Gadget macro to add gadgets
to pages or blog posts.

Confluence comes bundled with a few of its own gadgets that you can add to your pages or blog posts.
However, you can access additional gadgets in this list if your Confluence Administrator has:

* |nstalled additional gadgets in Confluence (typically as a Confluence plugin) or
® Registered gadgets served from an external web application or website (such as those from a JIRA
application).

Unlike other macros, the name of each gadget macro is unique and follows the convention "<gadget-name>
macro", where <gadget-name> is the name supplied by the gadget itself.

Inserting gadgets into a Confluence page or blog post

To add a gadget to a page:

1. Edit your page or blog post.

2. Choose Insert > Other Macros.

3. Click External Content to see a list of gadgets configured for use in your Confluence installation.
(Some Confluence macros like the JIRA Issues, RSS Feed, and Widget Connector macros also appear in
this category because they can also access external content.)
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4. Click the desired gadget to access its parameters and properties.

Almost all gadgets allow you to set basic parameters (listed below), which appear in the macro dialog.
Some gadgets also have their own set of parameters, that can only be set in the gadget itself. You can
use the preview in the macro browser to access them.

Set the parameters to your requirements.

Click Refresh to preview your changes.

7. Click Insert to add the gadget to the page.

o v

Editing gadgets on a Confluence page or blog post

To edit an existing gadget on a page or blog post:

1. Edit your page or blog post.

2. Click the Gadget macro placeholder and choose Edit (or double-click the placeholder).
3. Set the gadget's parameters to your requirements.

4. Click Refresh to preview your changes.

5. Save the gadget.

Standard gadget parameters

Almost all gadgets allow you to set basic parameters (listed below), which appear on the right of the macro
dialog. Each gadget may also have its own set of parameters, which appear on the left of the macro dialog.

Parameter Default Description

Width 450 pixels = Set the width of the gadget, using one of the following conventions:

® Width in pixels, using px or plain numbers. For example, 500px or 500
® A percentage of the page width, using % For example, 50%
® Automatic resizing of the gadget to fit 100% of the page width: aut o

Border true Places a thin grey border around the gadget.

Contents of a Gadget macro

In the addition to the standard parameters, the gadget macro contains ‘parameter-like’ content, which represents
specific property settings that are particular to each gadget. Hence they are not documented here. Typically, this
content would only be changed by customizing the gadget's default properties using the macro browser.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: gadget
Macro body: None.

This example shows the Confluence Page gadget:

{gadget : wi dt h=500| bor der =f al se| url =rest/ gadget s/ 1. 0/ g/ com at | assi an. conf
| uence. pl ugi ns. gadget s: conf | uence- page- gadget / gadget s/ conf | uence- page- ga
dget. xm }

spaceNanme=Docunent at i on&spaceKey=DOC&qui ckf i nd- space=Docunent at i on&pagel
d=753666&pageNane=Docunent at i on%20Hone&qui ckf i nd- page=Docunent at i on%20Ho
me& sEdit abl e=true& sConfi gur ed=true&r ef resh=15&showLi nk=f al se {gadget}
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This example shows the Confluence News gadget:
{gadget : url =rest/ gadgets/ 1.0/ g/ com atl assi an. conf| uence. pl ugi ns. gadget s:
conf |l uence- news- gadget / gadget s/ conf | uence- news- gadget . xm } {gadget}

The following additional parameters are available in wiki markup.
+ See additional parameters...

Parameter Required Default Parameter description and accepted values

name

ur | Yes (none) This is the location of the gadget specification (XML
file).

pref erences No (Gadget-dependent) Specific property settings that are particular to each
gadget.

A note about editing a gadget's properties (preferences) in markup: It is possible to edit the values of
these properties directly in the wiki markup or storage format. However, this will allow the entry of invalid
values. If a gadget property supports a certain set of values, the macro browser will restrict the user to
selecting only valid values for that property. For that reason, we recommend that you use the macro browser
to edit a gadget's properties.

Gallery Macro

The Gallery macro displays a collection of thumbnail images in a table, based on the images attached to a
Confluence page. When viewing the page, a user can click a thumbnail image to zoom into a screen-sized
image and then view the images as a slide show.

Overview:

®* The images shown in the gallery are taken from the files attached to the Confluence page. You can also
specify a different page where the attachments are located. For information about attaching images to a
page, see Upload Files.

® The captions below the images are drawn from the comments on the attachments. For information about
adding comments to attachments, see Upload Files.

® By default, the gallery will include all the images attached to the page. You can also exclude or include
images using parameters.

® You can sort your images into a particular order.

® You can specify a title for the gallery and also configure how many columns you want for the table in
which your images are displayed.

lllustration: Live example of the Gallery macro

Some office photos, and a waterfall
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Using the Gallery macro

To insert the Gallery macro onto a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.
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Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

The full list of parameters is shown in the following table. If the name of an attached file or page contains a
comma, you can refer to it in the relevant parameters below by enclosing it in single or double quotes, for

example "t hi s, that. j pg",

Parameter

Gallery Title
(title)

Number of
Columns
(col unms)

Images to
Exclude
(excl ude)

Include these
Images Only
(i ncl ude)

Exclude Images
with these
Labels

(excl udelLabel

)

Include Images
with these
Labels Only

(i ncl udeLabel

)

Use Images in
these Pages

(page)

Sort Images By
(sort)

Default

Nothing

No exclusions.
Include all the
pictures on the page.

Include all the
pictures on the page.

No exclusions.
Include all the
pictures on the page.

None. The images
are not filtered by
label.

If no page is
specified, the gallery
macro displays the
images attached to
the page on which
the macro is used.

None. The sort order
is unspecified and
therefore
unpredictable.

t heot her. png

Description

Specify a title for your gallery.

Specify the number of columns for your table.

The gallery will ignore any pictures specified. You can specify
more than one picture, separated by commas.

Note: The filename and filetype for this parameter are
case-sensitive. For example, 'my picture.PNG' will not be
recognized as 'my picture.png'.

If you specifically include one or more pictures, the gallery will
show only those pictures. You can specify more than one picture,
separated by commas.

Note: The filename and filetype for this parameter are
case-sensitive. For example, 'my picture.PNG' will not be
recognized as 'my picture.png'.

The gallery will ignore any pictures that have the specified label.
You can specify more than one label, separated by commas. For
information on labeling the attachments, see Add, Remove and
Search for Labels.

Filters the images to display, based on a list of labels. If you wish
to enter more than one label, separate the labels with commas.
Confluence will show only images that have all the labels
specified. (The match is an AND, not an OR.) For information on
labeling the attachments, see Add, Remove and Search for
Labels.

Specify the title of the page which contains the images you want
displayed. You can specify more than one page name, separated
by commas. To specify a page in a different space, use the
following syntax: SPACEKEY: Page Titl e

Specify an attribute to sort the images by. Sort order is
ascending, unless you select the Reverse Sort parameter (see
below). Options are:

name - file name.

comment — comment linked to the attached file.
date — date/time last modified.

size — size of the attached file.
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Reverse Sort Off. Sort order is Used in combination with the Sort Images By parameter above.
(reverse) ascending Use Reverse Sort to reverse the sort order, from ascending to
descending.

Available values in storage format and wikimarkup:

® true — Sortorder is descending.
® fal se — Sort order is ascending.

Image file formats

You can attach image files of any format to a page. Confluence supports the following image formats in the
Gallery macro and when displaying an image on a page:

gif

jpeg

png

bmp (depending on browser support)

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: gal | ery

Macro body: None.

..............................................................................................................................................................................
1

{gallery:title=My holiday pictures|reverse=true|sort=size| page=My pagel,
ds: Wl cone to Confl uence| excl udeLabel =badl abel 1,
badl abel 2| col ums=3| excl ude=badpi ct ur e. png}

Global Reports Macro

The Global Reports macro displays a list of links to some reports about content on your site.

These reports include a list of new or updated pages, orphan pages, undefined pages, and RSS feeds for new
pages and blog posts.

Screenshot: The Global Reports macro

This is the Global Reports macro

Global Reports

LI New or updated pages since your last login.

I Find all pages that aren't linked from anywhere.
|fj Find all undefined pages.

Feed for new pages and blogs.

Using the Global Reports Macro

To add the Global Reports macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro
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Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Width of 99% Specify the width of the table in which the links are displayed, as a percentage of
Table the window width.
(w dt h)

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: gl obal -reports

Macro body: None.

..............................................................................................................................................................................

HTML Include Macro

The HTML Include macro allows you to include the contents of an external HTML file (a webpage) in a
Confluence page.

HTML macros are disabled by default
The HTML macro will only be available if it has been enabled by an administrator. Enabling these
macros can make your Confluence site vulnerable to cross-site scripting attacks.

Using the HTML Include Macro

To insert the HTML Include macro into a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Required Default Description
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HTML Page's URL Yes None The URL of the page to include.
(url)

Enabling the HTML Include Macro

The HTML Include macro is disabled by default. You'll need Confluence Administrator or System Administrator
permissions to enable this macro.

I Enabling these macros can make your Confluence site vulnerable to cross-site scripting attacks. You should
only turn on these macros if you trust all your users not to attempt to exploit them. We strongly recommend
leaving this macro disabled if you allow self-signed up or anonymous users to create content.

To enable the HTML Include macro:

1. Goto

> Add-ons
2. Select System from the drop down and search for the Confluence HTML Macros add-on.
3. Expand the add-on and enable the html-include (html-include-xhtml) module.

Administrators can also choose to use the whitelist to restrict URLs that can be displayed in the HTML Include
macro.

Troubleshooting

® Administrators can define a whitelist of trusted URLs. If a URL is not in the whitelist, you will see an error
message in the HTML Include macro.

® You can only use the HTML Include macro for pages with absolute links. If you use the macro to include
an HTML page that has relative links, you will see a 'Page Not Found' error. See

CONFSERVER-6567 - HTML Include macro should rewrite relative links to point to remote site

RESOLVED

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: ht ml -i ncl ude

Macro body: None.

..............................................................................................................................................................................

HTML Macro

The HTML macro allows you to add HTML code to a Confluence page.

HTML macros are disabled by default
The HTML macro will only be available if it has been enabled by an administrator. Enabling these
macros can make your Confluence site vulnerable to cross-site scripting attacks.

Using the HTML Macro

To add the HTML macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
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suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

There are no parameters for this macro.

Enter the HTML code into the body of the macro placeholder.

Enabling the HTML Macro

The HTML macro is disabled by default. You'll need Confluence Administrator or System Administrator
permissions to enable this macro.

I Enabling these macros can make your Confluence site vulnerable to cross-site scripting attacks. You should
only turn on these macros if you trust all your users not to attempt to exploit them. We strongly recommend
leaving this macro disabled if you allow self-signed up or anonymous users to create content.

To enable the HTML macro:

1. Goto

> Add-ons.
2. Select System from the drop down and search for the Confluence HTML Macros add-on.
3. Expand the add-on and enable the html (html-xhtml) module.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name:; ht i

Macro body: Text, consisting of HTML code.

..............................................................................................................................................................................

{htm }<a href="http://wwmv. atl assi an. com >Cl i ck here</a> to see the
<b>At | assi an</ b> website.{htmnl}

..............................................................................................................................................................................

IM Presence Macro

The IM Presence macro indicates graphically when a contact is signed into an Instant Messaging (IM) service.
The IM Presence macro appears as a small icon on the page.

Using the IM Presence Macro

To add the IM Presence macro to a page:
1. Inthe Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
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browser, it will be listed below in brackets (exanpl e).

Parameter Description

User ID/Screen Identify the user by their ID, account name or screen name.
Name

Service aim — AOL Instant Messenger

(service)

gtalk — Google Talk

icq-1CQ

jabber — Jabber

msn — MSN Instant Messenger
sametime — IBM Lotus Sametime

skype — Skype. Note: Skype requires 'Show my status on the web' to be checked under
'Privacy’ preferences

skypeme — Skype
wildfire — Openfire Server

yahoo — Yahoo! Messenger

Show User ID Shows or hides the User ID of the contact.
(showi d)
Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: i m

Macro body: None.

..............................................................................................................................................................................

Include Page Macro

You can use the Include Page macro to display the contents of one Confluence page or blog post in another
page or blog post.

Using the Include Page Macro

To add the Include Page macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
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browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Page to None This is the name of the Confluence page or blog post that you want to include in the
Include current page. Start typing a page title, and Confluence will suggest matching pages
from the current space and other spaces.

Alternatively you can specify the page as follows:
* |f the page or blog post is located in another space, add the space key and a colon

in front of the page name. For example, DOC. My page nane. The space key is

case sensitive.
®* To include a blog post, specify the date as well as the title of the blog post. For

example: / 2010/ 12/ 01/ My bl og post.

® You can include pages from personal spaces using ~user nane as the space key,
where 'username'’ is the person's username. For example, ~j sni t h: My page
nane.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: i ncl ude

Macro body: None.

{i nclude: DOC. My chocol ate page}

Notes

® If you want to include part of a page rather than the whole page, use the Excerpt and Excerpt Include mac

ros.
® To display a page's contents, you need 'View' permission for that page. Similarly, people who view the
page will need 'View' permissions for the embedded page as well as the page into which it is embedded.
See space permissions or contact your Confluence space administrator for more information.
® If you want to embed an external page into a Confluence page, you need the HTML Include Macro.

Sample Include Page

Start of sample page content

Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Aliquam fermentum vestibulum est. Cras rhoncus.
Pellentesque habitant morbi tristique senectus et netus et malesuada fames ac turpis egestas. Sed quis tortor.
Donec non ipsum. Mauris condimentum, odio nec porta tristique, ante neque malesuada massa, in dignissim
eros velit at tellus. Donec et risus in ligula eleifend consectetuer. Donec volutpat eleifend augue. Integer gravida
sodales leo. Nunc vehicula neque ac erat. Vivamus non nisl. Fusce ac magna. Suspendisse euismod libero eget

mauris.
End of sample page content

Info, Tip, Note, and Warning Macros

The Info, Tip, Note, and Warning macros allow you to highlight information on a Confluence page. They
create a colored box surrounding your text, like this:
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@ Info macro example A\ Note macro example

This text is rendered inside the info macro. This text is rendered inside the note macro.
® Tip macro example ® Warning macro example

This text is rendered inside the tip macro. This text is rendered inside the warning macro.

To add an Info, Tip, Note, or Warning Macro to a page:
1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Optional Title none The title of the box. If specified, the title text will be
(title) displayed in bold next to the icon.

Show information/tip/Exclamation true If "false", the icon will not be displayed.
Mark/Warning lcon

(icon)

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in
the sidebar, header or footer of a space.

Macro name: i nf o/ ti p/ not e/ war ni ng

Macro body: Accepts rich text.

.........................................................................................................................................................................

{info:title=This is ny title|icon=fal se}
This is _inportant_ information.
{i nf o}

JIRA Chart Macro

If your Confluence site is connected to a JIRA On this page:
application, you can display issues as charts on _
Confluence pages. You can connect Confluence to ® Adding the JIRA Chart macro to a
any JIRA application, including JIRA Software and PR

JIRA Service Desk. Pie chart
Created vs Resolved chart

Two Dimensional Chart
Disabling the JIRA Chart macro
Notes

Before you can use this macro, your Confluence and
JIRA applications must be connected via Application
Links. People viewing the page will see charts for
publicly accessible issues. If your JIRA application
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has restricted viewing (that is, people need
permission to view issues) then they'll need to
authenticate before seeing the charts. This macro is
compatible with JIRA 5.x and later.

Adding the JIRA Chart macro to a page

To add a JIRA chart to your page:

1. In the editor choose Insert > Other macros > JIRA Chart.

2. Choose the type of report you want to create (for example Pie, Created vs Resolved)

3. Select your JIRA server.

If you have multiple JIRA servers linked to Confluence the drop down will default to the primary
application link.

Search for issues - you can enter the query in JQL or paste a JIRA URL directly into the search field.
Choose Preview to generate the chart.

Choose Display Options to further control how your chart appears.

Choose Insert.

No ok

To find out more about searching for issues see Displaying issues using JIRA Query Language (JQL).

Screenshot: The JIRA Chart Macro in the macro browser

Insert JIRA Chart

Pie Chart

Project = '"CONF' AND fix\ersion = '5.4" JAC |Z| Preview
More to come Search using any issue key, search URL, JIRA link, JQL or plain text
Resolved
19 —
Awaiting
. Merge
/=1
\ ,fl Quality
~ sReview
- =1
¥ Display options
Chartby | Status [~]
Width | 90%
Enter a width in pixels, percent or leave blank to automatically resize
[C] show border
[C] Show chart information
Select Macro Insert Cancel
Pie chart

Pie charts can be used to report on issue status, priority, assignee and more.
To further control how this chart appears on your page. Choose Display options:

® Chart by - select the field you want to segment the pie chart by such as:
® Status

Fix version

Assignee name

Priority

Component
® |ssue type

® Width - define the total width of the chart area. You can enter values in pixels, percent or leave blank

to auto fit.
¢ Show border - add a border around the chart area.
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® Show chart information - include a text summary under the chart with the total issues count and
chart by value.

Resolved
=830 o

Open =
32

T New = 23

Created vs Resolved chart

Created vs Resolved charts can be used to show the difference between the number of issues created
versus the number of issues resolved over time.

To further control how this chart appears on your page choose Display options:

Period - choose a time frame to report by (week, month, quarter etc).

Days previously - the total number of days to report on (counting back from today).

Cumulative totals - choose to progressively add totals or report individual values for each period.
Show unresolved trend - add a subplot showing unresolved issues over time.

Show versions - indicate version release dates as a vertical line on the chart.

Width - define the total width of the chart area. Enter values in pixels, percent or leave blank to auto
fit.

® Show border - add a border around the chart area

® Show chart information - include a text summary under the chart with the total issues count and
chart by value.

55 5.5-00-24 f Thunder 24

21-Apr 28-Apr S-May 12-May

Two Dimensional Chart

Two Dimensional Charts can be used to show issue statistics in a matrix. You can configure the X and Y
axes to display these issue fields:

Status
Priority
Assignee

[ ]
[ ]
[ ]
® Fix version
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® Component
® |ssue type.

For example you could use the chart to show issue types by status (as shown above).
To configure the chart axes choose Display options:

® X Axis - the issue field to display on the X axis (columns).
® Y Axis - the issue field to display on the Y axis (rows).
® Rows to display - the maximum number to display in the chart.

Status
Issue Type OPEN RESOLVED CLOSED | TECHNICAL REVIEW NEW | T:
(¢) Bug 13 121 41 1 0 176
Improvement 3 105 30 0 3 141
New Feature 1 11 2 0 1 15
Sub-task 0 169 430 0 0 599
Total Unique Issues: 28 836 652 1 22 1539

Showing 4 of 6 statistics. Show mare
View in JIRA

Disabling the JIRA Chart macro

The functionality is provided by an add-on (plugin) called 'JIRA Macros'. This macro is also used for the JIRA
Issues macro. To make the macro unavailable on your site, you can disable the add-on. See Disabling and
enabling add-ons.

Notes

HTTPS: The JIRA Chart macro can access a JIRA site running under SSL provided the Confluence server is
configured to accept the JIRA SSL certificate. See Connecting to LDAP or JIRA applications or Other
Services via SSL.

Authentication: If the query includes issues that require authentication (issues that are not visible to
anonymous users in JIRA), users will be prompted to authenticate to view charts on the Confluence page.

In order to search for issues in the macro browser you may need to authenticate. With JIRA 5.x you will be
able to search for unrestricted issues as an anonymous user, however with JIRA 6.x you must be
authenticated to search for any issues.

JIRA Issues Macro

If your Confluence site is connected to a JIRA application, you can create and display JIRA issues on
Confluence pages. You can connect Confluence to any JIRA application, including JIRA Software and JIRA
Service Desk.

Before you can use this macro, your Confluence and JIRA application must be connected via Application Links.
People viewing the page will see the publicly accessible issues from the JIRA site. If your JIRA site has
restricted viewing (that is, people need permission to view issues) then they will need to authenticate before
seeing the restricted issues. See more about restricted JIRA issues below.

What you can do with the JIRA Issues macro

Using the JIRA Issues macro, you can:

* Display a list of issues on your page, based on a JIRA Query Language (JQL) search, filter or URL.
® Display a single issue.
® Display a count of issues.
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® Create new issues and display the issues on your page without leaving Confluence.

Adding and updating the JIRA Issues macro — an overview

Quick guide to using the macro on a Confluence page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Screenshot: Example of JIRA issues macro on a Confluence page

Key

CONF-30894

CONF-30866
CONF-30663
CONF-30690

Summary T

User is not prompted before overwriting changes of another  (s]
5

TableOfContents Macros navigation is not working in (s)

Firefox 23.x / 24 x and Opera 12.16

Left panel overlaps custom banner in Chrome (s)

Dashboard popular stream won't render when it contains ()
content from an anonymous user

4issues % Refresh

Updated ~

Oct 22, 2013

Sep 24, 2013

Sep 23, 2013

Sep 19, 2013

P

Status

RESOLVED

RESOLVED

RESOLVED

RESOLVED

Resolution

Fixed

Fixed

Fixed

Fixed

Displaying issues via a JIRA Query Language (JQL) search

You can use the macro to display a table of issues on your page, based on the results of a search using JIRA
Query Language (JQL).

JQL is a simple query language that is similar to SQL. A basic JQL query consists of a field, followed by an oper

ator (such as = or >), followed by one or more values or functions.

Examples:

® The following query will find all issues in the 'TEST' project:

proj ect = "TEST"

® The following query will find all issues in the 'documentation' component of the 'CONF' project:

proj ect = CONF and conponent = docunentation

For more information about JQL syntax, see Advanced searchingin the JIRA Software documentation.

To display a table of issues based on a JQL search:

1. Insert the JIRA Issues macro onto your Confluence page, as described above.
2. Choose a JIRA server next to the Search button.
3. If prompted, log in to the JIRA server.

4. Enter the JQL query into the Search box.
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5. Choose Search.

6. If you want to customize the display, choose Display options and adjust the columns and number of
issues that will appear in your table of issues.

7. Choose Insert.

Screenshot: Display options in the JIRA Issues macro browser.

v Display options
Display as
Display the macro as a single issue.

Total issue count

Display total number ofissues as alink. E.g. 22 issues
@ Table
Customise your columns below.

Maximum issues | 20

Leave empty to get all issues.
Columns to display Key ® || Summary % | Issue Type x | Created =
Updated x | Due Date x| Assignee x| Reporter x
Priority x | | Status x | | Resolution x

Displaying issues via a JIRA URL

You can paste any of the following JIRA application URLSs into the JIRA Issues macro. Confluence will
immediately convert the URL to a JQL search.

® Any URL for an issue search or filter.
®* A URL for a single issue.
®* The URL of the XML view of a search.

Auto-convert: You can paste URLs directly into the Confluence editor (without calling up the macro browser).
Confluence will automatically convert the URL into a JIRA Issues macro.

Displaying a single issue, or selected issues

To display a single JIRA issue, choose one of the following methods:

® Paste the URL of the issue directly onto the Confluence page. (There is no need to use the macro
browser.) Confluence will auto-convert the link to a JIRA Issues macro.

® Or: Add the JIRA issues macro to the page as described above, and choose Recently Viewed to see the
issues you have visited recently. Select an issue and choose Insert.

® Or: Add the JIRA issues macro to the page as described above, and paste the issue URL into the search
box in the macro browser.

® Or: Add the JIRA issues macro to the page, define your search criteria in the macro browser via JQL as
described above, then select the check box next to the issue in the search results, within the macro
browser.

You can choose to show just the issue key, or the issue key and a summary. Select the macro placeholder and
choose Show Summary or Hide Summatry.

To display a subset of JIRA issues from your search results:

1. Add the JIRA issues macro to the page.
2. Define your search criteria in the macro browser via JQL, as described above.
3. Select the check boxes next to the required issues in the search results, within the macro browser.

Screenshot: Selecting a subset of issues to display
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Insert JIRA Issue
Search project = CONF Q
Create New |ssye Search using any issue key, search URL, JIRA link, JOL or plain text
Recently Viewed I Key Summary i
[ [#) CONF-31418 Error getting content from PDF document
[7) CONF-31417 Page Properties Report Macro should offer filtters on specifi... |5
[] [#] CONF-31415 Special Characters Entered info Link Macro Causes Link to ...
(7 CONF-31414 Add Attachments Macro (and Tools-=Attachments) plugin po_
£ [(®) CONF-31413 Code Block Macro creates hyperlinks from URLs when sett
[ () CONF-31411 Activity Stream gadget doesn't respect the Look and Feel s...
[Z) CONF-31410 Editor: Control of the Insert pull-down menu
[ [# CONF-31409 Use NoCookie directive in Multimedia Widgets for external c. ..
[ [#) CONF-31408 Merge Two Pages and Preserve the Incoming Links for Both
~ Display options
Select Macro Hint: type "Ctri+-Shift+J" in the editor to quickly access this dialog Insert | Cancel

Displaying a count of issues

You can choose to display the number of issues returned by your search, rather than a table of issues. The JIRA
Issues macro will display a count of issues, linked to the search in your JIRA application.

Screenshot: The JIRA Issues macro displaying an issue count on a Confluence page

28227 issues

To display an issue count:

1. Add the JIRA Issues macro to the page.

2. Define your search criteria in the macro browser via JQL, as described above.

3. Choose Display options, then choose Total issue count next to 'Display options' in the macro browser.
4. Choose Insert.

Creating a new issue

While editing a Confluence page, you can create an issue in JIRA and display it on your Confluence page,
without leaving the Confluence editor.

To create an issue and add it to your page:

1. Add the JIRA Issues macro to the page, as described above.

2. Choose Create New Issue.

3. Supply the information about your JIRA server, project, and issue, as prompted.
4. Choose Insert.

Confluence will send a request to your JIRA application, to create the issue, then display the newly created issue
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on your page.
Limitations

The JIRA Issues macro will notify you if it is unable to create an issue in the selected project. This may be
because the project has a required field, field configuration or other customization that is not supported by the
JIRA Issues macro. In this situation you will need to create the issue directly in your JIRA application.

Configuring application links to display restricted issues

Before you can use this macro, your Confluence and JIRA sites must be connected via Application Links.

If the JIRA site allows anonymous users to view issues, you must configure an application link, but there's no
need to configure any incoming or outgoing authentication between the JIRA application and Confluence.
People viewing the Confluence page will see the publicly accessible issues.

If your JIRA site has restricted viewing, or if some projects or issues are restricted to viewing by certain people,
then people will be prompted to Log in & Approve before seeing the restricted issues.

Rendering HTML from JIRA applications

Formatted fields from JIRA can be displayed in Confluence if you set up a Confluence-to-JIRA application link.
Otherwise, such formatted fields will be escaped within the output of the JIRA issues macro. This is to prevent
the possibility of malicious HTML being served by an untrusted JIRA server. The most likely field where you will
notice this is in the description field.

This example shows how a description column may be displayed in JIRA:
Description
This is

® the description
® of my issue

If there is no application link between JIRA and Confluence, the description will appear in the JIRA issues macro
like this:

Description

<p>This is<ul><li>the description</li><li>of my issue</li></ul></p>

Disabling the JIRA Issues macro

The functionality is provided by an add-on (plugin) called 'JIRA Macros'. To make the macro unavailable on your
site, you can disable the add-on. See Disabling and enabling add-ons.

Notes

HTTPS: The JIRA Issues macro can access a JIRA application running under SSL provided the Confluence
server is configured to accept the JIRA SSL certificate. See Connecting to LDAP or JIRA applications or Other
Services via SSL.

Custom fields can be added as columns to the table simply by using the name of the field with no quotes. Earlier
versions of the macro required you to use the custom field id, e.g. cust onfi el d_10100.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: j i rai ssues
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Macro body: None.

This example uses a JIRA filter.

{jiraissues: anonynmous=true|url=https://jira.atlassian.conissues/?filter

=41225}

A number of additional parameters that are not available via the macro browser are available in storage format

and wiki markup.
~ See additional parameters...

Parameter Required Default
name

anonynous  No fal se

baseur| No The value of
the "url’
parameter

col ums No By default,
the following
columns are
shown:

type
key

reporter
priority
status

created
updated
due

count No fal se

summary
assignee

resolution

Parameter description and accepted values

If this parameter is set to 'true’, your JIRA application will return
only the issues which allow unrestricted viewing. That is, the
issues which are visible to anonymous viewers. If this
parameter is omitted or set to 'false’, then the results depend
on how your administrator has configured the communication
between the JIRA application and Confluence. By default,
Confluence will show only the issues which the user is
authorized to view.

Note: This parameter is available only if you insert the macro
via wiki markup or by editing the storage format of the page.
The macro browser does not offer this parameter.

If you specify a 'baseurl’, then the link in the header, pointing to
your JIRA application, will use this base URL instead of the
value of the 'url' parameter. This is useful when Confluence
connects to JIRA with a different URL from the one used by
other users.

A list of JIRA column names, separated by semi-colons (;).
You can include many columns recognized by your JIRA
application, including custom columns.

Some columns, such as those that need to be calculated by
JIRA like 'work ratio' or 'time to resolution’, can't be viewed in
Confluence.

If this parameter is set to 'true’, the issue list will show the
number of issues in JIRA. The count will be linked to your JIRA
site.
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cache No on The macro maintains a cache of the issues which result from
the JIRA query. If the 'cache' parameter is set to 'off', the
relevant part of the cache is cleared each time the macro is
reloaded. (The value ‘'false’ also works and has the same effect
as 'off'.)

Note: This parameter is available only if you insert the macro
via wiki markup or by editing the storage format of the page.
The macro browser does not offer this parameter.

hei ght No 480 (if The height in pixels of the table displaying the issues.
render mode Note that this height specification is ignored in the following
is dynamic) situations:

* |f the 'renderMode’ parameter (see below) is set to 'static'.
®* When the issues are displayed in a PDF or Word
document, in an email message or in an RSS feed.

Note: This parameter is available only if you insert the macro
via wiki markup or by editing the storage format of the page.
The macro browser does not offer this parameter.

render Mode No static If the value is 'dynamic’, the JIRA Issues macro offers an
interactive display which people can manipulate as follows:

Click the column headers to sort the output.

Drag and drop the columns into a different order.
Temporarily remove a column from the display.

View a page of issues at a time, for faster response times.

A value of 'static' will disable the dynamic display features.

Note: This parameter is available only if you insert the macro
via wiki markup or by editing the storage format of the page.
The macro browser does not offer this parameter.

title No JIRA Issues  You can customize the title text at the top of the issues table
with this parameter. For instance, setting the title to
'‘Bugs-to-fix' will replace the default 'JIRA Issues' text. This can
help provide more context to the list of issues displayed.

Note: This parameter is available only if you insert the macro
via wiki markup or by editing the storage format of the page.
The macro browser does not offer this parameter.

ur | Yes none The URL of the XML view of your selected issues.

Note: If the URL in the 'url' parameter does not contain a t enp
Max argument, then the value of t enpMax will default to 500. If
your JIRA server is version 3.12 or earlier, this means that the
JIRA Issues macro will return a maximum of 500 issues. If your
JIRA server is version 3.13 or later, a value of 500 means that
the JIRA Issues macro will return a maximum of 500 issues per

page.

wi dt h No 100% The width of the table displaying the issues. Can be entered as
a percentage (%) or in pixels (px).

Note: This parameter is available only if you insert the macro
via wiki markup or by editing the storage format of the page.
The macro browser does not offer this parameter.

JUnit Report Macro

The JUnit Report macro displays a summary of JUnit test results from a directory accessible by the Confluence
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server. JUnit is a unit testing framework which allows programmers to ensure that individual units of Java source
code are functioning correctly.

For security reasons JUnit test result files can only be imported from a specified location in the

Confluence server's file system. We recommend administrators create a folder in their Confluence home
directory, add the system property conf | uence. junit. report. directory and specify the location for
JUnit test result files to be imported from. JUnit Test result files cannot be imported from the server until this
system property is set.

The JUnit Report macro appears as shown in the screenshot below.

Screenshot: The JUnit Report macro in Confluence

Test Time Messages
MDI’IE]I'TESI 100% _ 00:03.391 TEStSIFE”LIrESIEXEEptIDHSI
1 0 0
[» testAdd 00:03.0

Note:When generating reports from the JUnit Report macro, set the Apache Ant formatter to 'XML".

Using the JUnit Report macro

To add the JUnit Report macro to a page:
1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,

where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Required Default Description
URL of the test  Must None URL of a particular test result XML file. Is overridden by the Directc
result XML file include your test result files parameter if you use both.
(url) either the d )
irectory Example, from a Confluence instance: ht t p: / / your Conf | uence
or the ur | onl downl oad/ att achment s/ <page id>/file.xmn
parameter For Confluence installations without anonymous user access, you ¢
logon credentials as part of this parameter in the form of URL parar
® o0s_user name — The username of a Confluence user with peri
access to the JUnit test results.
®* os_passwor d — The password of the Confluence user specifit
user nane parameter.
Directory (URL) Must None URL of a directory containing your test result files. This must be a d
of your test include and not the XML file itself. Overrides the URL of the test result XN
result files either the d eter if you use both.
director i rector .
( ) y Example, fil e:///C | TEMP/
or the ur |
parameter Example, for a network drive: htt p: // *host */ * pat h*
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Report Detail No all Detall for the report. Can be all, fixture, summary or failuresonly.
(reportdetail

)

Debug No None Shows the content of failures, as well as the error messages.
(debug)

Wiki markup examples

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: j uni treport
Macro body: None.

Loading JUnit reports from a local drive:

..............................................................................................................................................................................

..............................................................................................................................................................................

..............................................................................................................................................................................

{junitreport:url=http://yourConfl uencel nstance. conl downl oad/ att achment s/
<page id>/file.xm}

Loading JUnit reports from a Confluence site that requires authentication:

If your Confluence site is not accessible by anonymous users, specify login credentials with the os_user nane a
nd os_passwor d URL parameters (as part of the macro's ur| parameter). In this case, we are specifying a
username of '‘admin’ and a password of 'secret'.

..............................................................................................................................................................................

{junitreport:url=http://yourConfl uencel nstance. coni downl oad/ attachment s/
<page id>/file.xm ?0s_user nane=adni n&s_passwor d=secret}

..............................................................................................................................................................................

Labels List Macro

The Labels List macro displays a list of all labels within the current space. Each label in the list links to a page
that displays all pages in the current space that contain that label.

Using the Labels List macro

To add the Labels List macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.
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To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter name Required Default Parameter description and accepted values
Restrict to this Space No Current The key of the space whose labels you want to

Key space display.

(spacekKey)

Excluded label(s) No Blank The labels that you do not want to appear in the list.

(excl udedLabel s)

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: | i st abel s

Macro body: None.

{l'i stl abel s: spaceKey=DCC}

Livesearch Macro

The Livesearch macro allows you to add a search box to a Confluence page. When users enter a search term
into the search box, Confluence will dynamically display matching results as they type.

Using the Livesearch macro

To add the Livesearch macro to a page:
1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Restrict to this  all Specify a space key to limit the search to the given space. Case-sensitive.
Space Key spaces . .

(spaceKey) Alternatively, use @el f to restrict the search to the current space.
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Restrict to Specify labels to limit the search to content with that label. If unspecified will
label(s) search all content regardless of label.

(1 abel s)

Size medium Choose a medium or large search field size.

(size)

Placeholder Specify the placeholder text to appear in the search field, for example 'Search
text this space’

(pl acehol der

)

Type all Specify the content types to be included in the search - choose from pages,
(type) blogs, comments, space descriptions, or all content types.

Additional space Display the space name, a page excerpt or nothing under the search result.

(additional) name

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: | i vesear ch

Macro body: None.

{l'i vesear ch: spaceKey=DOC| si ze=I ar ge| pl acehol der=Search this space}

Loremipsum Macro

The Loremipsum macro displays paragraphs of pseudo-Latin text (more information). You can use this macro to
generate more-or-less meaningless text for demonstration purposes in pages showing a draft layout or
arrangement of page elements. The text is deliberately non-meaningful so that it does not influence the viewer's
perception of the page arrangement or design.

A basic example of the Loremipsum text:

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aliquam fermentum vestibulum est. Cras
rhoncus. Pellentesque habitant morbi tristique senectus et netus et malesuada fames ac turpis
egestas. Sed quis tortor. Donec non ipsum. Mauris condimentum, odio nec porta tristique, ante
neque malesuada massa, in dignissim eros velit at tellus. Donec et risus in ligula eleifend
consectetur. Donec volutpat eleifend augue. Integer gravida sodales leo. Nunc vehicula neque ac
erat. Vivamus non nisl. Fusce ac magna. Suspendisse euismod libero eget mauris.

Using the Loremipsum macro

To add the Loremipsum macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters
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Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
Number of 3 Determines the amount of pseudo-Latin (space-filler) text to display. The macro
Paragraphs will display a maximum number of 30 paragraphs.

Parameter is unnamed in storage format and wikimarkup.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: | or ermi psum

Macro body: None.

{l orem psum 2}

Multimedia Macro

Use the multimedia macro to embed attached video, animation, and other multimedia files to your page. The
macro uses the HTML5 <vi deo> tag, so the type of video your page viewers can see depends on the video
formats their browser supports with the HTML5 <vi deo> tag. For example, Quicktime videos (.mov or .qt) can
only be viewed in Safari, as that file type is not supported by other browsers.

If you want to display online multimedia content, like YouTube and Vimeo videos, take a look at the Wid
get Connector Macro.

The file preview also supports MP3 audio and MP4 video files. This is handy when you want to play a
video in a larger format.

To add the Multimedia macro to your page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.
Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Required Default Parameter description and accepted values
name
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Page name (
page)

Current page

The name of the page to which the multimedia file is
attached. Start typing the name of the page and then select it
from list of suggested pages. Include the spacekey if you
want to specify a page in another space (for example, MYSPA
CE: MWy Page Title)

278

File* ( nane) None File name of the attached multimedia file.

Width If not specified, Width of the movie window to be displayed on the page. By
the browser will  default, this value is specified in pixels. You can also choose
determine the to specify a percentage of the window's width, or any other
width based on  value accepted by HTML.
the file type.

Height If not specified, Height of the movie window to be displayed on the page. By
the browser will  default, this value is specified in pixels. You can also choose
determine the to specify a percentage of the window's height, or any other
height based on  value accepted by HTML.
the file type.

Autoplay (au No fal se If the parameter is set to t r ue then the video or audio file will

tostart) start playing as soon as the page is loaded. If this option is

set to f al se then the file will not play until the user clicks the
icon or image on the page.
Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: nul ti nedi a

Macro body: None.

{mul ti nmedi a: space=DOC| page=My nmacr os| nane=ni nj as. swf | aut ostart=true}

Navigation Map Macro

The Navigation Map macro displays a navigable map of the pages tagged with a given label.

Using the Navigation Map Macro

To add the Navigation Map macro to a page:
1. Inthe Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters
Parameters are options that you can set to control the content or format of the macro output. Where the

parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).
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Parameter Default Description
Label none Specify the label associated with the pages you want to show in the navigation
map.

This parameter is unnamed in storage format and wikimarkup.

Map Title none Specify a title for the navigation map.
(title)

Number of 5 Specify the number of cells in a row
Cells Per

Row

(wrapAfter)

Cell Width 90 Specify the cell width (enter a number only, don't include px)
(Pixels)
(cel I Wdt h)

Cell Height 60 Specify the cell height (enter a number only, don't include px)
(Pixels)

(cel |l Hei ght

)

Navigation Confluence Define a theme for the navmap (Server only).
Map Theme

(thene) If you want to create your own navmap 'look and feel' (for example, one with

rounded corners), you need to add a customized navmap macro theme file to
the VEB- | NF/ cl asses/ t enpl at es/ macr os directory. The file name
convention to use is navimap- myt heme. vm Use the name of your choice for
the myt hemre part of the file name, which is also the value you use for this
parameter. Hence, if your theme was called navnap- r oundededges. vm use
the value of r oundededges for this parameter.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: navnap
Macro body: None.

{navmap: nyl abel | wapAfter=4|titl e=My map
nane| cel | Hei ght =50px| t heme=navnmap- nyt hene. vni cel | W dt h=80px}

Network Macro

The Network macro displays a list of Network activity on a Confluence page or blog post. You can specify the
user whose network activity you wish to show. These interactions include the users that the specified user is
following or users who are following the specified user. The Network macro shows each listed user by their
profile picture. It also provides a choice of two themes and the ability to limit the number of users in the list.

Screenshot: Network macro
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Following

Rach Admin is following 3 users

HiRE

Using the Network macro

To add the Network macro to a page:
1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Username Current The username of the Confluence user whose network interactions you wish to
user's show. If no username is specified, then current user’s (that is, your) network
username interactions are shown.

Mode following Determines which users are listed, with respect to the specified user:

® following — those who the user is following.
® followers —those who are following the user.

This parameter is unnamed in storage format and wikimarkup.

Theme full Determines how the user's network is displayed:

® full — shows a large version of user's profile pictures and, if the following
mode is set, provides an entry field function to follow more users.
® tiny — shows only the small version of user's profile pictures.

Maximum  No limit Restricts the number of users displayed. If the number of users exceeds the
Results imposed up  specified maximum, then a Show All link is provided. This link leads to the

toa specified user's Network view, showing the complete list of network interactions.
(max) maximum of

30

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: net wor k

Macro body: None.
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..............................................................................................................................................................................

Disabling the Network macro

The Network macro is provided by the 'network’ module in the 'Profile Macros' plugin. To remove the macro from
your site, you can disable the module in the plugin. See Disabling and enabling add-ons.

Noformat Macro

The Noformat macro displays a block of text in monospace font with no other formatting.

Using the Noformat Macro

To add the Noformat macro to a page:
1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Enter the content that is to be unformatted into the body of the macro placeholder.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter  Default Description
No Panel False Removes the panel around the content.
(nopanel)

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: nof or nat

Macro body: Accepts plain text.

..............................................................................................................................................................................

Office Excel Macro
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The Office Excel macro is going away in a future release

Read more about this change or find out about a better way to insert and preview Excel
files.

The Office Excel macro displays the content of an Excel spreadsheet on a wiki page. First attach the
spreadsheet to a Confluence page, then use the macro to display the content. When viewing the page, people
will see the content of the spreadsheet, without needing to have Office installed.

For details, see the View File Macro.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: vi ewx| s

Macro body: None.

..............................................................................................................................................................................

{vi ewxl s: col =5| page=Docs| name=My
docunent . x| s| gri d=f al se| sheet =nysheet | r ow=5}

..............................................................................................................................................................................

Office PowerPoint Macro

The Office PowerPoint macro is going away in a future release

Read more about this change or find out about a better way to insert and preview
PowerPoint files.

The Office PowerPoint macro displays the content of a PowerPoint presentation on a wiki page. First attach the
presentation to a Confluence page, then use the macro to display the content. When viewing the page, people
will see the content of the presentation, without needing to have Office installed.

For details, see the View File Macro.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: vi ewppt

Macro body: None.

..............................................................................................................................................................................

Office Word Macro

The Office Word macro is going away in a future release

Read more about this change or find out about a better way to insert and preview Word
files.

The Office Word macro displays the content of a Word document on a wiki page. First attach the document to a
Confluence page, then use the macro to display the content. When viewing the page, people will see the content
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of the document, without needing to have Office installed.

For details, see the View File Macro.
Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: vi ewdoc

Macro body: None.

..............................................................................................................................................................................

Page Index Macro

The Page Index macro creates an alphabetical index of all pages in the current space.

The top section provides the total number of pages in the space, followed by a count of pages for each letter.
Click any letter to jump to the bottom section, which lists all the pages in the space alphabetically. The first few
lines of each page will be included if there are less than 200 pages in the space.

The Page Index macro can be quite memory hungry in large spaces. To prevent it causing out of
memory errors in your site, we don't show page excerpts when there are more than 200 pages in the
space, and don't list any pages if there are more than 5000 in the space.

Screenshot: Page Index macro (partial view)

Space Index
Total number of pages: 9
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0-2 A
[8) 25 reasons people like Confluence (#) Angry Nerds Home
Integration with JIRA Great product its a Welcome to Anagry Merds, a sample Confluence space. We
wiki User experience design think you're gonna like it herel
B c
[S) Blog ideas (S Confluence hints and tips
Do users needto be told left side /right What hints and tips do you share with other Confluence
side of screen Macros and what you can users?
do with them
D E

Using the Page Index macro

Created in 2017 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 6.3 Documentation

To add the Page Index macro to a page:
1. Inthe Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

This macro accepts no parameters.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: i ndex

Macro body: None.

..............................................................................................................................................................................

Page Properties Macro
The Page Properties and Page Properties Report macro work together to

show summary information from one page on a another page. You can see On this page:
examples of these two macros in action in the Decisions and Product ® Adding the
Requirements blueprints. Page
Properties
macro to a
Adding the Page Properties macro to a page page
® Using
The Page Properties macro uses key/value pairs. multiple
. ) Page
To add the Page Properties macro to a page: Properties
1. Inthe editor, choose Insert > Other Macros > Page Properties macros on
2. In the macro body create a two column table one page
3. In the left column list your 'keys' — these will be the column headings ® Parameter
in your report table S

4. In the right column list the value for each key — these will populate the
rows in your report table

5. Add a label to your page (you'll need to specify this label in the page * Page
properties report macro) Properties

6. Save your page Report
Macro

® Decisions
Blueprint

® Product
Requireme
nts
Blueprint

Related pages:

Next you need to add the Page Properties Report macro to another page.

Here's an example of the Page Properties macro in the editor. Deadline, Current Status, and Team will be
column headings in the report.
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V! Page properties

Deadline 1 June
Current Status Mot Started

Team FPurple Monkeys

Here's what the example above will look like in the Page Properties Report.

Title Current status Deadline Team
Project DEF Mot started 1 June Purple Monkeys
Project ABC In Progress 15 November Green Parrots

You can also set up the Page Properties macro horizontally. To do this:

® Create a two row rather than two column table, and ensure the first row has the heading row style
applied.

|
® List your keys in the first row, and values in the second row.

The Page Properties Report Macro will be able to pull this information accurately even if you're using the
Page Properties Macro vertically elsewhere.

Using multiple Page Properties macros on one page

You can add multiple Page Properties macros on a single page, and choose whether to include all or only
specific macros in the report. You might use multiple macros because you want the information in the macro
to display in context with the rest of the page, or because you want to be able to report on individual Page
Properties macros separately.

The Page Properties macro includes an optional ID parameter that can be used to identify specific Page
Properties macros.

To show the contents of all Page Properties macros in the report:

1. Add a label to the page containing the Page Properties macros
2. Specify this label in the Page Properties Report macro

To show the contents of selected Page Properties macros in the report:

1. Add a label to the page containing the Page Properties macros
2. Specify an ID in the Page Properties macro that you want to report on
3. Specify both the label and ID in the Page Properties Report macro

Note: The Page Properties Report macro can only accept one page label, and one ID.

See the Page Properties macro in action in How to document product requirements in Confluence.
This powerful macro lets you create a summary page that pulls in information from multiple pages.
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Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the

parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro

browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Page (None) Optional ID used to identify a particular Page Properties macro on a page. Specify

Properties this ID in the Page Properties Report to include summary information from macros

ID with this 1D only.

Hidden False Determines whether the data in the Page Properties macro will be displayed on the

current page. This setting does not affect the display of the detail in the Page

Properties Report macro.

Notes

® You can't use macros in the left column as the data in this column is used to populate the column

headings in your Page Properties Report macro.

® |tis not possible to reference the metadata using the metadata key from within the page, or anywhere

else on a Confluence page.

® There is a known issue where the Page Properties Report macro does not correctly display content
CONFSERVER-34141

from multiple Page Properties macros. See |RESOLVED
information.

Page Properties Report Macro

The Page Properties and Page Properties Report macro work together to
enable you to show summary information from one page on a another
page. You can see examples of these two macros in action on the Decision
and Product Requirements blueprints.

This macro was previously known as the Details Summary macro.

Adding the Page Properties Report macro to a page

To add the Page Properties Report macro to a page:

1. Inthe editor, choose Insert > Other Macros > Page Properties
Report.

2. Enter the Labels you want to report on - this is the label added to
pages containing the Page Properties macro.

3. Further narrow down your search by adding more fields, or specifying
a Page Properties ID (more info on this below)

4. Choose Insert.

for more

On thi
[ )

S page:
Adding the
Page
Properties
Report
macro to a
page
Reporting
on specific
Page
Properties
macros

®* CQL fields
®* Macro

display
options
Troublesho
oting

Related pages:

Page
Properties
Macro
Decisions
Blueprint
Product
Requireme
nts
Blueprint
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Here's how the macro looks on your page:

Title Current status Deadline Team

Project DEF Mot started 1 June Purple Monkeys

Project ABC In Progress 15 November Green Parrots

And here's how you would set it up in the macro browser:
Insert ‘Page properties report’ Macro Help
S Preview

Label *
project | current Title Current status Deadline Team

In space Drr_ujec: DEF Mot started 1 June PUI’pIE P-.'1UI’1KE\_\-'S
Current space % Project ABC In Progress 15 November Green Parrots

Add a field

Options Show

Select macro Insert | Cancel

Reporting on specific Page Properties macros

It's possible to add multiple Page Properties macros on a page, and choose whether to include all or only
specific macros in the report. The Page Properties macro includes an optional ID parameter that can be
used to identify specific Page Properties macros.

To show the contents of:

®* Selected Page Properties macros in the report - specify the label for the page and the ID of the
particular Page Properties macro (under Options)

® All Page Properties macros in the report - specify just the label for the page - leave the Page
Properties ID field blank.

Note: The Page Properties Report macro can only accept one ID.

COQL fields

CQL (Confluence Query Language) is a query language developed for Confluence, which you can use in
some macros and the Confluence search. Confluence search and CQL-powered macros allow you to add
filters to build up a search query, adding as many filters as you need to narrow down the search results.

Use the Add a filter link to add more filters to your query.

~ Use AND, OR, and NOT operators
® For an OR search, specify multiple values in the same field.
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So to show pages with 'label-a’, 'label-b' or both you'd put 'label-a’ and 'label-b' in the same Label
field, like this:

Label *

label-a *

label-b *

® For an AND search, add more than one filter and specify a single value in each.

To show only pages with label-a and label-b you'd put 'label-a' in one label field, then add a second
Label field to the macro, and put 'label-b' in the second one, like this:

Label *

label-a *

Label [

label-b *

Put simply, OR values are entered in the same filter, AND values are entered in different filter.

Only some filters support AND. If the filter doesn't support the AND operator, you won't be able to

add that filter more than once.

®* For a NOT search, enter a minus sign (-) before the label. This'll exclude everything with that label.

You can use the following CQL filters to build your query:

Filter

Label*

With
ancestor

Contributor**
Creator
Mentioning
user

With parent
In space**
Including
text**

With title

Of type**

Description

Include pages, blog posts or attachments with these
labels.

Include pages that are children of this page.

This allows you to restrict the macro to a single page tree.

Include pages or blog posts that were created or edited by
these people.

Include items created by these people.

Include pages and blog posts that @mention these people.

Include only direct children of this page (further sub-pages
won't be included)

Include items from these spaces.

Include items that contain this text.

Include items that contain this text in the title.

Include only pages, blogs or attachments.

* This field is required in CQL-powered macros.

Operators

OR (multiple values in the
same filter)

AND (multiple Label filters)
OR (multiple values in the
same filter)

OR (multiple values in the

same filter)

OR (multiple values in the
same filter)

OR (multiple values in the
same filter)

EQUALS (one page only)

OR (multiple values in the
same filter)

CONTAINS (single word or
phrase)

CONTAINS (single word or
phrase)

OR (multiple values in the
same filter)
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so they don't appear in the Add a filter menu.

Macro display options

These options control how the macro appears on your page.

Parameter Default Description

Page Blank If not specified, the report will show data from all Page Properties macros on a
Properties page, where there are multiple macros. Specify an ID to include only data from
ID Page Properties macros with the same ID.

Title Title The heading to display on the first column in the report table. This column
column contains links to pages displayed by the report. The default column heading is
heading Title".

Columns If not specified, the report will show all columns. You can specify a comma

to show separated list of columns to include.

289

If your column heading includes commas, use double quotes around the column
name. If your column heading includes quotes, use double quotes. For example,
A column, "My ""new™ column, yes", Third column

Number of 30 Number of items to display in the table before displaying pagination options for

items to additional items.
display
Sort by Modified Sort the table by a specific column heading. Enter the column name, exactly as it
appears in the corresponding Page Properties macro.
Select the Reverse Sort check box to sort the table in reverse order.
Show No Displays the number of comments for each page in the table.
Comments
Count
Show No Displays the number of likes for each page in the table.
Likes
Count

Troubleshooting

If your report is empty, check:

®* You have entered the label correctly and that the label does appear on pages containing a Page
Properties macro.

® The Page Properties macros on each page are configured correctly.

® Any other fields you have specified have not narrowed your search too far (for example there are no
pages with that label under the Parent page you've specified).

®* There is a known issue where the Page Properties Report macro does not correctly display content

CONFSERVER-34141

from multiple Page Properties macros. See |[RESOLVED

information.

for more

Page Tree Macro
The Page Tree macro displays a dynamic, hierarchical list of pages starting from a specified parent (root) page.

It can act as a table of contents or a list of related topics. When viewing the page tree, your reader can click a
link to view the relevant page. The page's current position is highlighted in the page tree.
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Using the Page Tree Macro

To add the Page Tree macro to a page:
1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Click Refresh in the Macro Browser to see the effect of changes to the macro parameters.

Macro Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default  Description
Root Page The Specify the parent page for the page tree. The tree will include all
(root) home children of the given page, plus their children and grand-children etc.
page of  The tree will not include the root page itself.
the
space Specify the page title or a special value as follows:

® Your page title — to specify a page name for the parent or root of
the tree. The tree will include all children and grand-children of the
specified root. The tree will not include the specified root page itself.

* '‘@home' — will include all pages under the home page of the space
(default).

* '@self' — will include all pages under the current page.

* '@parent’ — will include all pages under the parent of the current
page, including the current page.

® '@none' — will include all pages in the space, including orphaned
pages and the home page.

Sort Pages By position Specify the order to display the pages in the tree. This sort order is for
(sort) display purposes only. It does not permanently re-arrange the page
order. The value may be one of the following:

bitwise — sort alphabetically, for example: titlel, title10, title2.
creation — sort by date of creation.

modified — sort by order of date last modified.

natural — sort in 'natural’ alphabetical order, for example: titlel,
title2, title10.

® position — sort by the default Confluence sorting rules. If your
pages have been ordered manually, this sort will respect the defined
order. Otherwise the pages will be displayed in the 'natural’
alphabetical order, such as: titlel, title2, title10.

Include Excerpts in false Select if you want the page tree to show excerpts from each page. The
Page Tree excerpts must be defined on each page by the Excerpt macro.
(excerpt)

Reverse Order false Select to show the pages in reverse (descending) natural order. Must
(reverse) be used in combination with the Sort Pages By parameter.
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Include Search Box false
above Page Tree
(sear chBox)

291

Select if you want to include a search box above the page tree. The
search box allows your readers to search within the page tree for the
specified value.

Show false Select if you want to display the 'expand all' and ‘collapse all' links at the
Expand/Collapse top of your page tree. Your readers can click these links to open or
Links close all branches of the tree at once.
expandCol | apseAl |
; P P Available values in wikimarkup and storage format:
® true — Show the 'expand all' and 'collapse all' options.
* fal se — Do not show the options.
Start Depth 1 Enter any number greater than 0 to set how many levels of children the

(startDepth) tree should show when it opens for the first time.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: pagetr ee

Macro body: None.

{ paget r ee: r oot =Page
Nane| sort =nat ur al | excer pt =t rue| r ever se=f al se| st art Dept h=3| expandCol | apse
Al'l =t rue| sear chBox=t r ue}

Page Tree Search Macro

Using the Page Tree Search macro, you can add a search box to your Confluence page. When a viewer enters
a search term, Confluence will search a hierarchy of pages starting from a specified parent (root) page and
return the search results.

You can also add a search box as part of a dynamic page tree, which looks like a table of contents. See the Pag
e Tree macro .

Using the Page Tree Search macro

To add the Page Tree Search macro to a page:
1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
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Name of none The name of the root page whose hierarchy of pages will be searched by this macro.
Root Page If this not specified, the root page is the current page.

r oot
( ) Note: Unlike the Page Tree macro, the Page Tree Search macro does not accept the

special values that start with an @ sign, such as @home or @self.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: paget r eesear ch

Macro body: None.

{paget reesear ch: root =My page nane}

Panel Macro

The Panel macro displays a block of text within a customizable panel, like this:

A formatted panel. ‘

Handy hint: You can use panels within columns, in table cells and in the sections defined by page layouts.

Using the Panel macro

To add the Panel macro to a page:
1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Panel Title none The title of the panel. If specified, this title will be displayed in its own title
(title) row.

Border Style solid The style of the panel's border. Accepted values are sol i d, dashed and
(border Styl e) other valid CSS border styles.

Border Color The color of the panel's border. Colors can be specified as HTML color
(bor der Col or) names or hexadecimal codes.
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Border Pixel Width The width of the panel's border (in pixels).

(Value Only)

(bor der W dt h)

Background Color The background color of the panel. Colors can be specified as HTML color
(bgCol or) names or hexadecimal codes.

Title Background The background color of the title row of the panel. Colors can be specified
Color as HTML color names or hexadecimal codes.

(titleBGCol or)

Title Text Color The color of the text in the title row of the panel. Colors can be specified as
(titleCol or) HTML color names or hexadecimal codes.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: panel

Macro body: Accepts rich text.

..............................................................................................................................................................................

{panel :titl e=Wy

titl e| border Styl e=dashed| bor der Col or =bl ue| ti t| eBGCol or =#00a400|titl eCol o
r =whi t e| bgCol or =#72bc72}

A formatted panel

{panel }

PDF Macro

The PDF macro is going away in a future release

Read more about this change or find out about a better way to insert and preview PDF
files.

The PDF macro displays the content of a PDF document on a page. First attach the document to a Confluence
page, then use the macro to display the document.

For details, see the View File Macro.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: vi ewpdf

Macro body: None.

..............................................................................................................................................................................

Popular Labels Macro

The Popular Labels macro displays the most popular labels used throughout your Confluence site or within a
space. A popular label is a label that has been added to many pages.
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Using the Popular Labels Macro

To add the Popular Labels macro to a page:
1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Number of Labels 100 Specifies the total number of labels to display in the heatmap.

to Display

(count)

Restrict Labels to  none Restricts the list of popular labels to the specified space.

this Space Key

(spacekKey)

Style of Labels list ® list — displays the popular labels as a bulleted list, ordered by popularity
(style) (highest first).

®* heatmap — displays the popular labels using different font sizes for each
label depending on the label's popularity, ordered by label names.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: popul ar - | abel s

Macro body: None.

{popul ar - | abel s: styl e=heat map| count =20| spaceKey=ds}

Profile Picture Macro

You can use the Profile Picture macro to display a
user's profile picture on a page, and it's useful for
things like creating team pages that show all
members of a project team.

Here's an example of how to use the Profile
Picture macro: How to build a release
planning page in Confluence.

Hover your mouse-over the picture to see the Hover
Profile for the user, and choose the user's picture or
name to view their user profile. When editing the

page, you can also select the macro and choose Vie
w User Profile to see the profile for the user.

Add the Profile Picture Macro

1. In the Confluence editor, choose Insert > Oth
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er Macros
2. Find and select the 'Profile picture’ macro e
3. Search for and select the user and choose Sa -4

ve Josh User
':' josh@user.com

Speeding up macro entry with autocomplete: Typ Follow More ~

e { and the beginning of the macro name, then

select the macro from a list of suggested macros. Profile Page

For more information, see Using Autocomplete. Status Updates Page
Network Page

Wiki markup

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.
Recently Updated Dashboard Macro

The Recently Updated Dashboard macro displays a list of the most recently changed pages, blogs and files in
your site. It is similar to the Recently Updated macro but with tabs to allow you to see all updates, updates from
your favorite spaces or updates from your network (the people you follow).

Using the Recently Updated Dashboard macro

To add the Recently Updated Dashboard macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Space(s) The space which Filter content by space. The macro will display only the pages etc

(spaces) contains the page  which belong to the space(s) you specify here. You can specify
on which the one or more space keys, separated by commas.

macro is added o
Use "*' for all spaces.

Include these all types Filter content by type. You can specify one or more types,
Content Types separated by commas. Available types are: page, bl ogpost or
Only news, spacedesc, att achnment , conment , mai | , useri nf o.
(types)

Label(s) none Filter content by label. The macro will display only the pages etc
(1 abel s) which are tagged with the label(s) you specify here. You can

specify one or more labels, separated by commas.

Note: If there are no pages matching any of the specified labels,
then Confluence will ignore the labels and will list all recently
updated pages.
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User(s) all users Filter by username of the user who updated the content. The

(users) macro will only display content created and updated by the
user(s) you specify here. You can specify one or more
usernames separated by commas.

Width of Table 100% Specify the width of the macro display, as a percentage of the
(wi dth) window width.

Show User Profile  false Select whether profile pictures of the users who updated the
Pictures content are displayed.

(showProfil ePic

)

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: r ecent | y- updat ed- dashboar d

Macro body: None.

{recent|y-updat ed- dashboar d: spaces=ds| user s=admi n| wi dt h=50% showPr of i | eP
i c=true| | abel s=choc|t ypes=page}

Recently Updated Macro

The Recently Updated macro displays a list of the most recently changed content within Confluence.

Using the Recently Updated Macro

To add the Recently Updated macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
Author(s) by None Filter the results by author. The macro will display only the pages etc
username specified.  which were last modified by the author(s) you specify here.
(aut hor) That is,
display all ~ You can specify multiple users.
content
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Space(s) @el f

(spaces) That is,

the space
which
contains
the page
on which
the macro
is used

Label(s) None

(1 abel s) specified
ie.
display all
content

Width of Table 100%
(w dt h)

This parameter allows you to filter content by space. The macro will
display only the pages etc which belong to the space(s) you specify here.

You can specify one or more space keys, separated by a comma or a
space.

® To exclude content in a specific space, put a minus sign (-)
immediately in front of that space key. For example: If you specify a
space key of - BADSPACE you will get only content which is not in the
BADSPACE.

® To indicate that the results must come from a specific space, put a
plus sign (+) immediately in front of that space key. For example: If
you specify a space key of +GOODSPACE you will get only content in
GOODSPACE. (Note that this is not particularly useful, because each
content item belongs to one space only. If you put a plus sign next to
one space key and list other space keys too, the other space keys will
be ignored.)

Special values:

@el f — The current space.

@er sonal — All personal spaces.

@l obal — All site spaces.

@ avorit e — The spaces you have marked as favorite.
@ avourite — The same as @ avori t e above.

@l | — All spaces in your Confluence site.

* — The same as @l | above.

When specifying a personal space, remember to use the tilde (~) sign in
front of the username, such as ~j bl oggs or ~j bl oggs@xanpl e. com

Filter the results by label. The macro will display only the pages etc which
are tagged with the label(s) you specify here.

You can specify one or more label values, separated by a comma or a
space.

® To exclude content which matches a given label, put a minus sign (-)
immediately in front of that label value. For example: If you specify a
label value of - badpage you will get only content which is not labeled
with 'badpage’.

® To indicate that the results must match a given label value, put a plus
sign (+) immediately in front of that label value. For example: If you
specify a label value of +super page, +goodpage you will get only
content which has at least two labels, being 'superpage’ and
‘goodpage’.

The labels parameter only applies to the page and bl og content types.

Specify the width of the macro display, as a percentage of the window
width.
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Include these All types
Content Types
Only

(types)

Maximum Number 15
of Results
( max)

theme conci se
(t hene)

Show User Profile fal se
Pictures
(showProfil ePic

)

Hide Title False
('hi deHeadi ng)

Notes

This parameter allows you to filter content by content type. The macro will
display only the content of the type you specify here.

You can specify one or more types, separated by a comma or a space.

To exclude content of a given content type, put a minus sign (-)
immediately in front of that content type. For example: If you specify a
content type of - bl ogpost you will get pages and all other content
except for blog posts.

Available values:

® page — Pages.

® bl ogpost or news — Blog posts, also known as news items.
®* comrent — Comments on pages and blog posts.

® attachment — Attachments.

Specify the maximum number of results to be displayed. If this parameter
is omitted, then a maximum of 15 results are displayed. The theoretical
maximum value that this parameter can accept is 2 to the power of 31,
minus 1 (or 2147483647), though this has been limited to 200 in the code,
for performance reasons. More details are here.

Choose the appearance of this macro:

® conci se — the default list, showing the names of pages which were
updated or commented on, the users who made the page
modifications and time when the modifications occurred.

® soci al — lists recent modifications in reverse chronological order,
but groups them by user into short time segments. A 'sub’ list appears
within each user's time segment, showing the names of pages which
they updated or commented on and time when these modifications
occurred.

® si debar — lists recent updates in reverse chronological order,
showing the names of pages which were updated or commented on
and time when the page modifications occurred. This theme does not
show authorship.

Specify showPr of i | ePi c=t r ue to display the profile pictures of the
users who updated the content.

Determines whether the macro hides or displays the text 'Recently
Updated' as a title above the list of content. Only available in wikimarkup
and storage format.

Accepted values:

® true — Title is hidden.
* fal se—Title is shown.

®* The Recently Updated Dashboard macro is similar to this macro, but is intended for display on the

Confluence dashboard.

® If you would like to change the wording displayed by the Recently Updated macro, please refer to the
document on modifying the Confluence interface text.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
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sidebar, header or footer of a space.
Macro name: r ecent | y- updat ed
Macro body: None.

{recent|y-updat ed: spaces=ds| aut hor =adni n| max=10| hi deHeadi ng=t r ue| wi dt h=5
0% t hene=si debar | showPr of i | ePi c=t rue| | abel s=choc| t ypes=page}

Recently Used Labels Macro

The Recently Used Labels macro displays a list of the labels that have been most recently added to a page, blog
post or attachment. You can define the number of labels to be displayed and the scope (the current space, your
personal space or site spaces, also known as 'global’ spaces).

Using the Recently Used Labels macro

To add the Recently Used Labels macro to a page:
1. Inthe Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters of this macro

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
Number of Labels 10 Specifies the total number of labels to display in the list.
to Display
(count)
Scope for global Specifies the scope of labels to be displayed in the list. Valid values include:
Retrieving Labels _ .
(scope) ® global — covers all site spaces (non-personal) in the Confluence
installation.
® space — the current space.
® personal — your own personal space.
List Style list ® list — displays the list of labels horizontally.
(style) ® table — includes additional information such as the page to which the
label was added and the user who added it.
Table Title none Adds a title to the top of the list in table style. Titles are only visible when the
(title) List Style parameter has been set to table.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: recent | y-used- 1| abel s
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Macro body: None.

{recently-used-labels:title=My title|scope=space|styl e=t abl e] count =20}

Related Labels Macro

The Related Labels macro lists all labels from every page which has one or more labels in common with the
current page.

Using the Related Labels Macro

To add the Related Labels macro to a page:
1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Restrict to these none Specify the labels for which you want to view related labels. For example, doc
Labels ument ati on, ny: stuff.

(1 abel s)

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: r el at ed- | abel s

Macro body: None.

{rel at ed- | abel s: | abel s=choc, cake}

Roadmap Planner Macro

Create simple, visual timelines that are useful for planning projects, software releases and much more with
the Roadmap macro.

Roadmaps are made up of:

bars to indicate phases of work

lanes to differentiate between teams, products or streams
markers to highlight important dates and milestones

a timeline showing months or weeks.

You can provide more information about items on your roadmap by linking a bar to a page.

Here's how it appears on a page:

Created in 2017 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 6.3 Documentation 301

2014
Feb Mar Apr May Jun
(1]
(&}
C
o
=
I=
(=]
o
c Topic wizard SEO
:
3 (3] SEC Requirements

Team Hulk working
on SEQ optimisation

Performance improvements

o]
S
E
m
a
'_

Questions 1.0 Confluence 5.4 Confluence 5.5

Adding the Roadmap macro

To add the Roadmap macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Editing your Roadmap

To edit your roadmap:

Select the roadmap and choose Edit.

Add lanes, bars and markers.

Drag lanes, bars and markers to the desired location on the roadmap.

Select lanes, bars and markers to add text, change colors and remove from the roadmap.
Select bars to add links to existing pages, create new pages or add a description.

Set the start and end dates for the roadmap and choose to display it by weeks or months.

Here's how the roadmap planner appears in the editor:

Insert Roadmap Planner

+ Addlane | + Addbar | +add Viewby = Months 4 2015-05-07 - 2016-01-31 E

2015 2016

May Jun Jul Aug Sep Oct Nov Dec Jan
|
i Gather requirements
New bar
Prepare launch
Research campaign ¢
o Prepare launch campaign Link page * Create page
Click to add description.
Kickoff General

mesting Delete bar

Insert  Cancel

1. Add lanes: to differentiate your teams or streams of work.
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2. Date range: display the plan by weeks or months.
3. Add bar info: to provide more info or link a bar to a page.
Parameters
This macro does not use the macro browser to set parameters. You also cannot add this macro via wiki
markup or by editing the storage format directly.
Notes

The Roadmap macro was previously available as an add-on from The Marketplace. The macro has changed
significantly. If you had an older version of the macro installed you will be able to view your existing
roadmaps but not edit them.

RSS Feed Macro

The RSS Feed macro embeds an RSS feed on a page. It can display the contents of external feeds, or of
internal feeds generated by Confluence. To display blog posts or to list recently updated pages in a space, use
the Feed Builder to create an internal feed, then render it using this macro.

CAUTION: Including unknown HTML inside a webpage is dangerous.

HTML inside an RSS feed can contain active scripting components. This means that it would be
possible for a malicious attacker to present a user of your site with script that their web browser would
believe came from you. Such code could be used, for example, to steal a user's authentication cookie
and give the attacker their Confluence login password.

The RSS Feed macro may be disabled by your Confluence administrator. Also, your Confluence administrator
can define a whitelist of trusted URLs. You will see an error message on the Confluence page, if the included
URL is not in the whitelist.

Using the RSS Feed macro

To add the RSS Feed macro to a page:
1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

RSS Feed URL none The URL of the RSS feed link you want to show.
(url)

Maximum Number of Entries 15 Limit the number of entries displayed.

(max)
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Show Item Titles Only false Show only the titles of the news items, not the content.
(showTi t] esOnl y)

Show Name/Title of RSS Feed true Hide the feeds title bar.
(titleBar)

How up to date is the feed?

By default, the RSS Feed macro caches the feed results for 60 minutes before fetching the data again.

If you wish to change the default caching, use the Cache macro to define how often the RSS Feed macro
fetches the feed updates. You will need to install the Cache plugin onto your Confluence site.

What happens to a page containing a disallowed URL?

Your Confluence Administrator can set up a whitelist of allowed URLSs. If this is the case, you may see an error
on the pages which contain the RSS Feed macro.

A user can add the RSS Feed macro or the HTML-include macro to a Confluence page. The macro code
includes a URL from which the content is drawn. When the page is displayed, Confluence will check the URL
against the whitelist. If the URL is not allowed, Confluence will display an error message on the page.

The error message says that Confluence "could not access the content at the URL because it is not from an
allowed source" and displays the offending URL. If the person viewing the page is a Confluence Administrator,
they will also see a link to the Administration page where they can configure the URL whitelist.

Here is an example of the error message, including the link shown only to Confluence Administrators:

Could not access the content at the URL because it is not from an allowed source.
http://ffeathers. wordpress.com

Configure whitelist ==

Here is an example of the error message, but without the link.

Could not access the content at the URL because it is not from an allowed source.
http://ffeathers wordpress.com

“ou may contact your site administrator and request that this URL be added to the list of allowed sources.

Authentication

Private feeds from external sites

RSS feeds which require authentication cannot be accessed using the RSS Feed macro.

Accessing internal HTTPS feeds

This applies only to Confluence instances which have enabled HTTPS for all content. If your site is fully HTTPS,
the RSS Feed macro cannot access internal feeds. To enable the RSS Feed macro to access internal feeds
without affecting your HTTPS setup, enable local-only HTTP access:

1. Shut down Confluence.

2. Consult the SSL guide to enable HTTP access to Confluence. You'll want to ensure that you have an
HTTP connector and an SSL connector, both commented in. This means that Confluence will be
accessible via both HTTP and HTTPS. However, you should not have a redirect port, nor rules in web.xml
to redirect all traffic.

3. Instead of using web.xml to redirect traffic, insert a firewall rule to redirect all HTTP requests not from the
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Confluence server to the equivalent HTTPS URL. This ensures that users will only be able to access
Confluence via HTTPS, as intended. If you have still left HTTP access for attachments enabled (to avoid
the IE download bug) you must selectively enable those URLS as well.

4. Modify your Confluence RSS Feed macro feed link to use the HTTP URL, and restart Confluence.

Enabling the RSS Feed macro

The RSS Feed macro is disabled by default.
To enable the RSS Feed macro:

1. Goto

> Add-ons.
Select System from the drop down and search for the Confluence HTML Macros add-on.
3. Expand the add-on and enable the rss (rss-xhtml) module.

N

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: rss

Macro body: None.

..............................................................................................................................................................................

{rss: max=10| showTi t| esOnl y=true|url =http://nmybl og. conifeed|titl eBar=fals
e}

..............................................................................................................................................................................

Search Results Macro

The Search Results macro searches your Confluence site based on search terms specified in the macro
parameters, and displays the results on the wiki page.

Using the Search Results macro

To add the Search Results macro to a page:
1. Inthe Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
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Search Terms none The search terms which this macro will use to generate its results.

(query)
You can refine your search query by using operators such as 'AND' and 'OR".

For example: my_queryl AND ny_query?2

For more information, take a look at the documentation on the Confluence
search syntax.

Maximum 10 Set a limit to the number of search results displayed.

Number of

Results

(maxLimt)

Restrict to this all Start typing the space name to find the space, or specify the key of the space
Space Key you want to search in. Note that the key is case sensitive.

Content Type all Specify the content type. The content types are: page, comment, blogpost, att
(type) achment, userinfo (the content of user profiles only) and spacedesc (the

content of space descriptions only).

Last Modified all Specify a period of time in weeks, days, hours and/or minutes, to see the
(lastModified content modified within that time frame.
) These are the values you can use:

w = weeks
d = days

h = hours
m= minutes

For example:

® 2h 35m
¢ 3d 30m

Notes:

® If no time category is specified, Confluence assumes minutes.

® If you specify more than one time period (for example, weeks and days),
you must separate the periods with a space. You can put them in any order.

® The time categories are not case sensitive. For example, '4d’ is the same as

'4D.
Restrict to this all Specify the username of a Confluence user, to show only content created or
Username updated by that user.

(contributor)

Notes

Permissions: When a user views the page containing the Search Results macro, the search results will show
only pages and other content types for which the user has 'View' permission.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: sear ch

Macro body: None.
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ge| spacekey=ds}

{search: | ast Modi fi ed=3w quer y=choc| contri but or =admni n| maxLi nmi t =10| t ype=pa

Section Macro

Used with the Column macro to define columns on a page. See Working with page layouts and columns and

sections.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the

sidebar, header or footer of a space.

Macro name: secti on

Macro body: Rich text, consisting of one or more Column macros.

..............................................................................................................................................................................

{section: border=true}
{col um: wi dt h=100px}
This is the content of
{col um}

{col um}

This is the content of
{col um}

{section}

Space Attachments Macro

The Space Attachments macro displays a list of all files attached to pages in a space. It shows details of the file

*col um 1*.

*col um 2*.

and the includes a link to the page a file is attached to.

Filters allow you to show only files with a particular label or file extension.

Screenshot: The Space Attachments macro

Sample Page

Filter By File Extension: Filter By Label:

Name Size Creator

@&z penguin_png 5kB  Rach
Admin

s iBugs gif 22 Josh User

kB

@&d sitelogo._png 2kB  Josh User

Wl 10 Rach

DefaultSpacelLogo_Angryherds. png kB Admin

03 Added by Rach Admin, last edited by Rach Admin on Feb 15, 2013 {view change)

Attachments in this space - displayed via the space attachments macro.

Creation
Date

20 minutes
ago

about an hour
ago

about an hour
ago

Feb 13, 2013

Last Modification

Date

20 minutes ago

about an hour ago

about an hour ago

Feb 13, 2013

Labels

penguin
chocolate 4
useful | logo &
logo  confluence

r4

No labels #

Attached To

[2) Sample Page

[2) Sample Page

[2) Sample Page

[2) Fancy Page

Using the Space Attachments macro
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To add the Space Attachments macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

The Space Attachments macro displays a list of all the attachments in a space. You can choose to show
attachments from the current space, or another space.

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Space (none)  Selects the Confluence space to display attachments for. If you do not specify a
space, the current space will be used.

Show Filter true Determines whether or not the filter panel is shown. If you select this option,

Controls people viewing the page will be able to filter the list of attachments by file type

(showFil ter (extension) and by label.

)

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: space- attachnents

Macro body: None.

{space-attachnents: showFi | t er=f al se| space=ds}

Space Details Macro

The Space Details macro displays the details of a Confluence space, including the space name, description, and
more.

Using the Space Details macro

To add the Space Details macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters
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Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Width of 100% The width of the space details table, specified as a percentage (%) of the page
Table width.

(wi dt h)

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: space-detail s

Macro body: None.

{space-detail s: w dt h=50%

Spaces List Macro

Use the Spaces List macro to display a list of spaces on a page.

Using the Spaces List macro

To add the Spaces List macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Required? Default Description
Scope of no all The view from which spaces are listed. Available options are:
spaces
P ® (blank) - All spaces in your site, with tabs.
¢ all — All spaces in your Confluence site.
® category — Spaces grouped according to space categories.
® favorite — Spaces which you have added to My Spaces.
[ ]

new — spaces created within the last 7 days.

This parameter is unnamed in wiki markup and storage format.

Width of List no 100% The width of the spaces list, specified as a percentage (%) of the
(wi dt h) window width.

Wiki markup example

Created in 2017 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 6.3 Documentation

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: spaces

Macro body: None.

..............................................................................................................................................................................

Status Macro

The Status macro displays a colored lozenge (a
rounded box) that is useful for reporting project
status. You can choose the color of the lozenge and
the text that appears inside the lozenge. The macro
also displays its current status in the editor, and you
can change the status directly in the editor.

ALL GOOD

Screenshot: Click on the Status macro lozenge to change the status.

ALL GOOD

See the Status macro put to excellent use in
How to build a release planning page in
Confluence.

Edit ALL GOOD [ BB remoe

Using the Status macro

To add the Status macro to a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Color Grey The color of the lozenge. The following colors are available: Grey , Red, Yellow,
(col our) Green and Blue.
Title The The text that will appear inside the lozenge. If you do not specify any text, the title
(title) color that  will be the color of the lozenge, that is 'Grey’, 'Red’, "Yellow', 'Green' or 'Blue’'.

you

select.
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Use False The style of the lozenge and its border. The default style lozenge is a solid
outline background color with white text. The outline style lozenge is white with a colored
style border and colored text as shown here
(subtle)

ALL GOOD!

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in
the sidebar, header or footer of a space.

Macro name: st at us

Macro body: None.

{status:colour=Green|title=On track]|subtle=true}

Table of Contents Macro

The Table of Contents macro scans the headings on
the current Confluence page to create a table of
contents based on those headings. This helps
readers find their way around lengthy pages, by
summarizing the content structure and providing
links to headings.

Want to see the Table of Contents macro in
action? Check out how it's used in Creating
insightful customer interview pages.

Using the Table of Contents macro

Hint: For quick access from the editor toolbar, choose Insert > Table of Contents.
To add the Table of Contents macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Macro parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default  Description

Output Type list ® list — produces a typical list-type table of contents.

(type) ® flat — produces a horizontal menu-type series of links.

Display clear Select the check box to apply outline numbering to your headings, for
Section example: 1.1, 1.2, 1.3.

Numbering

(outline)
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List Style
(style)

Heading
Indent
(i ndent)

Separator
(separator)

Minimum
Heading Level
(m nLevel)

Maximum
Heading Level
(maxLevel)

Include
Headings
(i ncl ude)

Exclude
Headings
(excl ude)

Printable
(printable)

CSS Class
Name
(cl ass)

Absolute URL
(absol ut eURL

)
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disc

brackets

checked

Select the style of bullet point for each list item. You can use any valid CSS
style. For example:

® none — no list style is displayed

® circl e — thelist style is a circle

® di sc —the list style is a filled circle. This is the typical bullet list, and is
used for this example list.

® squar e — the list style is a square

® deci mal — the listis numbered (1, 2, 3, 4, 5)

® | ower - al pha — the list is lower-case, alphabetized (a, b, c, d, €)

® | ower - r oman — the list style is lower roman numerals (i, ii, iii, iv, v, vi)

® upper-ronman — the list style is upper roman numerals (I, II, lll, IV, V,
VI)

Sets the indent for a list according to CSS quantities. Entering 10px will
successively indent heading groups by 10px. For example, level 1 headings
will be indented 10px and level 2 headings will be indented an additional
10px.

This parameter applies to flat lists only. You can enter any of the following
values:

br acket s — Each item is enclosed by square brackets: [ ].

br aces — Each item is enclosed by braces: { }.

par ens — Each item is enclosed by parentheses: ().

pi pe — Each item is separated by a pipe:

anything — Each item is separated by the value you enter. You can enter
any text as a separator, for example "***". If using a custom separator, be
aware that text displays exactly as entered, with no additional white
space to further separate the characters.

Select the highest heading level to start your TOC list. For example,
entering 2 will include levels 2, and lower, headings, but will not include level
1 headings.

Select the lowest heading level to include. For example, entering 2 will
include levels 1 and 2, but will not include level 3 headings and below.

Filter headings to include according to specific criteria. You can use wildcard
characters. See Sun's Regex documentation for examples of constructing
regular expression strings.

Filter headings to enclude according to specific criteria. You can use wildcard
characters. See Sun's Regex documentation for examples of constructing
regular expression strings.

By default, the TOC is set to print. If you clear the check box, the TOC will
not be visible when you print the page.

If you have custom TOC styles in your CSS style sheet, use this parameter
to output the TOC inside <di v> tags with the specified class attribute.

By default, the links in the TOC are relative URLs pointing to the current
page. If checked, the links in the TOC will be full URLs. This setting is useful
when you are including a page with a Table of Contents in another page, and
want to control where the links should take the user.
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Examples

The examples below are based on this table of contents:

s Places
« Favourite Places
* Unknown Places
« Foods
* Favourite Foods
« Lnknown Foods
* Things
« Favourite Foods
* Lnknown Foods

Filtered Table of Contents

This example filters the headings to include those that contain 'Favorite', but excludes headings which end
with "Things'. The list is styled with Roman numerals.

Parameter Value
List Style upper - r oman

Include Headings Favourite.*

Exclude Headings . *Thi ngs

The resulting table of contents is:

|. Favourite Places
. Favourite Foods

Flat List

This example filters all headings to render a flat list of 'Unknowns' enclosed in square brackets (the default

list style).
Parameter Value
Output Type flat
Maximum Heading Level 2
Include Headings Unknown. *

The resulting table of contents is:

[ Unknown Places ] [ Unknown Foods ] [ Unknown Foods ]

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in
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the sidebar, header or footer of a space.
Macro name: t oc
Macro body: None.

This example shows a list-type table of contents.

{toc: printabl e=true| styl e=squar e| maxLevel =2| i ndent =5px| m nLevel =2| cl a
ss=bi gpi nk| excl ude=[1// 2] | type=list]|outline=true|include=. *}

This example shows a flat table of contents.

{toc: printabl e=true| maxLevel =2| m nLevel =2| cl ass=Dbi gpi nk| excl ude=[1//2
]| type=flat|outline=true| separator=pi pe|include=. *}

Notes

®* When you use a Table of Contents macro in a template, you will see an error when you preview the
template itself. But the Table of Contents macro works on the pages that people create from the
template — the table of contents shows up after they have saved the page. (This is probably because
the template is not defined as a page, and the Table of Contents macro works for pages only.)

® The Table of Contents macro only displays page or blog post content. You can't use it to add a table of
contents of headings in a comment for example.

® Due to an outstanding issue in the Table of Contents macro (CONF-10619), the macro browser's Refr
esh function does not render any parameter modifications. Currently, the rendering of parameter value
modifications to the Table of Contents macro occurs only after the page is saved.

® Using HTML heading markup with the Table of Contents macro
The Table of Contents macro cannot handle HTML heading markup on its own. Hence, if you use the
HTML and HTML Include macros to render HTML heading markup in a Confluence page, the Table of
Contents macro will not create a contents list out of these headings.
However, if you insert an HTML anchor into each HTML heading on your page (based on the following
syntax), the Table of Contents macro will incorporate these headings into your contents list.

<h2><a nane="pagenane- headi ngname" ></ a>Headi ng Nanme</ h2>

The syntax for the anchor name is the page name and heading name separated by a hyphen.
Remove all spaces and convert all text to lower case. Convert all punctuation marks to their
URL-encoded equivalent.

Table of Content Zone Macro

You can use the Table of Content Zone macro to mark out a section (zone) within the page from which to create
a table of contents. You can style the headings as a flat list, and place the list of links at the top and bottom of
the section or page, to provide navigation bars similar to web navigation.

Using the Table of Content Zone macro

To add the Table of Content Zone macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
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where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default  Description

location both Specifies where in the zone the output list is displayed: top, bottom, or both,
(1 ocation) which encloses the page zone content.

Output Type list Specifies the layout for the table of contents:

(type)

® list — produces a vertical list, typical of a TOC.
® flat — produces a horizontal menu-type series of links, for example: [Heading 1]
[Heading 2] [Heading 3].

Display false Select to apply outline numbering to your headings, for example: 1.1, 1.2, 1.3.
Section

Numbering

(outline)

List Style none Specifies the style of bullet point for each list item. You can use any valid CSS
(style) style. For example:

® none — no list style is displayed

® circl e -- the list style is a circle

di sc — the list style is a filled circle. This is the typical bullet list, and is the
one we're using for this example list

squar e — the list style is a square

deci mal — the listis numbered (1, 2, 3, 4, 5)

| ower - al pha — the list is lower-case, alphabetized (a, b, c, d, e)

| ower - r oman — the list style is lower roman numerals (i, ii, iii, iv, v, vi)
upper - r oman — the list style is upper roman numerals (1, II, lll, IV, V, VI)

Heading Sets the indent for a list output type, according to CSS quantities. Entering "10px"
Indent will successively indent list heading levels by 10px. For example, h1l headings will
(i ndent) be indented 10px and h2 headings will be indented an additional 10px.

Separator brackets Only applies to the flat output type. Specifies the display style of the links. You
(separator can enter any of the following values:

)

bracket s — Each item is enclosed by square brackets: [ ].

br aces — Each item is enclosed by braces: { }.

par ens — Each item is enclosed by parentheses: ().

pi pe — Each item is separated by a pipe:

anything — Each is separated by the value you enter. You can enter any text
as a separator, for example "***', If using a custom separator, be aware that
text displays exactly as entered, with no additional white space to further
separate the characters.

Minimum 1 Select the largest heading level to start your TOC list. For example, 2 will list h2,
Heading h3, and h4 headings, but will not include h1 headings.
Level

(minLevel)
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Max 7
Heading

Level
(maxLevel )

Include
Headings
(i ncl ude)

Exclude
Headings
(excl ude)

Printable true
(printabl e

)

CSS Class
Name
(cl ass)
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Select the smallest heading level to include in the TOC. For example, 2 will list h1
and h2, but will not include h3 and below.

Filter the included headings according to specific criteria. You can use wildcard
characters. See Sun's Regex documentation for examples of constructing regular
expression strings.

Exclude headings according to specific criteria. You can use wildcard characters.
See Sun's Regex documentation for examples of constructing regular expression
strings.

By default, the TOC is set to print. If you clear this parameter, the TOC will not be

visible when you print the page.

If you have a custom TOC in your CSS style sheet, you can use this parameter to
output the TOC with the specified "class" attribute.

The examples are based on a page with the following headings:

» Places

e Fayvourite Places
= Lnknown Places

» Foods

= Favourite Foods
e Unknown Foods

= Things

e Favourite Foods
= Lnknown Foods

Filtered Table of Contents

This example will filter all headings to include those that contain "Favorite", but will exclude any heading which
ends with the word "Things". The list is styled with upper-case Roman numerals.

Parameter Value
Output Type list
List Style upper - roman

Include Headings

Exclude Headings

Favourite.*

. *Thi ngs

Screenshot: Filtered TOC 'zone' headings

Favourite Places
Favourite Foods
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Flat List

This example will filter all headings to render a flat list of "Unknowns" enclosed in square brackets.

Parameter Value
Output Type flat
Separator brackets

Max Heading Level 2

Include Headings Unknown. *

Screenshot: Filtered TOC 'zone' headings displayed as a flat list

[ Unknown Places ] [ Unknown Foods ] [ Unknown Foods ]

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: t oc- zone

Macro body: Accepts rich text.

{toc-zone: pri nt abl e=f al se| maxLevel =2| ni nLevel =2| | ocati on=t op|type=flat| o
utl i ne=true| separ at or =pi pe}

Only headings within this block are included in the table of contents.
{toc-zone}

Notes

® Due to an outstanding issue in the Table of Content Zone macro (CONF-10619), the Macro Browser's Ref
resh function does not render any parameter modifications. Currently, the rendering of parameter value
modifications to the Table of Content Zone macro occurs only after the page is saved.

® Using HTML heading markup with the Table of Content Zone macro — The Table of Content Zone macro
cannot handle HTML heading markup on its own. Hence, if you used the HTML and HTML Include macro
s to render HTML heading markup in a Confluence page, the Table of Content Zone macro will not create
a contents list out of these headings. (For more information on about this issue, please refer to TOC-93.)

However, if you insert an HTML anchor into each HTML heading on your page (based on the following
syntax), the Table of Content Zone macro will incorporate these headings into your contents list.

<h2><a nane="pagenane- headi ngnane" ></ a>Headi ng Nane</ h2>

The syntax for the anchor name is the page name and heading name separated by a hyphen. Remove all
spaces and convert all text to lower case. Convert all punctuation marks to their URL-encoded equivalent.

Task Report Macro

Use the Task Report macro to display a list of tasks on a page. Filter the
tasks by space, page, user, label, created date and more.

See Add, Assign, and View Tasks for more information on creating and
assigning tasks. You can also use the Task Report blueprint, which will
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create a page and add this macro for you.

Using the Task Report macro

To add the Content Report Table macro to a page:

1. In the Confluence editor, choose Insert > Other Macros

2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of

317

On this page:

® Using
the Task
Report
macro

®* Parameter
S

Related pages:

the macro name, to see a list of suggested macros. Details are in Autocompl * Add,
ete for links, files, macros and mentions. Assign,
. - . . and View
To edit an existing macro: Click the macro placeholder and choose Edit. A Tasks
macro dialog window will open, where you can edit the parameters of the
macro.
Task Report macro showing incomplete tasks, on pages with the label 'meeting-notes'.
Meeting actions this month
Created and last modified by Rach Admin a minute ago
Description Due date Assignee Task appears on
Leah Admin | to schedule a follow up meeting Leah Admin 2014-03-25 Meeting notes
Ewan User| to finish creating the new project space by =10 Mar 2014 10 Mar 2014  Ewan User 2014-03-25 Meeting notes
Josh User| add designs to the project space's file list by [ 02 Apr 2014 02 Apr2014  JoshUser  2014-03-29 Meeting notes

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Required Default
Space(s) and No None
Page(s)

(spaceAndPage)

Label(s) No None
(1 abel s)

Assigned to No None
(assi gnee)

Created by No None
(creator)

Description

Filter by the task location. The
macro will only display tasks in
the pages or spaces specified.
You can enter a combination
of spaces and pages.

Filter by Label. The macro will
only display tasks on pages
with this label. You can enter
multiple labels, separated by a
comma.

Filter by Assignee. The macro
will only display tasks
assigned to the users
specified.

Filter by Creator. The macro
will only display tasks created
by the users specified.
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Created after No None Filter by created date. The
(creat eddat eFrom macro will only display tasks
) created on or after the date

specified. Date must be
entered as dd- mm yyyy.

Task status Yes Incomplete Show complete or incomplete

(status) tasks.

Number of tasksto  No 20 The number of tasks to display

display on each page of results in the

(pageSi ze) table. Choose from 10, 20 or
40.

Display columns No description,duedate,assignee,location Columns to include in the

(col ums) table. Available columns

include description, duedate,
assignee, location,
completedate and labels.

Sort by No Due date Sort tasks by due date,
(sort By) assignee or page title.

Select the Reverse Sort check
box to sort the table in reverse
order.

Wiki markup

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.
User List Macro

The User List macro displays a list of Confluence users, based on their group membership. The macro can also
indicate when users are online or offline.

Using the User List macro

To add the User List macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
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Group(s) none Specify the group name. Specify multiple groups separated by a comma,
(groups) or use * to show all users in Confluence.

See this knowledge base page for more information about controlling
which users can see the details of other users.

Displa All _ ) . . .
Onl?ne¥0ffline registered List online or offline users. Leave blank to show all users, irrespective of
Users users status.

(online) Accepted values:

® Unspecified — The macro will show all registered users.
® true — The macro will show only online users.
® fal se —The macro will show only offline users.

See below for information on how to configure this macro to display online
/ offline users.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: user | i ster

Macro body: None.

{userlister:groups=confl uence-users|online=fal se}

Configuring the User List macro

In order to use the Display Online / Offline Users parameter to indicate whether users are currently logged in
to Confluence, you will need to enable the User Log In Listener component in the add-on that provides this
macro. You'll need Confluence Administrator permissions to do this.

To enable the Display Online/Offline Users filter in the User List macro:

1. Goto

> Add-ons
2. Select System from the drop down and search for the User Lister add-on
3. Expand the add-on and enable the User Log In Listener module.
4. Restart Confluence for the change to take effect.

User Profile Macro

The User Profile macro displays a short summary of a given Confluence user's profile. This is the same
summary that appears in a Hover Profile, which appears whenever you mouse over a user's name in the
Confluence interface.

Screenshot: Example of the User Profile macro

Created in 2017 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/
https://confluence.atlassian.com/pages/viewpage.action?pageId=329974674

Confluence 6.3 Documentation 320

Leah Admin
sample@email.com.au

Updating Confluence documentation
Position:  Tech Writer
Department: Department of Awesome
Location:  Aflassian, Sydney

Using the User Profile macro

To add the User Profile macro to a page:

1. In the Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
Username none The username of the Confluence user whose profile summary you wish to show.
(user)

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in the
sidebar, header or footer of a space.

Macro name: profil e

Macro body: None.

..............................................................................................................................................................................

View File Macro

The View File macros are going away in a future release

Read more about this change or find out about a better way to insert Office and PDF files

The View File macros allow you to embed an Office or PDF document on a page. First attach the document to a
page and then use one of the View File macros to display the document's content.

When people view the page, they will see the content of the Office or PDF document. They do not need to have
Office installed in order to see the content of the file.
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For a full list of Office Connector prerequisites and limitations, please refer to:

® Office Connector Prerequisites
® Office Connector Limitations and Known Issue

Displaying an Office or PDF Document in Confluence

To display an Office or PDF document in a page, use one of the following View File macros in the macro
browser:

Office Excel
Office PowerPoint
Office Word

PDF

To add one of the View File macros to a page:
1. Inthe Confluence editor, choose Insert > Other Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Autocomplete for links, files, macros and mentions.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,

where you can edit the parameters of the macro.

Parameters for the Office and PDF macros

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Macro Parameter Default Description
All View Page The page Enter a page name, if you wish to display a document which is
File Name which attached to another Confluence page.
macros contains the
macro
File Name none The file name of the Office or PDF document to be displayed. The
document must be attached to a page on your Confluence site.
Office Show true Select to show grid lines around each cell of the Excel spreadsheet.
Excel Grid? Clear to hide these grid lines.
Worksheet Last The name of the worksheet that you want displayed.
Name worksheet
viewed in
the
spreadsheet
Last Row  Lastrow The number of the last row you want displayed, starting from '0' as
with content  the first row.
Last Last column The number of the last column you want displayed, starting from '0’
Column with content  as the first column.

Hint for reducing the size of the spreadsheet: Use the Last
Column and Last Row parameters to reduce the size of the
spreadsheet displayed on the wiki page. This is especially useful to
prevent the display from showing empty cells. This will also help to
prevent 'out of memory' errors.
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Office Height Specify the height of the display, in pixels (default) or as a
. percentage of the window's height.
PowerPoint
Slide none Specify the number of the slide that you want displayed on the
Number Confluence page, where the first slide is numbered zero. Instead of

a slide show, the page will display just the single slide, represented
as a JPEG image. If not specified, all slides display as a slideshow.

Width Specify the width of the display, in pixels (default) or as a
percentage of the window's width.

Editing an Office document

You can launch your Office application and edit Office documents displaying in the view file macros directly from
your Confluence page.

®* Word and Excel - choose the Edit Document link above the content
® PowerPoint - choose the edit icon on the viewer.

You will find more information and other methods for editing attached Office documents in Edit Office Files.

Troubleshooting

Problems? Please refer to our guide to the Office Connector limitations and known issues.

Widget Connector Macro

Embed online videos, slideshows, photostreams and On this page:
more directly into your page with the Widget ) i
Connector macro. ® Using the Widget Connector
¢ Parameters
The macro currently supports content from these ® Examples
sites: ® YouTube
®* Vimeo
® YouTube * MySpace Video
®* Vimeo :
) ® Flickr
® MySpace Video O Tt
* Flickr e
: ¢ SlideRocket
* Twitter * Google Calendar
® Slide Rocket O TreulHEsnest
® Google Calendar roeshooting
® Wiki markup example

Using the Widget Connector

To add the Widget Connector to a page:

1. In the Confluence editor, choose Insert > Oth
er Macros
2. Find and select the required macro

Speeding up macro entry with autocomplete: Typ
e { and the beginning of the macro name, to see a
list of suggested macros. Details are in Autocomplet
e for links, files, macros and mentions.

To edit an existing macro: Click the macro
placeholder and choose Edit. A macro dialog
window will open, where you can edit the
parameters of the macro.

Parameters
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Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter  Description

Web Site's  This is the external site's URL. In some sites this will be the URL shown in the address bar
Widget of your browser, and in other sites you may need to click a Share or Link button to get the
URL URL.

(url)

Pixel The height of the display, in pixels.
Height

(Value

Only)

(hei ght)

Pixel Width  The width of the display, in pixels.
(value

Only)

(wi dt h)

Examples

Every site is a little different, so we've put together some info on what you'll need to do to embed each site's
content on a page.

YouTube

The fastest way to embed a YouTube video is to paste the URL into the editor. Confluence will autoconvert
the link and insert the macro for you, like magic. Autoconvert works with both long and short YouTube
URLs.

If you're pasting the URL into the Widget Connector macro URL field manually, you'll need to use the long
URL (from the address bar). Long URLs look something like this ht t ps: // www. yout ube. com wat ch?v=
k6l Kshl B1nQ

Atlassian Keynote in 7 minutes - Atlassian Summit 2014 L

WAtlassian

® |f you're not able to see the video in some browsers, try using https rather than http in your
link.

® Links that contain a parameter to start a video at a particular time won't autoconvert or work in
the Widget Connector macro, like this link: ht t ps: / / waw. yout ube. conf wat ch?t =15&v=L
hHKk odOPFo. Paste in the short sharing URL to be sure it works.
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Vimeo

The fastest way to embed a Vimeo video is to paste the URL into the editor. Confluence will autoconvert the
link and insert the macro for you.

You can use the URL from the address bar in your browser or the Share button in Vimeo.

MySpace Video

We don't autoconvert MySpace videos, so you'll need to add the Widget Connector macro to your page first,
and then paste the video's URL into the URL field.

You can use the URL from the address bar in your browser or the Sharing options in MySpace.

Flickr

You can embed a single photo, a set, an entire user's photo stream or collection of photos with a particular
tag.

The fastest way is to paste a URL into the editor. This works for sets and tags. For other URLs you'll need to
add the Widget Connector macro to the page first and then paste your link into the URL field.

Use the URL from the address bar in your browser.

flicl([‘f' & Atlassianexperience’s photostream

Twitter

To embed a single tweet you'll need to click the Details link on the tweet so you can grab the URL for just
that tweet. The URL will look something like https: //twitter.com atl assi an/ st at us/ 3469765212

50037760.
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atlassian W Follow

% @atlassian

Want to edit your @Confluence pages in fullscreen? Now
you can with the distraction-free editor — avail. now
ow.ly/m8d5Y #e2conf

11:03 PM - 18 Jun 2013

S5 RETWEETS J FAVORITES

To embed a dynamic list of tweets you'll need to create a Widget in Twitter first:

1.
2.

3.

In Twitter, go to Settings and Privacy > Widgets and create a new widget (search).

In Search Query, choose if want to search for a hashtag or a profile (for example,

#atlassian, @atlassian).

Create widget and copy only the data-widget-id from the HTML code generated (it should look
something like this example "854765133465255939").

The URL that you want for the Widget Connector Macro should look something like this htt ps: //tw
itter.com settings/w dgets/854765133465255939 (the numbers after the slash will be
different, you must change for the ones that you're going to generate in Twitter widget).

In Confluence, paste the URL into the Widget Connector.

The list of tweets will display, like this one below.

Tweaeats »F Follow @confluence

% Atlassian Confluence 2dul *
¥ Gconfluence L4

Walking the requirements
documentation tightrope in an agile
world atlss.inf12hgGlh via @atlassian

Expand

Y Atlassian Confluence 27 Jun
b

@confluenca

Keep up-to-date with the new Watch
button in Confluence — available
today! ow lyimagm 1l #collaboration

#atlassian

Tweet to @confluence

SlideRocket

We don't autoconvert SlideRocket presentations, so you'll need to add the Widget Connector macro to your
page first, and then paste the video's URL into the URL field.

You can get the URL from the Sharing button on the SlideRocket player.

Google Calendar

We don't autoconvert Google Calendars, so you'll need to add the Widget Connector macro to your page
first, and then paste the calender address into the URL field.
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You can only embed public calendars. To get your calendar's URL, in Google Calendar go to Calendar
Settings > Calendar Address and click the HTML button.

The URL will look something like this: htt ps: / / ww. googl e. coni cal endar/ enbed?sr c=en. aust r al
i an%23hol i day%0gr oup. v. cal endar . googl e. com&ct z=Aust r al i a/ Sydney

Troubleshooting

If the Widget Connector can't display content from the external site, the macro will look like this:

We rely on the external website's APIs to display content in the Widget Connector macro. APIs do change
from time to time and this can cause the Widget Connector macro to stop rendering content.

If you experience problems, you can raise an issue about it to let us know.

Wiki markup example

This example is useful when you want to add a macro outside the editor, for example as custom content in
the sidebar, header or footer of a space.

Macro name: wi dget

Macro body: None.

.........................................................................................................................................................................

{wi dget : hei ght =400| wi dt h=400| ur| =htt p://yout ube. conf wat ch?v=23pLByj q
s5U}

Your profile and settings

Confluence is very flexible — not only in the many ways you can create and Related pages:
share content, but also in how you can tailor your own Confluence
experience. Things like your profile picture, favorite spaces and pages, and * Watch
your personal space can say a lot about you, and can also make navigating Pages,
Confluence much quicker and easier. Even a simple thing like adding Spaces
shortcut links to the sidebar of your personal space, can save you a lot of and Blogs
time in finding the things you use all the time. ¢ Create a
Space

Set up your personal space, and take a look at any of the pages below, to ® Save for
start making Confluence feel like home. later

® Your User Profile

® Change Your Password

® Edit Your User Settings

® Set Your Profile Picture

® Choose Your Home Page

® Save for later

[ ]

View and Revoke OAuth Access Tokens

Your User Profile

Your user profile contains basic information about you, which other
Confluence users can see. It's also displayed to other users when they click
your name in the People Directory, if you haven't set up your personal space

In your own profile, you can access account management features and
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update information about yourself, like your name, email address, and pass On this page:
word. You can also view other users' profiles. .
® Find your
user profile
Find your user profile ® Edit your
user profile
To find your user profile: ®* Notes
Choose your profile picture at top right of the screen, then choose Profile, or Related pages:
choose the Profile link in the sidebar of your personal space.
® Set Your
To find someone else's user profile: Profile
Picture
¢ Create a
Personal
Space

Hover your mouse pointer over a user's linked name or profile picture and choose the user's linked name to
open their user profile. Alternatively, you can choose the Profile link in the sidebar of their personal space,
or go directly to this URL:

i http://your.confluence. site/users/viewserprofile.action?usernane=USE i
i RNAME i

Screenshot: User profile screen for the current user

People =
# Edit profile
Josh User -
Profile Network Favourites Waiches Drafts Seftings
Personal Space
About Me Personal
PROFILE Hi t.here. I'm Josh and u.nfcrr'lunately.r | am completelg Full Name  Josh User
Details fictional. If | was a real live person | think | would quite
like to be a fech writer. Email sample@email com au
Picture
Password ACtiVity Phone +55 987 654 321
& Josh User M
profile updated about 5 hours ago Website  hitp-/fwww.atlassian.com
[2) Josh User's Home
created about 5 hours ago
@ Josh User
created about 5 hours ago Company
Position  Tech Writer
Department Confluence
Location Sydney
From your user profile, you can access the following:
Profile ® View and edit your personal details, such as your name and email address details and

optionally, your photograph and other personal information. Note that as a security
precaution, in order to change your email address, you will be required to re-enter your
password.

® Upload a profile picture (optional).

® Change your password.
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Network View the recent activity of users that you are following via the Network view.

Follow other users from this view.

Favorites e View a list of your favorite spaces.
Watches * View a list of the pages and spaces you are currently watching.
Drafts ® Retrieve any pages you were in the process of editing. See Working with Drafts.

Settings Edit your General Settings (homepage, language and timezone).

Subscribe to email notifications.
® View and revoke your OAuth access tokens.

Edit your user profile

1. Choose your profile picture at top right of the screen, then choose Profile
Or, choose the Profile link in the sidebar of your personal space.

2. Choose Edit Profile

3. Enter details about yourself in the form displayed

4. Choose Save

Fields in your user profile:

Detail Description

Full Name Your name as you'd like it to appear in your profile.

Email Your email address that will be used to send you mail notifications.
Phone Your phone number.
IM Your Instant Messenger (IM) details.

To suit a variety of IM applications, this option accepts any string value. For example, you
can enter IM details in the form of an email address, or a user ID, like '123456789'.

Website Your website's URL.

About me Information about yourself that other users can view (such as your professional information,
hobbies, and other interests). You can use Confluence wiki markup in this field.

Position Your title or position within your organization.

Department The name of your department or team.

Location Your location. This can be your town, city, region or country.
Handy Hint

Confluence administrators can configure Confluence to mask email addresses (e.g. 'example at
atlassian dot com'), protecting your email address from search engine spiders and the like.

Notes

The 'Administer User' link is visible to Confluence administrators only. The administrator can click this link to
go directly to the user management screen in the Administration Console.

Change Your Password

There are two scenarios where you may want to change your Confluence
password:
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® You're logged in, but you want or need to change your password
® You've forgotten your password and can't log in, so you need to reset
your password

Change your password when you're logged in:

1. Choose your profile picture at top right of the screen, then choose Pr
ofile

2. Onyour Profile tab, click Password in the left-hand column

3. Enter your current password and your new password in the form
displayed

Related Topics:

® Your User
Profile

® Set Your
Profile
Picture

® Create a
Personal
Space

4. Click Submit

Reset your password from the login page:

If you've forgotten your password and need to reset it, you can do so from the Confluence login page.
Choose the 'Forgot your password?' link and Confluence will step you through the process to reset your

password.

Edit Your User Settings

If you want to make Confluence fit you, like a well-worn pair of sneakers,
you can set some preferences that will make you feel more at home:

General preferences such as home page, language and time zone
Editor settings

Email settings for subscriptions to email reports.

OAuth access tokens that you have granted from your Confluence
user account.

General User Preferences

To edit your general user settings:

1. Choose your profile picture at top right of the screen, then choose S

On this page:

® General
User
Preference
S

®* More
about
Language

* Editor
Preference
S

Related pages:

. ® Your User
ettings Profile
2. Choose Edit and update the settings e Set Your
3. Choose Submit Profile
Picture
® Create a
Personal
Space
® Autocompl
ete for
links, files,
macros
and
mentions
Setting Description
Site Homepage Select the page that you would like to see whenever you log into Confluence.
Language Select your language. See below.
Time zone Select your time zone.

Use Keyboard Shortcuts Enable keyboard shortcuts, other than for the editor.

Text select Turn off the popup options panel when highlighting text.
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Screenshot: Editing your user profile settings

Profile  MNetwork Favourites Watches Drafts Settings

GADGETS Settings

View OAuth Access Tokens Ny _
Site Homepage Site Default {Dashboard) E|

YOUR SETTINGS , )
Language Automatically detect browser settit |Z|

Password : : :
This feature is currently in development. Learn Maore

Email
Time zone | Site Default ((GMT+1000) Sydney [=]
Editor

Keyboard Shoricuts Enable

Enable keyboard shortcuts (does not apply to editor shortcuts).

Keyboard Shortcuts™ from the Browse menu to see available si
Text select Show option panel when fext is selected

Supmit | Cancel

More about Language

Setting your language preference in your user profile is described in the section above. This section gives
more information about that setting and other settings that affect the language Confluence will use.

Individual users can choose the language that Confluence will use to display screen text and messages.
Note that the list of supported languages depends on the language packs installed on your Confluence site.

The language used for your session will depend on the settings below, in the following order of priority from
highest to lowest:

®* The language preference defined in your user profile. Note that you need to be logged in for this
setting to take effect.

®* The language that you choose by clicking an option at the bottom of the Confluence login screen.
Confluence stores this value in a cookie. When the cookie expires, the setting will expire too.

® The language set in your browser. The browser sends a header with a prioritized list of languages.
Confluence will use the first supported language in that list. Confluence administrators can disable this
option by setting the conf | uence. br owser . | anguage. enabl ed system property to f al se.

® The default language for your site, as defined by your Confluence site administrator.

Editor Preferences

You can set some options that determine the way the Confluence editor works. Note that these settings
affect only you. Other people using Confluence can enable or disable the settings on their user profiles
independently.

To change your editor preferences:

1. Choose your profile picture at top right of the screen, then choose Settings
2. Click Editor under 'Your Settings' in the left-hand panel
3. Click Edit and make your changes

Created in 2017 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/
https://confluence.atlassian.com/display/CONF63/Configuring+System+Properties

Confluence 6.3 Documentation 331

4. Click Submit

Setting Description

Disable Select to disable autocompletion when you press one of the trigger characters.
Autocomplete

Disable Select to disable autoformatting when you type wiki markup in the editor. Click ? on
Autoformatting the editor toolbar to learn more.

Screenshot: User settings for the editor

People

Rach Admin

—

Profile  Metwork Favourites Watches Drafts Settings

GADGETS
View OAuth Access Tokens . .
Editor Settings
YOUR SETTINGS Disable Autocomplete
Password Disable Autocomplete in the Editor, where it allows links to be inserted with the
Email trigger [ and images with the trigger .
Editor Disable Autoformatting

Disable Autoformatting in the Editor, where it allows wiki-formatted text to be
converted to its Rich Text equivalent (e.g. "h1. title” for a heading).

Edit

Set Your Profile Picture
Your profile picture is used as the icon for your personal space, to represent

you in the People Directory, and to illustrate your comments. It also appears Related pages:
in various other places next to your name, such as in the list of recent ® Your User
updates on the dashboard. Profile
When you upload your profile picture, you can resize and reposition it to ¢ Create a
make sure it looks great. Personal
Space
Upload and adjust your profile picture: ® Your
_— . profile and
1. Choose your profile picture at top right of the screen, then choose Pr ti
ofile NI
2. Choose Picture on the left
3. Choose Upload image > Upload an image
4. Locate and select the picture on your computer or file server
5. Adjust the size and position of your photo, then choose Save
Screenshot: Choosing a profile picture Screenshot: Resize your

profile picture
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ﬂ: People Upload a profile picture
ws. Josh User

Profile Tasks Favourites Watches Drafts MNetwork Settings

PROFILE

Picture Your profile picture is used as the icon for your personal space,

w and to represent you in Confluence.
5
V

:} A =

Upload Image
You can't remove your profile picture, but you can upload a new one any N
time.

Upload an image

Choose Your Home Page

The dashboard is the default landing page when you log into Confluence. It Related pages:

gives you easy access to what's happening in your site, and helps you get

back to pages you recently viewed and worked on. * Your
profile and

You can choose to personalize your experience. and use an existing space settings

home page as your landing page. ® Your User
Profile

To set your home page:

1. Choose your profile picture at top right of the screen, then choose S
ettings

2. Choose Edit

3. Choose an option from the Site Homepage drop down.
Only spaces you're allowed to view will appear.

4. Choose Submit.

You'll be directed to your new home page the next time you log in. You can change your personal home page
at any time.

Alternatively, if your Confluence administrator has set a space home page as the landing page for the whole
site, you can choose Dashboard from the Site Homepage drop down to use the dashboard as your landing
page.

Screenshot: Profile Settings
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Profile Network Favourites Watches Drafis Settings

GADGETS Sel‘tings

View OAuth Access Tokens N _
Site Homepage = Site Default (Dashboard) (=]

YOUR SETTINGS . )
Language | Automatically detect browser settin=]

SSWOTr
Password Find more language packs on the ﬁ Aflassian Marketplace. ..
Email
Time zone Site Default ((GMT+1000}) Sydney_E
Editor

Use Keyboard Shortcuts
Enable keyboard shortcuts (does not apply to editor shortcuts). Select
Keyboard Shortcuts™ from the Browse menu to see available shortcuts.

Submit Cancel

ﬂ You can access the dashboard at any time using the dashboard URL. It'll look something like this: ht t ps
://yoursite.com w ki /dashboard. acti on.

Save for later

Saving pages for later helps you access them quickly from the dashboard or On this page:
from your profile.
® Savea
No time to read that page now? No problem, hit Save for later and it'll be page for
waiting for you on the dashboard when you have more time. It's also a later
great place to store those pages that you use on a day to day basis. ® Get back
. . to your
Save for later was previously called Favorites. -
pages

Save a page for later

To save a page for later, hit the Save for later button at the top of the page.

The star icon will change to dark grey to indicate the page is saved. Hit the
button again if you want to remove the page from the list.

Get back to your saved pages

To view your saved pages:

® Choose Saved for later on the dashboard sidebar.
® Choose your profile picture at top-right of the screen, then choose Saved for later — there's a list of
your saved pages, and the spaces that you've added to My spaces.

You can also use the Favorite Pages Macro to include a list of your saved pages on any page.

Screenshot: Viewing and removing saved pages from the dashboard
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= XConfluence Spaces- People Questions Calendars Create -»

DISCOVER Saved for later
s= All updates
+7 Popular THIS WEEK
MY WORK (5] Meeting Notes
pd
(5 Recently worked on (3] When should we launch?
(© Recently visited
. [ Meet the SeeSpaceEZ Team x
MY SPACES All @ Teams in Space Roadmap

@ Demonstration Space

@ Teams in Space

View and Revoke OAuth Access Tokens

OAuth access tokens allow you to use a Confluence gadget on an external On this page:
web application or website (also known as the 'consumer’) and grant this
gadget access to Confluence data which is restricted or privy to your

® View your

Confluence user account. OAuth
Access
OAuth access tokens will only appear in your user profile if the following Tokens
conditions have been met: ® Revoke

s : . . our
1. Your Confluence Administrator has established an OAuth relationship é Auth
between your Confluence site and the consumer. A

o S ccess
Confluence Administrators should refer to Configuring OAuth for Tokens

more information about establishing these OAuth relationships.
2. You have accessed a Confluence gadget on the consumer and have Related pages:
conducted the following tasks:

a. Logged in to your Confluence user account via the gadget and * Configurin
then, g OAuth
b. Clicked the 'Approve Access' button to allow the gadget for
access to data that is privy to your Confluence user account. Cc;\rglu.enc
e Admins

ﬂ Confluence will then send the consumer an OAuth ‘access
token', which is specific to this gadget. You can view the
details of this access token from your Confluence site's user
account.

An OAuth access token acts as a type of 'key'. As long as the consumer is in possession of this access
token, the Confluence gadget on the consumer will be able to access Confluence data that is both publicly
available and privy to your Confluence user account. As a Confluence user, you can revoke this access
token at any time. Furthermore, all access tokens expire after seven days. Once the access token is revoked
or has expired, the Confluence gadget will only have access to publicly available Confluence data.

View your OAuth Access Tokens

To view all of your Confluence user account's OAuth access tokens:

1. Choose your profile picture at top right of the screen, then choose Settings

2. Click View OAuth Access Tokens. A view similar to screenshot below is displayed. Refer to OAuth
Access Token Details below for information on interpreting this table.
@ f no access tokens have been set, then 'None specified' is shown.

Screenshot: Viewing your OAuth Access Tokens
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Authorised Applications

The following applications are using your account to access Confluence data

Consumer Consumer Description Issued on Actions
Atlassian JIRA Special Projects Atlassian JIRA at hitps.//atlassian.com/jira Jan 23, 2013 expires in 1.801 days Revoke Access

OAuth Access Token Details

Your list of OAuth access tokens is presented in a tabular format, with each access token presented in
separate rows and each property of these tokens presented in a separate columns:

Column Description
Name

Consumer  The name of the Confluence gadget that was added on the consumer.

Consumer A description of this consumer application. This information would have been obtained from
Description the consumer’'s own OAuth settings when an OAuth relationship was established between
Confluence and that consumer.
If the consumer is another Atlassian application, this information is obtained from the Consu
mer Info tab's 'Description’ field of the OAuth Administration settings. The application's
administrator can customize this Consumer Info detail.

Issued On  The date on which the OAuth access token was issued to the consumer by Confluence. This
would have occurred immediately after you approved this gadget access to your Confluence
data (privy to your Confluence user account).

Expires On The date when the OAuth access token expires. This is seven days after the ‘'Issued On'
date. When this date is reached, the access token will be automatically removed from this
list.

Actions The functionality for revoking the access token.

Revoke your OAuth Access Tokens

To revoke one of your OAuth access tokens:

1. View your Confluence user account's OAuth access tokens (described above).

2. Locate the Confluence gadget whose OAuth access token you wish to revoke and click Revoke
OAuth Access Token next to it.
The gadget's access token is revoked and the Confluence gadget on the consumer will only have
access to publicly available Confluence data.

Collaboration

Confluence is all about encouraging team collaboration to get the best Related pages:
results, so we've built in a number of ways you can notify other people about .
content that may be of interest to them. Pages and
blogs
You can: ® Watch
. . Pages,
® Work together with your team on a page or blog and see their Spaces
changes in real time
. . . and Blogs
® Share a link to a page or blog post via email * Export
Mention a user when you write a page, blog post, comment, or add a G
task
. Word,
® |ike a page, blog post or comment PDE
Whenever you mention another user, they'll receive an email notification; if HTML and
XML
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you like a page, blog post, or comment, the author will be notified that you lik
e the content.

Other users can also find out about changes to content in Confluence by wat
ching pages and spaces.

Another way to share Confluence content is by exporting it to other formats
such as XML, HTML, Microsoft Word and PDF-.

Network Overview

You can Create a network of users who are important to you, to make sure On this page:
you're always up-to-date with their Confluence activity. You might want to

follow your boss or teammates, to see what they're working on, or whoever * Follow
creates the most entertaining blog posts. another
user
When someone's part of your network, you'll be able to see when they: ® Access
i our
® Add or edit pages or blog posts zetwork
® Comment on a page or blog post or edit existing comments -
® Update their user profile e Notes

Related pages:

Follow another user O Nk
. . . ' Macro
You can follow another user by using either their Hover Profile or your e Subscribe
Network view.
to a
To follow a user with their Hover Profile, hover your mouse over their profile Network
picture when it appears in a page and choose Follow. RSS Feed
® Email
Notification
S

To follow a user from your Network view:

1. Choose your profile picture at top right of the screen, then choose Network
Alternatively, choose More in the Network section of your profile sidebar.

2. Search for and select the user in the Following field

3. Choose Follow

If you now refresh or revisit your Network view, the profile picture(s) of the user(s) you just followed will
appear within the Following list on the right. Their tracked activities will also start appearing in the Recent
Activity list.

Access your network view

If you want to see what's been happening in your network, access your network view as described above.
You can access another user's Network view using the Hover Profile by choosing More > Network Page.

Screenshot: Example of the Network view
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People
Rach Admin
Profile  Network Favourites Watches Drafts  Settings
Recent activity of the users you are following (=]

=l Ewan User
! (2 Step 1 - download the game commented about an hour ago

[5) Step 2 - Play updated about an hour ago « view change

Why | loved Angry Nerds created about an hour ago

Josh User

[3) Ideas for Angry Nerds 2 - revenge of the... updated about 2 hours ago - view change
[2) Games as a communication medium created about 2 hours ago

¢ Which nerd are you? commented about 2 hours ago

Following

You are following 3 users
L)
AR

User name

Followers

You have one follower
L

j-4

-

Follow

Sophie User
This is a sample blog created about 2 hours ago

Notes

® RSS feeds: you can subscribe to any Confluence user's network RSS feed and receive summaries on
the activities of other users they're following in their network. See Subscribe to a Network RSS Feed.
®* Email notifications: you can request email notifications of any activity in your network. See Email

Notifications.

Likes and Popular Content

Has someone written a good blog post or page on Confluence? Or made a
comment you agree with? Click the Like button to them know.

i3 Like

When you like a page, blog post or comment, the author of the content
receives a notification. If enough people like the content, it'll appear on the P
opular tab of the dashboard.

Disabling the 'like' feature

The like functionality is provided by a plugin called the 'Confluence Like
Plugin'. To remove the like functionality from your site, disable the plugin.

Disabling notifications when your content is 'liked'

There are two ways to turn the 'someone likes your page' notifications off.
Do either of the following:
® Open an email notification of a like, and click Manage Notifications
® Goto<your confluence

URL>/ pl ugi ns/ i kes/view notifications.action

Mentions

Mentions (often known as @mentions) are a seamless way of drawing
someone's attention to a page or comment, or assigning a task to them.
When you mention a user, they'll receive a notification by email and in their
workbox; if you mention them in a task, the task is assigned to them and
appears in their tasks list.

There are two ways to mention someone: using autocomplete, or via the

On this page:

® Disabling
the 'like'
feature

® Disabling
notification
s when
your
content is
'liked'

Related pages:

® The
dashboard

® Email
Notification
S

® Network
Overview
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Insert menu in the editor toolbar. Related pages:

®* The Editor
Use autocomplete ® Autocompl

ete for
links, files,
macros
and
mentions

® Keyboard
shortcuts

* \Workbox
Notification
S

To mention someone using autocomplete, type '@' in the editor then start typing their name. Choose the
person you want to mention from the list of suggestions.

Screenshot: Autocomplete for mentions

| want to mention someone @ josh|

User suggestions

) vosh user

The order Confluence suggests people is influenced by your network and the people you interact with on a
regular basis. People you follow or who are following you will be suggested first.

Use the Insert menu

If you'd rather use the Insert menu, choose Insert > User Mention then search for and select the user you
want to mention.

Notes

® Disable the user mention feature — The functionality is provided by a plugin called the 'Confluence
Mentions Plugin'. If you need to remove the user mention functionality from your site, you can disable
the plugin. See Disabling or Enabling a Plugin.

® Mentioning groups — You can only mention individual users. There's a feature request to allow

CONFSERVER-23015 - Extend 'Mentions' to work with groups as well

mentions for groups: |OPEN

® Link to a user profile — You can use a square bracket '[' and a person's name to trigger Confluence
autocomplete and link to a person's user profile or personal space. Confluence will send the person a
notification just as if you had used @mention (unless the administrator has disabled the user mention
feature).

Share a Page or Blog Post

Use the Share button when viewing a page or blog post to email anyone a
link to that page or blog post. You can either grab the short URL from the
share dialog, or enter a Confluence user, group or email address.

To share a page or blog post by email:

1. Go to the page or blog post you wish to share.

2. Choose Share.

3. Enter a username, group or email address, and select the appropriate
user, group or email address from the list of suggestions.
Repeat this process to add multiple recipients to the list (or use the
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trash icons to remove people from the list).
4. Enter an optional message.
5. Choose Share to send the link via email.

In addition to an email, Confluence users will also
receive a notification in their Confluence workbox.
See Workbox Notifications.

You can also share pages from inside the editor. Hit
the
+

button in the editor to invite people to edit the page
with you.

Notes:

® The option to add people is only available if
your site has a mail server configured.

® Sharing or inviting someone to edit a page or
blog post does not automatically grant any
permissions - they will still need the
appropriate Confluence permissions to
access Confluence and view or edit the

page.

Comment on pages and blog posts

339

Related pages:

® Workbox
Notification
S

® Create and
Edit Pages

® Blog Posts

® Configurin
g a Server
for
Outgoing
Mail

© Watching 2 Share ees

Share this page

Share link

https://yoursite.com/x/w4BC Copy

Add people

g Alex Yakovlev

g marketing

Include a message

I've made some edits to this page.
Could you please review?

Share Cancel

Comments are a great way to bring others into the conversation about a
page or blog post. They allow you to remark on content, add important
information, ask questions, and generally drive collaboration and teamwork.

You can add a comment at the bottom of any page or blog post, or add an in

line comment by highlighting specific text on the page.

Add a page or blog post comment
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N

4,

Type your comment in the comment field at the bottom of the page
Optionally, choose Preview to see how your comment will appear
By default, Watch this page is ticked (This means you'll start
receiving notifications about the page. Uncheck it if you don't want to
watch the page.)

Choose Save (Ctrl+S or +S)

Other users can reply and/or like your comment, and you or a space
administrator can edit your comment(s).

Add an inline comment

1.
2.

3.

The selected text will appear with a yellow highlight indicating an inline comment; choose any highlighted text

Highlight the text you want to comment on
Choose the add comment

0

button that appears above the highlighted text
Type your comment and choose Save (Ctrl+S or +S)

on the page to display the related comment(s).

On this page:

Add a
page or
blog post
comment
Add an
inline
comment
Resolve
inline
comments
Rich
comments
Link to a
comment
Comment
permission
S

Notes

Related pages:

Create and
Edit Pages

® Blog Posts
® Share and

Comment
on Files
Share a
Page or
Blog Post

Just like page and blog post comments, others can reply to, or like, your inline comments, and you'll be
notified when they do.
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with one click you can start X
omment is about. The page's 42 Giles Brunning

keep your project moving. Text

e comment and any replies. Hi Rachel,

of page comments in inline Can you check the wording on this
ed the JIRA issues macro. very important press release?

d the conversation is stored It must go out, urgently!

any resolved comments if you .
Here's a link to the product page.

Save

o the text you highlight rather

Resolve inline comments

Hit Resolve to hide a set of inline comments once the conversation's finished. If you want to view resolved
comments, choose

LE L]

> Resolved comments; to reopen a resolved comment, choose Reopen at the bottom left.

Rich comments

Inline and page comments might look simple, but they support rich text (like bold, underline, and italics), bull
eted and numbered lists, links, and @mentions. You can also drop images into any comment, to really
illustrate your point.

Link to acomment

You can link directly to a comment on a page. See Links for more information.

If you don't see a popup when you highlight text, check that Text Select is enabled in your profile
settings.

Comment permissions

® Add a comment — You need the 'Add Comments' permission in the space.

® Edit acomment — You need the 'Add Comments' permission. Space administrators can edit all
comments within their space. The date on a comment always indicates the time the comment was last
edited.

® Delete acomment — You need the 'Remove Comments' permission. Deleted comments cannot be
restored. If you don't have the 'Remove Comments' permission, you can delete your own comments,
but only if there are no replies to your comment.

® Disable comments — If you don't want comments in a particular space, remove the ‘Add Comments'
permission from the 'confluence-users' or ‘users' group, anonymous users and all other users and
groups. The option to add comments will no longer appear on pages or blog posts in that space.

See Space permissions for more information. There is no permission that controls comments across the
entire site.

Notes

® Choose Watch at the top-right of the page to receive an email notification whenever anyone edits or
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adds a comment to the page.

® On blog posts only, an 'Author’ lozenge will appear on any comments made by the original author of

the post.

® It's not possible to delete all comments on a page simultaneously, or change the order of comments.

Watch Pages, Spaces and Blogs

You can 'watch' a Confluence page, blog post or space. Confluence will then
send you a notification email whenever anyone updates your watched
content.

You'll receive email notifications for:

Edits (unless the author clears the ‘Notify watchers' check box).
Deletions.

® Attachments, including new versions or deletions of an existing
attachment.

® Comments, including new comments, edits of existing comments or
deletions of existing comments.

By default, Confluence will assign you as a watcher of any page or blog post
that you create or edit. This behavior is called 'autowatch'.

There's no daily digest for email notifications. You'll receive immediate
emails for important notifications (like mentions and new pages), but when
lots of changes are being made at the same time, you'll only receive a single
email with all the changes (within a 10 minute window).

You will not receive email notifications for content changes due to the
output of a macro, because the page content itself hasn't been edited.

You need 'View' permission for the page, blog post or space to receive
notifications.

Watching a page or blog post

To start watching a page or blog post:

1. Go to the page or blog post.
2. Choose Watch and select the relevant check box.
To stop watching the page or post, deselect the relevant check box.

Watching an entire space

You can choose to watch all the pages and blog posts in a particular space.

On this page:

Watching a
page or
blog post
Watching
an entire
space
Watch for
new blog
posts in a
space
Watch all
spaces on
the site
Watching
for all new
blog posts
on the site
Manage
watches
from your
user profile
Manage
watches
from the
email
message
Autowatch
and other
notification
options

Related pages:

The quickest way is to use the Watch option on a page or blog post, as described above.

To stop watching the space, deselect the relevant check box.

Manage
Watchers
Email
Notification
S

Your User
Profile

Alternatively, choose Pages in the space sidebar, then choose Watch this space at the top right.

Watch for new blog posts in a space

You can choose to receive a natification whenever someone adds a blog post in the space. You will not
receive notification of updates to or deletions of blog posts, nor of comments on the blog posts.

To watch for new posts:
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1. Go to a blog post in the space.
2. Choose Watch and select Watch all blog posts in this space.

To stop watching for new blog posts, deselect the relevant check box. Alternatively, choose Blog in the
space sidebar, then choose Watch this blog at the top right.

Watch all spaces on the site

You can receive notifications about changes to the content of pages, blog posts and comments from all
spaces on a Confluence site.

To start watching for content changes across the whole site:

1. Choose your profile picture at top right of the screen, then choose Settings
2. Choose Email.

3. Choose Edit then choose Subscribe to daily updates.

4. Choose Submit.

Watching for all new blog posts on the site

You can choose to watch for all new blog posts in all spaces on the Confluence site. You will not receive
notification of updates to or deletions of blog posts, nor of comments on the blog posts.

To start watching for all new blog posts:

1. Choose your profile picture at top right of the screen, then choose Settings
2. Choose Email.

3. Choose Edit then choose Subscribe to all blog posts.

4. Choose Submit.

Manage watches from your user profile

The 'Watches' page in your user profile displays a list of all pages and spaces you are currently watching.
To manage your watches:

1. Choose your profile picture at top right of the screen, then choose Watches.
2. Choose Stop Watching for any unwanted spaces or pages.

Manage watches from the email message

The email notifications that you receive from Confluence have some useful links at the bottom of the email
message. The links in each message vary, depending on the context. In general, the links allow you to view
the page online, reply to a comment, and so on.

In particular with respect to setting your notification preferences, you will see one or more of the following
links:

® Stop watching page — Click this link to stop watching the page that triggered the email notification.

® Stop watching space — Click this link to stop watching the space that triggered the email notification.

® Stop following this user — Click this link to stop following the user whose update triggered the email
notification.

® Manage Notifications — Click this link to go to the email settings page in your user profile.

Screenshot: Example email notification footer showing links

D Reply = ¢ Like

Stop watching space = Manage Motifications
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Autowatch and other notification options

344

By default, Confluence will assign you as a watcher of any page or blog post that you create or edit. This
behavior is called 'autowatch’. You can turn autowatch on or off, and set other notification options, in the
email settings section of your user profile. See Edit Your User Settings.

Manage Watchers

As a space admin, you may want to control who's notified about changes Related pages:
and updates to pages and posts within a space. You'll do this by managing
the watchers of specific pages and posts, or of the entire space. ¢ \é\g’ggz
Take the example of a new member starting on your team, who should see Spaces
when changes are made in the team space — you can add them as a space and Blogs
watcher so they get updates when any page or post in the space is ®* Email
changed. If someone no longer needs to be notified, you can remove them Notification
as a watcher just as easily. S
* Your
profile and
settings

To manage the watchers of a page or blog post:

1. Go to the page or blog post for which you want to manage the watchers

2. Choose Watch > Manage Watchers

The left-hand column of the 'Manage Watchers' dialog shows the users watching the page or blog
post. The right-hand column shows the users watching the space.

3. Do either of the following:

® Add someone as a watcher of the page, post, or space — type their username in the relevant

search box and hit Add

® Remove an existing page, post, or space watcher — choose the trash icon next to their name

Manage Watchers

Watching this page

Add

ﬁ Gil Admin (gbrunning)

These people are notified when the page is changed.

ab

Watching this space

These people are notified when any content in the sj
changed.

Add

ﬁ Gil Admin (gbrunning)
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Email Notifications

You can 'watch' a page, blog post or space. Confluence will then send you a
notification by email whenever anyone adds or updates content on that page . -
or space. You'll receive immediate emails for important notifications (like Subscribin

On this page:

mentions and new pages), but when lots of changes are being made at the g to email
same time, you'll only receive a single email with all the changes (within a notification
short window, usually 10 minutes). S

Notes for
You can also subscribe to daily email reports and other notifications of administrat
various updates, as described below. ors

You'll only receive notifications for content that you have permission to view.

Users that have been disabled by an administrator will not receive email

Related pages:

notifications. * \éVatch
ages,
Spaces
Subscribing to email notifications and Blogs
Subscribe
You can subscribe to be notified when: to RSS
® A blog post is added or changed in a space that you have permission \vaiﬁ?ns
to view. , . . Confluenc
® Someone you're following makes an update in a space that you have e
permission to view. NIl
® Someone follows you. profile and
You can also subscribe to these summary reports: settings
Edit Your
® A daily report of the 30 most popular updates to all spaces that you User
have permission to view. Settings

® A daily or weekly report of recommended updates, in all spaces that
you have permission to view.

To edit your email notification settings:

1. Choose your profile picture at top right of the screen, then choose S

ettings
2. Click Email in the left-hand panel
3. Click Edit

Here's an explanation of all the email settings.

Setting Description Content

Option: Do you want

Autowatch Confluence to
automatically add you as a
watcher on each page or
blog post that you add or
update? If you are a
watcher of a page or a
post, you will receive
notification of future
changes.

® Pages and blog posts that you create, edit or comment on.
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Subscribe to
daily updates

Subscribe to
all blog posts

Subscribe to
network

Subscribe to
new follower
notifications

Notify on my
actions

Receive daily email reports
showing changes to
content in all spaces that
you have permission to
view.

Note: Daily email reports
do not include information
about attachments on a
page or blog post that are
added, edited or deleted.
Up to 30 updates will be
included, sorted by
popularity.

Receive email notifications
for changes to blogs in
your Confluence
installation that you have
permission to view.

Receive email notifications
for changes to content by
all users that you are follo
wing, which you have
permission to view.

Receive an email message
when anyone chooses to
follow you.

Option: Do you want to
receive email notifications
for your own changes?

Note: If you have not
subscribed to any email
notifications and are not
watching any
pages/spaces, then
selecting 'Notify on my
actions' will not do
anything.

Pages and blog posts that are added, edited or deleted.

®* Comments on a page or blog post that are added, edited

or deleted.
Updates by users who have changed their personal
profile.

Blog posts added, edited or deleted.

® Pages being added, edited or deleted.
® Blog posts being added, edited or deleted.
® Comments being added, edited or deleted.

* All pages and spaces that you are watching.
® This affects all subscriptions set.
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Show
changed
content

Subscribe to
recommended
updates

Option: Do you want your
notifications to include
details of the changes
made to the content?

® If you do not select this
option, your
notifications will include
only the title of the
page, and any
comment the author
made when updating
the page.

® If you do select this
option, your
notifications will show
the differences
between the current
and previous versions
of the page. See Page
History and Page
Comparison Views.

Receive a daily or weekly
email message showing
the top content that is
relevant to you from
spaces that you have
permission to view.

How do you set the
frequency of the mail
message? A link in the
email message allows you
to choose daily or weekly
notifications.

How do you enable and
disable the notification?
You can turn off the
notification by clicking a
link in the email message.
You can also turn the
notification on or off by
setting the 'Subscribe to
recommended updates'
option in your user profile.

Notes for administrators

® Edits to pages and blog posts.

Confluence chooses the content to display, based on:

® Pages and blog posts that people have recently liked.

® Pages and blog posts that people have recently
commented on.

® Pages and blog posts that have recently been created.

'Recent’ means any activity that occurred since the last
recommended updates message was sent to you.

The activities are listed in order of popularity, with the most
popular at the top. Likes, comments and content creations are
scored equally. Activity that involves people in your network ra
nks higher than activity not involving your network. Content
from My spaces also ranks higher than content in other
spaces. The recommended updates summary does not
include any content that you created yourself, and it gives a
lower ranking to content that you have participated in, for
example by adding a comment or updating the page.

If there is no activity to report, Confluence will not send the
email message.

® To enable Confluence to send email notifications, a System Administrator must configure an email
server. See Configuring a Server for Outgoing Mail.

® System Administrators can change the batching window for changes and comments on the same
page or blog post in the Send batched notifications scheduled job. Increase the time for fewer
emails or reduce the time if more immediate notifications are essential in your site.

® Confluence Administrators can set the default options for the recommended updates
notification. Choose the cog icon

, then choose General Configuration under Confluence Administration. Click Recommended

Updates Email in the left-hand panel. See Configuring the Recommended Updates Email Notification.
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Subscribe to RSS Feeds within Confluence

An RSS feed is a format for delivering summaries of regularly changing web
content. Subscribing to an RSS feed allows you to stay informed of the
latest content from sites that you are interested in.

RSS is not designed to be read in a regular web browser. Specialized RSS
newsreader programs can check RSS files every so often, and tell you
what's new on a site. Your reader may be on a website, an add-on to your
browser, part of your email program, or a stand-alone program.

Confluence generates its own RSS feeds for tracking updates to content
within Confluence. You will need an RSS reader which can grab the RSS
feeds from Confluence and display them for you.

Confluence's RSS macro allows you to display the contents of an RSS feed
on a Confluence page. The feeds may come from a Confluence feed
generator or from external sites. In this way, Confluence can act as an RSS
reader.

Confluence RSS feeds

348

On this page:
® Confluenc
e RSS
feeds
®* Remove
an RSS
feed

Related pages:

® Waitch
Pages,
Spaces
and Blogs

® RSS Feed
Macro

RSS feeds allow you to track updates to content within Confluence. You will need an RSS newsreader to

read a feed.

You can create a customized RSS feed using the RSS Feed Builder or subscribe to one of the pre-specified

feeds generated by Confluence.

What would you like to do?

® Create and subscribe to customized RSS feeds using the RSS Feed Builder — Create a customized
RSS feed. For example, you can filter your feed using a label, specify the number of items and days to

include in your feed, and so on.
® Subscribe to pre-specified RSS feeds

u
— Generate an RSS feed automatically in a minimal number of steps.

® Subscribe to a feed of any Confluence user's network — Track the activities of users the selected

person is following.

Remove an RSS feed

There is no need to try to delete or remove an RSS feed built by the Confluence RSS feed builder.

Explanation: The feeds generated by the RSS Feed Builder are dynamically generated via the parameters
included in the feed URL (address). For example, take a look at the following feed URL:

http://confluence. atl assi an. coni creat er ssf eed. acti on?t ypes=page&sort =

modi f i ed&showCont ent =t r ue. ..

The above feed URL will generate a list of pages (‘types=page"), sorted by the modification date and showing
the page content. The feed is generated at the time when the URL is fetched and there is no RSS feed
information stored on the database. For that reason, there is no need to remove anything.

Subscribe to pre-specified RSS feeds

This page tells you how to get hold of an RSS feed which Confluence has
predefined for you.

To subscribe to predefined RSS feeds for a particular space:
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1. Go to the space and choose Space tools > Content Tools from the Related pages:
bottom of the sidebar
2. Choose RSS Feeds * The RSS
3. Copy and paste the link for one of the feeds into your RSS Feed
newsreader Builder
® RSS Feed
Feeds include: Macro
® Network
Overview
® Pages ¢ Comments
* Blog ® Attachments
® Mail ® All content

To subscribe to predefined RSS feeds for a particular page (where available):

Note that the word 'page’ here means a part of the Confluence user interface, rather than a page that
contains Confluence content. For example, your Network view offers an RSS feed.

1. Go to the page
2. Locate the following icon, which is available in the top-right corner of certain pages:

)
3. Copy and paste the icon's link into your RSS newsreader

Notes

The predefined RSS feed will return no more than 10 entries within the last 5 days, if you want to customize
your Confluence RSS feed (for example, use a label to filter your feed), use the RSS Feed builder instead of
the above instructions.

The RSS Feed Builder
Using the RSS feed builder, you can create customized RSS feeds to
subscribe to changes within Confluence.

Wondering what an RSS feed is? See more information about RSS Feeds.

On this page:
® Build an
Build an RSS feed RSS feed
. . ®* Notes
Follow the steps below to build your feed, choosing the type of content and
the time period you want to monitor. Related pages:
To create a customized RSS feed: ® Watch
Pages,

1. Choose the help icon

Spaces
and Blogs
at top right of the screen, then choose Feed Builder ® Subscribe

2. Select the content types you want in your feed to RSS
Check Mail if you want to know when the email archive is updated. \I,:Vi(:]?ns
(See the overview of mail archives in Confluence.) Confluenc

3. Select one or more spaces from the list e

4. Click Advanced Options to set the following:

Option Description

Feed Name The default name is based on
the name of your Confluence
installation. For example,
‘Extranet RSS Feed'.
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5.
6.

With these labels Enter one or more labels
separated by spaces or
commas. Confluence returns all
content (of the selected types)
that matches one or more of the
labels. See the hint below about
using labels to customize your
feeds.

Exclude these spaces Exclude specific spaces from
those already selected.

Sorted by Sort content by either the date
or creation or the date they
were last updated.

Limit to Specify the number of items
returned in your feed.

Within the last Specify how old items returned
can be.
Include content for pages Specify whether the entire page

is displayed in the feed.

Choose Create RSS Feed
Drag or copy the link into your RSS reader

Hints

Notes

Created in

Separate feeds. Try building separate feeds, one for pages only and one that includes comments as
well. This allows you to monitor only pages if you are short of time, and to read the comments when
you have more time.
Labels to customize your feed. You can use the RSS feed builder to track updates to labeled pages
and comments on those pages. Here is an idea for customizing your RSS feed by using your own
personal label(s). This is useful if you want to track updates to specific pages or blog posts, and you
do not want to deal with emails. You can use this method as an alternative to watching pages.

® Build an RSS feed that returns pages, blog posts and comments labeled with a personal label,

such as 'my:feed".
® Each time you want to 'watch' a page, just label it with 'my:feed'.
® All updates and comments will automatically come through your RSS feed.

Removing an RSS feed:
There is no need to try to delete or remove an RSS feed built by the Confluence RSS feed builder.

Explanation: The feeds generated by the RSS Feed Builder are dynamically generated via the
parameters included in the feed URL (address). For example, take a look at the following feed URL:

http://confl uence. atl assi an. coni cr eat er ssf eed. acti on?t ypes=page&
sort =nodi fi ed&showCont ent =t r ue. ..

The above feed URL will generate a list of pages (‘types=page’), sorted by the modification date and
showing the page content. The feed is generated at the time when the URL is fetched and there is no
RSS feed information stored on the database. For that reason, there is no need to remove anything.
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® Feed authentication options: Confluence can offer you the option of an anonymous feed or a feed
that requires authentication.

®* An anonymous feed will show only the content that is visible to anonymous users. The feed
URL does not contain the &s_aut hType parameter mentioned below. This feed is useful only
if your Confluence site allows anonymous access. If a feed is anonymous, you only get
anonymously-viewable content in the feed regardless of whether you are a Confluence user or
not.

® An authenticated feed requires you to log in to Confluence before you can retrieve the content.
The feed URL contains the following parameter: &os_aut hType=basi c.

® The option to choose between an anonymous and an authenticated feed is currently not
available on the feed builder screen. The feed builder offers only authenticated feeds. See CO
NF-21601 for details and a workaround.

Subscribe to a Network RSS Feed

You can create an RSS Feed from any user's network view, allowing you to On this page:
receive summaries on the activities of users they are following in their ® Subscribe
network. The types of activities tracked in these RSS feed summaries to a user's
include: network
. . feed
® Additions or edits to pages or blog posts 3
. - ¢ Customize
® Comments added to a page or blog post or edits to existing your
. ::Jon;n:entts < orofil network
pdates to a user's profile RSS feed
* Notes

Subscribe to a user's network feed
Related pages:

To subscribe to a user's network RSS feed: e Network
1. Locate the RSS icon . (S)VSW“?[‘:’)V
ubscribe
)
, Which is available from the top-right of: ? RdSS
® The 'Recent activity of the users you are following' section of ?tﬁ' N
your network page, or \C/:VI 'f?
® The 'Activity of followed users' section of another user's onfiuenc
network page. . 3
2. Copy and paste the icon's link into your RSS newsreader prc:)l;irle and
settings

Customize your network RSS feed

Confluence does not provide a way of customizing a network RSS feed via the user interface. However, you
can modify the maximum number of results and type of content displayed in these feeds by directly editing
the RSS feed link in your RSS newsreader.

To modify the maximum number of results displayed in your RSS feed:

1. Edit the RSS feed link in your RSS newsreader.

2. Change the value of the max parameter from its default value of 40 to a value of your choice.
Example:
http://confluence.atlassian.com/feeds/network.action?username=MYNAME&max=60&publicFeed=fals
e&o0s_authType=basic&rssType=atom

3. Save the modified link in your RSS newsreader.

To modify the type of content displayed in your RSS feed:

1. Edit the RSS feed link in your RSS newsreader.
2. Append the parameter cont ent Type to the end of the link, followed by an equals sign (=) and then
add the appropriate content type value of your choice:
® PAGE — restricts the RSS feed to page additions or updates.
BLOG— restricts the RSS feed to blog post additions or updates.
ATTACHVMENT — restricts the RSS feed to attachment additions or updates.
COMMVENT — restricts the RSS feed to comment additions or updates.
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Content type values are case-sensitive. Ensure that each parameter is separated from the other by an
ampersand (&).

Example:
http://confluence.atlassian.com/feeds/network.action?username=ggaskell&max=40&publicFeed=false
&0s_authType=basic&rssType=atom&contentType=BLOG

3. Save the modified link in your RSS newsreader.

Notes

It is not possible to filter for more than one type of content by adding multiple values to the cont ent Type pa
rameter.

Workbox Notifications

The Confluence workbox .
E On this page:
N e

displays all notifications collected from Confluence 'V'a‘?age your qotlflcatlops

) ®* Which notifications are included?
page watches, shares, mentions, and tasks. From e Kevboard shortcuts
your workbox you can reply to comments, like a o Ma>r/1a e notifications with
comment or page, watch a page, or open the 9

Confluence mobile
relevant page or blog post. o Notes

If your Confluence site is linked to a JIRA application
such as JIRA Software or JIRA Service Desk, you'll
also see notifications from your JIRA application in
the workbox.

Related pages:

Configuring Workbox Notifications
Email Notifications

Watch Pages, Spaces and Blogs
Likes and Popular Content

Looking to manage your notification email messages
instead? See Email Notifications.

Manage your notifications

1. Choose the workbox icon
=
in the header.
* A number will appear the workbox icon, to indicate the number of unread notifications waiting
for your attention.
® You can use the keyboard shortcut: Type g then n. (When in the Confluence editor, click
outside the editor before pressing the keyboard shortcut keys.)
2. Choose a notification from the list, to see the notification details. You can then:
® Open the related page, blog post, or comment.
® Like or Unlike the page, blog post, or comment.
® Watch or Stop Watching to receive notifications, or stop receiving notifications, about a page
or blog post.
® Reply a comment, without leaving the workbox.

Screenshot: Your Confluence notifications in the workbox
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Notifications

2 comments on New cluster monitoring scr._. »
[% Mat Lawrence mentioned you in (DRAFT) ... »
John Masson commented on Confluence 5.7 >

™ Denise Unterwurzach Q @ &$- 4O 'av

¢ 9 comments on File 5
¢ Back to notifications

o Agnes Ro liked Copy
File sharing experience

) 2likes of Re: File sha {2 9 comments on this page

O Shaun Esther comme Open - Stop Watching - Like

[@ Brenda Castro mentic 8 older comments on this page

Pﬁ; Valter Fatia commented on this

Yeah | really don't like it that way, but we have some cases
where we are unable to insert it in the white. ..

Lets go with the white and review later.

10 days ago - Open - Reply - Like

Which notifications are included?

The workbox displays a notification when someone does one of the following in Confluence:

® Shares a page or blog post with you.

® Mentions you in a page, blog post, comment or task.

® Comments on a page or blog post that you are watching.
® |ikes a page or blog post that you are watching.

The workbox does not show notifications triggered because you are watching a space. Only watches on
pages and blog posts are relevant here.

The notification in your workbox appears as 'read' if you have already viewed the page or blog post.

If your Confluence site is linked to a JIRA application, you will also see the following JIRA notifications in your

workbox:

® Comments on issues that you are watching.
® Mentions.
® Shares of issues, filters and searches.

Keyboard shortcuts

Shortcut Action
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gthenn  Open the Confluence workbox.

] Move down to the next entry in the notification list.

k Move up to the previous entry in the notification list.

n Move down to the next notification for a particular page or blog post.
p Move up to the previous notification for a particular page or blog post.
Enter Open the selected natification.

u Return to the notification list after opening a particular notification.

Manage notifications with Confluence mobile

You can also view and respond to notifications on your phone or other mobile device. See Confluence Mobile
for more about mobile platforms.

Notes

Read notifications are automatically deleted after 2 weeks.

Unread notifications are automatically deleted after 4 weeks.

You cannot delete your notifications yourself.

If a new notification arrives while you have workbox open, the count appears on the workbox icon

=5

but the notification is not added to the workbox. You need to close workbox and re-open it to see the
new notification.

® The ability to receive notifications from JIRA or another Confluence site is available in Confluence
4.3.3 and later. To receive JIRA notifications, you need JIRA 5.2 or later.

® Administrators can enable and disable the workbox on your Confluence site. They can also connect a
JIRA site or another Confluence site, so that notifications from those sites appear in your workbox too.
See Configuring Workbox Notifications.

® The Confluence workbox is provided by a set of plugins. To remove the personal notifications and
tasks functionality from your site, you can disable the following plugins. See Disabling or Enabling a
Plugin for instructions. Disabling these plugins will disable the entire workbox . It is not possible to
disable only tasks or only notifications:

® Workbox - Common Plugin
® Workbox - Host Plugin
® Workbox - Confluence Provider Plugin

® |f you want to re-enable the plugins, do so in the following order: Common Plugin, Host Plugin,
Confluence Provider Plugin.

® There is no option to disable the workbox for an individual user.

Search

Confluence gives you a few ways to find what you're looking for. Here's an
overview of Confluence search, and a few tips to help you find things more
easily.

Quick search

To perform a quick search in Confluence, choose the search field at the
top-right of every page or type / on your keyboard to place your cursor in the
search field. Type the name of a page, blog post, person, file/attachment, or
space and choose from the list of options displayed.

If you don't immediately see what you need in the quick search, hit Enter or
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choose the Search for option at the bottom of the search results to do a full .
search. On this page:
® Quick
search
® Full search
- = - ® Filter your
a & L search

) results
£* Global Templates and Blueprints e Filter with

£+ Spam Prevention %) Create Space CcQL

* Advanced

o Logging and Profiling search

® Search

(2] Product Team Confluenc
Product Team e from

your

%) Product Team browser's

search

field

egor

Q, Search for ‘pr’
Related pages:

® Confluenc
e Search
Syntax

® Confluenc
e Search
Fields

® Recently
Viewed
Pages and
Blog Posts

® Search
Results
Macro

® |ivesearch
Macro

® Search the
People
Directory

You can also search for administrative options in the quick search. For example, type 'general’ into
the search field to go to the General Configuration screen.

More information about quick navigation:

® Matching items are grouped by type so that you can quickly find the type you want. Confluence shows
a maximum of 3 administrative items, 6 pages and/or blog posts, 2 attachments, 3 people and 2
spaces

® Jtems are ordered with the most recently updated first

® Permissions determine the admin options that appear in the search results. You'll only see the options
you have permission to perform.

Full search

The full search allows you to search all content in all spaces (site and personal), mail, personal profiles,
attachments and space descriptions, or filter the results to show only what you're after.
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The search will also look at the content of the following types of attachments:

* Word ®* Excel
® Text * PDF
® PowerPoint * HTML

To search the content of other attachment types, you will need to use an attachment content extractor
plugin. For more information, take a look at the following:

® Existing extractor plugins which you can install on your Confluence site. See this search on Atlassian
Marketplace.

® Guidelines on developing your own attachment content extractor plugin. See our developer
documentation on extractor plugins.

To use the full search:

1. Type your query into the search field at the top-right corner of every screen (or at the top of the Search
screen)
2. Hit the Enter key

Screenshot: Search results page

Search caL —— e
—_—
o CONTRIBUTOR Page 1 of 1. Showing 3 results (0.41 seconds)

[® Summit 2015 - CQL Presentation
Abstract The Confluence platform team have been busy building exciting tools to help developers

IN SPACE build Confluence addons. CQL the Confluence Query Language extends the Confluence REST
API adding advanced search capabilities. In addition, content properties now support indexing and
C4L Home x querying using CQL especially handy
Steven Lancashire x Steven Lancashire

Search archived spaces (&) Atlascamp 2015 CQL : Extensible search for Confluence add-ons

Title CQL : Powerful and extensible search for Confluence addons What track will this fit in?
Developers building addons Abstract The Confluence platform team have been busy building
Any date exciting tools to help developers build Confluence addons. CQL the Confluence Query Language
extends the REST API adding advanced search
Steven Lancashire

LAST MODIFIED

Last 24 hours
Last week
(=) Steve and Richard discuss all the things
speccing Talk to Connect guys for their latest spec CQL for Space description, User Profile
Last year recentupdates macro "needs" this Maybe we don't implement this exact macro
Steven Lancashire

Last month

Custom

OF TYPE
All content
Pages
Blog Posts
Comments
Attachments
Spaces
People
Custom
CREATOR (]

@ Steven Lancashire x
i Ben Mackie x

e — Add a filter

1. Search filters: narrow your search by using and adding filters.
2. CQL filters: add CQL filters for even more precise search.
3. Search help: get tips effective searching and advanced search methods.

I We recommend you don't use special characters in page or attachment names, as the page or
attachment may not be found by Confluence search, and may cause some Confluence functions to behave
unexpectedly.

rFilter your search results

On the left of the search results page are options that allow you to filter the search results.
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You'll can filter using the following fields:

® Contributor — Restrict your search to content that's been modified (created, edited, or commented on)
by a particular person. Start typing the person's username or part of their name and Confluence will
offer you a list of possible matches.

You need to enter at least two letters. For example, if you enter just ‘john s', the filter will look
for users called 'john' and will ignore the 's'.

® |n space — Only search in a particular space or list of spaces. There are also preset groups of spaces
— favorite (my spaces), site, and personal spaces — which you can choose from the list of suggested
spaces. Tick the checkbox to include archived spaces if you need to.

® Last modified — Choose or enter a date range to only show content updated within a particular period

of time.
® Of type — Only return content of a certain type, like pages, blog posts, or comments.

Filter with CQL

Confluence search supports adding CQL filters to refine your results.

+ What's CQL, and how do | use it?
CQL (Confluence Query Language) is a query language developed for Confluence, which you can use in
some macros and the Confluence search. Confluence search and CQL-powered macros allow you to add
filters to build up a search query, adding as many filters as you need to narrow down the search results.

Use the Add a filter link to add more filters to your query.
~ Use AND, OR, and NOT operators
® For an OR search, specify multiple values in the same field.

So to show pages with 'label-a’, 'label-b* or both you'd put ‘label-a’ and 'label-b' in the same
Label field, like this:

Label *

label-a % | label-b %

® For an AND search, add more than one filter and specify a single value in each.
To show only pages with label-a and label-b you'd put 'label-a’ in one label field, then add a
second Label field to the macro, and put 'label-b' in the second one, like this:

Label *

label-a =

Label [ x]

label-b x

Put simply, OR values are entered in the same filter, AND values are entered in different filter.
Only some filters support AND. If the filter doesn't support the AND operator, you won't be able

to add that filter more than once.
® For a NOT search, enter a minus sign (-) before the label. This'll exclude everything with that

label.

You can use the following CQL filters to build your query:

Filter Description Operators
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Label* Include pages, blog posts or attachments with these OR (multiple values in the
labels. same filter)
AND (multiple Label filters)
With Include pages that are children of this page. OR (multiple values in the
ancestor same filter)

Contributor**

This allows you to restrict the macro to a single page
tree.

Include pages or blog posts that were created or edited
by these people.

OR (multiple values in the
same filter)

Creator Include items created by these people. OR (multiple values in the
same filter)

Mentioning Include pages and blog posts that @mention these OR (multiple values in the

user people. same filter)

With parent Include only direct children of this page (further EQUALS (one page only)

sub-pages won't be included)

In space** Include items from these spaces. OR (multiple values in the
same filter)

Including Include items that contain this text. CONTAINS (single word or

textr* phrase)

With title Include items that contain this text in the title. CONTAINS (single word or
phrase)

Of type** Include only pages, blogs or attachments. OR (multiple values in the

* This field is required in CQL-powered macros.

same filter)

** You can add these filters in CQL-powered macros but in search they're part of the standard search
filters, so they don't appear in the Add a filter menu.

358

Advanced search

Still need more ways to search? For more advanced search syntax, check out Confluence Search Syntax fo
r more ways to refine the text you enter in the search field. You can also read Confluence Search Fields for
special parameters you can use to search various types of content metadata.

Search Confluence from your browser's search field

If you're using Firefox or Internet Explorer, you can add your Confluence site as a search provider using the
dropdown menu next to the browser's search field.

The example below shows the 'Extranet’ Confluence site offered for inclusion as a search engine in the
browser's search field.
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IGl Jo
Google

“¥? Yahoo.co.uk

2 Amazon.co.uk

Az Answers.com
Chambers (UK)
@ Creative Commuons
Y eBay.co.uk

W Wikipedia (en)

| ER add "Bxtranet”

Manage Search Engines...

Information about OpenSearch:

® Confluence supports the autodiscovery part of the OpenSearch standard, by supplying an OpenSearc
h description document. This is an XML file that describes the web interface provided by Confluence's
search function.

® Any client applications that support OpenSearch will be able to add Confluence to their list of search
engines.

® Your Confluence Administrator can enable or disable the Open Search feature using the Confluence
Administration Console.

Confluence Search Syntax

This page describes the special words and punctuation marks you can use
to refine your search.

Matched phrase search

Use double quotes to search for content that contains the phrase 'cheese
one', or a phrase where 'cheese' and 'one' are the major words:

...................................................................................................................

Note: Confluence will ignore common words (stop words), including 'and’,
‘the’, 'or', and more, even if they are included within double quotes. See the
default list of stop words used by Confluence's search engine, Lucene, in
the Lucene documentation.

For example:

1. Searching for "cheese one" returns only pages in which ‘one' appears
as the first word after 'cheese'.

2. Searching for "the one" returns all pages containing 'one' because
'the' is a stop word.

If you'd like to override Lucene's tokenization and stemming, cast your vote
on this improvement request:

CONFSERVER-14910 - Provide ability to override Lucene tokenisation and
stemming and search for exact text | OPEN
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OR search
To search for content that contains one of the terms, 'chalk’ or ‘cheese’, use the operator OR in capital letters

.........................................................................................................................................................................

AND search

To search for content that contains both the terms 'chalk’ and ‘cheese’, use the operator AND in capital
letters:

.........................................................................................................................................................................
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NOT search

To search for content that contains ‘chalk' but NOT 'cheese’, use the operator NOT in capital letters:

.........................................................................................................................................................................

Excluded term search

To search for content that contains ‘chalk’ and 'butter' but not ‘cheese":

.........................................................................................................................................................................

chal k butter -cheese

Group search terms

To search for content that must contain 'chalk’ but can contain either ‘cheese' or 'butter’, use brackets to
group the search terms:

.........................................................................................................................................................................

Title search

To search for pages and posts with certain words in the title, use the Add a filter option at the bottom left of
the page and choose With title. Enter the words you're looking for, in any order, and hit enter.

Confluence search filters are powered by CQL.

~ What's CQL, and how do | use it?
CQL (Confluence Query Language) is a query language developed for Confluence, which you can use in
some macros and the Confluence search. Confluence search and CQL-powered macros allow you to add
filters to build up a search query, adding as many filters as you need to narrow down the search results.

Use the Add afilter link to add more filters to your query.

~ Use AND, OR, and NOT operators
® For an OR search, specify multiple values in the same field.
So to show pages with ‘label-a’, 'label-b" or both you'd put 'label-a’ and 'label-b' in the same
Label field, like this:

Label *

label-a % || label-b ®

® For an AND search, add more than one filter and specify a single value in each.
To show only pages with label-a and label-b you'd put 'label-a’ in one label field, then add a
second Label field to the macro, and put 'label-b' in the second one, like this:

Label *

label-a ®

Label [ X

label-b
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Put simply, OR values are entered in the same filter, AND values are entered in different filter.

Only some filters support AND. If the filter doesn't support the AND operator, you won't be able

to add that filter more than once.
® For a NOT search, enter a minus sign (-) before the label. This'll exclude everything with that

label.

You can use the following CQL filters to build your query:

Filter

Label*

With
ancestor

Contributor**
Creator
Mentioning
user

With parent
In space**
Including
text**

With title

Of type**

Description

Include pages, blog posts or attachments with these
labels.

Include pages that are children of this page.

This allows you to restrict the macro to a single page
tree.

Include pages or blog posts that were created or edited
by these people.

Include items created by these people.
Include pages and blog posts that @mention these
people.

Include only direct children of this page (further
sub-pages won't be included)

Include items from these spaces.

Include items that contain this text.

Include items that contain this text in the title.

Include only pages, blogs or attachments.

* This field is required in CQL-powered macros.

Operators

OR (multiple values in the
same filter)

AND (multiple Label filters)

OR (multiple values in the
same filter)

OR (multiple values in the
same filter)

OR (multiple values in the
same filter)

OR (multiple values in the
same filter)

EQUALS (one page only)

OR (multiple values in the
same filter)

CONTAINS (single word or
phrase)

CONTAINS (single word or
phrase)

OR (multiple values in the
same filter)

** You can add these filters in CQL-powered macros but in search they're part of the standard search
filters, so they don't appear in the Add a filter menu.

Date range search

To search for content modified within a certain date range, pick a timeframe in the Last modified section on

the left. If you're looking for something created within a particular date range, use the Add a filter option at
the bottom left of the page and choose Created. For either option, you can pick from some predefined
options, like last 24 hours and last week.

Confluence search filters are powered by CQL.
~ What's CQL, and how do | use it?
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363

CQL (Confluence Query Language) is a query language developed for Confluence, which you can use in
some macros and the Confluence search. Confluence search and CQL-powered macros allow you to add
filters to build up a search query, adding as many filters as you need to narrow down the search results.

Use the Add a filter link to add more filters to your query.

~ Use AND, OR, and NOT operators
® For an OR search, specify multiple values in the same field.
So to show pages with 'label-a’, 'label-b* or both you'd put ‘label-a’ and 'label-b' in the same
Label field, like this:

Label *

label-a % | label-b %

® For an AND search, add more than one filter and specify a single value in each.
To show only pages with label-a and label-b you'd put 'label-a’ in one label field, then add a
second Label field to the macro, and put 'label-b' in the second one, like this:

Label *

label-a =

Label [ x]

label-b x

Put simply, OR values are entered in the same filter, AND values are entered in different filter.

Only some filters support AND. If the filter doesn't support the AND operator, you won't be able

to add that filter more than once.
® For a NOT search, enter a minus sign (-) before the label. This'll exclude everything with that

label.

You can use the following CQL filters to build your query:

Filter

Label*

With
ancestor

Contributor**
Creator
Mentioning
user

With parent

In space**

Description

Include pages, blog posts or attachments with these
labels.

Include pages that are children of this page.

This allows you to restrict the macro to a single page
tree.

Include pages or blog posts that were created or edited
by these people.

Include items created by these people.

Include pages and blog posts that @mention these
people.

Include only direct children of this page (further
sub-pages won't be included)

Include items from these spaces.

Operators

OR (multiple values in the
same filter)

AND (multiple Label filters)

OR (multiple values in the
same filter)

OR (multiple values in the
same filter)

OR (multiple values in the
same filter)

OR (multiple values in the
same filter)

EQUALS (one page only)

OR (multiple values in the
same filter)

Created in 2017 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 6.3 Documentation 364

Including Include items that contain this text. CONTAINS (single word or

text** phrase)

With title Include items that contain this text in the title. CONTAINS (single word or
phrase)

Of type** Include only pages, blogs or attachments. OR (multiple values in the

same filter)

* This field is required in CQL-powered macros.

** You can add these filters in CQL-powered macros but in search they're part of the standard search
filters, so they don't appear in the Add a filter menu.

Wildcard searches

You can use one or more wildcard characters in your search. For example, you could search for ht t p*. at |
assi an. * to find https://www.atlassian.com or http://www.atlassian.jp.

Leading wildcards

Lucene doesn't allow wildcards at the beginning of your search, but you can format your search as a
regular expression as a workaround. For example, you can't search for * hunt or ?hunt, as they

begin with a wildcard, but you can search for /.*hum.*/ and find things like hum, human, and
inhumane.

Wildcards can either replace a single character in your search, or multiple characters.

Single character

To replace a single character in your search, use a question mark (?) as a wildcard, For example, to search
for 'butter’, 'bitter', 'better’, or 'batter".

.........................................................................................................................................................................

Multiple characters
To replace multiple characters in your search, use an asterisk (*) as a wildcard. For example, to search

for ‘chicken’ or 'chickpea’

.........................................................................................................................................................................

Multiple wildcards

Use multiple wildcards in your search. The following query will search find 'chick’, ‘coconut’, or ‘chickpea

.........................................................................................................................................................................

You can also combine wildcard characters in one search. For example, the search term below will return
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‘chick’ but not 'chickpea”:

.........................................................................................................................................................................

Note: Confluence doesn't support leading wildcards. This means searching for * heese will not return
cheese.

Proximity searches

Use a tilde character followed by a number, to find two words within a certain number of words of each other.

For example, the following search will return 'Octagon blog post’, but not 'Octagon team blog post':

.........................................................................................................................................................................

The following search isn't valid, because you can't search for two words within zero words of each other. If
you think the words are next to each other, use the matched phrase search.

.........................................................................................................................................................................

Range search

Use the operator 'TO', in capital letters, to search for names that fall alphabetically within a specified range:

.........................................................................................................................................................................

Note: You can't use the AND keyword inside this statement.

Fuzzy search

Use a tilde (~) character to find words spelled similarly.

If you want to search for octagon, but you're not sure how it's been spelt, type the word followed by a tilde:

.........................................................................................................................................................................

Combined search

You can also combine various search terms together:

.........................................................................................................................................................................

Searching for macros

You can search Confluence content to find where a macro is used. Start your search string with macr oName
. and type the macro name after the colon. For example, to search for all excerpt-include macros:
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macr oNane: excer pt -i ncl ude*

For more information about macr oName and other search fields, see Confluence Search Fields.

Searching for labels

To search for pages and posts with a particular label or labels, use the Add a filter option at the bottom left
of the page and choose Label.

Confluence search filters are powered by CQL.

~ What's CQL, and how do | use it?
CQL (Confluence Query Language) is a query language developed for Confluence, which you can use in
some macros and the Confluence search. Confluence search and CQL-powered macros allow you to add
filters to build up a search query, adding as many filters as you need to narrow down the search results.

Use the Add afilter link to add more filters to your query.

~ Use AND, OR, and NOT operators

® For an OR search, specify multiple values in the same field.
So to show pages with ‘label-a’, 'label-b' or both you'd put 'label-a’ and 'label-b' in the same
Label field, like this:

Label *

label-a % || label-b %

® For an AND search, add more than one filter and specify a single value in each.
To show only pages with label-a and label-b you'd put 'label-a’ in one label field, then add a
second Label field to the macro, and put 'label-b' in the second one, like this:

Label *

label-a ®

Label [ X
label-b %

Put simply, OR values are entered in the same filter, AND values are entered in different filter.
Only some filters support AND. If the filter doesn't support the AND operator, you won't be able

to add that filter more than once.
® For a NOT search, enter a minus sign (-) before the label. This'll exclude everything with that

label.

You can use the following CQL filters to build your query:

Filter Description Operators
Label* Include pages, blog posts or attachments with these OR (multiple values in the
labels. same filter)

AND (multiple Label filters)

With Include pages that are children of this page. OR (multiple values in the
ancestor _ ) _ same filter)

This allows you to restrict the macro to a single page

tree.
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Contributor** Include pages or blog posts that were created or edited
by these people.

Creator Include items created by these people.
Mentioning Include pages and blog posts that @mention these
user people.

With parent Include only direct children of this page (further
sub-pages won't be included)

In space** Include items from these spaces.

Including Include items that contain this text.

text**

With title Include items that contain this text in the title.
Of type** Include only pages, blogs or attachments.

* This field is required in CQL-powered macros.

OR (multiple values in the
same filter)

OR (multiple values in the
same filter)

OR (multiple values in the
same filter)

EQUALS (one page only)

OR (multiple values in the
same filter)

CONTAINS (single word or
phrase)

CONTAINS (single word or
phrase)

OR (multiple values in the
same filter)

** You can add these filters in CQL-powered macros but in search they're part of the standard search

filters, so they don't appear in the Add a filter menu.

Confluence Search Fields

This page gives an overview of the Apache Lucene search fields used in
Confluence.

Filter with CQL

Before you dive into learning more about Lucene fields, you may want to
learn about the powerful search filtering offered by Confluence Query
Language (CQL).

~ What's CQL, and how do | use it?
CQL (Confluence Query Language) is a query language developed for
Confluence, which you can use in some macros and the Confluence
search. Confluence search and CQL-powered macros allow you to add
filters to build up a search query, adding as many filters as you need to
narrow down the search results.

Use the Add a filter link to add more filters to your query.

~ Use AND, OR, and NOT operators

® For an OR search, specify multiple values in the same field.
So to show pages with 'label-a’, 'label-b' or both you'd put
'label-a’ and 'label-b' in the same Label field, like this:

Label *

label-a % || label-b %

® For an AND search, add more than one filter and specify a
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single value in each.

To show only pages with label-a and label-b you'd put 'label-a’
in one label field, then add a second Label field to the macro,
and put 'label-b' in the second one, like this:

Label *

label-a ®

Label [ X
label-b %

Put simply, OR values are entered in the same filter, AND
values are entered in different filter.
Only some filters support AND. If the filter doesn't support the
AND operator, you won't be able to add that filter more than
once.

® For a NOT search, enter a minus sign (-) before the label.
This'll exclude everything with that label.

You can use the following CQL filters to build your query:

Filter Description Operators

Label* Include pages, blog OR (multiple values
posts or attachments  in the same filter)

with these labels. .
AND (multiple Label

filters)

With ancestor Include pages that OR (multiple values
are children of this in the same filter)
page.

This allows you to
restrict the macro to a
single page tree.

Contributor** Include pages or blog OR (multiple values
posts that were in the same filter)
created or edited by
these people.

Creator Include items created OR (multiple values
by these people. in the same filter)

Mentioning user Include pages and OR (multiple values
blog posts that in the same filter)
@mention these
people.

With parent Include only direct EQUALS (one page

children of this page only)
(further sub-pages
won't be included)

In space** Include items from OR (multiple values
these spaces. in the same filter)

On this page:
® Filter with
CQL
® Searching
for content
in specific
fields
® Confluenc
e search
fields
®* Per
son
al
Infor
mati
on
®* Pag
es
® Blog
* Atta
chm
ents
®* Mail
item
S
* Useful
plugins
®* Notes

Related pages:

® Search

® Confluenc
e Search
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® Search the
People
Directory
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Including text** Include items that CONTAINS (single
contain this text. word or phrase)

With title Include items that CONTAINS (single
contain this text in the  word or phrase)
title.

Of type** Include only pages, OR (multiple values

blogs or attachments. in the same filter)

* This field is required in CQL-powered macros.

** You can add these filters in CQL-powered macros but in search
they're part of the standard search filters, so they don't appear in the Ad
d afilter menu.

Searching for content in specific fields
Confluence data is stored in fields which can be specified in the search. To

search a specific field, type the name of the field followed by a colon "' and
then the term you are looking for.

Preliminary examples:

...................................................................................................................

...................................................................................................................

The field specification applies only to the term directly preceding the colon.
For example, the query below will look for "Some" in the title field and will
search for "Heading" in the default fields.

.........................................................................................................................................................................

Confluence search fields
Below are the fields which can be searched, listed by content type.

Personal Information

Name Indexed Stored Tokenized Notes
handle true true false
type true true false
urlPath true true false
fullName true true true
title true true false
labelText true true true
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modified true true false

created true true false

contentBody true true true
Pages

Name Indexed Stored Tokenized Notes
handle true true false

type true true false

urlPath true true false

title true true true

spacekey true true false

labelText true true true

modified true true false

created true true false

contentBody true true true

macroName true true false The name of a macro used on the page
Blog

Name Indexed Stored Tokenized Notes
handle true true false

type true true false

urlPath true true false

title true true true

spacekey true true false

labelText true true true

modified true true false

created true true false

contentBody true true true

macroName true true false The name of a macro used in the blog
Attachments

Name Indexed Stored Tokenized Notes
handle true true false

type true true false

urlPath true true false

filename true true true
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title true true false
comment true true true
spacekey true true false
modified true true false
created true true false
contentBody true true true
Mail items

Name Indexed Stored Tokenized Notes
handle true true false
type true true false
urlPath true true false
title true true true
spacekey true true false
messageid true true false
inreplyto true true false
recipients true true true
labelText true true true
modified true true false
created true true false
contentBody true true true

Useful plugins

Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's
information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our
guidelines on add-on support.

This plugin extends the Confluence search, so that you can search for macro parameter names and
values: the Confluence Macro Indexer plugin.

Notes

To find out the version of Lucene Confluence is using go to <i nstal | ati on
di rectory>/ confl uence/ VIEB- | NF/ | i b and locate the Lucene jar files. The Lucene version number will
be part of the filename.

Search the People Directory
The people directory displays a list of people who
are authorized to log in to your Confluence site.

The people directory includes anybody who has
logged into Confluence or who has had a user
account created for them in Confluence.
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The people directory does not include users who can . :
log into Confluence using external user management On this page:

if they have never yet logged in. ® View the people directory
® Search for people

® Follow people's activities
View the people directory ®* Notes

Choose People at the top of the screen. Related pages:

® Create a Personal Space
® Editing your User Profile
® Set Your Profile Picture

Search for people

To search for a particular person, type their first name and/or last name into the search box and choose Sear
ch.

® To see everyone who uses your Confluence site, choose All People.
® To see just those people who have set up a personal space, choose People with Personal Spaces.

Follow people's activities

Confluence's network features allow you to follow' (that is, keep track of) other people's activities in your
Confluence site. For more information, please refer to Network Overview. You can use the hover profile
feature in the people directory to start following other people.

® To start following someone, move your mouse over their name or profile picture and choose Follow in
their profile popup.

® To stop following someone, move your mouse over their name or profile picture and choose Stop
Following in their profile popup.

Once you start following another person, their activities will start appearing in your network view.

Screenshot: The people directory

People Directory

All People All People Search | Clear

People with Personal

Spaces Josh User kel Ewan User
sample@email com au j sample@email com au

Sophie Staunton Gl Rach Admin
sample@email.com.au sample@email.com.au

Notes

® The people directory uses the hCard microformat for simple integration with a variety of
microformat-enabled tools. hCard is an open data format for representing people, companies,
organizations, and places. Read more about microformats and hCard.

® By default, deactivated users (disabled user accounts) are excluded from the people directory. You
can include them by adding the showDeact i vat edUser s parameter to the URL. For example:
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tivatedUser s=true

http://ny.confl uence. conf dopeopl edi rect orysearch. acti on?showbDeac

® By default, externally deleted users (for example, users deleted from an LDAP repository) are

excluded from the people directory. You can include them by adding the showExt er nal | yDel et edU

ser s parameter to the URL. For example:

rnal | yDel et edUser s=t rue

http://ny.confl uence. conf dopeopl edi rect orysearch. acti on?showkxt e

® The Confluence administrator can hide the people directory. If it is hidden, you will not see the People

Directory option.

Recently Viewed Pages and Blog Posts

The Recently Viewed list in Confluence keeps track of pages and blog
posts you've recently visited, and allows you to easily navigate back to them.

To view your recently viewed content:

1. Choose your profile picture at top right of the screen, then choose
Recently Viewed
2. Choose the title of the page you want to revisit

To filter the list, type part of a page title or user's name in the Filter field.

Your last ten recently viewed pages also appear when you click in Confluence's Search field before you start

typing a search query.

Related pages:

® Create and
Edit Pages

®* Your
profile and
settings
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Recently Viewed Pages

Filter
TODAY
Status update - Josh User
[S) Josh User's Home - Josh User
[S) Angry Nerds Home - Angry Nerds
[S) Sophie User's Home - Sophie User

Blogs are a great way to communicate - Sophie User

[©) Test page 1 - Sophie User

OLDER
[2) Test Space Home - Sample Space

[S) step 3 - share your favourite nerd - Angry Nerds
(2 step 2 - Play - Angry Nerds
[S) step 1 - download the game - Angry Nerds

Hint: type "g" and then "r" anywhere to quickly open this menu

Permissions and restrictions

As a tool for communication and collaboration, we .
believe Confluence is at its best when everyone can On this page: o
participate fully. Confluence keeps a history of all ® Levels of permission
changes to pages and other content, so it's easy to ® Global permissions
see who has changed what, and reverse any ® Space permissions

changes if you need to. * Page restrictions
®* How do permissions and

Confluence does, however, give you the choice to restrictions interact?
make your site, spaces, and pages as open or
closed as you want to. Related pages:
® Confluence Groups
Levels of permission ® Global Permissions Overview
® Space Permissions Overview
There are three levels of permissions in Confluence: ® Page Restrictions
Global permissions, space permissions, and page ® Configuring Confluence Security
restrictions. ® Confluence Security Overview and
Advisories

Global permissions

Global permissions are site-wide permissions, and
can be assigned by either a System or Confluence
administrator.

These permissions are pretty broad, and don't really
interact with space permissions or page restrictions.
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For full details, check out the overview of global
permissions in the Administrator's Guide.

Space permissions

Every space has its own independent set of permissions, managed by the space admin(s), which determine
the access settings for different users and groups.

They can be used to grant or revoke permission to view, add, edit, and delete content within that space, and
can be applied to groups, users, and even to anonymous users (users who aren't logged in) if need be.

One thing to watch out for is where a user is a member of multiple groups. You may have revoked
permission for that individual user to add pages, for example, but if they're a member of a groups
that is allowed to add pages, they'll still be able to create new pages in the space.

If you can't get the result you want from space permissions, or you're not sure, check with one of
your Confluence administrators to determine what permissions you should apply to individuals and
groups.

Page restrictions

Page restrictions work a little differently to global and space permissions. Pages are open to viewing or
editing by default, but you can restrict either viewing or editing to certain users or groups if you need to. Page
restrictions can be applied to published or unpublished pages and blog posts (drafts).

Don't forget, every page in Confluence lives within a space, and space permissions allow the space admin to
revoke permission to view content for the whole space. Even the ability to apply restrictions to pages is
controlled by the 'restrict pages' space permission.

How do permissions and restrictions interact?

You can restrict viewing of a page or blog post to certain users or groups, so that even if someone has the
'view' permission for the space, they won't be able to view the content of the page or blog post.

If someone's a space admin and you've used page restrictions to prevent them viewing a page, they won't be
able to see the page when they navigate to it. As a space admin though, they can see a list of restricted
pages in the space and remove the restrictions.

What about links?
Space permissions and page restrictions affect how links between Confluence pages are displayed.

® If someone doesn't have 'View' space permission, links to pages in that space will be visible, but they'll
get a "page not found" message. The space key is not revealed in the link URL.

® If someone has the "View" space permission, but the page has view restrictions, the link will be visible
but they'll get an "access denied" message when they click the link.

Links to attachments are also affected. If the visitor doesn't have permission to view the page the attachment
lives on, the link won't be rendered.

Confluence Groups

For Confluence administrators, grouping users in Confluence is a great way
to cut down the work required when managing permissions and restrictions.
Groups are also very useful, however, to anyone who's a space admin, or
can apply page restrictions.

If you're a space admin, you can assign a set of space permissions to a
group rather than to each individual user. And as a page creator with
'Add/Delete Restrictions' permission, you can also add and remove page
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restrictions for groups. .
On this page:
® Default

Default Confluence groups
Confluenc

There are some default groups in every Confluence instance but, beyond € groups
that, Confluence administrators are free to set up and edit groups in any way * Anonymou

they see fit. S U;ers
® Unlicensed

users from
linked
application
S

Related Pages:

® Space
Permission
s Overview

® Assign
Space
Permission
S

®* Page
Restriction
S

® Confluenc
e Groups
for
Administra
tors

The two special groups in Confluence are:

® confluence-administrators — Can perform most of the Confluence administrative functions, like
assign permissions to other users, but they can't perform any functions that could compromise the
security of the Confluence system. They can also access the Confluence Admin console.

® confluence-users - this is the default group into which all new users are assigned. Permissions
defined for this group will be assigned to all new Confluence users.

Anonymous Users

All users who don't log in when they access Confluence are know as ‘anonymous' users. By default,
anonymous users don't have access to view or change any content in your Confluence instance, but
Confluence admins can assign permissions to this group if it's required.

Overlapping group and user permissions
When a user is assigned more than one permission, the more powerful permission will prevail.

Further explanation:

® A user may be assigned a permission specifically to their username. They may also be
assigned a permission by belonging to a group, or even several groups.

® The user will then be able to perform all functions assigned to them.

® Soif a user is allowed to do something over and above what the group can do, the user will be
able to do it. And if the group is allowed to do something over and above the specific
permissions granted to the user, the user will still be able to do it.

® |f anonymous users are allowed to do something over and above what the user or group can
do, the user will be able to do it, (even while logged in).
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Unlicensed users from linked applications

If you're using Confluence as a knowledge base for JIRA Service Desk, your JIRA Service

Desk administrator can choose to allow all active users and customers (that is logged in users who do not

have a Confluence license) to view specific spaces.

These users have very limited access, and cannot be granted permissions in the same was as an individual
or group. However, it's important to note that this permission overrides all existing space permissions, so any
logged in Confluence user will also be able to see the space (regardless of their group membership). This is

due to the way Confluence inherits permissions.

Add-ons and integrations

Confluence has a wide range of features on its own, but you can also extend
those features with add-ons, and by integrating Confluence with other
applications. Integrating with JIRA applications and HipChat can really take
your Confluence experience to the next level by improving the way your

Related pages:

Use JIRA
application

teams communicate and collaborate, track vital work, and plan and release

new products.

If there's an extra piece of functionality you need, the Atlassian Marketplace
is the place to look for useful Confluence add-ons (or add-ons for other
Atlassian products). Whether you need to create diagrams, like the ones you
can create with Gliffy, or you want to make awesome mockups and
wireframes with Balsamiq, there are heaps of great add-ons in the
marketplace. You may even find a really useful add-on you never knew you

needed, but now can't live without.

In this section:

Use HipChat and Confluence together
Request Add-ons

Use a WebDAV Client to Work with Pages
Mail Archives

Gadgets

Use JIRA applications and Confluence together

Confluence and JIRA are like bacon and eggs;
coffee and cake; Simon and Garfunkel. Separately,
they're great, but together, they're amazing!

If your Confluence and JIRA sites are connected
using Application Links, you can display and create
JIRA issues and more from within Confluence.

What you can do with Confluence and JIRA depends
on the JIRA application and version you have. Find
out about the required applications and versions late
r in this page.

For every project or team

Display issues on a page

You can display JIRA issues on a Confluence page
using the JIRA Issues macro. Display a single issue,
a list of issues, or show the total number of issues.

The simplest way to add a JIRA issue to Confluence
is to paste a JIRA URL on a Confluence page.
~ Here's some examples...

Use JIRA applications and Confluence together

s and
Confluenc
e together

® Use
HipChat
and
Confluenc
e together

® Usea
WebDAV
Client to
Work with
Pages

® Gadgets
Mail
Archives

® Request
Add-ons

On this page:

® For every project or team
® Display issues on a page
® Create reports and charts
® Create issues from inside
Confluence
®* Move between JIRA and
Confluence
® For software teams
® Define your requirements
® Manage your sprints
® For service desk teams
® Provide self help resources
for your customers
® Create knowledge base
articles
® Allow any active user to see
knowledge base spaces
® JIRA applications required
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® <yourjirasite.conp/ browse/ CONF-
1234 will insert the JIRA Issues macro
and display a single issue.

® <yourjirasite.conp/issues/?filt
er =56789 will insert the JIRA Issues
macro and display a list of issues
matching the saved filter.

® <yourjirasite.conp/issues/?jql=
proj ect ¥20Y8D¥R20CONF will insert the
JIRA Issues macro and display a list of
issues matching the JIRA search.

Alternatively, you can add the JIRA Issues Macro to the page and search for issues directly:

1. In the editor choose Insert > JIRA Issue.
2. Follow the prompts in the macro browser to choose a project and search for an issue — you can even
use JIRA Query Language (JQL).

Once you've added the macro, you can customize how the issue or list of issues appears on the page,
including how much information to display, how many issues, and more.

T Key Summary Status

a CONF-26T91 PODF Export Table RESOLVED
Hidden by Margin

Ed CONF-35848 Roadmap time RESOLVED
period only
showing months

+ CONF-25846  Automated row RESOLVED
number I1.__'| n
tables

3issues " Refresh

Create reports and charts

Reporting on information stored in JIRA is simple in Confluence. In addition to the JIRA Issues Macro, you
can use the JIRA Report blueprint or JIRA Chart macro to show information from your JIRA application
visually. It's the best way to give your stakeholders a snapshot of your team or project's progress.

You can:

® Use the JIRA Report blueprint to create a Change Log or Status report.

® Use the JIRA Chart Macro to display data as a chart, including pie charts, created vs resolved, and
two dimensional charts.

® Use JIRA Gadgets to display detailed JIRA reports and charts on pages.

Create issues from inside Confluence

You can create issues while viewing a page or from the within the editor. This is really useful if you use
Confluence for planning and gathering requirements.

To create an issue when viewing a page:

1. Highlight some text on your page and choose the
X
Create JIRA issue icon that appears above the highlighted text.
2. Enter your server (if you have multiple JIRA sites connected to Confluence), project, issue type and
description. Your highlighted text will populate the issue summary automatically.
3. Choose Create.
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The issue will be created in JIRA and added to your page. If your text is in a table, you'll have the option to
create multiple issues using text from the same column.

If you don't see a popup when you highlight text, check that Text Select is enabled in your profile settings.
To create an issue in the editor:

1. In the editor choose Insert > JIRA Issue > Create new issue.

2. Enter your server (if you have multiple JIRA sites connected to Confluence), project, issue type, su
mmary, and description.

3. Choose Insert.

The issue will be created in JIRA and added to your page.

There are some limitations when creating JIRA issues from Confluence. The JIRA Issues macro or Create
JIRA Issue dialog will notify you if it's unable to create an issue in the selected project. You can find out more
in the JIRA Issues Macro page.

Move between JIRA and Confluence

Whenever you add a link to JIRA issues in Confluence, or link to a Confluence page from your JIRA
application, the JIRA Links button appears at the top of the Confluence page. This makes it really easy to
jump from Confluence to JIRA and vice versa, speeding up your workflow.

The number on the JIRA Links button indicates the total number of issues, epics, and sprints connected to
that page, regardless of whether you have permission to view them. The dropdown, however, will only show
details of issues, epics, and sprints that you have JIRA permissions to view.

The button doesn't detect links from issues displayed in the JIRA Issues macro in table format.

Pages / Mobile Development Team / Product requirements o' ¥ 6 JIRA links
Mobile Web Requirements
Created by Mitch Davis, last modified just a moment ago JIRA links
(%) Epics
Target release 1.0 MDT-18 and
Epic (¥) MDT-18 - Mobile optimized web app 1~ "o01e oplimized web app s on
aily bg
Document status DRAFT (2] Issues dtoh
MDT-17 TODO
Document owner  [@LY[[T =15 Twitter Integration
arch
Designer Cassie Owens MDT-16 T0DO
API tervie
Developers Harvey Jennings MDT-15 ToDpo tervie
QA Kevin Campbell Post Updates fervie
MDT-14 TODO
Requirements Activity Stream
MDT-13 TODO
#  User story User story description Facebock Integration Prioril
title
1 Facebook A user wants to sign up via Facebook Must
Integration Have

For software teams

Here's some suggestions to help you get the most out of Confluence and JIRA Software and unleash the
potential in your agile development team.

Define your requirements

Confluence is the perfect place to start defining your requirements. You can use the Product Requirements
Blueprint to capture your requirements, then create your JIRA epic and other issues right from the
requirements page in Confluence.

Here's how it works:

1. Create a Confluence page using the Product Requirements Blueprint.
2. Choose the placeholder text 'Link to JIRA epic or feature' and choose Create new issue to create
your epic in JIRA.
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3. Collaborate with your team to define your stories and save the page.

4. Highlight text on your requirements page and choose the Create JIRA issue
X
link to create stories in JIRA, and automatically link them to your epic.

5. Track the progress of the stories from the Confluence page or from within JIRA.

Awesome new product requirements

Createc

Create Issue Server: Atlassian J... ~

Targ
® Angry Nerds <
Epic ; stories OPEN

(5] Sto v
Doct — g

Summary*
Doct
Require no work
Desi
Description
Deve¢

QA 2
Link to epic [¥] ANERDS-4575
Goal Create = Cancel

S S — —

* Require no work

The tight integration between Confluence and JIRA Software means you can easily access issues from the
Confluence page and see their status at a glance, and from within JIRA Software you can see links to related
Confluence pages. All the information you need is right there.

Manage your sprints

There's often a lot of material in Confluence that provides useful context for your team during a sprint. These
might be requirements documents, designs, tech specs, customer research and more. By linking these
pages to epics, you make them easy for your team to find during the sprint.

Here's how you can use Confluence to support your sprint from within JIRA Agile:

* In JIRA Software, create a Confluence page to plan your sprint. The page is created using the Meeting
Notes Blueprint — a handy template that helps capture the details you need — and is automatically
linked to the sprint.

In an epic, link to useful Confluence pages, including requirements, designs, and more.

Report on your progress to stakeholders using the JIRA Report blueprint in Confluence.

Use the Retrospective Blueprint in Confluence at the end of your sprint to take stock of what went well
and not so well.

For people who work mostly in JIRA Software, the integration means that useful Confluence pages are only a
click away.

For service desk teams

Provide self help resources for your customers

If you use JIRA Service Desk, you can help your customers resolve their issues without creating a request by
connecting your Service Desk project to a knowledge base in Confluence.

In Service Desk, head to Project settings > Knowledge base to connect or create a Confluence space.

When Service Desk customers search in the Customer Portal, pages in the linked knowledge base space will
be suggested, allowing customers to help themselves.
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print]

& Printer jam

@ Printer out of toner
& Printer out of paper

. Set up your remote office
Get assistance from IT on setting up your remote workstation (including
requesting new equipment for telecommuting)

Create knowledge base articles

The Knowledge Base space blueprint, along with templates for how-to and troubleshooting articles make
creating new knowledge base articles super simple for your Service Desk agents.

The templates used in the how-to and troubleshooting blueprints are completely customizable too. Set up the
template with all your standard information and let your agents take it from there.

Allow any active user to see knowledge base spaces

If your Confluence instance is not public, you can still make a knowledge base space available via the
customer portal.

When you link your JIRA Service Desk project to a Confluence space, you can choose to allow all active
users and customers to see pages in the linked space, even if they don't have a Confluence license. These
people get very limited Confluence access.

Unlicensed users can:

® View pages via the JIRA Service Desk customer portal.
® Follow a URL to a page and then navigate within the linked space.

Unlicensed users can't:

® |ike, comment on or edit pages (or be granted permission to do this).
® See the dashboard, user profiles, the people directory or space directory.
® Search the whole site.

This permission can only be enabled via JIRA Service Desk, but you can revoke access to the whole site or

to particular spaces via Confluence's global permissions or space permissions.

~ A note about Confluence permissions...
Allowing all active users and customers to view a space will override all existing space permissions, so
any logged in, licensed Confluence user will also be able to see the space (regardless of their group
membership). This is due to the way Confluence inherits permissions.

JIRA applications required

As you've seen, Confluence has many integration points, some of which are only available in particular JIRA
applications or versions.

This matrix outlines the specific JIRA applications you'll need for each feature. We've also included the
minimum legacy JIRA Server version (plus any add-ons) that you'll need if you're not using the latest JIRA

applications.
Feature JIRA JIRA JIRA Service  Minimum legacy
Core Software Desk version
Display issues using JIRA issues macro JIRA 4.3
Display issue and project information JIRA 5.0

using JIRA chart macro
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Display issue and project information o
using the JIRA Report blueprint

Create an issue from JIRA issues macro

Create issues by highlighting text on a
Confluence page

Create issue by highlighting text on a
Confluence page and automatically link
issues to an epic

Link and create Confluence pages from
epics and sprints

View linked issues with the JIRA links
button in Confluence

Create a space using the Software
Project space blueprint

Use a Confluence space as a knowledge
base in the customer portal

Allow Service Desk customers to view
knowledge base articles without a
Confluence license

Search for an existing Confluence page
within the JIRA link dialog

Delegate user management to JIRA

Add a JIRA gadget to a Confluence page

(] (] JIRA 5.0

JIRA 4.3

JIRA6.3.1

JIRA 6.3.1 and
JIRA Agile 6.3.5

JIRA 6.3.1 and
JIRA Agile 6.3.5

JIRA6.3.1

JIRA Software 7.0

JIRA 5.2 and

JIRA Service Desk

1.0

JIRA Service Desk

3.1

JIRA 4.3

JIRA 4.3

JIRA 4.3

That's it? Time to jump into Confluence and give some of these great features a try with your team or

project.Want to find out more about how to connect your JIRA application to Confluence? Check out Integrati

ng JIRA and Confluence.

Use HipChat and Confluence together

HipChat is a group messaging and video chat app
for team communication.

Connect a Confluence space to a HipChat room to
get instant updates about changes in the space,
send realtime notifications to the room, and share
what you've been working on with your team.

Don't have HipChat yet? Sign up for free and start
chatting right away.

Connect Confluence and HipChat

You'll need to be a site admin with global
permissions for both Confluence and HipChat to set
up the initial connection between Confluence and
your HipChat group. Go to

> General Configuration > HipChat Integration a
nd choose Connect HipChat.

Connect spaces to rooms

On this page:

® Connect Confluence and HipChat

® Connect spaces to rooms

® Send space notifications to
HipChat

® Get Confluence in your HipChat
sidebar

®* Need to chat? See from
Confluence if someone's online on
HipChat

® Spice up your pages with HipChat
emoticons

® Create HipChat rooms from
Confluence

® |nvite users to HipChat from
Confluence
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If you're a space admin, connect your space to a HipChat room by going to Space Tools > Integration > Hip
Chat and selecting which rooms you'd like to connect. A space can be connected to as many HipChat rooms
as you like, and a HipChat room can be connected to multiple spaces.

Send space notifications to HipChat

When choosing which rooms to connect, you can also choose which notifications you'd like to send to each
room.

HipChat =~ Application Links

Hipchat integ ration (&) Invite users to HipChat
° Connect ° Choose Invite
Confluence is integrated with Awesome! Go ahead and set up Invite your team to collaborate in
HipChat group Atlassian - testing. more rooms below. HipChat
From space: Sample Space = | Select HipChat room < [ o
Space Room
Sample Space -+ Marketing Team Edit notifications €
Sample Space - Sydney Social Done €
NOTIFY THIS ROOM WHEN
Blog post is created Page is created Page is updated Question is asked ® e

HIPCHAT CLIENT NOTIFICATIONS

Notify users in the room

1. Pick aroom: choose a HipChat room to send natifications to.
2. Decide what to send: select the type of notifications to send to the room.

Notifications appear in realtime, and clicking on them takes you straight to Confluence.

You can choose different notification settings for each space-room connection. A design team working on a
specific project could choose to get updates from that project's space whenever a page is updated, so they
can keep close track of its progress. From their team space, though, they might choose to be notified only
when there’s a new a blog post, so they're up to date on important team news but don't get interrupted by
any other changes in that space.

Change the notification settings whenever you like by going to Space Tools > Integration > HipChat, and
clicking on Edit Notifications next to the room name.

Permissions and restrictions
Want to keep something private? Don't worry, rooms are never notified about the creation or update

of any content with view restrictions on it.

Get Confluence in your HipChat sidebar

Find content you've viewed or worked on in Confluence in your HipChat sidebar, so you can easily resume,
share or discuss work with your team. Once a space has been linked to a room, you can find this in your
sidebar either under the space name or, if you have multiple spaces linked to your room, under the name of

your instance.

Select the name of your space or instance, then follow the prompts to authenticate your account. This will let
you open up a Confluence glance in your sidebar. Switch tabs to view either all Updates from the space
linked to that room, or My Work from across Confluence.

The My Work tab lets you filter all the content from Confluence that you've been Mentioned in, Recently
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Worked on, Recently Visited or Saved for later. Now, when you want to share an important piece of
information with your team, ask them to review your work or collaborate with you, you can find and link them
to relevant content directly from HipChat.

Need to chat? See from Confluence if someone's online on HipChat

Got questions about something someone else has worked on? Once your Confluence instance is linked to
your HipChat group, you can hover over a user mention or a byline in Confluence to see if the user is
available in HipChat. Green for available, yellow for away, or red for do not disturb.

Staff Mannian [Atlassian] @
smrigdatlassian.com

Follow Maore -

Spice up your pages with HipChat emoticons

In the editor go to Insert > Emoticons to bring your pages to life with

@)

emoticons. You can also type them right into the editor like this (success)

2

All HipChat's default emoticons can be found here, along with any custom ones people in your organization
have added.

Create HipChat rooms from Confluence

Setting up a new team or project? Create a new HipChat room at the same time, through Confluence. If
you're a space admin, go to Space Tools > Integration > HipChat and instead of selecting an existing room
in the dropdown, type in the name of the new room you want to create and hit Add.

Invite users to HipChat from Confluence

If you're a global admin for both Confluence and HipChat, you can send users HipChat invites directly from
Confluence. Go to

> General Configuration > HipChat Integration > Invite users to HipChat.

You'll need at least one space integrated with a room to see the Invite users link.
Request Add-ons

The Atlassian Marketplace website offers hundreds of add-ons that the administrator of your Atlassian
application can install to enhance and extend Confluence. If the add-on request feature is enabled for your
Confluence instance, you can submit requests for add-ons from the Marketplace to your Confluence
administrator.

The 'Atlassian Marketplace for Confluence' page provides an integrated view of the Atlassian Marketplace from
within your Confluence instance. The page offers the same features as the Marketplace website, such as
searching and category filtering, but tailors the browsing experience to Confluence.

This in-product view of the Marketplace gives day-to-day users of the Atlassian applications, not just
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administrators, an easy way to discover the add-ons that can help them work. When you find an add-on of
interest, you can submit a request with just a few clicks.

Submit an add-on request

To browse for add-ons in the Atlassian Marketplace, follow these steps:

1. Choose your profile picture at top right of the screen, then choose Atlassian Marketplace.

2. In the Atlassian Marketplace page, use the search box to find add-ons or use the category menus to
browse or filter by add-ons by type, popularity, price or other criteria. You can see what your fellow users
have requested by choosing the Most Requested filter.

3. When you find an add-on that interests you, click Request to generate a request for your administrator.

4. Optionally, type a personal message to your administrators in the text box. This message is visible to
administrators in the details view for the add-on.

Request an Add-on

ﬁﬁ:ﬁ% Confluence Source Editor

by Atlassian Labs

L]
=
You can request that your system administrators install this add-on. They will get a

notification inside the application that you have made this request. You can check back
here to see if it has been installed.

Please enter an oplional message with your request:
This would really help me

Submit Request

5. When ready, click Submit Request.
6. Click Close to dismiss the 'Success!" message dialog box.

At this point, a notification appears in the interface your administrators use to administer add-ons. Also your
request message will appear in the add-on details view, visible from the administrator's 'Find New Add-ons'
page. From there, your administrator can purchase the add-on, try it out or dismiss requests.

Update an add-on request

After submitting the request, you can update your message at any time. Click the Update Request button next
to the listing in the Atlassian Marketplace page to modify the message to your administrator.

The administrator is not notified of the update. However, your updated message will appear as you have
modified it in the details view for the add-on immediately.

Use a WebDAYV Client to Work with Pages

Create, move and delete pages and attachments in Confluence using a file manager like Finder (OS X), Explorer
(Windows) or Dolphin (Linux) or other WebDav compatible local client like CyberDuck.

For example, if you need to delete a lot of pages you can bulk delete them in your local file manager (like Finder
or Explorer), rather than one by one in your browser.

Access to Confluence through a native client is provided by the WebDav plugin. Your administrator may have
disabled the WebDav plugin, or may have restricted the actions that you can perform using a local client. See Co
nfiguring a WebDAYV client for Confluence for more information on how to set it up.
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Manage pages and files in a native client

Accessing Confluence through a native client is useful for performing bulk actions. Before you can start creating
and moving things around, it's useful to understand how the content is organized.

The hierarchy in the file system looks like this:

® Type of space (global or personal)
® Space (folder name is the spacekey)
®* Homepage (and other top level pages)
® Child pages (folder name is the name of the page)
® Attachments (filename of the attachment)

Essentially the file structure is the same as the page tree in your space. Here's how the Confluence
demonstration space looks in Finder.

@00
L >

= r

) default .
B () (8] (5 (2] (=] @

Date Modified Size Kind

Name a

# Applications

_ v [ Global -
o || Desktop ov [ ds )
Jﬂ] Documents » [ @news —

0 Downloads " Demaonstration Space.txt Zero bytes Plain 1
5 . v || Welcome to Confluence -
H Movies b || @exports - Folder
J3 Music » [ @versions --  Folder
o T PreTTes ® » [ ] A quick look...or (step 2 of 9) -- Folder
- » [ Get serious wi...e (step 5 of 9) -- Folder
il Confluence » | ] Lay out your page (step 6 of 9) Today 5:08 pm -- Folder
|- Macintosh HD » [ ] Learn the wo...rt (step 7 of 9) Today 5:08 pm Folder
T > Q Let's edit this page (step 3 of 9) To 5:08 pr -- Folder
. » | ] Share your pa...r (step 9 of 9) -- Folder
() Remote Disc » [ Tell people w...nt (step 8 of 9) --  Foldet
SHARED | Welcome to Confluence.txt 28 am 3 KB Plain 1
— @ Welcome to Confluence.url 28 am 92 bytes Web s
e L_I—rad‘doc"“ = ® « welcome.png 28 am 3 KB PNG ir
» ] What is Confl...e? (step 1 of 9) Today 5:08 pm -- Folder

» [0 ss

Today 5:08 pm —

1. Space key
2. Page title
3. Attached file

Here's some things you might choose to do in a local client, rather than in your browser:

® Move pages to another space
Select the page folders, and drag them into the other space's folder (drag them from Space A to Space B)
® Delete multiple pages
Select all the page folders you want to delete and delete them.
® Delete multiple attachments from a page
Navigate down to the page folder, select the attachments you want to delete and delete them.
® Upload multiple attachments
Navigate to the page folder, and drag the files into the folder (note you can attach multiple files through
the insert dialog as well).

Mail Archives

Confluence allows you to collect and archive mail within each space. It's
useful for storing the email messages that relate to a particular project — you

Related pages:

can put them in the same Confluence space as the content for that project. ® Spaces
® Add a Mail
You can download mail from one or more POP or IMAP accounts, or import Account

mail from an mbox file on your local system or on the Confluence server.

You need space administration permissions to manage the mail archives.

Confluence mail archiving is an optional feature. This means that
the 'Mail' options may be disabled and will therefore not appear in
the Confluence user interface. Mail archiving features are contained
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in a bundled plugin. To activate mail archiving features in
Confluence, enable the plugin — choose

> General Configuration > Manage Add-ons. Then choose Syste
m in the drop down, and enable the Confluence Mail Archiving
Plugin.

To see archived mail:

® Go to a space and choose Space tools > Integrations > Mail
® Choose a message to see its contents, or choose Next, Previous an
d other options to navigate around the mail archives.

Manage mail archives:
® Add a Mail Account
® Delete and Restore Mail
® |Import Mail from an mbox

Screenshot: Viewing a message in the mail archive

Confluence Development / Browse Space / Mail Archive

Tom's on annual leave today (Monday)

Add
. Mail Operations
Subject Tom's on annual leave today (Monday) (find more) & Next By Date
From: Tom Davies <tomdavies@exemail.com au= (find more) & Previous By Date

Date: Oct 22, 2006 16:12 =
i Remove Mall

I'll see you all on Tuesday. £ Mail Archive

Tom

Notes

® Only site spaces — not personal spaces — can store mail archives. See Spaces for information on site
and personal spaces.

® You can also search the mail messages and their attachments. See Search.

® Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled
and will therefore not appear in the Confluence user interface. Mail archiving features are contained in
a bundled plugin. To activate mail archiving features in Confluence, enable the plugin — choose

> General Configuration > Manage Add-ons. Then choose System in the drop down, and enable
the Confluence Mail Archiving Plugin.

Add a Mail Account
When you add a mail account, you're configuring Confluence to download
mail from that account and archive it within the space.

You need space administration permissions to add a mail account. See Spa
ce Permissions Overview.

I Note: Confluence will remove email messages from an email account
when it transfers them to the mail archive. You must therefore configure
Confluence to poll a clone email account rather than the actual account. For
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example, to archive the actual account sal es@onpany. com to your
Confluence Sales space, you must first create a clone account such as con
f-sal es@onpany. com that contains the same email content.

Add a mail account

Step 1. Create a clone email account on the mail server

1.

2.

Add a new email account on the mail server with the clone email
address.

Copy all existing email messages from the actual account to the
clone account.

Set up the actual account to bcc sent email messages to the clone
account.

Set up the actual account to forward received email messages to the
clone account.

Step 2. Configure Confluence to archive the clone account

Enter configuration details for the account:

Description: Provide a description for this account (optional).
Protocol: Choose from POP, IMAP, POPS or IMAPS.

® Password: Enter the account's password.
Choose Test Connection to verify the details
Choose Create to add the account to Confluence

On this page:

®* Add a mail
account

® Fetching
Mail

®* Notes

Related pages:

* Malil
Archives

®* Howdol
check
which
spaces
have email
accounts?

®* Howdol
disable
automatic
mail
polling?

. Go to the space and choose Space tools > Integrations from the bottom of the sidebar.
. Choose Mail Accounts > Add mail account.

Account Name: Enter a name for this account by which it will be known in Confluence.
Hostname: Enter the host name of the mail server on which the account resides.

Port: Don't edit this field. The mail server's port number will be displayed by default.
Username: Enter a username that has permission to retrieve mail from this account.
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Application Links = Mail Accounts = Mailbox Import  Mail

Configured accounts (including IMAP) will have
their mail downloaded and removed from the
server. For more information, please refer to our
online documentation.

Account Name  Gil's Mail

Description My Atlassian email

4»

Protocol = IMAP
Hostname | imap.gmail.com
Port | 143
Username  username@atlassian.com
Password | essesess

Create Test Connection = Cancel

For each mail account you add, you can perform these actions in the Mail Accounts tab:

® Edit: Change the configuration settings for the mail account.
®* Remove: Remove the account permanently.
* Disable/Enable: Temporarily disable the account, or enable a disabled account.

Fetching Malil

Confluence automatically fetches mail from the server once every 30 minutes. You can manually retrieve
new mail from the configured mail accounts by selecting the Mail tab and choosing Fetch new mail.

® You need to be a space administrator to manually retrieve mail. See Space Permissions.

Notes

® Only site spaces — not personal spaces — can store mail archives. See Spaces for information on site
and personal spaces.

® Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled
and will therefore not appear in the Confluence user interface. Mail archiving features are contained in
a bundled plugin. To activate mail archiving features in Confluence, enable the plugin — choose

> General Configuration > Manage Add-ons. Then choose System in the drop down, and enable
the Confluence Mail Archiving Plugin.
® Once malil is fetched it will be removed from the server.

Delete and Restore Mail

To delete mail from a space, you need 'Delete Mail' permission. Related pages:
© Only a space administrator can delete all email messages in the space * Mail
simultaneously. Archives
To delete mail from a space: 7 cald @i
Account

1. Go to a space and choose Space tools > Integrations > Mail
A list of email messages in the space is displayed in reverse
chronological order.
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2. Do either of the following:
® Delete an individual email message by choosing the trash
T}
icon beside it.
® Delete all email messages within the space by choosing Delet
e All.

I, Email messages deleted using the 'Delete All' option can't be restored.
Space administrators can restore deleted email messages, provided they were deleted individually.
To restore deleted mail:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Trash

You'll see a list of email messages and other content deleted from the space.
3. Choose Restore beside the email message you want to restore.

Import Mail from an mbox

Confluence allows you to import mail from mbox files located either on your Related pages:
local system or in a specified location on the Confluence server. Confluence

will store the imported email messages in the space's mail archive. * Malil )
Archives

You need to be a space administrator to import mail for a space. See Space * Add a Malil

Permissions. Account

NB: You may need to enable the Confluence Mail Archiving Plugin as itis
disabled by default.

To import mail from an mbox file:

1. Go to the space and choose Space tools > Integrations from the bottom of the sidebar.
2. Choose Mailbox Import.
®* To import from a location on your file system: Browse to the location of the mbox file, select the
file and then choose Import.
® To import from the Confluence server: Enter the location of the mbox file on the server, then
choose Import.

Notes

® Only site spaces can store mail archives. Personal spaces cannot. See Spaces for an explanation of
site spaces and personal spaces.

® Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled
and will therefore not appear in the Confluence user interface. Mail archiving features are contained in
a bundled plugin. To activate mail archiving features in Confluence, enable the plugin — choose

> General Configuration > Manage Add-ons. Then choose System in the drop down, and enable
the Confluence Mail Archiving Plugin.

® For security reasons mail can only be imported from a specified location in the Confluence server's file
system. We recommend administrators create a folder in their Confluence home directory, add the
system property confl uence. nmbox. di r ect ory and specify the location for mailboxes to be
imported from . Mail cannot be imported from the server until this system property is set. See Configuri
ng System Properties.

Gadgets

Gadgets allow you to add dynamic content to a Confluence page or JIRA
application dashboard. Confluence can display gadgets that support the Op
enSocial specification, including third party gadgets.

For more information about Atlassian gadgets, see the introduction to
Atlassian gadgets and the big list of Atlassian gadgets.

To see a list of available gadgets in your Confluence site go to Help > Avail
able Gadgets.

Created in 2017 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/
https://confluence.atlassian.com/display/CONF63/Configuring+System+Properties
https://confluence.atlassian.com/display/CONF63/Configuring+System+Properties
http://www.opensocial.org
http://www.opensocial.org
https://confluence.atlassian.com/display/GADGETS/Introduction+to+Atlassian+Gadgets+and+Dashboards
https://confluence.atlassian.com/display/GADGETS/Introduction+to+Atlassian+Gadgets+and+Dashboards
https://confluence.atlassian.com/display/GADGETS/All+Atlassian+Gadgets

Confluence 6.3 Documentation

The following gadgets are bundled with Confluence. On this page:
®* Adda
Name Description Confluenc
e gadget to
Confluence Page Gadget The Confluence page gadget a page
allows you to show content from a e Adda
page on your Confluence site in a JIRA
gadget. You can optionally gadget to a
configure the gadget to display page
links to view and/or edit the page e Adda
on your Confluence site. The page Confluenc
gadget can also be displayed in e gadget to
canvas view, so that it takes up all your JIRA
of the space provided by your application
dashboard. dashboard
Activity Stream Gadget The activity stream gadget is Related pages:
similar to the recently updated
macro and shows a list of the most * Gadget
recently changed content within Macro
your Confluence site. * ﬁltllassian
Confluence News Gadget The Confluence news gadget is an gadgets
example of a 'news feed' gadget * External
that shows a list of recent Confluen Gadgets
ce Product Blogs and events at
Atlassian.
Confluence Quicknav Gadget The Confluence QuickNav gadget

provides the Quick Navigation Aid f
unctionality for searching the
Confluence site. For more
information on how to use this
feature, refer to the Quick
Navigation Aid section of Search.

Add a Confluence gadget to a page

Where a similar result can be achieved using standard Confluence macros (for example using the Include
Page Macro instead of Confluence Page Gadget), we recommend using macros as they have better
performance and are easier to configure than gadgets.

To add a Confluence gadget to a page:

® |n the editor go to Insert > Other Macros.
® Select the gadget you wish to add, and use the preview area to configure the gadget.
® Choose Insert.

See Gadget Macro for more information on adding the macro to your page, configuring the gadget itself and
display options.

Add a JIRA gadget to a page

For displaying basic JIRA information, such as issues and charts, we recommend using the JIRA Issues
Macro and JIRA Chart Macro as these macros have better performance and are easier to configure than
gadgets.

If the JIRA information you want to display is not available from either of these macros a gadget will likely do
the trick.

To add a JIRA Gadget to a Confluence page:

® |n the editor go to Insert > Other Macros.
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® Select the gadget you wish to add, and use the preview area to configure the gadget.
® Choose Insert.

See Gadget Macro for more information on adding the macro to your page, configuring the gadget itself and
display options.

If you don't see any JIRA Gadgets in the macro browser, ask your Confluence administrator to add
the JIRA Gadget urls to the list of authorized external gadgets in Confluence, and check that the
application link between Confluence and your JIRA application is configured correctly.

Add a Confluence gadget to your JIRA application dashboard

To add a Confluence gadget to your JIRA dasboard:

1. Go to the dashboard by selecting the Dashboard link in the header.

2. On the dashboard, Click Add Gadget.
3. Use the gadget wizard to choose the gadgets you want to add.

If you don't see any Confluence gadgets in the JIRA gadget directory, ask your JIRA administrator to
add the gadget URLs as follows.

To add a Confluence gadget to your JIRA application's gadget directory:

1. In Confluence, go to Help > Available Gadgets and copy the gadget URL for the gadget you

want to make available in JIRA.
2. In JIRA, go to the dashboard and choose Add Gadget.
3. Choose Manage Gadgets or Add Gadget to Directory (depending on your JIRA application

and version)
4. Paste in the Confluence gadget URL and choose Add Gadget.

The gadget will now be available from the JIRA Gadget Directory.

Activity Stream Gadget
The activity stream gadget is similar to the recently updated macro and shows a list of the most recently

changed content within your Confluence site.

In addition to showing a list of most recently changed content, the activity stream gadget also groups activities
by separate date, and provides an RSS feed link to its content in the top-right corner.

Activity Stream Gadget Properties

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data
retrieved by the gadget. These are similar to a Confluence macro's parameters. The table below lists relevant

properties for this gadget.

These properties are located in the preview panel in the macro browser.

Property Required? Default Description

Title Yes None Adds a title to the top of the Activity Stream.
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Global No None Allows you to add filters to the gadget including:
filters

® space

® username

® update date

[ ]

JIRA application)

Available Yes All If you have application links to other sites, JIRA or another
streams Confluence site, you can choose to include activity from those

streams also.

Display No 10 Specify the maximum number of results to be displayed. A
options: maximum of 10 results will be displayed by default. The maximum
limit value that this property can accept is 100.

Display No Never/false Specify the time interval between each 'refresh' action undertaken
options: by the activity stream gadget. A refresh makes the activity stream
Refresh gadget reflect any new activity that has been conducted on the
Interval Confluence site.

Confluence News Gadget

The Confluence news gadget is an example of a 'news feed' gadget that shows a list of recent Confluence

Product Blogs and events at Atlassian.

Clicking an item in the Confluence news gadget takes you directly to the selected blog post of the Confluence

Product Blogs feed or event details on the events at Atlassian page.

Clicking More news takes you to the Confluence Product Blogs feed page and clicking More events takes you

to the events at Atlassian page.

Screenshot: The News Gadget

JIRA issue key (if your Confluence instance is integrated with a

News

® Confluence 5 Highlights: 4 Improvements to User and Content Manageme
® Confluence 5 Highlights: Automagic Theming

® How-to: Building a Company Glossary with Confluence — Part Three

Ore News

Events

* NTRAMNET Reloaded When: Thu Apr 25, 2013 to Fri Apr 26, 2013

& Facebook Conference When: Tue Mar 12, 2013 5am to 10:30am PDT

* Fefifizierungsschulungen zum JIRA Professional von SEIBERT MEDIA Wi

ATLASSIAN
USER GROUP

Find an Atlassian User

Group in your area »
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Confluence: News Gadget Properties

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data
retrieved by the gadget. These are similar to a Confluence macro's parameters. The table below lists relevant

properties for this gadget.

Property Required? Default Description

Show News? No True Shows a short list of the most recent Confluence Product Blogs.
Show Events?  No True Shows a short list of the most recent events at Atlassian.

Show Banners? No True Shows any banner advertisements (if available).

Confluence Page Gadget

The Confluence page gadget allows you to show
content from a page on your Confluence site in a
gadget. You can optionally configure the gadget to
display links to view and/or edit the page on your
Confluence site. The page gadget can also be
displayed in canvas view, so that it takes up all of
the space provided by your dashboard.

Macros that work with the page gadget

Please note, not all macros work with the page gadget. Please refer to the Working Macros section

below for more information.

On this page:

® Confluence Page Gadget
Properties
® \Working Macros

Screenshot: The Confluence page gadget displaying a sample page

Sample Page

@ iew

Two penguins find themselves together on an ice floe, drifting
helplessly into warmer waters. The penguins are very fond of each
other. Suddenly cra-a-a-a-ck the ice flow splits in half, right between
the penguins. As they drift apart, one penguin sadly waves a flipper

and calls out "Chocolate milk!"

Confluence Page Gadget Properties

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of
data retrieved by the gadget. These are similar to a Confluence macro's parameters. The table below lists

relevant properties for this gadget.

Property Required? Default Description
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Space No None Specify the space that your desired page is located in. Suggestions
will display in a dropdown when you start typing.
(Note, this property is only used to make searching for pages
easier. It is not required.)

Page Yes None Specify the page that you want to display in your gadget.
Suggestions will display in a dropdown when you start typing.

Show No Yes Select whether to display a link to view the page on your

View Confluence site. Clicking the link will open the page in Confluence.

Link

Show No No Select whether to display a link to edit the page on your Confluence

Edit Link site. Clicking the link will open the page for editing in Confluence.

Refresh  No Never/false Specify the time interval between each 'refresh' action undertaken

Interval by the page gadget. A refresh makes the activity stream gadget
reflect any new activity that has been conducted on the Confluence
site.

Working Macros

The Confluence page gadget will only render a subset of the macros that are used in Confluence correctly.
Refer to the table below for the list of macros that work and do not work with the page gadget and known
limitations.

Some of the issues with macros in the page gadget can be worked around, if you are comfortable
developing in Confluence. Please see Troubleshooting Macros in the Page Gadget for more
information.

Key:

@ works with the page gadget

0 * Partially works with the page gadget
B Does not work with the page gadget

Macro Works Limitations
with
page
gadget?
Activity You cannot have another gadget embedded within the Confluence Page Gadget
Stream
Anchor (wit  * Opens in a new page
hin a page)
Attachments N/A
Blog Posts N/A
Chart N/A
Children N/A
Display
Content By N/A
Label
Content By N/A
User

Created in 2017 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.

395


http://creativecommons.org/licenses/by/2.5/au/
https://confluence.atlassian.com/display/DOC/Activity+Stream+Macro
https://confluence.atlassian.com/display/DOC/Activity+Stream+Macro
https://developer.atlassian.com/display/CONFDEV/Troubleshooting Macros in the Page Gadget

Confluence 6.3 Documentation 396

Excerpt (] N/A

Gallery N/A

Include N/A

Page

Info N/A

Labels List N/A

Livesearch N/A

Note N/A

Metadata N/A

Metadata N/A

Summary

Pagetree N/A

Search

Pagetree N/A

Panel N/A

Quick Nav You cannot have another gadget embedded within the Confluence Page Gadget
Recently N/A

Updated

RSS Feed N/A

Section & C N/A

olumn

Spaces List N/A

Table of * Works, however links will be opened in a new browser window when clicked.
Contents

Team See here for the Improvement Request:

Calendars

for CONFSERVER-51407 - Make Team Calendars display in a Confluence Page Gadget,
Confluence for use on a JIRA Dashboard | OPEN

Server

View File (P * Works, but you may need to refresh the gadget the first time (see CONF-19932)
DF or PPT) .

Widget * Only works for some content:

Connector

® Works: blip.tv, Episodic, Flickr, Google Calendar, presentations on Google
Docs, MySpace Video, Scribd, Skitch.com, SlideRocket, SlideShare, Viddler,
Vimeo, YouTube, Dailymotion, Metacafe, FriendFeed, Yahoo Video, Wufoo
HTML Form Builder

®* Does not work: FriendFeed, Google Gadgets, Google Video (consumer
service discontinued), Twitter, Widgetbox, DabbleDB, BackType

Confluence Quicknav Gadget
The Confluence QuickNav gadget provides the Quick Navigation Aid functionality for searching the Confluence
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site. For more information on how to use this feature, refer to the Quick Navigation Aid section of Search.

Screenshot: Using the QuickNav Gadget

Example

Example Fage
Example Human Resources Fage
Examples

Example Sales Team Page

[y (o) [ [ o

Example Development Team Fage

Example Excel 2007 Document.xlsx

Y &

Example PDF Document. pdf

&

Example Space

‘=4 Search for ‘Examnple’

Confluence QuickNav Gadget Properties
This gadget has no properties and cannot be customized.

Confluence use-cases

This section describes some specific use cases for Confluence. Related pages:
® Using Confluence for technical documentation ¢ Confluenc
A technical communicator's guide to using Confluence — see Develop e
Technical Documentation in Confluence. administrat
or's guide
® Setting up a knowledge base * Add-ons
A support engineer's guide to using Confluence as a knowledge base and
— see Use Confluence as a Knowledge Base. You can also check out integration
our handy guides on writing how-to and troubleshooting articles. S

® Setting up an intranet
A quick guide to setting up an intranet wiki — see Use Confluence as
your Intranet.

® Confluence for software teams

A series of blog posts to help your agile team get the most out of
Confluence. See Confluence for Software Teams.

You may also be interested in:
® Confluence markup formats
The syntax and usage of Confluence wiki markup and the Confluence XHTML-based storage format —
see Confluence Markup.
® Gadgets
How to add gadgets to a wiki page, or use Confluence gadgets on other sites — see Gadgets.

Develop Technical Documentation in Confluence

Confluence is a flexible platform with a range of features and add-ons that
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can help you capture, distribute, and update your technical documentation.
Below are some tips to help you get your technical documentation site
started, and to save you time and effort managing your documentation's life
cycle.

Create your Documentation Space

Creating spaces in Confluence is quick and easy. All you need to do to get
your documentation started is choose Spaces > Create space from the
Confluence header. To make things even easier, choose the
'Documentation Space' option in the create space dialog; it'll give you a
custom home page with a search box (the livesearch macro) to search just
your documentation space, a recently updated macro, and a few other
goodies.

Give your space a name, and Confluence will automatically create the home
page and space key for it (change the space key if you're not happy with the
one Confluence chooses for you). Feel free to customize the home page at
any time; what it looks like is completely up to you!

Save time by re-using content

If there's something you're going to use multiple times in your
documentation space — whether it's a word, sentence or paragraph; an
image; a product version humber; or anything else — you can create it once
and include it on as many pages as you like (or use it in the header and/or
footer). Inclusions not only save you typing the same thing many times, they
also make it easier when things change — it's much better to update the info
in one place, than 47!

There are 3 macros that allow you to re-use content:

® The Excerpt macro to define a re-usable section, or 'excerpt’, on a page — add content inside this

macro, and you can reuse it on as many pages as you like.

® The Excerpt Include macro (excer pt -i ncl ude) to include the contents of an excerpt on another

page.

On this page:

Create
your
Document
ation
Space
Save time
by re-using
content
Use page
templates
Draft your
work

Use links
and
anchors
Useful
macros
Keep track
of page
updates
Customize
PDF
export
Other
useful
tools and
add-ons
Document
ation
theme
(discontinu
ed)

Related pages:

Spaces

® The Include Page macro (i ncl ude) to include the entire content of a page on another page.

For example, let's say you create release notes for each major release of your product, and you want to

include the intro from each release notes page on a 'what's new' page. Place each release notes intro in an E

xcerpt macro, then add an Excerpt Include macro for each set of release notes to the what's new
page. Your intros will magically appear on the what's new page, and if you update the release notes it'll

automatically update the what's new.
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Technical
8 Technical Doco Pages / Technical Doco )

What's new?

Created by Gil Admin, last modified less than a minute ago

PAGE TREE
> Getting started

What's new?

Version 1

Release notes 1 ® o
"—.

Version 1 of our product is so amazing!
Release notes 2 B g

Release notes 3

Version 2

Version 2 is even better than version 1!

1. Excerpts: the intros to these pages are in excerpt macros.
2. Excerpt include: these are excerpt include macros.

Another example is one of the ways we use the Include Page macro. Whenever the ellipsis (

LE L

) appears in our documentation — for example, go to

> Copy —it's actually an Include Page macro. We have a page with just that image on it, so we can include
it whenever we need an ellipsis.

Why do we do use an Include Page macro for one tiny image? Well, just in case that Ul element is ever
changed. If we attach the image to every page, there might be 50 pages we need to update when things
change; if we use an Include Page macro, we update once and it's changed everywhere. Doing it this way
also allows us to know how many pages we're using the image on. By going to

(L L]
> Page Information, we can see how many incoming links there are to this page, and that tells us how
many pages use the image.

Create an inclusions library (optional)

You can include content from any Confluence page, but you may want to create an 'inclusions library' to hold

content that's specifically for re-use. The inclusions library isn't a specific feature of Confluence; the pages in

the inclusions library are just like any other Confluence page. This is just a technique you can use if you want
a place to store content that's specifically for re-use.

To create your inclusions library:

1. Choose Create and create a hew page in your space

2. Enter a suitable title. We use '_Confluencelnclusions' (the underscore before the title helps to let
people know this page is special)

3. Enter some content and save the page
We enter text explaining the purpose of the inclusions library and how to re-use the content

4. Choose Space tools > Reorder pages and drag your new page above the space homepage

5. Go to your new inclusions page and choose Create to add child pages containing your re-usable
content

Because you've moved the pages to the root of the space, they won't appear in the page tree in the
sidebar. The pages will be picked up by other searches though, as they're normal Confluence pages.

Templates = Reorder Pages @ Orphaned Pages Undefined Pages  Attac

o_' > [2) _Confluencelnclusions

> [#) Confluence Documentation Home
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1. Inclusions library location: drag your inclusions library here, above the rest of your documentation.

Use page templates

Creating one or more page templates can be a real time-saver if you're creating a lot of pages with the same
layout. If you're constantly adding the same macros, like panels and table of contents, save yourself from RSI
and put them into a template — you can start with one, but make as many as you need to maximize your

efficiency.
To create a page template that's available in all spaces:

1. Goto

> General Configuration
2. Select Global Templates and Blueprints from the list on the left

3. Choose the Add global page template button at the top-right
4. Create your template page and choose Save

For detailed info on page templates, see Create a Template.

To get to Global Templates and Blueprints , or any other admin page quickly, hit / on your
keyboard and start typing the name of the admin page you're looking for.

Draft your work

When you're creating a new page in your documentation, you'll likely want to do it over time, saving as you
go, and have a select few people review it to provide feedback. A loose description of this workflow is 'draft,

review, publish'.

You don't want any half-finished pages being seen by your users, and most documentation needs to be
reviewed before it's finalized, so here's a technique for drafting pages and allowing for review:

1. Create a page and restrict its permissions
For example, you might restrict viewing to a group of people such as your team, or a few select
individuals. On a public site, you might restrict viewing to staff members, so that the general public
can't see the page.

2. Write your page content
3. Share the page with your reviewers and ask them for feedback (make sure you haven't restricted them

from seeing the page!)
The reviewers can add comments to the bottom of the page or highlight text to add a comment inline.

If you give them permission, they can also edit the page content directly.
4. Publish the page when ready, by doing the following:
a. Delete any comments on the page
b. Remove page restrictions so that your audience can see it

You've now published your page. The space permissions and site permissions now determine who can see
and/or update the page.

Use links and anchors

Add links

In any documentation site, it's essential to be able to link from one page to another, and often to specific
sections on a page. You can add any URL to a Confluence page and Confluence will automatically detect
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it and turn it into a link.

If you paste the URL for another page in your Confluence site, Confluence will display the link text as the
page name and turn it into a relative link, meaning if the name of the page changes, Confluence will adjust
the link so it doesn't break.

Add and link to anchors

The anchor macro allows you to create anchors in your documentation, which can be linked to from
anywhere. I've added an anchor at the top of this page so you can click to go back to the top.

To add a macro and link to it from the same page:

1. Type {anchor in the editor, select the anchor macro and give your anchor a name (t op in my

example)

2. Select the text that'll link to the macro and hit Ct r | +K (Windows) or Cmd+K (Mac) (this opens the link
dialog)

3. Choose Advanced from the options on the left and type # followed by your anchor name (#t op in my
example)

Check out our documentation for links and anchors to get the full rundown on linking to anchors on other
pages and other anchor goodness.

Useful macros

Confluence ships with a great range of macros, and there are a few that are particularly useful in technical
documentation. Here's a few:

Table of contents macro

The Table of Contents macro helps people navigate lengthy pages by summarizing the content structure and
providing links to headings used on the page. The best part is, you don't need to do anything except add the
macro; once you've added it, it'll automatically detect headings and add them to the table of contents.

Tip, Note, Info, Warning, and Panel macros

Often when creating documentation, there are elements of a page that you want to highlight or draw the the
viewers' attention to. Confluence ships with the Tip, Info, Warning, Note and Panel macros, which will help
you focus a viewer's attention on a particular part of your content.

Tip of the day
Use the tip macro to give your readers handy hints!

Keep track of page updates

In Confluence, it's quite usual for a number of different people to update a single page. Technical writers
need to know what happens to our documents, both during review and after publication.

Watch pages or the space

So that you know when changes are made, it's a good idea to watch pages or even the entire space. That
way, when changes are made to pages you're watching, or someone comments on them, you'll get an email
notification letting you know who changed what.

Whenever you're on a page in your documentation space, choose the Watch button at the top-right of the
page. From there, you can choose to watch just that page, or all pages in the space.
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View page history

Confluence creates a new version of the page every time someone edits the page. The page history shows
all the versions, with date, author, and any comments made on the update.

To view page history, go to the page and choose

LE L

> Page History
On the page history view, you can:

® View the content of a specific version of the page.

® Revert to (restore) a specific version.

® Select any two versions and ask for a comparison, to see what has changed between those two
versions.

Take a look at Page History and Page Comparison Views for a detailed explanation.

Show a list of contributors

If you want to see at a glance who's updated a page or pages, you can add the contributors macro. This
macro displays a customizable list of people who've contributed by creating, editing, or, optionally,
commenting on the page.

Customize PDF export

If you're planning to provide a PDF version of your documentation — whether it be for email, download, print,
or any other form of delivery — you can customize the look of the PDF by adding a title page, header, and
footer.

The process you take depends on whether you're trying to customize the PDF export for one space or for
your whole site, so, if you're keen to make these changes, take a look at our page on Customize Exports to
PDF for more detailed instructions.

Other useful tools and add-ons

Confluence is already a great tool for technical documentation, but you can still add to it depending on your
documentation and workflow needs. Here are some useful add-ons available on the Atlassian Marketplace,
most of which we use ourselves, which can extend the functionality of Confluence.

Scroll Versions (supported)

Scroll Versions, by K15t, allows you to tie versions of your documentation to versions of your product, so that
when a new version of your product ships you can publish that version of your documentation. Create as
many versions of your documentation as you like, make the changes you need to, and keep them up your
sleeve until release time. You can even publish different variations of your documentation — like if you have
versions of your documentation for different operating systems — to different spaces or Confluence instances.

Copy Space (unsupported)

The Copy Space add-on, by Atlassian Labs, does what its name suggests; it allows a space administrator to
copy a space, including the pages within the space. Great for when you want a space template that you can
copy to create other spaces.

This plugin is also useful when you need to archive a copy of a current space at a particular point in time, like
when you're moving from one version of your product to the next — copy the space, give it a new name, and
keep it wherever you like, all without losing the existing space.

ﬂ' At this point this plugin won't copy page history, blog posts and email.
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Scroll PDF Exporter (supported)

If you're going to produce a PDF of your documentation space, wouldn't you like it to be professionally
formatted? The Scroll PDF Exporter, by K15t, lets you style single pages or whole spaces for export, using
handy PDF templates.

Gliffy (supported)

Create diagrams, wireframes, flowcharts and more with Gliffy. Gliffy features a highly intuitive drag-and-drop
interface, and allows you to export your diagrams in multiple formats, including: JPEG, PNG and SVG. Add
Gliffy flowcharts, Ul wireframes, and network diagrams directly to your Confluence pages to communicate
your ideas visually, making them easy to understand and faster to spread through your team.

Lucidchart (supported)

Lucidchart is available in versions for Cloud and Server, and allows you to create and insert diagrams within
your Confluence Cloud environment. Quickly draw flowcharts, wireframes, UML diagrams, mind maps, and
more inside our feature-rich editor.

The server version also comes with a free Visio viewer, so you can view Microsoft Visio (.vsd) files, Visio
stencils (.vss) and it also supports exporting back to Visio.

Documentation theme (discontinued)

Confluence historically provided a theme specifically for documentation. This theme was removed

in Confluence 6.0.A number of the original Documentation theme features, such as headers, footers and the
ability to add custom content to the sidebar, are now available in Confluence's more modern default theme,
which make it a great choice for your documentation space.

Use Confluence as a Knowledge Base

A knowledge base is a repository for how-to and
troubleshooting information. Knowledge Bases are
commonly used by IT Support teams, but can be
useful for procedural and troubleshooting information
in any organization or team.

What do people want out of a knowledge
base? Using an IT Support team as an example:

® Customers want fast access to a solution, and
relevant search results.

® Help desk staff want to be able to create new
articles quickly.

® Help Desk team leads wants the space to be
self curating, and do not want to spend a lot
of time manually organizing content.

® Everyone wants a way to be notified when
articles they are interested in have been
updated or important notices are added.

Create a knowledge base space

I You'll need the Create Space global permission to do this.
To create your knowledge base space:

1. Choose Spaces > Create space > Knowledge base space

2. Choose Space Tools > Permissions to set permissions for the space, including anonymous access

3. Choose Create > How-to or Troubleshooting and follow the prompts to create your first knowledge
base article

The knowledge base space blueprint includes everything you need to get started, including article templates,
and a pre-configured homepage with Livesearch and Content By Label macros.

Page labels are essential in knowledge base spaces. These are used to add topics to your articles, and
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allows your knowledge base to become self-organizing over time.

Users will generally find articles by searching, and using the topic navigation on the homepage and end of
each article, rather than navigating through a tree-like page hierarchy.

When starting off your knowledge base space, it's a good idea to brainstorm a few topics to get started.
Customize your knowledge base space

You'll need Space Admin permissions to do this.

To make it easy for your users to create knowledge base articles, such as your help desk or support team,
we recommend customizing the how-to and troubleshooting article templates to make them relevant for your
organization. The more guidance and structure you can put in your template, the faster it will be for your team
to create great articles.

To edit the article templates:

1. Goto Space Admin > Content Tools > Templates.
2. Edit the How-to or Troubleshooting article templates.
3. Add headings and instructional text (choose Template > Instructional Text).

You can also add additional templates, such as a policy or procedure page templates.

We also recommend customizing the look and feel of your space. Simple changes like a space logo and
welcome message can make a huge difference.

To change the look and feel:

® Add a space logo and useful shortcuts to the sidebar (choose Space Tools > Configure Sidebar)
® Edit the homepage to add a custom welcome message.
® Edit the color scheme (choose Space Tools > Look and Feel > Color Scheme).

Provide communication and notification options

Channels of communication with your audience, internal or external, are essential in a good knowledge base.
Here are some out-of-the-box options:

® Blog - blog updates and important notices, and encourage people to watch for new blogs in your
space.

® Watch - encourage people to watch pages that interest them, or watch the entire space.

® Comments - allow logged in users (or even anonymous users) to comment on knowledge base
articles. This is a simple way to connect with your end users.

® RSS - create an RSS feed and add the link to your knowledge base homepage (choose Help > Feed
Builder). Alternatively encourage users to create their own feed - useful if they want to keep up with
particular topics (labels), rather than receive notifications for the whole space.

Integrating your knowledge base with other Atlassian products

If your Confluence site is connected to another Atlassian product (via an application link), you can make use
of these great integration features:

® If you use any JIRA application - add a JIRA Issues macro to your troubleshooting article to provide
quick access to known issues. This has the added advantage of automatically updating when an issue
is resolved or its status changes. One simple way to do this would be to add some labels to JIRA to
indicate the issue should appear in the knowledge base (for example 'printer-kb'), and then add a JIRA
Issues macro with a query like 'label = 'printer-kb and status <> resolved" on all articles with the printer
topic.

® |f you use JIRA Service Desk - link a Confluence space to be used as a knowledge base. Users
(including those without a Confluence license) can search your knowledge base directly from within
the Service Desk customer portal.

® If you use Questions for Confluence Server - add a Questions list macro to troubleshooting articles,
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to highlight the top questions with the same topic as the article, and an Ask a Question button to the
knowledge base homepage.

Extending your knowledge base with third party add-ons

The Atlassian Marketplace has a large number of add-ons for Confluence. A common addition to Knowledge
Base spaces is a survey or form tool, which enables you to get feedback on the usefulness or usability of
your knowledge base articles.

Search for 'knowledge base' on Marketplace and see if there is an add-on that's right for your knowledge
base.

Use Confluence as your Intranet

Your intranet is the hub of your organization. When choosing your intranet platform, you need to ensure that
the system is simple enough for non-technical users, information and content can be shared easily, and
access is restricted to those within your organization.

Confluence has a host of great out-of-the-box features that allow you to share and collaborate with your
colleagues, while keeping your information secure. Share things like procedures, specifications and important
files — or organize company events and functions — and get your teams working together. It's one place to
share, find, and collaborate to get work done.

Create your community

It's quick and easy to add users to your Confluence site. Allow people to add themselves as users of the site;
invite people to sign up by sending them an invitation link; add new users manually; or use an existing
directory — like an LDAP directory — for authentication and to manage users and groups.

Whichever way you choose, you can quickly build a community of Confluence users and give them access to
your intranet; you'll also have a ready-made people directory.

Match your company branding

Upload your company logo, and Confluence's auto look and feel will change the color scheme to match. It'll
make your intranet feel more familiar to your colleagues, and help with adoption.

A space for everything, and everything in its space

A Confluence space is essentially a container for a group of pages and blog posts with related content.

When you're starting out with Confluence, the easiest way to organize things is to create a space for each
team or department within your organization. Each team's space is then a place for them to create and share
pages, blog posts, meeting notes, files, and much more — and becomes the place to go for team members to
get the information they need.

Just choose Spaces > Create space from the header, and Confluence provides a list of space blueprints to
help get you started.
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Create Team Space

Space name | Tech Writing About Team Spaces

Share knowledge and collaborate on

Space key | TW ® projects, processes and procedures with
your team. They will be notified about this
Team members | & Gil Admin x || [ Josh User x space and all updates. Team members will
be granted permissions and added as
Description | Welcome to the Technical Writing space! Find watchers of the space.
out about our projects, meet the team
members, check out our calendar, and watch
our blog.

Z

Back Close

Each space can have its own color scheme and has a customizable home page, which you can edit to suit
your purpose — like displaying and tracking team goals and displaying a list of team members. Use the
built-in "'Team Space' template to automatically add all members of the team to the homepage, to help
everyone get to know each other.

You can set permissions for each space, so if there's sensitive information that should only been seen by
certain users or groups, it's easy to secure it with Confluence.

Don't feel restricted to creating spaces for teams though; you can also create spaces for projects (large or
small), events, and anything else where you want to collect information under a common heading or
permissions structure.

Once you have some spaces set up, create some pages and blog posts to give your colleagues an example
of how Confluence can be used, then invite them to create their own pages and blogs.

Add a personal space

Every Confluence user, including you, can also create their own personal space; it can be a place to keep
your own work, add shortcuts to your most used content, and you even get your own blog for sharing your
ideas and opinions with the rest of your organization (or just those that you want to see them).

Create pages, meeting notes and more

You can create pages for anything you want in Confluence - meeting notes, project plans, decisions, and
more. Pages are editable so others can contribute and keep them up to date after you create them. Choose
Create from the Confluence header and choose a blank page, or use a template to get you started.

Type your page, change its layout, add images and links, and do it all without any specialist skills or training.
You can also attach files — allowing everyone in a team access to assets that are critical to the project — like
mockups and requirements. You and your colleagues can like the page, and comment on it to start a
conversation about the content.

Confluence also offers a series of useful built-in page blueprints, which help you with the content and
formatting of the page. The meeting notes and decisions blueprints are two that can be really useful when
others need to be in-the-know about what happened, and why it happened.

Avoid the reply-all and blog about it

Each space you create in Confluence has its own blog, where you and your teams can share news and
events, discuss important projects and developments, or congratulate a teammate for a special effort;
blogging is a great way to foster company culture and celebrate achievements across your organization.

You can watch any blog to make sure you get updated when there's a new post. Blog posts are automatically
organized by date, and grouped by year and month, so they're also easy to find.

Share stuff that matters
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If you need to be sure that the right people see a page or blog post, Confluence offers a range of ways to
make sure you can get their attention. Type the @ symbol and the name of a Confluence user to mention the
m in a page, blog post, or comment. They'll get an email notification that you've mentioned them, with a link
to the page, post or comment.

There's also a Share button at the top right of every page. Type the name or email address of a user or
group and send them a short message with a link to the content you're sharing.

Watch and learn

Don't miss out on important updates. Watching spaces, pages, and blogs is a great way to stay up-to-date
with what's happening in your own team, or any other team or person you need to keep up with. When you
watch something, you'll get email updates when changes are made or a comment is added.

The Confluence dashboard also has a recent activity feed, which allows you and your team to see what's
trending throughout the company or in your network.

Let team collaboration take on a life of its own

If you want to communicate in-the-moment, HipChat — our private service for chat, video, and screen sharing
— is built for teams. Share ideas and files in persistent group chat rooms, or chat 1-1 for that personal touch.
HipChat integrates with Confluence, so you can get real-time notifications in HipChat whenever new
information is shared in Confluence pages and blogs.

Got a question (that's not rhetorical)? Why not ask your team? Questions for Confluence is an add—on for
Confluence that gives you knowledge sharing with your own Q&A service. Run company-wide polls to gauge
reaction to a new marketing initiative, or let people vote on the venue for the Christmas party. Ask questions,
get answers, and identify experts.

You can also try Team Calendars for Confluence for organizing and sharing team events, leave, and other
important appointments. Embed each team's calendar on their home page so that everyone knows what's
happening, and when.

= XUConfluence sSpaces -~ People Calendars  Create  ses

Calendars [l Add Event = b Add Calendar
Today 4 » August 2013 Month = Week = List Timeline N
Mon Tue Wed Thu Fri Sat Sun
1 2 3 4
. Dev Team -
o Travel
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Confluence for Software Teams
Welcome to the Software Team's guide to using Confluence.

Check out the articles in this collection:
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https://www.atlassian.com/software/hipchat
https://www.atlassian.com/software/confluence/questions
https://www.atlassian.com/software/confluence/team-calendars
https://confluence.atlassian.com/display/TEAMCAL/Embed+Calendars+on+Confluence+Pages
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How to write product How to build arelease Creating insightful customer
requirements planning page interview pages
@
ol A o
Create sprint retrospective How to make better decisions How to document releases
and demo pages (like a BOSS) as a development team and share release notes
'y ﬂ
Use blogs to share your development How to create technical and
team's progress onboarding documentation

Like what you see? Start creating these pages and more in
Confluencel!

Try it for free

Created in 2017 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/
https://confluence.atlassian.com/doc/blog/2015/08/how-to-document-product-requirements-in-confluence
https://confluence.atlassian.com/doc/blog/2015/08/how-to-document-product-requirements-in-confluence
https://confluence.atlassian.com/doc/blog/2015/08/how-to-build-a-release-planning-page-in-confluence
https://confluence.atlassian.com/doc/blog/2015/08/how-to-build-a-release-planning-page-in-confluence
https://confluence.atlassian.com/doc/blog/2015/08/creating-insightful-customer-interview-pages
https://confluence.atlassian.com/doc/blog/2015/08/creating-insightful-customer-interview-pages
https://confluence.atlassian.com/doc/blog/2015/08/create-sprint-retrospective-and-demo-pages-like-a-boss
https://confluence.atlassian.com/doc/blog/2015/08/create-sprint-retrospective-and-demo-pages-like-a-boss
https://confluence.atlassian.com/doc/blog/2015/09/how-to-make-better-decisions-as-a-development-team
https://confluence.atlassian.com/doc/blog/2015/09/how-to-make-better-decisions-as-a-development-team
https://confluence.atlassian.com/doc/blog/2015/10/how-to-document-releases-and-share-release-notes
https://confluence.atlassian.com/doc/blog/2015/10/how-to-document-releases-and-share-release-notes
https://confluence.atlassian.com/doc/blog/2015/11/how-to-use-blogs-to-share-your-development-team-s-progress
https://confluence.atlassian.com/doc/blog/2015/11/how-to-use-blogs-to-share-your-development-team-s-progress
https://confluence.atlassian.com/doc/blog/2015/11/how-to-create-your-team-s-technical-and-onboarding-documentation
https://confluence.atlassian.com/doc/blog/2015/11/how-to-create-your-team-s-technical-and-onboarding-documentation

	Confluence Server documentation
	Get started
	Tutorial: Navigate Confluence
	The dashboard
	The space directory
	The space sidebar
	Keyboard shortcuts
	Complete your mission

	Tutorial: Space ace
	Create a project space
	Create your personal space
	Create the team's PR space
	Delete and archive spaces


	Spaces
	Create a Space
	Create a Space From a Template
	Space Keys

	Navigate Spaces
	Space Permissions Overview
	Assign Space Permissions
	Make a Space Public
	Give Access to Unlicensed Users from JIRA Service Desk

	Organize your Space
	Set up a Space Home Page
	Use Labels to Categorize Spaces

	Customize your Space
	Configure the Sidebar
	Edit a Space's Color Scheme
	Apply a Theme to a Space
	Documentation theme migration FAQ

	Customize Space Layouts

	Archive a Space
	Delete a Space
	Export Content to Word, PDF, HTML and XML
	Customize Exports to PDF
	Advanced PDF Export Customizations
	Create a PDF in Another Language



	Pages and blogs
	Create and Edit Pages
	Blog Posts
	The Editor
	Symbols, Emoticons and Special Characters
	Collaborative editing

	Move and Reorder Pages
	Copy a Page
	Delete or Restore a Page
	Add, Remove and Search for Labels
	Display Pages with Label Macros

	Drafts
	Concurrent Editing and Merging Changes

	Page Restrictions
	Links
	Anchors
	Tables
	Add, Assign, and View Tasks
	Autocomplete for links, files, macros and mentions
	Page Layouts, Columns and Sections
	Create Beautiful and Dynamic Pages
	Page Templates
	Create a Template
	Create a Page from a Template

	Blueprints
	Decisions Blueprint
	File List Blueprint
	Meeting Notes Blueprint
	Product Requirements Blueprint
	Shared Links Blueprint
	JIRA Report Blueprint
	Retrospective Blueprint
	How-To Article Blueprint
	Troubleshooting Article Blueprint
	Create a Blueprint-Style Report

	Import Content Into Confluence
	Import a Word Document into Confluence

	Orphaned Pages
	Undefined Page Links
	View Page Information
	Page History and Page Comparison Views
	Confluence Markup
	Confluence Storage Format
	Confluence Wiki Markup


	Files
	Upload Files
	Display Files and Images
	Manage Files
	Share and Comment on Files
	Edit Office Files
	Office Connector Prerequisites
	Install the Firefox Add-On for the Office Connector



	Confluence Mobile
	Macros
	Activity Stream Macro
	Anchor Macro
	Attachments Macro
	Blog Posts Macro
	Change-History Macro
	Chart Macro
	Wiki Markup Examples for Chart Macro

	Cheese Macro
	Children Display Macro
	Code Block Macro
	Column Macro
	Content by Label Macro
	Content by User Macro
	Content Report Table Macro
	Contributors Macro
	Contributors Summary Macro
	Create from Template Macro
	Create Space Button Macro
	Excerpt Include Macro
	Excerpt Macro
	Expand Macro
	Favorite Pages Macro
	Gadget Macro
	Gallery Macro
	Global Reports Macro
	HTML Include Macro
	HTML Macro
	IM Presence Macro
	Include Page Macro
	Sample Include Page

	Info, Tip, Note, and Warning Macros
	JIRA Chart Macro
	JIRA Issues Macro
	JUnit Report Macro
	Labels List Macro
	Livesearch Macro
	Loremipsum Macro
	Multimedia Macro
	Navigation Map Macro
	Network Macro
	Noformat Macro
	Office Excel Macro
	Office PowerPoint Macro
	Office Word Macro
	Page Index Macro
	Page Properties Macro
	Page Properties Report Macro
	Page Tree Macro
	Page Tree Search Macro
	Panel Macro
	PDF Macro
	Popular Labels Macro
	Profile Picture Macro
	Recently Updated Dashboard Macro
	Recently Updated Macro
	Recently Used Labels Macro
	Related Labels Macro
	Roadmap Planner Macro
	RSS Feed Macro
	Search Results Macro
	Section Macro
	Space Attachments Macro
	Space Details Macro
	Spaces List Macro
	Status Macro
	Table of Contents Macro
	Table of Content Zone Macro
	Task Report Macro
	User List Macro
	User Profile Macro
	View File Macro
	Widget Connector Macro

	Your profile and settings
	Your User Profile
	Change Your Password
	Edit Your User Settings
	Set Your Profile Picture
	Choose Your Home Page
	Save for later
	View and Revoke OAuth Access Tokens

	Collaboration
	Network Overview
	Likes and Popular Content
	Mentions
	Share a Page or Blog Post
	Comment on pages and blog posts
	Watch Pages, Spaces and Blogs
	Manage Watchers
	Email Notifications
	Subscribe to RSS Feeds within Confluence
	Subscribe to pre-specified RSS feeds
	The RSS Feed Builder
	Subscribe to a Network RSS Feed

	Workbox Notifications

	Search
	Confluence Search Syntax
	Confluence Search Fields
	Search the People Directory
	Recently Viewed Pages and Blog Posts

	Permissions and restrictions
	Confluence Groups

	Add-ons and integrations
	Use JIRA applications and Confluence together
	Use HipChat and Confluence together
	Request Add-ons
	Use a WebDAV Client to Work with Pages
	Mail Archives
	Add a Mail Account
	Delete and Restore Mail
	Import Mail from an mbox

	Gadgets
	Activity Stream Gadget
	Confluence News Gadget
	Confluence Page Gadget
	Confluence Quicknav Gadget


	Confluence use-cases
	Develop Technical Documentation in Confluence
	Use Confluence as a Knowledge Base
	Use Confluence as your Intranet
	Confluence for Software Teams



