Commits

Ben Woskow committed 71bea2a

forgot to commit additional modifications

  • Participants
  • Parent commits e8ebbd4

Comments (0)

Files changed (1)

                             com.atlassian.upm.license.storage.lib*
                         </Private-Package>
                         <DynamicImport-Package>
-                            com.atlassian.upm.api.license;version="2.0",
-                            com.atlassian.upm.api.license.entity;version="2.0",
-                            com.atlassian.upm.api.util;version="2.0",
-                            com.atlassian.upm.license.storage.plugin;version="2.0"
+                            com.atlassian.upm.api.license;version="2.0.1",
+                            com.atlassian.upm.api.license.entity;version="2.0.1",
+                            com.atlassian.upm.api.util;version="2.0.1",
+                            com.atlassian.upm.license.storage.plugin;version="2.0.1"
                         </DynamicImport-Package>
                     </instructions>
                     <productVersion>${jira.version}</productVersion>
                 </configuration>
             </plugin>
             <plugin>
+                <!-- Include the Plugin License Storage artifact such that it can be found on the classpath when we need to install it -->
+                <artifactId>maven-dependency-plugin</artifactId>
+                <executions>
+                    <execution>
+                        <id>copy-storage-plugin</id>
+                        <phase>process-resources</phase>
+                        <goals>
+                            <goal>copy-dependencies</goal>
+                        </goals>
+                        <configuration>
+                            <outputDirectory>${project.build.outputDirectory}</outputDirectory>
+                            <includeArtifactIds>plugin-license-storage-plugin</includeArtifactIds>
+                            <stripVersion>true</stripVersion>
+                        </configuration>
+                    </execution>
+                </executions>
+            </plugin>
+            <plugin>
                 <artifactId>maven-compiler-plugin</artifactId>
                 <configuration>
                     <source>1.6</source>
     </dependencies>
     <properties>
         <amps.version>3.7.2</amps.version>
-        <jira.version>5.0-rc2</jira.version>
-        <upm.license.compatibility.version>2.1-m3</upm.license.compatibility.version>
+        <jira.version>5.0-rc3</jira.version>
+        <upm.license.compatibility.version>2.1-m5</upm.license.compatibility.version>
     </properties>
 </project>