Can not login into Bitbucket Cloud from VSCode

Issue #21 resolved
Dominik Siefert created an issue


i am use VSCode 1.31.1 on Manjaro and wants to integrate Jira Cloud and Bitbucket Cloud. Therefore i am use the Extension "Atlassian for VSCode". I can login / authenticate into my Jira Account - but not into the Bitbucket Account. When i am click an Login to Bitbucket on the Extension Settings Screen i am landing on the adress and receive the message that the login was successful (but i cant use the bitbucket features within my vscode) ...

Comments (34)

  1. Pramod Busam Account Deactivated

    @dominiksiefert Could you try restarting VSCode and logging in again?

    If you still see issues, can you open developer tools (Developer: Toggle Developer Tools in command palette) in VS Code and let us know if you see any errors in the console log?

  2. Pramod Busam Account Deactivated

    We have released a new version of the extension (1.0.2) today. Please try the steps in the previous comment with the new version.

  3. Hugo Nogueira


    I've just installed 1.0.4 and I can't log in to Bitbucket Cloud either. The Developer Tools show this error in the console: Failed to obtain access token

  4. Nick Caine

    I have this same issue in vscode v1.32.3 and Extension v1.04. Click on authenticate and it doesn't do anything. JIRA is hooked up correctly and can see "YOUR ISSUES" and "OPEN ISSUES". Bitbucket pull requests isn't finding any repositories.

    Click on authenticate and it lands here.

    Developer: Tools Console output. /Applications/Visual…kbench.main.js:3113 [Extension Host] debugger listening on port 34236 /Applications/Visual…rkbench.main.js:272 [Extension Host] (node:78429) [DEP0005] DeprecationWarning: Buffer() is deprecated due to security and usability issues. Please use the Buffer.alloc(), Buffer.allocUnsafe(), or Buffer.from() methods instead. /Applications/Visual…kbench.main.js:1398 INFO standard startup /Applications/Visual…rkbench.main.js:272 [Extension Host] server started on port 9090 /Applications/Visual…rkbench.main.js:272 [Extension Host] ?[43m?[30m BITBUCKET CLOUD API CHANGING NOTICE: ?[0m?[33m ?[0m /Applications/Visual…rkbench.main.js:272 [Extension Host] ?[46m?[30m BITBUCKET CLOUD API MIGRATION GUIDE: ?[0m?[36m ?[0m

  5. Pramod Busam Account Deactivated

    A new version of the extension has been released v1.1.0 which should fix this issue. Please re-open if you find this happening again.

  6. Nick Caine

    This still doesn't work. Same issue I reported before. Is there a way that I can complete remove the plugin and any cached data and start from scratch? Running vscode from mac.

  7. Pramod Busam Account Deactivated

    Can you try logging out from the settings screen, restarting VS Code, and logging in again and see if that helps?

  8. Sneh Shah

    I am having V1.1.0 and V1.33.1 of VS Code, still facing the issue. I have not authenticated the JIRA site just trying to authenticate the BitBucket.

  9. Nick Caine

    Ok.. This is working and I think I found the issue. You have to have a git project folder open in VSCode for the bitbucket extension to work. Unlike the Jira extension which just works on the Global Jira target, the bitbucket plug-in only works if I have the project folder open. Can the bitbucket side of this plugin work the same way as the JIRA one? When I log into the bitbucket I would have expected to see all of my bitbucket repositories regardless of what folder I have open in VSCode.

  10. Sneh Shah

    I have the git project folder open that has the bitbucket remote repository linked to, still no luck. can you may be tell me some steps I can try?

  11. Bruno Alexandre

    @Nick Caine darn… as Jira works on global we simply expect the same behavior … well spotted and thanks a bunch!

  12. Dave Frascone

    Do you need an additional git plugin installed? Still doesn’t work for me, no matter what windows are open when I authenticate, or when I try to click refresh on pull requests

  13. Bruno Alexandre

    @Dave Frascone with the plugin installed, and terminal open, navigate to a repository folder where in the `git remote -v` has a Bitbucket path…

  14. John Hamel Account Deactivated

    I have the same issue as #69, but posting details here instead, since it was marked a duplicate.

    Atlassian for VSCode is logged in to Bitbucket but showing “No Bitbucket repositories found” in the “BITBUCKET PULL REQUESTS” and other sidebars. Tried suggestion from @Nick Caine but same behavior.

    VS Code 1.33.1
    Plugin 1.2.3
    macOS 10.14.4

  15. Bruno Alexandre

    @Tiaan Swart you might want to uninstall, reload window, install plugin, reload window, authenticate … as that’s a token error … after login, you will have the logged in user in the bottom left status bar in VSCode, like:

  16. Bruno Alexandre

    Remember that, like @Nick Caine said, opposite from the Jira contrapart, Bitbucket is not made to work in the Global Scope, so, it will only work if you load a project that contains a GIT repository and a remote url of an existing Bitbucket repository.

    To check this, open your project in VSCode, open the terminal and write

    git remote -v

    and verify that you have a remote URL of the type:

    origin  https://<your_username><your_account>/<your_repo_name>.git (fetch)
    origin  https://<your_username><your_account>/<your_repo_name>.git (push)

    This also work if you have an SSH entry like

    origin<your_account>/<your_repo_name>.git (fetch)
    origin<your_account>/<your_repo_name>.git (push)

    also works if you have specified that your remote is anything other than origin and with multiple remotes as long one is a Bitbucket remote

    tested with plugin version 1.2.3, on Windows 10.0.17763, Mac 10.14.4 and Ubuntu 16.04 (all with VS Code 1.33.1)

  17. John Hamel Account Deactivated

    @Bruno Alexandre If that was for my benefit, note that I’ve already checked that the directory has a repo with a Bitbucket remote. Perhaps there’s some other edge case in play in my situation.
    Edit: Also tried several different repos, restarting VS Code, etc.

  18. Tiaan Swart

    Thanks Bruno (not sure how to @ mention, too many options 😅 ). I have tried your suggestion and did not work.

    I can confirm that I also have the correct Bitbucket repo and remotes etc.

    I also checked the responses between local and and the Bitbucket access page. Everything seems okay.

  19. Dave Frascone

    Ahh - I see the problem I’m having. Since I have both work and personal repositories on bitbucket, I use a cheater url:

    From git remote -v:

    origin  git@COMPANY:ACCOUNT/REPO/ (fetch)
    origin  git@COMPANY:ACCOUNT/REPO/ (push)

    And, my magic that makes git clone COMPANY://REPO work:


    # Cheater for work bitbucket
    [url "git@COMPANY:ACCOUNT/"]
        insteadOf = COMPANY://


    Host COMPANY
        IdentityFile ~/.ssh/id_ed25519_work

    So, for me, looks like I’ll either have to invert my cheater logic to use my magic for my personal Bitbucket account, or not use the pullrequests stuff at work.

    Unless you can think of a better option for me?

  20. Mauricio Farías

    It still does not work for me. Maybe because I’m behind a corporate proxy.

    I open vscode in a project with a .git folder and “git remote -v” shows origin and remote correctly.

    The environment is vscode 1.33.1, atlascode 1.2.3, Windows 7.

    The browser shows “Internal Server Error“ and developer console shows “r: Failed to obtain access token at s.h._createOAuthError“.

    This issue should not be marked as resolved.

  21. Mihai Stefanescu Account Deactivated

    Issue is not fixed. Same as David Friscone, I have in the ssh config two hosts, one for the personal Bitbucket accounts and one for the company one, so the url from git remote -v is ‘origin: git@company:project/repository.git’ etc.

  22. Jan Semmelink

    Using Ubuntu, I had similar trouble, then saw that my vscode terminal starts in a different directory as my projects folder, because I source some scripts in my bashrc file.
    Removed the bashrc code, then it worked. My vscode terminal now opens in my workspace and problems terminal is showing compiler output.

  23. Rafed Alwani

    I am having the same issue and tried to understand and do everything mentioned so far. Please help!

  24. Mihai Stefanescu Account Deactivated

    In your ~/.ssh/config file you need to update the section header from

    Host yourcompanyalias
      User           git
      IdentityFile ~/.ssh/your_ssh_key
      IdentitiesOnly yes


      User           git
      IdentityFile ~/.ssh/your_ssh_key
      IdentitiesOnly yes

    and update your git remote to the new host alias. it needs to contain the word ''

    See and

  25. Log in to comment