JIRA Issues not working anymore

Issue #407 resolved
Fabrizio Rizzonelli created an issue

Hello,

Starting yesterday, I’m unable to use Jira integration in VSCode. All of a sudden, my issues filters are not working anymore and I’m getting the following error:

JQL Error
"Error: cannot get client for: Jira"

Already tried to reboot VSCode, machine and re-authenticate myself to Jira and Bitbucket 😞

Best regards,

Fabrizio

Comments (8)

  1. Jonathan Doklovic

    Hi @Fabrizio Rizzonelli

    Could you please update the Atlassian extension to the latest version? We recently released a new version with a completely rewritten JQL editor.

    Let me know how it goes!

  2. Fabrizio Rizzonelli reporter

    Hi @Jonathan Doklovic

    I’ve updated the extension, still same error. I can see new UI and everything, but JQL editor isn’t working. I can’t save any filter, every time I type something in JQL section, an infinite loader appears and the message “cannot get client for: Jira” as a red box at the top of the window.. 😞

  3. Jonathan Doklovic

    @Fabrizio Rizzonelli Sounds like there’s an issue with your authentication. Can you please:

    • Log out of Jira
    • Open your keychain and delete any entries whose names are like: atlascode*/jira
    • Restart VSCode
    • Re-auth with Jira

    Let me know if that helps. Thanks!

  4. Felipe Vignon de Castro Rios

    @Jonathan Doklovic I’m getting this same error, but I’m working on windows/wsl.
    I’m not sure how to “open my keychain” here, can you help me out?

  5. Nick Rundquist

    On Windows the credentials are stored in Credential Manager. You can search for it in the search bar or find it in the control panel at Control Panel > User Accounts > Credential Manager

  6. Log in to comment