Issue #72 wontfix

Incompilable in Ubuntu Lucid 10.04 LTS

Anonymous created an issue

I need version for "Mupen64Plus 1.99" , because , if i compile "Mupen64Plus 2.0" i can't use it . when i try to use version "2.0" , appear this in terminal

dlopen('./libmupen64plus.so.2') error: ./libmupen64plus.so.2: undefined symbol: png_set_write_fn AttachCoreLib() Error: failed to find Mupen64Plus Core library

and if install the Version 2.0 from "SVN / GIT" or something like that , and try to Download wxmupen64plus , lastest version , the same via , i have this errors :

$ ./waf Waf: Entering directory /home/inukaze/Mupen64Plus/auria-wxmupen64plus-cfd1ff43c54c/build' [ 1/12] cxx: main.cpp -> build/main.cpp.0.o [ 5/12] cxx: mupen64plusplus/MupenAPIpp.cpp -> build/mupen64plusplus/MupenAPIpp.cpp.0.o In file included from ../mupen64plusplus/MupenAPIpp.cpp:27: /home/inukaze/Mupen64Plus/auria-wxmupen64plus-cfd1ff43c54c/mupen64plusplus/MupenAPI.h:43: error: ‘ptr_StateCallback’ was not declared in this scope /home/inukaze/Mupen64Plus/auria-wxmupen64plus-cfd1ff43c54c/mupen64plusplus/MupenAPI.h:43: error: expected primary-expression before ‘void’ /home/inukaze/Mupen64Plus/auria-wxmupen64plus-cfd1ff43c54c/mupen64plusplus/MupenAPI.h:43: error: expected primary-expression before ‘const’ /home/inukaze/Mupen64Plus/auria-wxmupen64plus-cfd1ff43c54c/mupen64plusplus/MupenAPI.h:43: error: initializer expression list treated as compound expression ../mupen64plusplus/MupenAPIpp.cpp: In constructor ‘Mupen64PlusPlus::Mupen64PlusPlus(const char*, const char*, const char*, const char*, const char*, const char*, const char*)’: ../mupen64plusplus/MupenAPIpp.cpp:86: error: ‘InitCore’ cannot be used as a function In file included from ../main.cpp:32: ../mupen64plusplus/MupenAPI.h:43: error: ‘ptr_StateCallback’ was not declared in this scope ../mupen64plusplus/MupenAPI.h:43: error: expected primary-expression before ‘void’ ../mupen64plusplus/MupenAPI.h:43: error: expected primary-expression before ‘const’ ../mupen64plusplus/MupenAPI.h:43: error: initializer expression list treated as compound expression Waf: Leaving directory/home/inukaze/Mupen64Plus/auria-wxmupen64plus-cfd1ff43c54c/build' Build failed -> task failed (exit status 1): {task 20479184: cxx MupenAPIpp.cpp -> MupenAPIpp.cpp.0.o} ['/usr/bin/g++', '-O2', '-DNEBUG=1', '-pthread', '-pthread', '-I/home/inukaze/Mupen64Plus/auria-wxmupen64plus-cfd1ff43c54c/build', '-I/home/inukaze/Mupen64Plus/auria-wxmupen64plus-cfd1ff43c54c', '-I/usr/include/mupen64plus', '-I/usr/include/SDL', '-I/usr/local/lib/wx/include/gtk2-unicode-2.9', '-I/usr/local/include/wx-2.9', '-DHAVE_PRINTF=1', '-DHAVE_M64P_FRONTEND_H=1', '-DHAVE_M64P_CONFIG_H=1', '-DHAVE_M64P_TYPES_H=1', '-DHAVE_SDL=1', '-DHAVE_WXWIDGETS=1', '-D_GNU_SOURCE=1', '-D_REENTRANT', '-D_FILE_OFFSET_BITS=64', '-DWXUSINGDLL', '-DWXGTK', '../mupen64plusplus/MupenAPIpp.cpp', '-c', '-o', 'mupen64plusplus/MupenAPIpp.cpp.0.o'] -> task failed (exit status 1): {task 20478224: cxx main.cpp -> main.cpp.0.o} ['/usr/bin/g++', '-O2', '-DNEBUG=1', '-pthread', '-pthread', '-I/home/inukaze/Mupen64Plus/auria-wxmupen64plus-cfd1ff43c54c/build', '-I/home/inukaze/Mupen64Plus/auria-wxmupen64plus-cfd1ff43c54c', '-I/usr/include/mupen64plus', '-I/usr/include/SDL', '-I/usr/local/lib/wx/include/gtk2-unicode-2.9', '-I/usr/local/include/wx-2.9', '-DHAVE_PRINTF=1', '-DHAVE_M64P_FRONTEND_H=1', '-DHAVE_M64P_CONFIG_H=1', '-DHAVE_M64P_TYPES_H=1', '-DHAVE_SDL=1', '-DHAVE_WXWIDGETS=1', '-D_GNU_SOURCE=1', '-D_REENTRANT', '-D_FILE_OFFSET_BITS=64', '-DWXUSINGDLL', '-DWXGTK', '../main.cpp', '-c', '-o', 'main.cpp.0.o']

It's imposible compile it! , and the file "https://bitbucket.org/auria/wxmupen64plus/downloads/wxmupen64plus-0.1.tar.bz2" , dont have "waf" file , how i can compile it , under Linux Ubuntu Lucid ???

Comments (2)

  1. Marianne Gagnon repo owner

    "error: ‘ptr_StateCallback’ was not declared in this scope" is a sign that you are using mupen64plus 1.99.4 or earlier, please update to the latest hg version of mupen if you wish to use wxmupen46plus

  2. Log in to comment