1. Marianne Gagnon
  2. wxMupen64Plus
  3. Issues
Issue #75 new

0.2 does not start on Windows

Vincent Beers
created an issue

On Windows, the application does not seem to want to start. The application asks for the Mupen64plus core library, which it simply won't load under any circumstance.

The terminal spews out a Dutch message, which makes debugging a bit more difficult. But it seems to be complaining about something called side-by-side assembly, on which I found some possibly relevant information: http://msdn.microsoft.com/en-us/library/ms235342.aspx (since there's no manifest files that come with the 0.2 installer).

Running Windows 7, on an Asus K93SV notebook. Hope the info helps. Definitely willing to provide more (even the unhelpful Dutch messages) if needed.

Comments (12)

  1. Vincent Beers reporter

    So the core library is not mupen64plus.dll but libmupen64pluscore.dll? wxMupen64PlusCombo_0.2_Setup.exe did not install that particular file, just mupen64plus.dll. (Which means the combo pack is incomplete.) The 1.99.4 version of Mupen64plus also does not seem to come with libmupen64pluscore.dll, and there is no official 1.5 download on their site.

    Selecting mupen64plus.dll still gives me the same side-by-side assembly problem (and a subsequent "library not found" error even though the file exists), so I will run Dependency Walker on that.

  2. Vincent Beers reporter

    The following files were reported missing:


    The first two files seem to return a fair amount of Google results which might actually help the developer more than the user. :P

    Edit: after some more searching I might just be missing a VC runtime. Edit 2: found this tidbit: "MSVCP90D.dll is a debug version of MSVCP90.dll which is why it has a "D" on the end of the name. Actual release programs should not be linked with it."

    From: http://www.reactos.org/forum/viewtopic.php?p=59267

    So the released version is linked to the wrong DLL. I'd need to install Visual Studio itself before the application would work, which is a bit much to ask from anyone who won't use it.

  3. Anonymous

    DaVince, I'm getting the same thing here. Can't install at all and the core library is nowhere to be found. It's not included with the Win32 bundle found here: http://code.google.com/p/mupen64plus/

    I'm using Win7 x64. GIven that we both see the same thing I don't think this could be installed at all under this platform from a scratch installation.

  4. Anonymous

    Ok, this installs on Win7 at least, but with several major issues:

    1) No sound when launching a game 2) Won't recognize zipped roms or roms with .bin extension 3) Stop button doesn't work 4) Once a game has started you cannot quit frontend without crashing it - so it forgets all settings. 5) Throws a warning every time emulator is started about joysticks not available (even though keyboard has been defined)

    Plus, is there a way to decouple the frontend from the Mupen64Plus binary so that you can upgrade Mupen64Plus independently from this frontend?

  5. Marianne Gagnon repo owner
    • changed milestone to 0.3


    issues 1 and 3 can be worked around by going in the plugins section and selecting external video. Internal video is disabled by default now but if you upgraded it may remember the previous settings

    Regarding 5, this is a known issue which I reported to the developers of mupen

    Regarding decoupling UI and core, not at this time because the mupen 2.0 API is still not finalized and keeps on changing so it likely wouldn't work. Maybe in the future when it gets more stable.

    Regarding .bin extensions I guess I could make extensions customizable

    I don't know about item 4 since this doesn't happen for me

  6. Anonymous

    Regarding 1 and 3: I switched to external video but that didn't fix either problem.

    Regarding 2: thanks for looking into the extensions. I imagine most people keep their roms zipped, so that would be a great help. I'm guessing you'll also need a zip library to decompress them? Second best solution is to support .bin files - actual rom format should be the same as e.g. v64.

    Regarding 4: Thanks DaVince for the advice.

    Really looking forward to decoupling the UI from core - that's the biggest thing keeping me from really using your frontend (though with that said, this is the only Mupen64Plus frontend that works at ALL in Windows from what I've found - so thanks for the effort).

  7. Log in to comment