1. Marianne Gagnon
  2. wxMupen64Plus
  3. Issues
Issue #94 new

OSX with Afterglow 360 controller (wired)

Anonymous created an issue

I can not configure this controller. Each button gives me an axis -5. I have no ability to program for anything else. I'm using the tattiebogle driver. The OS recognizes the controller without a problem. How do get Mupen to recognize it without defaulting to axis -5?

Comments (6)

  1. Marianne Gagnon repo owner

    Hi, are you sure it's axis "-5", or is it "axis 5 in the negative direction"? Is it possible that you have a device on your gamepad that receives a negative value by default when it's at rest?

  2. Anonymous

    Before I start complaining/bug reporting, I'd like to say thanks. Thank you for making this frontend and sharing it.

    I'm having the same issue as above, but I'm using an official Microsoft Xbox 360 wired controller. I'm also using the tattiebogle driver version 0.11 found at http://tattiebogle.net/index.php/ProjectRoot/Xbox360Controller/OsxDriver and Mac OS X 10.6.8.

    In version 0.3 of wxMupen64Plus, when I go to the Input page "Joystick 0 (Not plugged)" is displayed in the device box. I get the same result whether I plug in my 360 controller before or after starting the program. When the controller is plugged in and I attempt to reassign a key, the box that says "Please use your keyboard/gamepad now" flashes on screen for a split second before disappearing. When this happens the key is always assigned as "Axis 5 -" even though I didn't press any keys, buttons, sticks or triggers. I can only reassign keys with the controller unplugged.

    The issue appears with both wxMupen64Plus 0.2 and 0.3, however, version 0.1 works as it should. wxMupen64Plus 0.1 reports the right trigger of the 360 controller as "axis(5 +)" when the trigger is fully pressed and "axis(5 -)" when partially pressed.

    Thanks again and I hope my wall of text helps you find the issue. :)

  3. Anonymous

    This is an awesome emulator, runs games in a smooth way than other emulators in mac. Thanks a lot.

    But I have the exact same issue than anonymous. I'm using combo 0.3 with an original xbox360wired. I can't reassign the keys correctly, the window flashes when I try to reassign, and "Axis -5" appear even when I didn't push any button.

  4. Anonymous

    I have the same issue as above. Axis -5 seems to be the right analog bumper while released. If I balance the bumper just right then axis -4 is always reported which makes me think that the same problem is also happening with the left analog bumper but the right bumper is just being registered first.

    Version 0.1 does not work for me though.

  5. Liam Cain

    I'm having the same problem with my wired xbox controller. It reports Axis 5- every time I try to configure the joysticks or dpad. Even worse, it seems to forget my configuration when I actually run the emulator. I'll try 0.1 to see if that makes a difference. In case it doesn't, is there a temporary solution I could try?

    Thanks! P.S. I'm running on OSX 10.7

  6. Robert Rosales

    Same issue..

    My Mac's running on OSX 10.10 now and the updated tattiebogle worked perfectly in recognizing my controller, but when I try to configure my xbox controller with the wxMupen64plus, it just gave me 'axis (5-)' over and over again for every button config.

    What would be a great way to go around this? Though my controller works fine when I manually built it and I finished Paper Mario, I still get bugged by why isn't the front-end working like the one I built?

    Btw, the graphics is great compared to the manual build.

    Thanks in advance for the reply! ^_^

  7. Log in to comment