Question about stash repository configuration

Issue #36 resolved
Maya Chase created an issue

Hi, me again, I just have a question this time and not sure how else to ask it. We set up the plug-in with our stash test server, but when I try to view a file with the "View Git File" macro, all I get in the repository/branch/file path is "no matches found" even though I can go over to stash and look at the repository or whatever. So, we don't have something set up right, and I have no idea what. Can you help? I'm going to attach some screenshots to make things clearer.

Comments (31)

  1. Tomas Theunissen

    I think you forgot to configure the repository in Confluence. If you go back to where you configured the server, you can click on the server you configured. There you can add a repository, just choose any name you want and in the URL field you wil have to fill in: 'AIR/airnav.git' (the full URL should be the same as shown in Stash when you get the clone pop-up).

    We are working on making the integration with Stash easier, but these steps are needed in order to support, Bitbucket, Github, internal Git repositories and the like.

    Let me know if this resolved your issue.

  2. Tomas Theunissen

    Ah, I didn't realise that the HTTP URL is different from the SSH URL.

    Hmm.. are you logged in as the same user as which you added the Git server? This error should only occur when you are logged out or do not have the correct permissions.

  3. Maya Chase reporter

    Hmm, actually, my coworker added the Git server, and I’m trying to add the repository. We both have the same permissions, but we’re not the same person, obviously. I know I’m logged in and have admin permissions or I wouldn’t be able to get to the add-ons section at all.

    Maya S. Chase Support Contractor, Team LCI IT Analyst ATO-IT Solutions Delivery Group (ADE-422) Solutions Support Division (405) 954-5138 maya.ctr.chase@faa.gov

    Tool InfoSpace: http://wiki.faa.gov/display/TSIS/Welcome+to+the+Tool+InfoSpace

  4. Tomas Theunissen

    For some reason you are most likely not being redirected to the login screen (after the websudo token expired) and you get the websudo error. I'll investigate this more tomorrow at work. Sorry for the inconvenience.

  5. Mitchel Kuijpers

    Hi @mschase

    We were able to reproduce your bug and released a new version with a fix 11.1.6. Please let us know if this fixes the bug you are experiencing.

  6. Maya Chase reporter

    Hi, we installed the update, and when I try to configure a repository, I get the attached error. I'm using the rest of the URL from the clone pop-up - is that not right? Thanks for all your help, you guys have been great helping me out with this.

  7. Mitchel Kuijpers

    Hi Maya, using the rest of the URL from the clone pop-up should be correct. Maybe it is something with a firewall or authentication?

    Could you answer the following questions for me:

    1. Can you clone it on the server?
    2. We should also log the error could you send us the Confluence logs?
  8. Maya Chase reporter

    My co-worker that set up the server changed the authentication from “no authentication” to a username/password combo, so maybe that has something to do with it?

    When I click the button to clone, nothing happens, but I don’t actually have a git client installed, so I’m not sure that’s unexpected.

    Will get the logs for you shortly.

    Maya S. Chase

  9. Mitchel Kuijpers

    That might have something todo with it, but the logs should help us find the root cause :)

  10. Mitchel Kuijpers

    Are you sure your repository should be cloned over http our Stash only has an https option but that might be our configuration. That might be an issue otherwise I would think it is an authentication error. So could you double check if you need to use http or https and check the credentials?

    The URL seems correct since you don't get any org.eclipse.jgit.errors.NoRemoteRepositoryException on the last URL you tried.

    When I am back at work tomorrow I will look over over the logs with @tomtheun and we will get back to you as soon as possible. Thank you for being so patient we're almost there :)

  11. Maya Chase reporter

    I don’t at the moment, but I’ll get it and send the logs as soon as I can.

    Maya S. Chase

  12. Maya Chase reporter

    I hope this is the right stash log; if not, let me know where to find the correct one. I went back and tried the same operation in the configuration right before I zipped the file, to make sure if there's something to find, it's there.

    My coworker who set up the link to stash test said it's supposed to use http, but he didn't elaborate on why. He did check the credentials.

  13. Tomas Theunissen

    It looks like you copied the wrong contents in the log file?

    The Stash log files can be found in the home/data directory of Stash. Inside that directory there should be a directory called 'log'. In this log directory there should be a file named 'atlassian-stash.log'.

  14. Tomas Theunissen

    Yes, this is the correct one. It looks like Stash is for some reason killing the Git clone. I'll have to see if I can reproduce this locally with an HTTP accessible Stash server.

    Does Confluence connect to the Stash server directly or is there a proxy or something else in between Confluence and Stash?

  15. Tomas Theunissen

    Alright, i'll try and see if I can clone from Stash through HTTP tomorrow.

    Sorry that it's taking so long to get it working!

  16. Tomas Theunissen

    Hmm.. you could also create a support zip (under administraiotn > Atlassian Support Tools) with only 'Application Properties' selected. If you extract this zip, there should be one file. In this file there should be something like (most likely with another version):

    <git>
        <binary>/usr/bin/git</binary>
        <version>1.7.10.4</version>
    </git>
    

    Could you send that bit?

  17. Tomas Theunissen

    I tried to reproduce the problem, but HTTP clones are working fine.

    Are you able to clone over HTTP on your own computer? Also could you run the following command on the Stash server? It's the same command that Stash tries to run, but fails.

    /app/jira/local/bin/git http-backend
    
  18. Tomas Theunissen

    Hmm... it looks like there is something wrong with the Git client on the server. The 'git http-backend' command is used to serve Git files over HTTP(s), see also http://git-scm.com/docs/git-http-backend. But it looks like it's missing on the server. It might be a good idea to ask you system administrator to take a look at it and reinstall it or update it to a newer version.

    You will indeed need a Git client to do a clone on your workstation. You can download an official Git client from http://git-scm.com/ or try SourceTree (http://www.sourcetreeapp.com/), which is a more user friendly Git client from Atlassian. Both are free to use.

  19. Maya Chase reporter

    I've asked my coworker that set it up to either update the git client on the server or let me know what to do and I'll do it, so I'll have to get back to you on that.

    I downloaded Sourcetree (the easier the interface the better!) and tried to clone a repository. I get the attached error, which I presume is not unexpected, given the other errors we've received.

  20. Tomas Theunissen

    Yes, that looks like the same error. I'll hear from you when you got news from your coworker.

  21. Tomas Theunissen

    Good to hear that it works now! If you find any other issues or need help for anything, just create a new ticket. Going to close this issue for now.

  22. Log in to comment