TransportException: http://bshus\confluencegit@git-server/BSF-Confluence.git: cannot open git-upload-pack

Issue #45 resolved
Henrik Bach created an issue

Hi Avsi.

I cannot configure Git for Confluence, due to above error.

What am I doing wrong or need?

My configurations and a support zip containing confluence.log are attached this issue.

Thank you.

/Henrik (hba@lbf.dk)

Comments (27)

  1. Tomas Theunissen

    Hi Henrik,

    Thanks for adding the logs and screenshots, this helps a lot in finding the cause of this problem.

    Do you have access to the server Confluence is running on? If so, could you check if you can clone the Git repository on the server itself? Depending on if this works or not, we can see if the problem is in the configuration of the Git for Confluence add-on (or perhaps a bug in the add-on itself) or if it's a connectivity issue between the Confluence and Git server.

  2. Henrik Bach reporter

    Hi Tomas,

    Thank you for trying to help me sort out the Git configuration for Confluence issues with me.

    Yes, I have access to the Confluence server. However, with respect to the steps for cloning the repository, I would rather prefer, if you don’t mind, you to outline them for me because, I see a lot of ways to do it.

    I’ve installed Git-1.9.5-preview and TortoiseGit-1.8.14.0 on the Confluence server. The Git server is a Bonobo Git Server 1.2.0 and is named git-server and its web-interface has the URL http://git-server-interface.

    The ConfluenceGit user is able to create a repository on the git-server through the git-server-interface.

    Furthermore, I’ve noticed, a change in error messages, when I change Git configuration from git-server to git-server-interface, then it needed WebSudo package!?

    /Henrik

  3. Tomas Theunissen

    Hi Henrik,

    No worries, we are here to help!

    Could you add a screenshot of the Git server configuration in Confluence? I will need that to put together a command you can execute on the server for testing.

    About the 'WebSudo' error message, can you also add a screenshot of it to this issue?

  4. Henrik Bach reporter

    Hi Tomas,

    The git-server configuration:

    [cid:image004.png@01D10806.BC867750]

    And the error message, when trying to attach to the repository at the server:

    [cid:image005.png@01D10807.2DB11BB0]

    The git-server-interface configuration:

    [cid:image001.png@01D10806.EE6A1290]

    [cid:image002.png@01D10807.C9F73630]

    [cid:image006.png@01D10808.69B4C430]

    The other error I mentioned was for the case, when the ConfluenceGit user also was able to create its own repositories on the Git server. I/We have now disabled this ability, because, we/I only want the ConfluenceGit user to act as a contributor/administrator for known and allowed repositories.

    So, returning to the original issue: All-in-all, it is the same error messages we get, when we are accessing the same repository through different interfaces. This simplifies things… ☺

    /Henrik

  5. Henrik Bach reporter

    Hi Tomas,

    I’ve attached the (five) missing images.

    Hopes my previous mail and this with the attached images still makes sense, otherwise, I’ll create another mail, if you like.

    /Henrik

  6. Tomas Theunissen

    Hmm, I don't see them. Might be better if you add them directly to the issue on the Bitbucket page, instead of mailing.

  7. Tomas Theunissen

    No problem, I will try to get a command ready for you today or at least monday.

    Btw, you can safely delete the 'Gitorious' server. This server causes many errors in the log since it does not exist anymore.. (we will release a new version soon without it, but until then you can just delete it).

  8. Henrik Bach reporter

    Okay, I’ll delete Gitorious as suggested.

    However, don’t hurry, because I’m leaving the office for weekend soon.

    Have a nice weekend, though.

    /Henrik

  9. Tomas Theunissen

    Hi Henrik, hope you had a good weekend.

    Could you try the following git clone directly on the Confluence server:

    git clone http://bshus\confluencegit@git-server/BSF-Confluence.git
    

    You should get a prompt for the password. If it does not try the following (replace '<PASSWORD>' with the actual password of the user.

    git clone http://bshus\confluencegit:<PASSWORD>@git-server/BSF-Confluence.git
    

    If one of those works, then it is most likely a bug in the add-on and we will see if we can reproduce it somehow (could be the fact that the username has a backwards slash in it). If both don't work, could you add the output of both commands to this issue?

  10. Henrik Bach reporter

    Hi Tomas,

    Yes, thank you. Hopefully you, too.

    None of them worked in the MingW32 Bash-git CLI:

  11. Tomas Theunissen

    Hmm... did you get any error on the command line? Or are you able to clone with that command from your own machine?

  12. Henrik Bach reporter

    Hi Tomas,

    I’ve some troubles with cloning git repositories using the confluencegit user, both from the confluence server and other machines.

    I’ll report back later, my findings.

    /Henrik

  13. Tomas Theunissen

    Hey Henrik,

    So the command worked on the machine with the escaped backslash? If so, can you change the configuration in the add-on and also escape it there and see if that works?

  14. Tomas Theunissen

    Too bad that it didn't work. But the good news is that the connectivity between the Confluence server and the Git server is working and that the problem is most likely in the add-on code. I am going to create a similar setup as yours and see if I can reproduce it. I'll get back to you ASAP (probably tomorrow).

  15. Tomas Theunissen

    Hi Henrik,

    We were able to reproduce this issue and have a possible fix in sight! We are going to test if this change does not break anything else. I will get back to you tomorrow and will probably have a version with the fix before the end of the week.

  16. Tomas Theunissen

    We just released a new version of the add-on (1.13.2) which fixes this issue.

    You should not have to escape the username so you can just use: 'bshus\confluencegit'.

  17. Henrik Bach reporter

    Hi Tomas,

    Now Git for Confluence functions as expected.

    However, may I suggest you an improvement:

    “If It is possible, when registering a new git server, that before you save the configuration values, validates the given credentials against the given git server. It is rather annoying first finding that I have given wrong credentials, when registering a repository ☺”

    Case may be closed as resolved.

    Have a nice day.

    /Henrik

    Sendt: 28. oktober 2015 10:28 Til: Henrik Bach Emne: Re: [Bitbucket] Issue #45: TransportException: http://bshus\confluencegit@git-server/BSF-Confluence.git: cannot open git-upload-pack (avisi/git-for-confluence)

    [Billede fjernet af afsender. tomtheun]

    Tomas Theunissen commented on issue #45:

    TransportException: http://bshus\confluencegit@git-server/BSF-Confluence.git: cannot open git-upload-packhttps://bitbucket.org/avisi/git-for-confluence/issues/45/transportexception-http-bshus

    We just released a new version of the add-on (1.13.2) which fixes this issue.

    You should not have to escape the username so you can just use: 'bshus\confluencegit'.

    Status:

    new resolved

    View this issuehttps://bitbucket.org/avisi/git-for-confluence/issues/45/transportexception-http-bshus or add a comment by replying to this email.

    Unwatch this issuehttps://bitbucket.org/api/1.0/avisi/git-for-confluence/issue/45/unwatch/HenrikBachLBFHBA/bb76fc33bc9128595f7f4302488b23ca1c85fe5f/ to stop receiving email updates.

    [Billede fjernet af afsender. Bitbucket]https://bitbucket.org

  18. Tomas Theunissen

    Thats certainly a good suggestion. Though technically it's a bit difficult, since we need both the information from the server and repository to do a validation that works in every use case. One way of solving this might be to add the ability to add the repository details directly when creating a server.

  19. Henrik Bach reporter

    Yes, two possibilities to create repositories: Either from the new “Create Server” and/or from the old “Configure Repositories from Server”.

    /Henrik

  20. Henrik Bach reporter

    Hi Tomas,

    Now, I’m at it: Another suggestion for improvements is that I would like, if you could adhere to an equal functionality like TechTime’s SpaceUnzip regarding creation of the file/page hierarchy given from the repository:

    https://marketplace.atlassian.com/plugins/org.techtime.confluence.plugins.spaceunzip

    It will save me lot of time tampering in documents… ☺

    /Henrik

    Sendt: 28. oktober 2015 12:12 Til: Henrik Bach Emne: Re: [Bitbucket] Issue #45: TransportException: http://bshus\confluencegit@git-server/BSF-Confluence.git: cannot open git-upload-pack (avisi/git-for-confluence)

    [Billede fjernet af afsender. tomtheun]

    Tomas Theunissen commented on issue #45:

    TransportException: http://bshus\confluencegit@git-server/BSF-Confluence.git: cannot open git-upload-packhttps://bitbucket.org/avisi/git-for-confluence/issues/45/transportexception-http-bshus

    Thats certainly a good suggestion. Though technically it's a bit difficult, since we need both the information from the server and repository to do a validation that works in every use case. One way of solving this might be to add the ability to add the repository details directly when creating a server.

    View this issuehttps://bitbucket.org/avisi/git-for-confluence/issues/45/transportexception-http-bshus or add a comment by replying to this email.

    Unwatch this issuehttps://bitbucket.org/api/1.0/avisi/git-for-confluence/issue/45/unwatch/HenrikBachLBFHBA/bb76fc33bc9128595f7f4302488b23ca1c85fe5f/ to stop receiving email updates.

    [Billede fjernet af afsender. Bitbucket]https://bitbucket.org

  21. Log in to comment