Cannot install plugin due to java version

Issue #49 resolved
T created an issue

When installing version 1.13.2 plugin in Confluence 5.5.4 it shows following error in the logs: Confluence is using java 1.7

java.lang.UnsupportedClassVersionError: nl/avisi/confluence/plugins/gitplugin/configuration/dao/ActiveObjectsServerDao : Unsupported major.minor version 52.0

Comments (8)

  1. Mitchel Kuijpers

    Hi @kenisTomas

    We currently compile Git For Confluence for java 1.8. This is a mistake on our part because confluence 5.4 still supports java 1.7.

    I compiled the latest version of Git for Confluence for java 1.7 Could you try it out and see if it works? If it works we will cut a release with Java 1.7 support as soon as possible.

  2. Thomas Herzog

    I have the same problem. Is the provided version still valid or is there a never one ?

    We run Confluence 5.6.5 on java 1.7

  3. Tomas Theunissen

    Hi @cchet, the version attached to this issue should work and is the latest version that should work for you (it seems we never actually released that version on the marketplace...). All the other (newer) versions on the marketplace are for newer versions of Confluence than you are running.

    Let me know if you run into any issues when installing this version (1.13.5-SNAPSHOT). If it works like you expect, we will create a new official release.

  4. Tomas Theunissen

    Good to hear! I just released an official 1.13.5 version to the Atlassian Marketplace. If you don't see this update in the add-on manager within Confluence, then you should first uninstall the 'SNAPSHOT' version and reinstall it from the marketplace.

  5. Log in to comment