Confluence 5.5.2 -Wiki markup - Unknown macro numberedheading

Issue #55 resolved
Kristof Vandermeersch created an issue

Hello, we have this problem: Apparently, when we did the upgrade from Confluence 5.2.5 to 5.5.2 (or to 5.5.4), the numberedheadings macro's don't work anymore. We have version 2.6.0 of the Numberedheadings add-on.

It seems that the pages containing wiki markup and numberedheadings don't work anymore.

In this article https://answers.atlassian.com/questions/190768/upgrade-of-confluence-3-5-17-to-5-1-4-problems-with-numberedheading-plugin the solution was to install Numberedheadings 2.3.1 and then run the wikimarkupconvert process. BUT with Confluence 5.5.2, version 2.3.1 cannot be installed anymore, it gives errors when loading: Caused by: java.lang.NoSuchMethodError: com.atlassian.plugin.descriptors.AbstractModuleDescriptor: method <init>()V not found at nl.avisi.confluence.plugins.numberedheadings.NumberFormatterDescriptor.<init>(NumberFormatterDescriptor.java:8)

How should I solve this problem with the numberedheadings macro?

Comments (16)

  1. Tomas Theunissen

    Hi Kristof,

    Thanks for reporting this issue. The question on answers.atlassian.com you refer to, was caused by dropping wiki markup support (which occurred in Confluence 4). Since you upgraded from 5.2.5 (I assume the NH macro worked in this version), you shouldn't be affected by this. Could you make a screenshot of the error you get?

  2. Kristof Vandermeersch reporter

    Yes, in 5.2.5, the NB macro worked in XHTML storage format

    But in 5.2.5 there were still some pages containing Wiki markup and numberedheading macros and they all worked, but now not anymore.

    I investigated some more, and I found out that the {numberedheadings} macro has this behaviour when pasting via insert->wiki markup: Paste Wiki Markup via insert markup with numberedheadings.png

    Without {numberedheadings} macro, this works: Paste Wiki Markup via insert markup.png

  3. Kristof Vandermeersch reporter

    We really want to get rid of the wiki markup, but since {numberedheadings} macro cannot be converted to xhtml automatically, we want to do it manually for some pages, but since pasting wiki markup does not work for NH macro, we can't do that at the moment. And NH add-on 2.3.1 is not compatible anymore with Confluence 5.5...

  4. Tomas Theunissen

    Thanks for the screenshots. I was able to reproduce the problem locally (when inserting wiki markup). I'll see if I can find out why it happens and if we can get a fix for it.

  5. Tomas Theunissen

    Most likely the automatic transformation is not working because the 'wiki macro' does not exist in newer NH versions. I think the easiest way to fix this, is for us to create a specific version for you with both macro versions and that will work on your Confluence version. This will allow you to run the wiki markup conversion. If this works as I expect all your content should be transformed. After that you can uninstall the specific NH version and install the latest from the Atlassian marketplace.

    I have attached the specific version to this issue. Let me know if it works!

  6. Kristof Vandermeersch reporter

    Wow, that was fast, thank you. This indeed works, now the NH macro is recognized, BUT the auto-conversion (.../admin/unmigratedcontent.action) does not convert the pages containing wiki markup into XHTML. Any idea on this?

  7. Kristof Vandermeersch reporter

    I tried that, but no result. After 1 second he is done without result, no way he can check in that timespan all the pages that need to be converted from wiki markup to XHTML. I don't know the details of that process...

  8. Kristof Vandermeersch reporter

    But it's all right, I'm doing the conversion manually, there are not too many pages containing NH macro's that were still in wiki markup. Thank you for your support!

  9. Tomas Theunissen

    Too bad you have to do them manually (you might try the following query to see which pages still have unmigrated content; SELECT * FROM BODYCONTENT WHERE BODY like '%{numberedHeadings}%'). If you encounter any other issues, please contact us!

    If you have time, we appreciate it if you could give us a review on the Atlassian Marketplace or try one of our other add-ons. Je mag natuurlijk ook paar biertjes uit België sturen ;)

  10. Ringo De Smet

    @tomtheun, @gerstree I have a setup where the SQL query returned 2707 entries. Help appreciated... Is this the same issues as #59 ?

    Screen sharing allowed by the customer to get this resolved.

  11. Log in to comment