Unmigrated content after Confluence update to v5.5

Issue #59 resolved
Jochen created an issue

We migrated our Confluence installation from v3.5 to v5.5. However, under v3.5 we missed to update the Numbered Headings add-on as it was not shown as an update. So we are still using v1.4 of the plugin under Confluence v5.5.

Pages using the add-on are rendered correctly so they show all numbered headings correctly. However, if you edit a page, you see that the content was not migrated and is displayed as Wiki markup (see attached file unmigrated-page.png).

I wonder if there is any way to re-migrate the pages. In a test system, I tried installing the new version and follow the Atlassian guide for handling unmigrated wiki content but unfortunately this didn't work.

Do you have any idea how this problem could be solved? I am aware that the cause for the problem is that we didn't update the add-on before the migration - but maybe there is a way to fix this. Any help would be greatly appreciated!

Comments (27)

  1. Tomas Theunissen

    Hi, thanks for contacting us about your problem.

    Have you tried the '2.6.1' version that is attached to Issue 55? It should contain the old macro which is needed for the conversion.

  2. Jochen reporter

    Hi Tomas, Thanks for your quick reply. So what would be the correct steps?

    • update plugin to v2.6.1
    • either run the unmigratedcontent.action
    • or run the force-upgrade.action for wiki2Xhtml?
  3. Tomas Theunissen

    Installing the 2.6.1 version and running the 'unmigratedcontent.action' should be enough. Let me know if you run into any problems.

  4. Jochen reporter

    I tried this but no content was migrated. I think the problem here is that the content on the page is shown as Wiki markup which does not get migrated by the 'unmigratedcontent.action'.

  5. Tomas Theunissen

    Hmm.. if I reread the documentation and noticed that 'unmigratedcontent.action' only migrates content that is wrapped in a 'unmigrated-wiki-markup' macro. Which is not the case in this situation. Have you tried the 'force upgrade' as described here?

  6. Tomas Theunissen

    I just did some testing in our own instance and for me the '../admin/unmigratedwikicontent.action' (which has been moved in later versions to '../admin/unmigratedcontent.action') action worked. Could you add the raw storage format (of a page with this problem) to this issue? You can get it when you view the page and then under 'Tools' > 'View Storage Format'.

  7. Jochen reporter

    I tested it again - the unmigratedcontent.action does not change anything. It is finished after one second which is much too fast, I guess. Please find attached one wiki page in the storage format.

  8. Gert-Jan van de Streek

    After you check, can you please try to stop / start Confluence. This specific plugin version has some plugin components that Confluence may have missed when upgrading to 2.6.1

  9. Jochen reporter

    Sorry for the delay... I did the following: - uninstall add-on - restart Confluence - install plugin - restart Confluence - executed both beforementioned actions Still no success, all pages contain wiki markup.

  10. Jochen reporter

    This might get difficult due to security restrictions. What kind of access would you need? Access to a space?

  11. Gert-Jan van de Streek

    Preferrably your complete instance as an admin user. Maybe we can arrange a screen share where @tomtheun can talk you through some basic checks.

    Do you have a test environment with comparable content?

  12. Jochen reporter

    We decided not to fix this problem. All pages are displayed correctly and most of them probably won't be edited in future. For those being edited we wrote some step-by-step instructions on how to fix this issue.

    Thanks again for your quick and professional help!

  13. Gert-Jan van de Streek

    You're welcome. Although it still leaves us with an uneasy feeling that we could not help you solve it. Any time you need to pick this up again, contact us.

  14. Ringo De Smet

    @gerstree I have this situation too after a migration for one of our customers (I work for iDalko, Atlassian Platinum partner in Belgium).

    The {numberedheadings} macro is in a Wiki Markup block. I don't even know how many pages are affected but it seems that every page which is not converted included the {numberedheadings} macro.

    Can you help?

  15. Gert-Jan van de Streek

    @ringods can you tell me what version of Confluence you are upgrading? And to what version? Same for the numbered headings macro versions.

  16. Ringo De Smet

    @gerstree, the old Confluence server was still running v3.4.9. Don't know which version of Numbered Headings was on that one. I upgraded Confluence via versions:

    • 3.5.17 (for the migration of AD users to the new Embedded Crowd)
    • 4.2.13 (for upgrade issues with the Scaffolding & Reporting add-ons)
    • 4.3.7 (latest in the v4 series)
    • 5.7

    This Confluence v5.7 is running Numbered Headings 2.6.1. As I mentioned in #55, the customer allows me to do screen sharing with you to get this resolved.

  17. Ringo De Smet

    @gerstree I can only connect to the customer's systems via VPN and they block HipChat. Other option?

  18. Log in to comment