No macro found on content id after migrating from on-premise to cloud

Issue #71 resolved
Adriaan Peeters created an issue

Hi,

After migrating from on-premise to cloud we are having this issue. After reading through the extensive list of bug reports and workarounds these do not seem to work in our environment. What workaround should I use?

Exact error message: No macro found on content id : ContentId{id=66125846} with version: 3 and macroId: 5ef041a38037c061dd21ce081a8f292f

The Numbered Headings user has read access on the space.

Thanks, Adriaan

Comments (9)

  1. Mitchel Kuijpers

    Hi @apeeters

    Sorry to hear that it doesn't work for you. Where do you get the error? After you save or in the 'Macro Browser'.

  2. Adriaan Peeters reporter

    Hi @mitchelkuijpers I get the error while viewing a page that contains the macro. This page was migrated from on-premise to cloud.

  3. Adriaan Peeters reporter

    No, in that case it works.

    Also: editing and saving the page seems to solve the problem. Is there any way to do this in bulk for all affected pages?

  4. Mitchel Kuijpers

    @apeeters That sounds very weird... let's keep this issue open and close it a after a week if you don't get any new hiccups ;)

  5. Adriaan Peeters reporter

    @mitchelkuijpers The behaviour seems to be consistent and is most likely caused by caching: pages that were viewed by a user while the plug-in had no view permission on the space keep the error message until the page is edited. A fix without having to edit all affected pages would be welcome.

  6. Mitchel Kuijpers

    Hi @apeeters,

    We send a caching instruction to Confluence but it should only be valid for one day. So it should resolve itself within one day. Please let us know the result :)

  7. Log in to comment