Commits

Sean Cribbs committed 6e8c731

Update README for recent changes.

  • Participants
  • Parent commits 3a6067d

Comments (0)

Files changed (1)

File README.textile

 
 h2. Dependencies
 
-@riak-client@ requires ActiveSupport 2.3.5 or later, but the version 3 is recommended. I highly recommend the "curb":http://curb.rubyforge.org/ gem for better HTTP client performance.
+@riak-client@ requires i18n and either json or yajl-ruby. For higher performance on HTTP requests, install the 'curb' or 'excon' gems. The cache store implementation requires ActiveSupport 3 or later.
 
 @ripple@ requires Ruby 1.8.7 or later and versions 3 or above of ActiveModel and ActiveSupport (and their dependencies, including i18n).
 
 # Create a client interface
 client = Riak::Client.new
 
+# Create a client interface that uses Excon
+client = Riak::Client.new(:http_backend => :Excon)
+
 # Retrieve a bucket
 bucket = client.bucket("doc")  # a Riak::Bucket