Overview

CodeIgniter PHPIDS library
==========================

Version 0.0.1

This library is an implementation of PHPIDS (http://php-ids.org) for the CodeIgniter framework, it detects and reacts on intrusions.


Requirements
------------
1) CI 2.0 and up
2) PHPIDS 0.6.4 and up


Installation
------------
1) Copy the files into your application folder.
2) Use the sql file to setup the tables in your database.
3) Download the latest version of PHPIDS from http://php-ids.org/downloads/
4) Copy the IDS folder (located in the lib folder) from the download into /application/third_party/phpids/ 
   You can put these files in a different location as long as you update the ids_url config value.
5) Change the base_path value in /application/third_party/phpids/IDS/Config/Config.ini.php to the correct path
   Example: /var/www/codeigniter/application/third_party/phpids/IDS/
6) Change the use_base_path value to true
7) Make sure the application/third_party/phpids/IDS/tmp folder writable
8) Update the config file located at application/config/php_ids.php
9) Update the autoload file located at application/config/autoload.php and add 'database' and 'php_ids' to the $autoload['libraries'] array
10) That should be it :)


Acknowledgement
---------------
This library is an implementation to connect two great pieces of art. Therefore, a big thank you goes out to everyone involved in the PHPIDS project, 
in special Mario Heiderich, Christian Matthies and Lars H. Strojny. Also everyone involved in the CodeIgniter project from EllisLab Inc, are thanked, 
as well as the whole CodeIgniter community for making CodeIgniter such a success!


Todo list
---------
1) Sending text alerts for high impact intrusions.
2) Automated check for updated rules and converter files (default_filter.xml and Converter.php) @ http://php-ids.org