ListAll tags length is 0

Issue #41 invalid
Anonymous created an issue

nppColdfusion 0.8.1 with Notepad++ 5.8.4

On editor launch: alert (similar to JS alert) appears with title nppColdFusion

Contents: "ListAll tags length is 0"

Notepad++ runs after clearing the error, but only some syntax color coding.

Comments (6)

  1. Ben Bluemel repo owner


    This is down to nppColdFusion not having access to the database... (Generally caused by the config folder being put in the `Program Files\Notepad++\plugins` folder, rather than the `%appdata%\Notepad+\plugins` folder).

    You can use the install script, which will put everything in the right place for you.

    Kind Regards


  2. Anonymous


    When I try to use the install script, I get a .vbs file and not an executable. I'm confused.

    - roger

  3. Anonymous

    roger, you'r config is in wrong place. Just copy - nppColdFusion.db3 - nppColdFusion.xml

    to %appdata%\Notepad++\plugins\config (for me it is = C:\Users\Administrator\AppData\Roaming\Notepad++\plugins\config)

  4. Anonymous

    I had this issue with getting the "listall tags length is 0" error. I am running Notepad++ from a USB stick so that folder does not exist on my computer. After reading this thread and seeing that it must be in this folder, I created the folder structure in "Application Data" (WinXP), put the files where they needed to go and VOILA!, it worked. This plugin displays ColdFusion better than DreamWeaver, its nice!!

    The installation instructions should be updated for folks running this on USB.

  5. Ed Dorsey

    Ben, I seem to be experiencing the same error message. Running Win7, Npp 6.15, nppColdFusion 0.8.1. I used the installer, and confirmed that the config files are in %appdata%\Notepad++\plugins\config. I get the error message "ListAll tags length is 0" twice on launching npp, and when I start a tag.

    Any thoughts?

    TIA - Ed

  6. Log in to comment