Issue #4 resolved

do not fail for old versions of b

Simon H.
created an issue

hotfiles fails with version 0.6.0 because {{{b.version}}} is a string and not a callable.

This patch fixes this: {{{

!diff

HG changeset patch

User simohe@besonet.ch

Date 1331895096 -3600

Node ID 7317174fef67772ed6799791a1bab803d39831b5

Parent c251c4685f5856be0fe5ecb1da5c39d1b6be7ae6

do not fail for old versions of b

diff -r c251c4685f58 -r 7317174fef67 hotfiles.py --- a/hotfiles.py Tue Mar 06 20:34:11 2012 +0100 +++ b/hotfiles.py Fri Mar 16 11:51:36 2012 +0100 @@ -44,6 +44,8 @@ bversionfunc = getattr(b, 'version') if bversionfunc is None: return None + if isinstance(bversionfunc, type('')): + return None #version is too old if bversionfunc() < bversionfunc('0.6.2'): return None return b }}}

Comments (6)

  1. Log in to comment