'module' object has no attribute 'graph'

Issue #34 resolved
Anonymous created an issue

After running hg chist or hg cup I've got this output and the main window is empty (can't do anything). System is ArchLinux x86_64. {{{ Traceback (most recent call last): File "/usr/lib/python2.6/site-packages/cutehg/views/models/historymodel.py", line 52, in run for (context, (column, color), edges) in graphmod.graph(self._repository, len(self._repository), 0): File "/usr/lib/python2.6/site-packages/mercurial/demandimport.py", line 76, in getattribute return getattr(self._module, attr) AttributeError: 'module' object has no attribute 'graph' Traceback (most recent call last): File "/usr/lib/python2.6/site-packages/cutehg/views/diffview.py", line 61, in displayDiff diff = str(self.model.data(index, QtCore.Qt.DisplayRole).toString()) UnicodeEncodeError: 'ascii' codec can't encode characters in position 51-56: ordinal not in range(128) }}}

Comments (5)

  1. Wojciech Czarnowski

    I have the same on Mac OS X Snow Leopard, python2.6, pyqt 4.5.4, mercurial 1.3.1.

    Traceback (most recent call last): File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/cutehg/views/models/historymodel.py", line 52, in run for (context, (column, color), edges) in graphmod.graph(self._repository, len(self._repository), 0): File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/mercurial/demandimport.py", line 76, in getattribute return getattr(self._module, attr) AttributeError: 'module' object has no attribute 'graph'

  2. Anonymous

    Same issue on Ubuntu 9.04 x86_64, Python 2.6.2, PyQt 4.6, Mercurial 1.3.1, with the same tracelog as above.

  3. Anonymous

    From "ubuntu 9.04 x86_64" : Just saw the patch in the other issue, and applied it succesfully. Sorry guys for not looking better.

  4. Log in to comment