Issue #1 resolved

slf4j conflict with grails

Ford Guo
created an issue

atmosphere use slf4j-api 1.6.1,but grails use 1.5.8. so the simple way is use exclude ,see this :

    runtime('org.atmosphere:atmosphere-runtime:0.7.2'){
            exclude 'slf4j-api'
    }

Comments (2)

  1. Bertrand Goetzmann repo owner

    You are right: your correction will be part of the 0.4.1.1 plugin version. Can you describe me the way you see the error (the error doesn't appear when running atmosphere-labs)?

  2. Ford Guo reporter

    long time ago :),I can reproduce it now :( I think if you run-app the grails(above 1.3.7) app ,there is no error,but when you package the war and deploy it to web container,there will be a error.

  3. Log in to comment