Commits

Anonymous committed 8077e18

we require python >= 2.4 now

  • Participants
  • Parent commits 32612c2

Comments (0)

Files changed (2)

 NEW IN WAF 1.7.0
 ----------------
 * Do not load the compat15 tool by default
+* Minor API cleanup
+* Require Python >= 2.4
 
 NEW IN WAF 1.6.11
 -----------------
 
 	f.close()
 	if path.endswith('.py') :
-		cnt = process_decorators(cnt)
-
-		if cnt.find('set(') > -1:
-			cnt = 'import sys\nif sys.hexversion < 0x020400f0: from sets import Set as set\n' + cnt
+		# WARNING: since we now require python 2.4, we do not process the decorators anymore
+		# if you need such a thing, uncomment the code below:
+		#cnt = process_decorators(cnt)
+		#if cnt.find('set(') > -1:
+		#	cnt = 'import sys\nif sys.hexversion < 0x020400f0: from sets import Set as set\n' + cnt
 		cnt = '#! /usr/bin/env python\n# encoding: utf-8\n# WARNING! Do not edit! http://waf.googlecode.com/git/docs/wafbook/single.html#_obtaining_the_waf_file\n\n' + cnt
 
 	return (io.BytesIO(cnt.encode('utf-8')), len(cnt), cnt)