Remove nose dependency

Issue #1490 new
Matěj Cepl
created an issue

nose seems to me mostly obsolete and dead project (even its own maintainers seem to move to its successor). Moreover, it seems to be mostly unnecessary now, at least as far as the code itself is concerned by API provided by the very standard library of Python even in the version 2.7. Therefore, dependency on nose is no longer necessary and thus advisable.

This attached patch suggests removal of this dependency (I am sorry, with all due respect, I really have hard time to fight with Mercurial, so I am just attaching patch to this issue).

Thank you for considering this issue.

Comments (0)

  1. Log in to comment