1. Georg Brandl
  2. pygments-main
  3. Issues
Issue #845 resolved

pygments 1.6's guess_lexer() returns LassoXmlLexer for plain XML

Piotr Ożarowski
created an issue
>>> from pygments.lexers import guess_lexer as g
>>> g('<?xml version="1.0"?><eggs>ham</eggs>')
<pygments.lexers.LassoXmlLexer>

It should return a pygments.lexers.XmlLexer instance instead. This is what pygments 1.5 did.

(forwarded from http://bugs.debian.org/700049)