Commits

Jon Waltman committed 5bebd2a

setup.py: Update "requires" to docutils>=0.10.0 under Python 3.3

Comments (2)

Files changed (1)

 
 requires = ['Pygments>=1.2', 'Jinja2>=2.3', 'docutils>=0.7']
 
+if sys.version_info[:3] >= (3, 3, 0):
+    requires[2] = 'docutils>=0.10'
+
 if sys.version_info < (2, 5):
     print('ERROR: Sphinx requires at least Python 2.5 to run.')
     sys.exit(1)
 
-if sys.version_info[:3] >= (3, 3, 0):
-    try:
-        import docutils
-        x, y = docutils.__version__.split('.')[:2]
-        if (int(x), int(y)) < (0, 10):
-            sys.stderr.write('ERROR: Sphinx requires at least '
-                             'Docutils 0.10 for Python 3.3 and above.\n')
-            sys.exit(1)
-    except Exception:
-        pass
-
 # Provide a "compile_catalog" command that also creates the translated
 # JavaScript files if Babel is available.
 
Tip: Filter by directory path e.g. /media app.js to search for public/media/app.js.
Tip: Use camelCasing e.g. ProjME to search for ProjectModifiedEvent.java.
Tip: Filter by extension type e.g. /repo .js to search for all .js files in the /repo directory.
Tip: Separate your search with spaces e.g. /ssh pom.xml to search for src/ssh/pom.xml.
Tip: Use ↑ and ↓ arrow keys to navigate and return to view the file.
Tip: You can also navigate files with Ctrl+j (next) and Ctrl+k (previous) and view the file with Ctrl+o.
Tip: You can also navigate files with Alt+j (next) and Alt+k (previous) and view the file with Alt+o.