Jon Waltman avatar Jon Waltman committed f0272d2

sphinx-build: Require Docutils >= 0.10 when running under Python >= 3.3

Comments (0)

Files changed (1)

sphinx/__init__.py

 
 def main(argv=sys.argv):
     """Sphinx build "main" command-line entry."""
-    if sys.version_info[:3] < (2, 4, 0):
+    if sys.version_info[:3] < (2, 5, 0):
         sys.stderr.write('Error: Sphinx requires at least '
-                         'Python 2.4 to run.\n')
+                         'Python 2.5 to run.\n')
         return 1
-
+    if sys.version_info[:3] >= (3, 3, 0):
+        try:
+            import docutils
+            x, y = docutils.__version__.split('.')[:2]
+            if (int(x), int(y)) < (0, 10):
+                sys.stderr.write('Error: Sphinx requires at least '
+                                 'Docutils 0.10 for Python 3.3 and above.\n')
+                return 1
+        except Exception:
+            pass
     try:
         from sphinx import cmdline
     except ImportError:
Tip: Filter by directory path e.g. /media app.js to search for public/media/app.js.
Tip: Use camelCasing e.g. ProjME to search for ProjectModifiedEvent.java.
Tip: Filter by extension type e.g. /repo .js to search for all .js files in the /repo directory.
Tip: Separate your search with spaces e.g. /ssh pom.xml to search for src/ssh/pom.xml.
Tip: Use ↑ and ↓ arrow keys to navigate and return to view the file.
Tip: You can also navigate files with Ctrl+j (next) and Ctrl+k (previous) and view the file with Ctrl+o.
Tip: You can also navigate files with Alt+j (next) and Alt+k (previous) and view the file with Alt+o.