Commits

Jon Waltman committed f485e91

setup.py: Require Docutils >= 0.10 when running under Python >= 3.3

  • Participants
  • Parent commits 0d4632a

Comments (0)

Files changed (1)

     print('ERROR: Sphinx requires at least Python 2.5 to run.')
     sys.exit(1)
 
+if sys.version_info[:3] >= (3, 3, 0):
  1. Georg Brandl repo owner

    I don't think this should be a fatal error. You can for example do "python setup.py sdist" without docutils even installed on 3.3.

    Either change it to a warning, or maybe just update the "requires" list on 3.3.

+    try:
+        import docutils
+        x, y = docutils.__version__.split('.')[:2]
+        if (int(x), int(y)) < (0, 10):
+            sys.stderr.write('ERROR: Sphinx requires at least '
+                             'Docutils 0.10 for Python 3.3 and above.\n')
+            sys.exit(1)
+    except Exception:
+        pass
 
 # Provide a "compile_catalog" command that also creates the translated
 # JavaScript files if Babel is available.