Jon Waltman committed f485e91 Require Docutils >= 0.10 when running under Python >= 3.3

Comments (0)

Files changed (1)

     print('ERROR: Sphinx requires at least Python 2.5 to run.')
+if sys.version_info[:3] >= (3, 3, 0):
  1. Georg Brandl repo owner

    I don't think this should be a fatal error. You can for example do "python sdist" without docutils even installed on 3.3.

    Either change it to a warning, or maybe just update the "requires" list on 3.3.

+    try:
+        import docutils
+        x, y = docutils.__version__.split('.')[:2]
+        if (int(x), int(y)) < (0, 10):
+            sys.stderr.write('ERROR: Sphinx requires at least '
+                             'Docutils 0.10 for Python 3.3 and above.\n')
+            sys.exit(1)
+    except Exception:
+        pass
 # Provide a "compile_catalog" command that also creates the translated
 # JavaScript files if Babel is available.
Tip: Filter by directory path e.g. /media app.js to search for public/media/app.js.
Tip: Use camelCasing e.g. ProjME to search for
Tip: Filter by extension type e.g. /repo .js to search for all .js files in the /repo directory.
Tip: Separate your search with spaces e.g. /ssh pom.xml to search for src/ssh/pom.xml.
Tip: Use ↑ and ↓ arrow keys to navigate and return to view the file.
Tip: You can also navigate files with Ctrl+j (next) and Ctrl+k (previous) and view the file with Ctrl+o.
Tip: You can also navigate files with Alt+j (next) and Alt+k (previous) and view the file with Alt+o.