latest Jinja2 (2.7) requires Python 2.6 or later
Currently, the requirements in setup.py simply demand "Jinja2>=2.3"; however, this breaks Python 2.4, 2.5, 3.1, and 3.2, which are not supported by Jinja2 2.7:
Ideally, for these older Python versions, the requirement could be stated instead as 'Jinja2>=2.3,<2.7' I'm not sure if the requirement in setup.py can be simply made conditional on the Python version with something like this:
if sys.hexversion < 0x02060000 or 0x03000000 <= sys.hexversion < 0x03030000: requires = ['Pygments>=1.2', 'Jinja2>=2.3,<2.7', 'docutils>=0.7'] else: requires = ['Pygments>=1.2', 'Jinja2>=2.3', 'docutils>=0.7']
but that might be worth a try.
It might also be worth adding some kind of mention of this issue to http://sphinx-doc.org/intro.html#prerequisites