Issues

Issue #488 resolved

jsonimpl.py fails with Python <=2.5 if json-py is installed

Anonymous created an issue

json-py seems to be yet another JSON implementation for python. See http://sourceforge.net/projects/json-py/.

If it's installed, util/jsonimpl.py fails to import simplejson as {{{import json}}} imports the json-py library.

Suggested fix in util/jsonimpl.py: {{{ try: import json + if not hasattr(json, 'JSONEncoder'): + raise ImportError JSONEncoder = json.JSONEncoder except ImportError: }}}

Comments (3)

  1. Log in to comment