CMake under windows WSL

Issue #396 resolved
Pedro Alves created an issue


Probably a weird use case, but I was trying to setup a testing environment on WSL and I think I found a small bug in the CMakeLists.

When generating code with cmake I get:

CMake Error at CMakeLists.txt:148 (string):
string sub-command REGEX, mode MATCH needs at least 5 arguments total to

I fixed it by updating line 148 from the main CMakeLists.txt file:

string(REGEX MATCH "([0-9][0-9]+)" tmp ${tmp})


string(REGEX MATCH "([0-9][0-9]+)" tmp "${tmp}")

Based on feedback from:

I believe this to be a (very small) bug, right? I tested with a few CMake versions under WSL, all produced the same error.

Thanks in advance

Comments (5)

  1. Klaus Iglberger

    Hi Pedro!

    Thanks a lot for reporting this defect. Since we cannot test Blaze in every possible environment, we depend on this kind of feedback and very much appreciate the help. We’ll fix the issue as quickly as possible.

    Best regards,


  2. Klaus Iglberger

    Commit 68cc002 fixes the CMakeLists.txt file based on suggestion. The fix is immediately available via cloning the Blaze repository and will be officially released in Blaze 3.9.

  3. Log in to comment