1. Erik Svensson
  2. transmissionrpc
  3. Issues
Issue #54 resolved

Error: Flexget Unhandled error

Anonymous created an issue

I'm having an issue with Flexget failing to add torrents to transmission, which appears to be due to the transmissionrpc. Here is the output that I have:

2013-10-03 20:34 ERROR    task          torrentdaymovies BUG: Unhandled error in plugin transmission: 'torrent-added'
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/flexget/task.py", line 365, in __run_plugin
    return method(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/flexget/event.py", line 21, in __call__
    return self.func(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/flexget/plugins/plugin_transmission.py", line 27, in new_f
    f(self, *args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/flexget/plugins/plugin_transmission.py", line 245, in on_task_output
    self.add_to_transmission(self.client, task, config)
  File "/usr/local/lib/python2.7/dist-packages/flexget/plugins/plugin_transmission.py", line 330, in add_to_transmission
    r = cli.add(filedump, 30, **options['add'])
  File "/usr/local/lib/python2.7/dist-packages/transmissionrpc-0.10-py2.7.egg/transmissionrpc/client.py", line 427, in add
    return self._request('torrent-add', args, timeout=timeout)
  File "/usr/local/lib/python2.7/dist-packages/transmissionrpc-0.10-py2.7.egg/transmissionrpc/client.py", line 273, in _request
    item = data['arguments']['torrent-added']
KeyError: 'torrent-added'

The torrents actually ARE added to transmission, so other than the error, this isn't really a huge problem for me.

Comments (5)

  1. Erik Svensson repo owner

    This might be an issue with the new 'torrent-duplicate' response to 'torrent-add'. This has been fixed in the repository, please try to use development version if possible. If you need further help, please describe which Transmission version you use.

  2. Rowan Johnas

    I was having the same error and thought it had to do something with flexget, so I had reported it as issue #2212 on flexget.

    However jstapels did some research on it and determined that the following would fix it:

    elif method == 'torrent-add':
                if 'torrent-duplicate' in data['arguments']:
                    item = data['arguments']['torrent-duplicate']
                    item = data['arguments']['torrent-added']
                results[item['id']] = Torrent(self, item)

    I just tried it out and it fixed the above error for me.

  3. Log in to comment