Commits

basvandijk committed 010ea64

Allow building with both the newest deepseq (>= 1.2) and containers (>= 0.4.2)
Use the flag old-deepseq-containers to build with older versions.

  • Participants
  • Parent commits d2b8c90

Comments (0)

Files changed (1)

   description: operate in developer mode
   default: False
 
+flag old-deepseq-containers
+  default: False
+
 library
   exposed-modules:
     Data.Aeson
     blaze-builder >= 0.2.1.4,
     blaze-textual >= 0.2.0.2,
     bytestring,
-    containers,
-    deepseq < 1.2,
     hashable >= 1.1.2.0,
     mtl,
     old-locale,
     unordered-containers >= 0.1.3.0,
     vector >= 0.7
 
+  if flag(old-deepseq-containers)
+    build-depends:
+      containers < 0.4.2,
+      deepseq < 1.2
+  else
+    build-depends:
+      containers >= 0.4.2,
+      deepseq >= 1.2
+
   if flag(developer)
     ghc-options: -Werror
     ghc-prof-options: -auto-all