Commits

Bryan O'Sullivan committed b3d6f77

Replace old-deepseq-containers flag with a GHC version check.

This seems to be much more portable across versions of GHC older than 7.2.

  • Participants
  • Parent commits da2deb3

Comments (0)

Files changed (1)

   description: operate in developer mode
   default: False
 
-flag old-deepseq-containers
-  default: False
-
 library
   exposed-modules:
     Data.Aeson
     unordered-containers >= 0.1.3.0,
     vector >= 0.7.1
 
-  if flag(old-deepseq-containers)
+  if impl(ghc < 7.2)
     build-depends:
       containers < 0.4.2,
       deepseq < 1.2