Source

text / Data / Text / Lazy / Fusion.hs

Author Commit Message Labels Comments Date
Bryan O'Sullivan
Change Tom's email address
Bryan O'Sullivan
Rename :!: to :*: for consistency with other stream-based packages.
Bryan O'Sullivan
Get rid of most of findIndex, findIndices, elemIndex, and elemIndices.
Bryan O'Sullivan
ZOMG size isn't everything.
Bryan O'Sullivan
Rename count to countChar.
Bryan O'Sullivan
Update copyrights and maintainers.
Tags
0.2
Bryan O'Sullivan
Implement and test lazy elemIndex, elemIndices, and count
Bryan O'Sullivan
Implement and test lazy findIndex and findIndices
Bryan O'Sullivan
Implement and test lazy zipWith
Nicolas Pouillard
Annotate the precision of hints in fusions for documentation purpose.
Nicolas Pouillard
Remove fromIntegral in Data.Text.{Lazy.,}Fusion.unfoldrN
Nicolas Pouillard
Data.Text.Lazy.Fusion: fix a bug in unstreamChunks.
Bryan O'Sullivan
Refactor common fusion code into one module
Bryan O'Sullivan
Minor cleanups
Bryan O'Sullivan
Clean up some unhelpful warnings
Bryan O'Sullivan
More progress on laziness
Bryan O'Sullivan
Add a missed file