Pull requests

#1 Merged
Repository
r_rudi r_rudi
Branch
default
Repository
brendan brendan
Branch
default

Compatibility with hg 2.3

Author
  1. WAKAYAMA shirou
Reviewers
Description

Updated)

  • make try/except style
  • make wrapper function to get capabilities

As mercurial 2.3 changed API, rdiff extension did not work. I made it works with backward compatibility. Please check and merge it.

Comments (2)

  1. Brendan Cully repo owner

    Thanks for the patch! Elsewhere in this extension I've used a try/except style for backward compatibility instead of getattr, and I think it would be nice to be consistent here. Also, this doesn't appear to have been tested against older hg: getattr(other, '_capabilities', None) should be getattr(other, 'capabilities', None). Care to revise the patch?