[CaWE, 3D view, Tooltip] Tooltip blinking when rendered over 3D view

Issue #135 resolved
Anonymous created an issue

Tooltips rendered over the 3D view blink crazily (1.jpg), making them unreadable.

Comments (3)

  1. Carsten Fuchs

    Thanks for the report and the nice screenshot, but I'm not sure if we can do anything about this:

    I just tried to reproduce this under Windows 7 and Ubuntu 12.10 (both 64-bit), and none of these shows flickering when a tooltip overlaps an OpenGL view. (Under Ubuntu it's even mildly translucent, and still properly rendered.)

    Anyways, the tooltip rendering is eventually done by the OS, not by application code, and I wonder if the OS version and/or the currently installed graphics driver have a larger impact on the observed problem than anything that we can do to stop the flickering ourselves... that is, at this time I have no idea what exactly we could change in our code (in fact, not even where to look at) in order to improve the situation.

    Tomorrow I'll also try an older Windows 2000 system and report what I find, but I strongly suspect that the only solution to this problem is to update your graphics driver and/or OS in order to fix this problem.

  2. Carsten Fuchs

    As promised, I just tried to reproduce this also under Windows 2000, and there too is no flickering.

    As mentioned above, it's probably something involved with the OS and/or video drivers and their settings that causes this. If there is anything that we can do, I'm happy to reopen the ticket and further pursue this, but it really looks that this is not related to our code.

  3. Log in to comment