Commits

camlspotter committed 2eaa208

js_of_ocaml.deriving is not used

  • Participants
  • Parent commits 9edcf03

Comments (0)

Files changed (1)

 OCAMLCFLAGS   += -annot -w Ae
 OCAMLOPTFLAGS   += -annot -w Ae
 
-OCAMLDEPFLAGS= -syntax camlp4o -package lwt,js_of_ocaml.syntax,js_of_ocaml.deriving.syntax
-OCAMLPPFLAGS= -syntax camlp4o -package lwt,js_of_ocaml.syntax,js_of_ocaml.deriving.syntax
+OCAMLDEPFLAGS= -syntax camlp4o -package lwt,js_of_ocaml.syntax
+OCAMLPPFLAGS= -syntax camlp4o -package lwt,js_of_ocaml.syntax
 
 MyOCamlJSProgram(name, files) =
     NATIVE_ENABLED = false
 
-    # Strange workaround... there is no OMy package js_of_ocaml.deriving, but it is required
-    OCAML_PREINSTALLED_PACKS[] += js_of_ocaml.deriving
-    OCAMLPACKS[] += lwt js_of_ocaml js_of_ocaml.deriving
+    OCAML_PREINSTALLED_PACKS[] +=
+    OCAMLPACKS[] += lwt js_of_ocaml
 
     public.OCAML_BYTE_LINK_FLAGS = -linkpkg # removes -custom