Commits

camlspotter committed bb17cae

update

Comments (0)

Files changed (1)

 ことになる
 
 =================================================
+3.09以前型と 3.10以降系
+=================================================
+
+多分あなたが触っている P4 は 3.10以降系。これは OCaml のバージョンを見ればわかる。
+これは 3.09以前系と結構中身が違う。困ったことに CamlP4 のチュートリアルは 3.09以前系の物が
+インターネットに結構転がっており、これを読みながら 3.10以降系を使ってみて惨めにハマるという
+若者が跡を絶たない。何か読む際にははっきりと 3.10以降系と明示されたものを読むこと。
+
+ちなみに、この文章は 3.10以降系の P4 について書かれてある。
+
+=================================================
 Original Syntax, Revised Syntax なんと複雑な!
 =================================================