1. camlspotter
  2. omy

Commits

camlspotter  committed 79df029

require

  • Participants
  • Parent commits fcc5f17
  • Branches default

Comments (0)

Files changed (3)

File OMakefile

View file
  • Ignore whitespace
 Subdirs()
+
+
+

File OMyMakefile

View file
  • Ignore whitespace
 # =========================================================
 
 #| OCaml packages required for compilation. MyCaml* functions automatically add necessary dependencies over packages in $(OCAMLPACKS).
+# 
+# .. note:: They are also required for dependency analysis.
 public.OCAMLPACKS[]=
 
 #| CamlP4 syntax extension packages required for parsing. MyCaml* functions automatically add necessary dependencies over packages in $(CAMLP4PACKS).
 AddLocalOCamlPackageDependencies() =
   # We make sure the required libraries are installed
   OCamlRequirePackages($(OCAMLPACKS)) # must be exported!
-  OCamlRequireCamlP4Packages($(CAMLP4PACKS))
+  OCamlRequireCamlP4Packages($(OCAMLPACKS) $(CAMLP4PACKS))
   export
 
 #| Add a rule for OCaml package $(library_name).cmo, $(library_name).cmx and etc.

File doc/OMakefile

View file
  • Ignore whitespace
 .PHONY: clean
 
+RequireAptPackages(python-sphinx)
+
 MODULES[]=
     OMyMakefile
     OMyExternal
     OMyTar
+    OMyApt
 
 RSTS=$(addsuffix .rst, $(MODULES)) index.rst GeneralUsage.rst