Commits

camlspotter  committed 8c38f30

opam port

  • Participants
  • Parent commits e104886

Comments (0)

Files changed (2)

 
 OCAML_WHERE = $(shell ocamlc -where)
 
+OPAM_CAMLIDL_INCLUDE=""
+if $(CheckProg opam)
+  OPAM_CAMLIDL_INCLUDE=-I $(shell opam config -var lib)/camlidl
+  export
+
 REQUIRED_PACKS[]=camlidl
 
 ################################################################## C BUILD RULE
 
 PY_PREFIX=/usr
 PY_VERSION=2.7
-CFLAGS+= -fPIC -I $(OCAML_WHERE) -I $(PY_PREFIX)/include/python$(PY_VERSION)
+CFLAGS+= -fPIC -I $(OCAML_WHERE) $(OPAM_CAMLIDL_INCLUDE) -I $(PY_PREFIX)/include/python$(PY_VERSION)
 OCAMLFLAGS= -warn-error A-4-9-31
 
 # I (jfuruse) install camlidl using findlib, but not for the others.

File oowrap/OMakefile

 
 LIB = oowrap
 
-.DEFAULT: $(OCamlLibrary $(LIB), $(FILES))
+NO_INSTALL=true
+MyOCamlLibrary($(LIB), $(FILES))
 
 clean:
 	rm $(filter-proper-targets $(ls R, .))