Source

opycaml / INSTALL.txt

Requirements:
	ocaml 3.11.2 or newer
	findlib
	camidl
	python 2.x (>= 2.6) library and header
	omake
	OMyMakefile of omy package at https://bitbucket.org/camlspotter/omy, if not included in the source
        perl :-)

To compile:

  Create OMakeroot by omake --install . Do NOT overwrite OMakefile!

  Make sure you have OMyMakefile.

  Set PREFIX environment variable:

    % export PREFIX=/usr (in bash)

  If you are enough lucky:

    % omake

  just do the build.

    % omake install

  installs opycaml as an ocamlfind package.

  Reinstall requires ocamlfind remove opycaml beforehand.