Commits

camlspotter committed 5a49878

opam fix from upstream

  • Participants
  • Parent commits 01122fc
  • Branches opam_releases

Comments (0)

Files changed (6)

File opam/spotlib.2.0.1/opam

 opam-version: "1"
 maintainer: "jun.furuse@gmail.com"
 build: [
-  ["ocaml" "setup.ml" "-configure" "--prefix" "%{prefix}%"]
+  ["ocaml" "setup.ml" "-configure" "--prefix" prefix]
   ["ocaml" "setup.ml" "-build"]
   ["ocaml" "setup.ml" "-install"]
 ]
-remove: [
-  ["ocaml" "setup.ml" "-uninstall"]
+remove: [["ocaml" "setup.ml" "-uninstall"]]
+depends: [
+  "ocamlfind"
+  "omake"
 ]
 ocaml-version: [>= "4.0.0"]
-depends: ["ocamlfind" "omake"]
 os: ["linux"]

File opam/spotlib.2.1.0/opam

 opam-version: "1"
 maintainer: "jun.furuse@gmail.com"
 build: [
-  ["ocaml" "setup.ml" "-configure" "--prefix" "%{prefix}%"]
+  ["ocaml" "setup.ml" "-configure" "--prefix" prefix]
   ["ocaml" "setup.ml" "-build"]
   ["ocaml" "setup.ml" "-install"]
 ]
-remove: [
-  ["ocaml" "setup.ml" "-uninstall"]
+remove: [["ocaml" "setup.ml" "-uninstall"]]
+depends: [
+  "ocamlfind"
+  "omake"
 ]
 ocaml-version: [>= "4.0.1"]
-depends: ["ocamlfind" "omake"]
 os: ["linux"]

File opam/spotlib.2.1.1/opam

 opam-version: "1"
 maintainer: "jun.furuse@gmail.com"
 build: [
-  ["ocaml" "setup.ml" "-configure" "--prefix" "%{prefix}%"]
+  ["ocaml" "setup.ml" "-configure" "--prefix" prefix]
   ["ocaml" "setup.ml" "-build"]
   ["ocaml" "setup.ml" "-install"]
 ]
-remove: [
-  ["ocaml" "setup.ml" "-uninstall"]
+remove: [["ocaml" "setup.ml" "-uninstall"]]
+depends: [
+  "ocamlfind"
+  "omake"
 ]
 ocaml-version: [>= "4.0.1"]
-depends: ["ocamlfind" "omake"]
 os: ["linux"]

File opam/spotlib.2.1.2/opam

 opam-version: "1"
 maintainer: "jun.furuse@gmail.com"
 build: [
-  ["ocaml" "setup.ml" "-configure" "--prefix" "%{prefix}%"]
+  ["ocaml" "setup.ml" "-configure" "--prefix" prefix]
   ["ocaml" "setup.ml" "-build"]
   ["ocaml" "setup.ml" "-install"]
 ]
-remove: [
-  ["ocaml" "setup.ml" "-uninstall"]
+remove: [["ocaml" "setup.ml" "-uninstall"]]
+depends: [
+  "ocamlfind"
+  "omake"
 ]
 ocaml-version: [>= "4.0.1"]
-depends: ["ocamlfind" "omake"]
 os: ["linux"]

File opam/spotlib.2.2.0/opam

 opam-version: "1"
 maintainer: "jun.furuse@gmail.com"
 build: [
-  ["ocaml" "setup.ml" "-configure" "--prefix" "%{prefix}%"]
+  ["ocaml" "setup.ml" "-configure" "--prefix" prefix]
   ["ocaml" "setup.ml" "-build"]
   ["ocaml" "setup.ml" "-install"]
 ]
-remove: [
-  ["ocaml" "setup.ml" "-uninstall"]
+remove: [["ocaml" "setup.ml" "-uninstall"]]
+depends: [
+  "ocamlfind"
+  "omake"
+  "pa_ounit" {>= "109.18.00"}
 ]
 ocaml-version: [>= "4.0.1"]
-depends: ["ocamlfind" "omake" "pa_ounit" {>="109.18.00"}]
 os: ["linux"]

File opam/spotlib.2.3.0/opam

 opam-version: "1"
 maintainer: "jun.furuse@gmail.com"
 build: [
-  ["ocaml" "setup.ml" "-configure" "--prefix" "%{prefix}%"]
+  ["ocaml" "setup.ml" "-configure" "--prefix" prefix]
   ["ocaml" "setup.ml" "-build"]
   ["ocaml" "setup.ml" "-install"]
 ]
-remove: [
-  ["ocaml" "setup.ml" "-uninstall"]
+remove: [["ocaml" "setup.ml" "-uninstall"]]
+depends: [
+  "ocamlfind"
+  "omake"
+  "pa_ounit" {>= "109.18.00"}
 ]
 ocaml-version: [>= "4.0.1"]
-depends: ["ocamlfind" "omake" "pa_ounit" {>="109.18.00"}]