Commits

camlspotter committed 9c4f18f

preparing 2.2.0_js

Comments (0)

Files changed (26)

 (* OASIS_START *)
-(* DO NOT EDIT (digest: 63582a408b9848b727b92904ac3074af) *)
-Authors of spotlib
+(* DO NOT EDIT (digest: 7997cc9b7805485933c8b62a0dbd12b7) *)
+Authors of spotlib_js
 Jun FURUSE
 (* OASIS_STOP *)
 (* OASIS_START *)
-(* DO NOT EDIT (digest: 88ed6e6bb9da0cbbd39aa3c4d7bb5134) *)
-This is the INSTALL file for the spotlib distribution.
+(* DO NOT EDIT (digest: bc37831500eae6ebc8855e08d3fdeaab) *)
+This is the INSTALL file for the spotlib_js distribution.
 
 This package uses OASIS to generate its build system. See section OASIS for
 full information. 
 OASISFormat: 0.2
-Name:        spotlib
-Version:     2.2.0
+Name:        spotlib_js
+Version:     2.2.0_js
 Synopsis:    Useful functions for OCaml programming used by @camlspotter
 Authors:     Jun FURUSE
 License:     LGPL-2.0 with OCaml linking exception
 name="spotlib_js"
-version="2.2.0"
+version="2.2.0_js"
 description="Spotter's garbages"
 requires=""
 archive(byte)="spotlib_js.cmo"

opam/spotlib.1.0.0/descr

-Useful functions for OCaml programming used by @camlspotter
-Spotlib is a small library package used for several softwares by Jun Furuse.
-It is almost a poor replication of Jane Street Core, but it is small.

opam/spotlib.1.0.0/opam

-opam-version: "1"
-maintainer: "jun.furuse@gmail.com"
-build: [
-  ["ocaml" "setup.ml" "-configure" "--prefix" "%{prefix}%"]
-  ["ocaml" "setup.ml" "-build"]
-  ["ocaml" "setup.ml" "-install"]
-]
-remove: [
-  ["ocamlfind" "remove" "spotlib"]
-]
-depends: ["ocamlfind" "omake"]
-ocaml-version: [= "3.12.1"]

opam/spotlib.1.0.0/url

-archive: "https://bitbucket.org/camlspotter/spotlib/downloads/spotlib-1.0.0.tar.gz"
-checksum: "4053da0d16f5608deee22be0604d5b3d"

opam/spotlib.2.0.1/descr

-Useful functions for OCaml programming used by @camlspotter
-Spotlib is a small library package used for several softwares by Jun Furuse.
-It is almost a poor replication of Jane Street Core, but it is small.

opam/spotlib.2.0.1/opam

-opam-version: "1"
-maintainer: "jun.furuse@gmail.com"
-build: [
-  ["ocaml" "setup.ml" "-configure" "--prefix" "%{prefix}%"]
-  ["ocaml" "setup.ml" "-build"]
-  ["ocaml" "setup.ml" "-install"]
-]
-remove: [
-  ["ocaml" "setup.ml" "-uninstall"]
-]
-ocaml-version: [>= "4.0.0"]
-depends: ["ocamlfind" "omake"]

opam/spotlib.2.0.1/url

-archive: "https://bitbucket.org/camlspotter/spotlib/get/2.0.1.tar.gz"

opam/spotlib.2.1.0/descr

-Useful functions for OCaml programming used by @camlspotter
-Spotlib is a small library package used for several softwares by Jun Furuse.
-It is almost a poor replication of Jane Street Core, but it is small.

opam/spotlib.2.1.0/opam

-opam-version: "1"
-maintainer: "jun.furuse@gmail.com"
-build: [
-  ["ocaml" "setup.ml" "-configure" "--prefix" "%{prefix}%"]
-  ["ocaml" "setup.ml" "-build"]
-  ["ocaml" "setup.ml" "-install"]
-]
-remove: [
-  ["ocaml" "setup.ml" "-uninstall"]
-]
-ocaml-version: [>= "4.0.1"]
-depends: ["ocamlfind" "omake"]

opam/spotlib.2.1.0/url

-archive: "https://bitbucket.org/camlspotter/spotlib/get/2.1.0.tar.gz"

opam/spotlib.2.1.1/descr

-Useful functions for OCaml programming used by @camlspotter
-Spotlib is a small library package used for several softwares by Jun Furuse.
-It is almost a poor replication of Jane Street Core, but it is small.

opam/spotlib.2.1.1/opam

-opam-version: "1"
-maintainer: "jun.furuse@gmail.com"
-build: [
-  ["ocaml" "setup.ml" "-configure" "--prefix" "%{prefix}%"]
-  ["ocaml" "setup.ml" "-build"]
-  ["ocaml" "setup.ml" "-install"]
-]
-remove: [
-  ["ocaml" "setup.ml" "-uninstall"]
-]
-ocaml-version: [>= "4.0.1"]
-depends: ["ocamlfind" "omake"]

opam/spotlib.2.1.1/url

-archive: "https://bitbucket.org/camlspotter/spotlib/get/2.1.1.tar.gz"

opam/spotlib.2.1.2/descr

-Useful functions for OCaml programming used by @camlspotter
-Spotlib is a small library package used for several softwares by Jun Furuse.
-It is almost a poor replication of Jane Street Core, but it is small.

opam/spotlib.2.1.2/opam

-opam-version: "1"
-maintainer: "jun.furuse@gmail.com"
-build: [
-  ["ocaml" "setup.ml" "-configure" "--prefix" "%{prefix}%"]
-  ["ocaml" "setup.ml" "-build"]
-  ["ocaml" "setup.ml" "-install"]
-]
-remove: [
-  ["ocaml" "setup.ml" "-uninstall"]
-]
-ocaml-version: [>= "4.0.1"]
-depends: ["ocamlfind" "omake"]

opam/spotlib.2.1.2/url

-archive: "https://bitbucket.org/camlspotter/spotlib/get/2.1.2.tar.gz"

opam/spotlib.2.2.0/descr

-Useful functions for OCaml programming used by @camlspotter
-Spotlib is a small library package used for several softwares by Jun Furuse.
-It is almost a poor replication of Jane Street Core, but it is small.

opam/spotlib.2.2.0/opam

-opam-version: "1"
-maintainer: "jun.furuse@gmail.com"
-build: [
-  ["ocaml" "setup.ml" "-configure" "--prefix" "%{prefix}%"]
-  ["ocaml" "setup.ml" "-build"]
-  ["ocaml" "setup.ml" "-install"]
-]
-remove: [
-  ["ocaml" "setup.ml" "-uninstall"]
-]
-ocaml-version: [>= "4.0.1"]
-depends: ["ocamlfind" "omake" "pa_ounit" {>="109.18.00"}]

opam/spotlib.2.2.0/url

-archive: "https://bitbucket.org/camlspotter/spotlib/get/2.2.0.tar.gz"

opam/spotlib_js.2.2.0_js/descr

+Useful functions for OCaml programming used by @camlspotter
+Spotlib is a small library package used for several softwares by Jun Furuse.
+It is almost a poor replication of Jane Street Core, but it is small.

opam/spotlib_js.2.2.0_js/opam

+opam-version: "1"
+maintainer: "jun.furuse@gmail.com"
+build: [
+  ["ocaml" "setup.ml" "-configure" "--prefix" "%{prefix}%"]
+  ["ocaml" "setup.ml" "-build"]
+  ["ocaml" "setup.ml" "-install"]
+]
+remove: [
+  ["ocaml" "setup.ml" "-uninstall"]
+]
+ocaml-version: [>= "4.0.1"]
+depends: ["ocamlfind" "omake"]

opam/spotlib_js.2.2.0_js/url

+archive: "https://bitbucket.org/camlspotter/spotlib_js/get/2.2.0_js.tar.gz"
 (* setup.ml generated for the first time by OASIS v0.3.0 *)
 
 (* OASIS_START *)
-(* DO NOT EDIT (digest: 702a6368b36328b90b46227f19536cb1) *)
+(* DO NOT EDIT (digest: 6d07bc5be506f8d696186d65908feae1) *)
 (*
    Regenerated by OASIS v0.3.0
    Visit http://oasis.forge.ocamlcore.org for more information and
           oasis_version = "0.2";
           ocaml_version = None;
           findlib_version = None;
-          name = "spotlib";
-          version = "2.2.0";
+          name = "spotlib_js";
+          version = "2.2.0_js";
           license =
             OASISLicense.DEP5License
               (OASISLicense.DEP5Unit
           };
      oasis_fn = Some "_oasis";
      oasis_version = "0.3.0";
-     oasis_digest = Some "\201\167C;\171\201&\bj\177\229\150\171J\203\191";
+     oasis_digest = Some "\193'\152^.\200\1277\nR(\018\153\230x\235";
      oasis_exec = None;
      oasis_setup_args = [];
      setup_update = false;